import mercurial-6.8.1-3.el10

i10ce changed/i10ce/mercurial-6.8.1-3.el10
Arkady L. Shane 2 weeks ago
parent 02131af577
commit e16992af04
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

2
.gitignore vendored

@ -1 +1 @@
SOURCES/mercurial-4.8.2.tar.gz
SOURCES/mercurial-6.8.1.tar.gz

@ -1 +1 @@
f2389e708db2358e43d35d37a16fb08cfc6e1284 SOURCES/mercurial-4.8.2.tar.gz
1c214d0242134c63f7eb9b9f480bd87478e10ca1 SOURCES/mercurial-6.8.1.tar.gz

@ -1,3 +0,0 @@
test-https.t
test-profile.t
test-wireproto-exchangev2.t

@ -0,0 +1,34 @@
# HG changeset patch
# User Mads Kiilerich <mads@kiilerich.com>
# Date 1728323604 -7200
# Mon Oct 07 19:53:24 2024 +0200
# Branch stable
# Node ID fa708fa22276b2f9fb2043eea64e5a4d6d53a994
# Parent 7ff35f1290c0f922c6f6d77b1113679346d59f9d
hgdemandimport: add collections.abc to the ignore list because Python 3.13 rc3
Everything worked fine with Python 3.13 rc2, but something changed for rc3 ...
and seems to have been released that way in the final 3.13 .
Now, when i18n.py imports typing and it touches collections.abc.Hashable , we
get:
ValueError: module object for collections.abc substituted in sys.modules during a lazy load
I have not analyzed the problem in details.
We *could* work around the problem by disabling demand import of typing. But
that would effectively disable demand import of collections.abc too. Instead,
just disable demand import for collections.abc .
diff --git a/hgdemandimport/__init__.py b/hgdemandimport/__init__.py
--- a/hgdemandimport/__init__.py
+++ b/hgdemandimport/__init__.py
@@ -62,6 +62,7 @@ IGNORES = {
'_weakrefset',
'warnings',
'threading',
+ 'collections.abc',
}
_pypy = '__pypy__' in sys.builtin_module_names

@ -0,0 +1,14 @@
Patch cargo metadata for Fedora build
diff --git a/rust/hg-core/Cargo.toml b/rust/hg-core/Cargo.toml
--- a/rust/hg-core/Cargo.toml
+++ b/rust/hg-core/Cargo.toml
@@ -31,7 +31,7 @@ sha-1 = "0.10.0"
twox-hash = "1.6.3"
same-file = "1.0.6"
tempfile = "3.3.0"
-toml = "0.6"
+toml = "0.8"
thread_local = "1.1.4"
crossbeam-channel = "0.5.6"
log = "0.4.17"

@ -1,46 +1,62 @@
%{!?python2_sitearch: %define python2_sitearch %(%{__python2} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
Summary: Mercurial -- a distributed SCM
# build Rust binary and extensions for non-Enterprise Linux systems
%if ! 0%{?rhel}
%ifarch %{rust_arches}
%bcond_with rust
%else
%bcond_with rust
%endif
%endif
Summary: A fast, lightweight Source Control Management system
Name: mercurial
Version: 4.8.2
Release: 1%{?dist}
Version: 6.8.1
Release: 3%{?dist}
# Release: 1.rc1%{?dist}
# Release: 1.rc1%%{?dist}
#% define upstreamversion %%{version}-rc
%define upstreamversion %{version}
License: GPLv2+
Group: Development/Tools
URL: http://www.selenic.com/mercurial/
Source0: https://www.selenic.com/mercurial/release/%{name}-%{upstreamversion}.tar.gz
License: GPL-2.0-or-later
URL: https://mercurial-scm.org/
Source0: https://www.mercurial-scm.org/release/%{name}-%{upstreamversion}.tar.gz
Source1: mercurial-site-start.el
Source2: blacklist
BuildRequires: python2 python2-devel bash-completion
BuildRequires: emacs-nox emacs-el pkgconfig gettext python2-docutils
# Patch cargo metadata for dependency versions available in Fedora
Patch0: mercurial-rust-metadata.patch
Patch1: demand-collections-abc.patch
BuildRequires: make
BuildRequires: emacs-el
BuildRequires: emacs-nox
BuildRequires: gcc
BuildRequires: less
Requires: python2 emacs-filesystem
BuildRequires: gettext
BuildRequires: pkgconfig
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-docutils
%if %{with rust}
BuildRequires: rust-packaging
%endif
Provides: hg = %{version}-%{release}
Obsoletes: emacs-mercurial <= 3.4.1, emacs-mercurial-el <= 3.4.1
Provides: emacs-mercurial <= 3.4.1, emacs-mercurial-el <= 3.4.1
Requires: python3
Requires: emacs-filesystem
Recommends: python3-fb-re2
Provides: mercurial-rust = %{version}-%{release}
Obsoletes: mercurial-rust < %{version}-%{release}
%description
Mercurial is a fast, lightweight source control management system designed
for efficient handling of very large distributed projects.
Quick start: http://www.selenic.com/mercurial/wiki/index.cgi/QuickStart
Tutorial: http://www.selenic.com/mercurial/wiki/index.cgi/Tutorial
Extensions: http://www.selenic.com/mercurial/wiki/index.cgi/CategoryExtension
Quick start: https://www.mercurial-scm.org/wiki/QuickStart
Tutorial: https://www.mercurial-scm.org/wiki/Tutorial
Extensions: https://www.mercurial-scm.org/wiki/UsingExtensions
%define pkg mercurial
# If the emacs-el package has installed a pkgconfig file, use that to determine
%package hgk
Summary: Hgk interface for mercurial
Group: Development/Tools
Requires: hg = %{version}-%{release}, tk
Requires: hg = %{version}-%{release}
Requires: tk
%description hgk
A Mercurial extension for displaying the change history graphically
@ -49,55 +65,127 @@ understandable way and shows diffs for each revision. Based on
gitk for the git SCM.
Adds the "hg view" command. See
http://www.selenic.com/mercurial/wiki/index.cgi/UsingHgk for more
https://www.mercurial-scm.org/wiki/HgkExtension for more
documentation.
%package chg
Summary: A fast Mercurial command without slow Python startup
Requires: hg = %{version}-%{release}
%description chg
chg is a C wrapper for the hg command. Typically, when you type hg, a new
Python process is created, Mercurial is loaded, and your requested command runs
and the process exits.
With chg, a Mercurial command server background process is created that runs
Mercurial. When you type chg, a C program connects to that background process
and executes Mercurial commands.
%if %{with rust}
%package rust
Summary: Mercurial Rust binaries and extensions
# Effective license for the rust binaries, computed from statically linked dependencies:
# BSD
# GPLv2+
# MIT
# MIT or ASL 2.0
# MPLv2.0
# Python
# Unlicense or MIT
# zlib or ASL 2.0 or MIT
License: GPL-2.0-or-later
Requires: hg = %{version}-%{release}
%description rust
This subpackage provides following Mercurial components implemented in Rust:
The `rustext` extension speeds up some functionality of Mercurial, e.g.
ancestry computations in revision graphs, status or discovery of differences
between repositories.
The experimental `rhg` executable implements a subset of the functionality of
`hg` using only Rust, to avoid the startup cost of a Python interpreter. This
subset is initially small but grows over time as `rhg` is improved. When
fallback to the Python implementation is configured, `rhg` aims to be a drop-in
replacement for `hg` that should behave the same, except that some commands run
faster.
%endif
%prep
%setup -q -n %{name}-%{upstreamversion}
%autosetup -p1 -n %{name}-%{upstreamversion}
%if %{with rust}
pushd rust
%cargo_prep
popd
# Patch files to use python2 instead of (since lately) non existent python binary.
sed -i 's|python|python2|' %{_builddir}/%{name}-%{version}/Makefile %{_builddir}/%{name}-%{version}/doc/Makefile
%generate_buildrequires
for crate in rust/hg-core rust/hg-cpython rust/rhg; do
cd $crate
# Temporarily remove hg-core = { path = "../hg-core"} dependencies while generating buildrequires.
sed -i.br -r -e '/=\s*\{[^}]+path\s*=/d' Cargo.toml
%cargo_generate_buildrequires
mv -f Cargo.toml{.br,}
cd - >/dev/null
done
%endif
# /with rust
# These are shipped as examples in /usr/share/docs and should not be executable
chmod -x hgweb.cgi contrib/hgweb.fcgi
%build
# Fix python shebang in hg-ssh
sed -i -e '1s,#!.*python$,#!%{__python2},' contrib/hg-ssh
make all
PYTHON=%{python3} make all
%install
rm -rf $RPM_BUILD_ROOT
%{__python2} setup.py install -O1 --root $RPM_BUILD_ROOT --prefix %{_prefix} --record=%{name}.files
make install-doc DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir}
# chg will invoke the 'hg' command - no direct Python dependency
pushd contrib/chg
make
popd
grep -v -e 'hgk.py*' -e %{python2_sitearch}/mercurial/ -e %{python2_sitearch}/hgext/ < %{name}.files > %{name}-base.files
grep 'hgk.py*' < %{name}.files > %{name}-hgk.files
%if %{with rust}
# Mercurial build system hardcodes too much. Instead, just build with Fedora macro.
pushd rust
%cargo_build
popd
%endif
%install
%py3_install
make install-doc DESTDIR=%{buildroot} MANDIR=%{_mandir}
install -D -m 755 contrib/hgk $RPM_BUILD_ROOT%{_libexecdir}/mercurial/hgk
install -m 755 contrib/hg-ssh $RPM_BUILD_ROOT%{_bindir}
# Overrule setup.py policy "c" for module usage: always allow rust extension (if available)
echo 'modulepolicy = b"rust+c-allow"' > %{buildroot}%{python3_sitearch}/mercurial/__modulepolicy__.py
bash_completion_dir=$RPM_BUILD_ROOT$(pkg-config --variable=completionsdir bash-completion)
mkdir -p $bash_completion_dir
install -m 644 contrib/bash_completion $bash_completion_dir/hg
%if %{with rust}
# We are not using the Mercurial build system to build rust, and must thus manually install relevant parts.
install -D -m 755 -pv rust/target/release/rhg %{buildroot}%{_bindir}
install -D -m 755 -pv rust/target/release/librusthg.so \
%{buildroot}%{python3_sitearch}/mercurial/rustext%{python3_ext_suffix}
%endif
zsh_completion_dir=$RPM_BUILD_ROOT%{_datadir}/zsh/site-functions
mkdir -p $zsh_completion_dir
install -m 644 contrib/zsh_completion $zsh_completion_dir/_mercurial
install -D -m 755 contrib/hgk %{buildroot}%{_libexecdir}/mercurial/hgk
install -m 755 contrib/hg-ssh %{buildroot}%{_bindir}
mkdir -p $RPM_BUILD_ROOT%{_emacs_sitelispdir}/mercurial
mkdir -p %{buildroot}%{_emacs_sitelispdir}/mercurial
pushd contrib
for file in mercurial.el mq.el; do
#emacs -batch -l mercurial.el --no-site-file -f batch-byte-compile $file
%{_emacs_bytecompile} $file
install -p -m 644 $file ${file}c $RPM_BUILD_ROOT%{_emacs_sitelispdir}/mercurial
install -p -m 644 $file ${file}c %{buildroot}%{_emacs_sitelispdir}/mercurial
rm ${file}c
done
popd
pushd contrib/chg
make install DESTDIR=%{buildroot} PREFIX=%{_prefix} MANDIR=%{_mandir}/man1
popd
mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/mercurial/hgrc.d
mkdir -p %{buildroot}%{_sysconfdir}/mercurial/hgrc.d
mkdir -p $RPM_BUILD_ROOT%{_emacs_sitestartdir} && install -m644 %SOURCE1 $RPM_BUILD_ROOT%{_emacs_sitestartdir}
mkdir -p %{buildroot}%{_emacs_sitestartdir} && install -m644 %SOURCE1 %{buildroot}%{_emacs_sitestartdir}
cat >hgk.rc <<EOF
[extensions]
@ -107,59 +195,408 @@ hgk=
[hgk]
path=%{_libexecdir}/mercurial/hgk
EOF
install -m 644 hgk.rc $RPM_BUILD_ROOT/%{_sysconfdir}/mercurial/hgrc.d
install -m 644 hgk.rc %{buildroot}%{_sysconfdir}/mercurial/hgrc.d
cat > certs.rc <<EOF
# see: http://mercurial.selenic.com/wiki/CACertificates
# see: https://www.mercurial-scm.org/wiki/CACertificates
[web]
cacerts = /etc/pki/tls/certs/ca-bundle.crt
EOF
install -m 644 certs.rc $RPM_BUILD_ROOT/%{_sysconfdir}/mercurial/hgrc.d
mv $RPM_BUILD_ROOT%{python2_sitearch}/mercurial/locale $RPM_BUILD_ROOT%{_datadir}/locale
rm -rf $RPM_BUILD_ROOT%{python2_sitearch}/mercurial/locale
install -m 644 certs.rc %{buildroot}%{_sysconfdir}/mercurial/hgrc.d
mv %{buildroot}%{python3_sitearch}/mercurial/locale %{buildroot}%{_datadir}/locale
rm -rf %{buildroot}%{python3_sitearch}/mercurial/locale
%find_lang hg
grep -v locale %{name}-base.files > %{name}-base-filtered.files
%py3_shebang_fix %{buildroot}%{_bindir}/hg-ssh
%files -f %{name}-base-filtered.files -f hg.lang
%doc CONTRIBUTORS COPYING doc/README doc/hg*.txt doc/hg*.html *.cgi contrib/*.fcgi contrib/*.wsgi
%doc %attr(644,root,root) %{_mandir}/man?/hg*.gz
%files -f hg.lang
%doc CONTRIBUTORS COPYING doc/README doc/hg*.html hgweb.cgi contrib/hgweb.fcgi contrib/hgweb.wsgi
%doc %attr(644,root,root) %{_mandir}/man?/hg*
%doc %attr(644,root,root) contrib/*.svg
%{_datadir}/zsh/site-functions/_mercurial
%{_bindir}/hg-ssh
%{_datadir}/bash-completion/
%dir %{_datadir}/zsh/
%{_datadir}/zsh/site-functions/
%dir %{_sysconfdir}/mercurial
%dir %{_sysconfdir}/mercurial/hgrc.d
%{python2_sitearch}/mercurial
%{python2_sitearch}/hgext
%{bash_completions_dir}/hg
%{zsh_completions_dir}/_hg
%pycached %exclude %{python3_sitearch}/hgext/hgk.py
%if %{with rust}
%exclude %{python3_sitearch}/mercurial/rustext%{python3_ext_suffix}
%endif
%{python3_sitearch}/mercurial-%{version}-py%{python3_version}.egg-info/
%{python3_sitearch}/mercurial/
%{python3_sitearch}/hgext/
%{python3_sitearch}/hgext3rd/
%{python3_sitearch}/hgdemandimport/
%{_emacs_sitelispdir}/mercurial
%{_emacs_sitestartdir}/*.el
%{_bindir}/hg
%{_bindir}/hg-ssh
%config(noreplace) %{_sysconfdir}/mercurial/hgrc.d/certs.rc
%files hgk -f %{name}-hgk.files
%files hgk
%{_libexecdir}/mercurial/
%{_sysconfdir}/mercurial/hgrc.d/hgk.rc
%pycached %{python3_sitearch}/hgext/hgk.py
%config(noreplace) %{_sysconfdir}/mercurial/hgrc.d/hgk.rc
%files chg
%{_bindir}/chg
%doc %attr(644,root,root) %{_mandir}/man?/chg.*
%if %{with rust}
%files rust
%{_bindir}/rhg
%{python3_sitearch}/mercurial/rustext%{python3_ext_suffix}
%endif
#%%check
# The test suite is too slow and fragile to run here by default.
#cd tests && %%{python3} run-tests.py
%check
cd tests && %{__python2} run-tests.py -t 360 --blacklist %{SOURCE2}
%changelog
* Tue Jan 08 2019 Marcel Plch <mplch@redhat.com> - 4.8.2-1
- New release 4.8.2
- enable tests
- use https for sources
- Resolves: rhbz#1650525
* Tue Jul 31 2018 Sebastian Kisela <skisela@redhat.com> - 4.6.2-1
- New release 4.6.2.
- Convert deprecated specfile python macros to use python2 macros.
- Explicitly depend on gcc, as it was removed from buildroot default packages.
* Wed Jan 01 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 6.8.1-3
- Rebuilt for MSVSphere 10
* Mon Oct 07 2024 Mads Kiilerich <mads@kiilerich.com> - 6.8.1-3
- Disable demandimport of collections.abc because Python 3.13 rc3 (#2316252)
* Thu Aug 01 2024 Mads Kiilerich <mads@kiilerich.com> - 6.8.1-2
- Drop upstreamed demandimport patch.
* Thu Aug 01 2024 Mads Kiilerich <mads@kiilerich.com> - 6.8.1-1
- mercurial 6.8.1
* Fri Jul 26 2024 Mads Kiilerich <mads@kiilerich.com> - 6.8-5
- Also exclude 'warnings' from demandimport.
* Fri Jul 26 2024 Mads Kiilerich <mads@kiilerich.com> - 6.8-4
- Exclude threading from demandimport. That became a problem with recent
"stable" cpython changes. (#2299346)
* Fri Jul 26 2024 Miroslav Suchý <msuchy@redhat.com> - 6.8-3
- convert license to SPDX
* Thu Jul 18 2024 Fedora Release Engineering <releng@fedoraproject.org> - 6.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Tue Jul 09 2024 Mads Kiilerich <mads@kiilerich.com> - 6.8-1
- mercurial 6.8
* Fri Jun 07 2024 Python Maint <python-maint@redhat.com> - 6.7.3-2
- Rebuilt for Python 3.13
* Mon May 06 2024 Mads Kiilerich <mads@kiilerich.com> - 6.7.3-1
- mercurial 6.7.3
* Mon Apr 08 2024 Mads Kiilerich <mads@kiilerich.com> - 6.7.2-3
- Disable rust packaging - cpython create doesn't work with Python 3.12
(#2249383)
* Mon Apr 08 2024 Mads Kiilerich <mads@kiilerich.com> - 6.7.2-2
- Drop python3-zombie-imp - it is no longer needed
* Mon Apr 08 2024 Mads Kiilerich <mads@kiilerich.com> - 6.7.2-1
- mercurial 6.7.2
* Mon Feb 12 2024 Mads Kiilerich <mads@kiilerich.com> - 6.6.3-1
- mercurial 6.6.3
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 6.6.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 6.6.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Thu Jan 11 2024 Mads Kiilerich <mads@kiilerich.com> - 6.6.2-1
- mercurial 6.6.2
* Wed Jan 10 2024 Mads Kiilerich <mads@kiilerich.com> - 6.6.1-2
- Fix sources file
* Mon Dec 11 2023 Mads Kiilerich <mads@kiilerich.com> - 6.6.1-1
- mercurial 6.6.1
* Tue Nov 21 2023 Mads Kiilerich <mads@kiilerich.com> - 6.6-1
- mercurial 6.6 and patch to use cargo toml 0.8
* Thu Nov 09 2023 Mads Kiilerich <mads@kiilerich.com> - 6.5.3-2
- Better support for custom _prefix
* Wed Nov 08 2023 Mads Kiilerich <mads@kiilerich.com> - 6.5.3-1
- mercurial 6.5.3
* Mon Aug 07 2023 Mads Kiilerich <mads@kiilerich.com> - 6.5.1-1
- mercurial 6.5.1
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 6.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Fri Jul 07 2023 Mads Kiilerich <mads@kiilerich.com> - 6.5-1
- mercurial 6.5
* Mon Jun 26 2023 Python Maint <python-maint@redhat.com> - 6.4.5-2
- Rebuilt for Python 3.12
* Thu Jun 22 2023 Mads Kiilerich <mads@kiilerich.com> - 6.4.5-1
- mercurial 6.4.5
* Tue Jun 13 2023 Python Maint <python-maint@redhat.com> - 6.4.4-2
- Rebuilt for Python 3.12
* Thu Jun 08 2023 Mads Kiilerich <mads@kiilerich.com> - 6.4.4-1
- mercurial 6.4.4
* Thu May 04 2023 Mads Kiilerich <mads@kiilerich.com> - 6.4.3-1
- mercurial 6.4.3
* Tue Apr 18 2023 Mads Kiilerich <mads@kiilerich.com> - 6.4.2-1
- mercurial 6.4.2
* Thu Apr 13 2023 Mads Kiilerich <mads@kiilerich.com> - 6.4.1-1
- mercurial 6.4.1
* Fri Mar 24 2023 Mads Kiilerich <mads@kiilerich.com> - 6.4-1
- mercurial 6.4
* Thu Mar 02 2023 Mads Kiilerich <mads@kiilerich.com> - 6.3.3-1
- mercurial 6.3.3
* Thu Feb 23 2023 Fabio Valentini <decathorpe@gmail.com> - 6.3.2-4
- Bump zstd crate dependency from 0.11 to 0.12.
* Sun Feb 05 2023 Fabio Valentini <decathorpe@gmail.com> - 6.3.2-3
- Rebuild for fixed frame pointer compiler flags in Rust RPM macros.
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 6.3.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Wed Jan 04 2023 Mads Kiilerich <mads@kiilerich.com> - 6.3.2-1
- mercurial 6.3.2
* Sat Nov 19 2022 Mads Kiilerich <mads@kiilerich.com> - 6.3.1-1
- mercurial 6.3.1
* Mon Nov 14 2022 Mads Kiilerich <mads@kiilerich.com> - 6.3.0-1
- mercurial 6.3.0
* Tue Oct 04 2022 Mads Kiilerich <mads@kiilerich.com> - 6.2.3-1
- mercurial 6.2.3
* Sun Sep 04 2022 Mads Kiilerich <mads@kiilerich.com> - 6.2.2-1
- mercurial 6.2.2
* Sat Aug 06 2022 Fabio Valentini <decathorpe@gmail.com> - 6.2.1-3
- Bump zstd crate dependency from 0.10 to 0.11.
* Sat Aug 06 2022 Mads Kiilerich <mads@kiilerich.com> - 6.2.1-2
- Own .egg-info as directory, as introduced by setuptools 60 (#2115906)
* Thu Jul 28 2022 Mads Kiilerich <mads@kiilerich.com> - 6.2.1-1
- mercurial 6.2.1
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 6.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Mon Jul 11 2022 Mads Kiilerich <mads@kiilerich.com> - 6.2-2
- Update sources with mercurial-6.2.tar.gz
* Mon Jul 11 2022 Mads Kiilerich <mads@kiilerich.com> - 6.2-1
- mercurial 6.2
* Mon Jul 11 2022 Mads Kiilerich <mads@kiilerich.com> - 6.1.4-2
- Fix build after upstream applied patch
* Thu Jun 16 2022 Mads Kiilerich <mads@kiilerich.com> - 6.1.4-1
- mercurial 6.1.4
* Tue Jun 14 2022 Python Maint <python-maint@redhat.com> - 6.1.3-3
- Rebuilt for Python 3.11
* Fri Jun 03 2022 Mads Kiilerich <mads@kiilerich.com> - 6.1.3-2
- work around too narrow im-rc version constraint
* Thu Jun 02 2022 Mads Kiilerich <mads@kiilerich.com> - 6.1.3-1
- mercurial 6.1.3
* Mon May 23 2022 Stefan Bluhm <stefan.bluhm@clacee.eu> - 6.1.2-3
- Disable Rust components for Enterprise Linux.
* Fri May 13 2022 Mads Kiilerich <mads@kiilerich.com> - 6.1.2-2
- Rust dependency catch-up
* Thu May 05 2022 Mads Kiilerich <mads@kiilerich.com> - 6.1.2-1
- mercurial 6.1.2
* Tue May 03 2022 Mads Kiilerich <mads@kiilerich.com> - 6.1.1-4
- Address some rpmlint issues
* Thu Apr 14 2022 Aleksei Bavshin <alebastr@fedoraproject.org> - 6.1.1-3
- Build Rust components
* Wed Apr 06 2022 Mads Kiilerich <mads@kiilerich.com> - 6.1.1-2
- Undo accicental commit
* Wed Apr 06 2022 Mads Kiilerich <mads@kiilerich.com> - 6.1.1-1
- mercurial 6.1.1
* Tue Mar 01 2022 Mads Kiilerich <mads@kiilerich.com> - 6.1-1
- mercurial 6.1
* Fri Feb 18 2022 Mads Kiilerich <mads@kiilerich.com> - 6.0.3-1
- mercurial 6.0.3
* Wed Feb 02 2022 Mads Kiilerich <mads@kiilerich.com> - 6.0.2-1
- mercurial 6.0.2
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Wed Jan 05 2022 Mads Kiilerich <mads@kiilerich.com> - 6.0.1-1
- mercurial 6.0.1
* Wed Nov 24 2021 Mads Kiilerich <mads@kiilerich.com> - 6.0-1
- mercurial 6.0
* Thu Nov 18 2021 Mads Kiilerich <mads@kiilerich.com> - 5.9.3-2
- Drop old upgrade path
- Recommend python3-fb-re2 which will speed up some operations
* Wed Oct 27 2021 Mads Kiilerich <mads@kiilerich.com> - 5.9.3-1
- mercurial 5.9.3
* Wed Oct 06 2021 Mads Kiilerich <mads@kiilerich.com> - 5.9.2-1
- mercurial 5.9.2
* Wed Sep 01 2021 Mads Kiilerich <mads@kiilerich.com> - 5.9.1-1
- mercurial 5.9.1
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 5.8.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Mon Jul 12 2021 Mads Kiilerich <mads@kiilerich.com> - 5.8.1-1
- mercurial 5.8.1
* Thu Jun 03 2021 Python Maint <python-maint@redhat.com> - 5.8-2
- Rebuilt for Python 3.10
* Tue May 11 2021 Mads Kiilerich <mads@kiilerich.com> - 5.8-1
- mercurial 5.8
* Tue Mar 09 2021 Mads Kiilerich <mads@kiilerich.com> - 5.7.1-1
- mercurial 5.7.1
* Wed Feb 03 2021 Mads Kiilerich <mads@kiilerich.com> - 5.7-1
- mercurial 5.7
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.1-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Wed Jan 20 2021 Petr Stodulka <pstodulk@redhat.com> - 5.6.1-6
- Set Provides for the obsoleted mercurial-py3 and mercurial-lang rpms
- Relates: #1917946
* Sun Jan 3 03:39:35 CET 2021 Mads Kiilerich <mads@kiilerich.com> - 5.6.1-5
- Stop providing hg3 - that is the only hg we have
- Drop alternatives - there is no alternative
- Move main package back to mercurial without py3 suffix
- Drop the -lang package
* Tue Dec 8 17:14:14 CET 2020 Mads Kiilerich <mads@kiilerich.com> - 5.6.1-4
- Change mercurial-hgk to use py3
- Use py3 for locales - py2 is going away
- Clarify in comment that chg has no py2/py3 concerns
- Drop comment left over from 53899096 when it introduced use of PYTHON=
- Let mercurial-py3 obsolete mercurial-py2 - it is going away soon
- Trivial removal of py2 package - no cleanup
* Sat Dec 5 14:50:30 CET 2020 Mads Kiilerich <mads@kiilerich.com> - 5.6.1-3
- Fix ownership of hgext3rd and hgdemandimport (#1897681)
* Thu Dec 3 21:24:26 CET 2020 Mads Kiilerich <mads@kiilerich.com> - 5.6.1-2
- Drop hgdemandimport_ast.patch - it has been fixed both in Mercurial 5.5.2 and
Python 3.9.0rc2
* Thu Dec 3 20:39:41 CET 2020 Mads Kiilerich <mads@kiilerich.com> - 5.6.1-1
- mercurial 5.6.1
* Mon Nov 30 2020 Miro Hrončok <mhroncok@redhat.com> - 5.4-5
- Install Python 3 based mercurial by default
* Wed Sep 02 2020 Petr Viktorin <pviktori@redhat.com> - 5.4-4
- Add _ast to hgdemandimport ignore list
Works around: BZ#1871992
* Mon Aug 10 2020 Petr Stodulka <pstodulk@redhat.com> - 5.4-3
- Fix upgrade from previous mercurial 4.9 causing broken alternatives for
mercurial
- Resolves: #1831562
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Wed Jun 3 2020 Neal Becker <ndbecker2@gmail.com> - 5.4-1
- Update to 5.4
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 5.2-5
- Rebuilt for Python 3.9
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Dec 12 2019 Miro Hrončok <mhroncok@redhat.com> - 5.2-3
- Remove stray Python 2 files from the Python 3 package
* Tue Nov 26 2019 Miro Hrončok <mhroncok@redhat.com> - 5.2-2
- Use alternatives for /usr/bin/hg
* Mon Nov 25 2019 Petr Stodulka <pstodulk@redhat.com> - 5.2-1
- Update to 5.2
- Mercurial port is now much more stable on Python3 than before;
still some issues can be discovered regarding the Python3
- Relates: #1737931
* Sat Oct 19 2019 Petr Stodulka <pstodulk@redhat.com> - 5.1.2-2
- first attempt to create builds for py2 & py3 version
- separate lang into the own subpackage as files are shared between
mercurial for both pythons
- extensions are now prepared and working only under Python2
- the core mercurial is prepared in mercurial-python3 subpackage providing
the hg3 executable
- Relates: #1737931
* Sat Oct 19 2019 Petr Stodulka <pstodulk@redhat.com> - 5.1.2-1
- Update to 5.1.2
- fix patching of Makefiles
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Mon Apr 8 2019 Neal Becker <ndbecker2@gmail.com> - 4.9-1
- Update to 4.9
* Tue Mar 5 2019 Neal Becker <ndbecker2@gmail.com> - 4.7-3
- Fix shebang for python2
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Mon Aug 20 2018 Petr Stodulka <pstodulk@redhat.com> - 4.7-1
- Update to 4.7
* Sat Aug 11 2018 Tom Prince <tom.prince@ualberta.net> - 4.5.3-1
- Package chg extension.
* Sat Aug 11 2018 Petr Stodulka <pstodulk@redhat.com> - 4.5.3-1
- Update to 4.5.3
- Resolves: CVE-2018-1000132
* Tue Jul 24 2018 Sebastian Kisela <skisela@redhat.com> - 4.4.2-6
- Stop using deprecated python macros: https://fedoraproject.org/wiki/Packaging:Python
- Add gcc build time dependency, as gcc was removed from default buildroot package set.
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.4.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

Loading…
Cancel
Save