parent
12396cdc87
commit
cb9deda12a
@ -0,0 +1,34 @@
|
||||
From 04983c2511531fa1b8e2cb11d75af534fb462b02 Mon Sep 17 00:00:00 2001
|
||||
From: tigro <tigro@msvsphere-os.ru>
|
||||
Date: Fri, 31 May 2024 15:38:08 +0300
|
||||
Subject: [PATCH] Find BCG729
|
||||
|
||||
---
|
||||
CMakeLists.txt | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index adfe087..0bbd99e 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -135,6 +135,7 @@ include(CheckIncludeFile)
|
||||
include(CheckLibraryExists)
|
||||
include(CMakePushCheckState)
|
||||
include(GNUInstallDirs)
|
||||
+include(FindPkgConfig)
|
||||
|
||||
if(NOT CMAKE_INSTALL_RPATH AND CMAKE_INSTALL_PREFIX)
|
||||
set(CMAKE_INSTALL_RPATH ${CMAKE_INSTALL_FULL_LIBDIR})
|
||||
@@ -334,6 +335,9 @@ endif()
|
||||
if(ENABLE_G729 OR ENABLE_G729B_CNG)
|
||||
find_package(BCG729 1.1.1)
|
||||
if(NOT BCG729_FOUND)
|
||||
+ pkg_search_module(BCG729 REQUIRED libbcg729)
|
||||
+ endif()
|
||||
+ if(NOT BCG729_FOUND)
|
||||
message(WARNING "Could not find bcg729, mediastreamer2 will be compiled without G729 codec and G729 AnnexB in RFC3389.")
|
||||
set(ENABLE_G729 OFF CACHE BOOL "Build mediastreamer2 with the G729 codec." FORCE)
|
||||
set(ENABLE_G729_CNG OFF CACHE BOOL "Build mediastreamer2 with G729 Annex B cng." FORCE)
|
||||
--
|
||||
2.45.1
|
||||
|
Loading…
Reference in new issue