commit
7dbebc55f0
@ -0,0 +1 @@
|
|||||||
|
SOURCES/lrzsz-0.12.20.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
451e6a1813dfb71a412c973acd1b88b9ee3f28c4 SOURCES/lrzsz-0.12.20.tar.gz
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,20 @@
|
|||||||
|
--- lrzsz-0.12.20/src/lsz.c.glibc21 Tue Dec 29 17:07:59 1998
|
||||||
|
+++ lrzsz-0.12.20/src/lsz.c Mon Mar 8 10:56:19 1999
|
||||||
|
@@ -53,7 +53,6 @@
|
||||||
|
#ifndef STRICT_PROTOTYPES
|
||||||
|
extern time_t time();
|
||||||
|
extern char *strerror();
|
||||||
|
-extern char *strstr();
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifndef HAVE_ERRNO_DECLARATION
|
||||||
|
--- lrzsz-0.12.20/src/lrz.c.glibc21 Wed Dec 30 02:49:24 1998
|
||||||
|
+++ lrzsz-0.12.20/src/lrz.c Mon Mar 8 10:56:01 1999
|
||||||
|
@@ -44,7 +44,6 @@
|
||||||
|
#ifndef STRICT_PROTOTYPES
|
||||||
|
extern time_t time();
|
||||||
|
extern char *strerror();
|
||||||
|
-extern char *strstr();
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifndef HAVE_ERRNO_DECLARATION
|
@ -0,0 +1,67 @@
|
|||||||
|
diff -up lrzsz-0.12.20/man/lsz.1.man lrzsz-0.12.20/man/lsz.1
|
||||||
|
--- lrzsz-0.12.20/man/lsz.1.man 1998-04-26 15:22:41.000000000 +0200
|
||||||
|
+++ lrzsz-0.12.20/man/lsz.1 2011-03-07 13:02:40.069778076 +0100
|
||||||
|
@@ -133,7 +133,7 @@ The user must supply the file name to bo
|
||||||
|
|
||||||
|
If
|
||||||
|
.B sz
|
||||||
|
-is invoked with $SHELL set and iff that variable contains the
|
||||||
|
+is invoked with $SHELL set and if that variable contains the
|
||||||
|
string
|
||||||
|
.I "rsh"
|
||||||
|
,
|
||||||
|
@@ -207,7 +207,7 @@ for ZMODEM.
|
||||||
|
.B "-B NUMBER, --bufsize NUMBER"
|
||||||
|
Use a readbuffer of
|
||||||
|
.B NUMBER
|
||||||
|
-bytes. Default ist 16384, which should be enough
|
||||||
|
+bytes. Default is 16384, which should be enough
|
||||||
|
for most situations. If you have a slow machine or a bad disk interface
|
||||||
|
or suffer from other hardware problems you might want to increase
|
||||||
|
the buffersize.
|
||||||
|
@@ -219,7 +219,7 @@ option - things normally get worse, not
|
||||||
|
to swap.
|
||||||
|
|
||||||
|
Using this option turns of memory mapping of the input file. This
|
||||||
|
-increases memory and cpu usage.
|
||||||
|
+increases memory and CPU usage.
|
||||||
|
.TP
|
||||||
|
.B "-c COMMAND, --command COMMAND"
|
||||||
|
Send COMMAND to the receiver for execution, return with COMMAND\'s exit status.
|
||||||
|
@@ -265,7 +265,7 @@ give help.
|
||||||
|
.TP
|
||||||
|
.B "-i COMMAND, --immediate-command COMMAND"
|
||||||
|
Send COMMAND to the receiver for execution, return immediately
|
||||||
|
-upon the receiving program's successful recption of the command.
|
||||||
|
+upon the receiving program's successful reception of the command.
|
||||||
|
.TP
|
||||||
|
.B "-k, --1k"
|
||||||
|
(XMODEM/YMODEM) Send files using 1024 byte blocks
|
||||||
|
@@ -509,7 +509,7 @@ with conversion
|
||||||
|
.RB ( \-a )
|
||||||
|
to end of line conventions appropriate to the receiving environment.
|
||||||
|
With ZMODEM AutoDownload enabled, Professional-YAM and ZCOMM
|
||||||
|
-will automatically recieve
|
||||||
|
+will automatically receive
|
||||||
|
the files after performing a security check.
|
||||||
|
|
||||||
|
.br
|
||||||
|
@@ -593,7 +593,7 @@ the source file.
|
||||||
|
.SH "VMS VERSION"
|
||||||
|
The VMS version does not support wild cards.
|
||||||
|
Because of VMS DCL, upper case option letters muse be represented
|
||||||
|
-by \\ proceding the letter.
|
||||||
|
+by \\ proceeding the letter.
|
||||||
|
|
||||||
|
The current VMS version does not support XMODEM, XMODEM-1k, or YMODEM.
|
||||||
|
|
||||||
|
@@ -682,7 +682,7 @@ getting hot and bothered.
|
||||||
|
The test mode leaves a zero length file on the receiving system.
|
||||||
|
|
||||||
|
A few high speed modems have a firmware bug that drops characters when the
|
||||||
|
-direction of high speed transmissson is reversed.
|
||||||
|
+direction of high speed transmission is reversed.
|
||||||
|
The environment variable ZNULLS may be used to specify the number of nulls to
|
||||||
|
send before a ZDATA frame.
|
||||||
|
-Values of 101 for a 4.77 mHz PC and 124 for an AT are typical.
|
||||||
|
+Values of 101 for a 4.77 MHz PC and 124 for an AT are typical.
|
@ -0,0 +1,20 @@
|
|||||||
|
diff -urN lrzsz-0.12.20/src/zm.c lrzsz-0.12.20.new/src/zm.c
|
||||||
|
--- lrzsz-0.12.20/src/zm.c Tue Dec 29 09:48:38 1998
|
||||||
|
+++ lrzsz-0.12.20.new/src/zm.c Tue Oct 8 12:46:58 2002
|
||||||
|
@@ -431,10 +431,12 @@
|
||||||
|
VPRINTF(3,("zsdata: %lu %s", (unsigned long) length,
|
||||||
|
Zendnames[(frameend-ZCRCE)&3]));
|
||||||
|
crc = 0;
|
||||||
|
- do {
|
||||||
|
- zsendline(*buf); crc = updcrc((0377 & *buf), crc);
|
||||||
|
- buf++;
|
||||||
|
- } while (--length>0);
|
||||||
|
+
|
||||||
|
+ for( ; length; length--) {
|
||||||
|
+ zsendline(*buf); crc = updcrc((0377 & *buf), crc);
|
||||||
|
+ buf++;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
xsendline(ZDLE); xsendline(frameend);
|
||||||
|
crc = updcrc(frameend, crc);
|
||||||
|
|
@ -0,0 +1,33 @@
|
|||||||
|
Add additional #include directives to avoid implicit function
|
||||||
|
declarations and build failures with future compilers.
|
||||||
|
|
||||||
|
diff --git a/lib/long-options.c b/lib/long-options.c
|
||||||
|
index 76b979634aa4be46..9ee8f6609cdd2c2b 100644
|
||||||
|
--- a/lib/long-options.c
|
||||||
|
+++ b/lib/long-options.c
|
||||||
|
@@ -22,6 +22,7 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#include <stdio.h>
|
||||||
|
+#include <stdlib.h>
|
||||||
|
#include <getopt.h>
|
||||||
|
#include "long-options.h"
|
||||||
|
|
||||||
|
diff --git a/src/lsyslog.c b/src/lsyslog.c
|
||||||
|
index 6baf4a2b0a372fc5..0500280259b1af0a 100644
|
||||||
|
--- a/src/lsyslog.c
|
||||||
|
+++ b/src/lsyslog.c
|
||||||
|
@@ -18,11 +18,13 @@
|
||||||
|
02111-1307, USA.
|
||||||
|
|
||||||
|
*/
|
||||||
|
+#define _GNU_SOURCE /* for vasprintf */
|
||||||
|
#include "config.h"
|
||||||
|
#ifdef ENABLE_SYSLOG
|
||||||
|
#include "zglobal.h"
|
||||||
|
#include <pwd.h>
|
||||||
|
#include <stdlib.h>
|
||||||
|
+#include <stdio.h>
|
||||||
|
#include <string.h>
|
||||||
|
#endif
|
||||||
|
|
@ -0,0 +1,153 @@
|
|||||||
|
Various fixes for the configure script for C99 compatibility.
|
||||||
|
Most of the changes are generic in nature, due to the old version
|
||||||
|
of autoconf used by upstream (2.12).
|
||||||
|
|
||||||
|
diff --git a/configure b/configure
|
||||||
|
index db2672686719f7e1..c82ff072e4e1de5d 100755
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -1008,7 +1008,7 @@ cross_compiling=$ac_cv_prog_cc_cross
|
||||||
|
cat > conftest.$ac_ext <<EOF
|
||||||
|
#line 1010 "configure"
|
||||||
|
#include "confdefs.h"
|
||||||
|
-main(){return(0);}
|
||||||
|
+int main(){return(0);}
|
||||||
|
EOF
|
||||||
|
if { (eval echo configure:1014: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
|
||||||
|
ac_cv_prog_cc_works=yes
|
||||||
|
@@ -1489,8 +1489,8 @@ else
|
||||||
|
#define TOUPPER(c) (ISLOWER(c) ? 'A' + ((c) - 'a') : (c))
|
||||||
|
#define XOR(e, f) (((e) && !(f)) || (!(e) && (f)))
|
||||||
|
int main () { int i; for (i = 0; i < 256; i++)
|
||||||
|
-if (XOR (islower (i), ISLOWER (i)) || toupper (i) != TOUPPER (i)) exit(2);
|
||||||
|
-exit (0); }
|
||||||
|
+if (XOR (islower (i), ISLOWER (i)) || toupper (i) != TOUPPER (i)) return 2;
|
||||||
|
+return 0; }
|
||||||
|
|
||||||
|
EOF
|
||||||
|
if { (eval echo configure:1497: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest && (./conftest; exit) 2>/dev/null
|
||||||
|
@@ -1645,7 +1645,7 @@ for ac_kw in inline __inline__ __inline; do
|
||||||
|
#include "confdefs.h"
|
||||||
|
|
||||||
|
int main() {
|
||||||
|
-} $ac_kw foo() {
|
||||||
|
+} $ac_kw int foo() {
|
||||||
|
; return 0; }
|
||||||
|
EOF
|
||||||
|
if { (eval echo configure:1652: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
|
||||||
|
@@ -1917,8 +1917,8 @@ else
|
||||||
|
#define TOUPPER(c) (ISLOWER(c) ? 'A' + ((c) - 'a') : (c))
|
||||||
|
#define XOR(e, f) (((e) && !(f)) || (!(e) && (f)))
|
||||||
|
int main () { int i; for (i = 0; i < 256; i++)
|
||||||
|
-if (XOR (islower (i), ISLOWER (i)) || toupper (i) != TOUPPER (i)) exit(2);
|
||||||
|
-exit (0); }
|
||||||
|
+if (XOR (islower (i), ISLOWER (i)) || toupper (i) != TOUPPER (i)) return 2;
|
||||||
|
+return 0; }
|
||||||
|
|
||||||
|
EOF
|
||||||
|
if { (eval echo configure:1925: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest && (./conftest; exit) 2>/dev/null
|
||||||
|
@@ -2488,14 +2488,14 @@ else
|
||||||
|
#include "confdefs.h"
|
||||||
|
#include <stdio.h>
|
||||||
|
/* If setvbuf has the reversed format, exit 0. */
|
||||||
|
-main () {
|
||||||
|
+int main () {
|
||||||
|
/* This call has the arguments reversed.
|
||||||
|
A reversed system may check and see that the address of main
|
||||||
|
is not _IOLBF, _IONBF, or _IOFBF, and return nonzero. */
|
||||||
|
if (setvbuf(stdout, _IOLBF, (char *) main, BUFSIZ) != 0)
|
||||||
|
- exit(1);
|
||||||
|
+ return 1;
|
||||||
|
putc('\r', stdout);
|
||||||
|
- exit(0); /* Non-reversed systems segv here. */
|
||||||
|
+ return 0; /* Non-reversed systems segv here. */
|
||||||
|
}
|
||||||
|
EOF
|
||||||
|
if { (eval echo configure:2502: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest && (./conftest; exit) 2>/dev/null
|
||||||
|
@@ -2694,12 +2694,15 @@ else
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <fcntl.h>
|
||||||
|
#include <sys/mman.h>
|
||||||
|
+#include <sys/stat.h>
|
||||||
|
+#include <stdlib.h>
|
||||||
|
+
|
||||||
|
+#ifdef HAVE_UNISTD_H
|
||||||
|
+# include <unistd.h>
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/* This mess was copied from the GNU getpagesize.h. */
|
||||||
|
#ifndef HAVE_GETPAGESIZE
|
||||||
|
-# ifdef HAVE_UNISTD_H
|
||||||
|
-# include <unistd.h>
|
||||||
|
-# endif
|
||||||
|
|
||||||
|
/* Assume that all systems that can run configure have sys/param.h. */
|
||||||
|
# ifndef HAVE_SYS_PARAM_H
|
||||||
|
@@ -3032,9 +3035,9 @@ find_stack_direction ()
|
||||||
|
else
|
||||||
|
return (&dummy > addr) ? 1 : -1;
|
||||||
|
}
|
||||||
|
-main ()
|
||||||
|
+int main (void)
|
||||||
|
{
|
||||||
|
- exit (find_stack_direction() < 0);
|
||||||
|
+ return find_stack_direction() < 0;
|
||||||
|
}
|
||||||
|
EOF
|
||||||
|
if { (eval echo configure:3041: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest && (./conftest; exit) 2>/dev/null
|
||||||
|
@@ -3470,7 +3473,7 @@ else
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <sys/timeb.h>
|
||||||
|
#include <stdio.h>
|
||||||
|
-main ()
|
||||||
|
+int main (void)
|
||||||
|
{
|
||||||
|
struct timeb s, slast;
|
||||||
|
int c = 0;
|
||||||
|
@@ -3482,14 +3485,14 @@ main ()
|
||||||
|
|| (s.time == slast.time && s.millitm < slast.millitm)) {
|
||||||
|
fprintf(stderr,"s: %ld, %ld, slast: %ld, %ld\n",
|
||||||
|
s.time,s.millitm, slast.time,slast.millitm);
|
||||||
|
- exit (1);
|
||||||
|
+ return 1;
|
||||||
|
}
|
||||||
|
if (s.time != slast.time)
|
||||||
|
++c;
|
||||||
|
slast.time = s.time;
|
||||||
|
slast.millitm = s.millitm;
|
||||||
|
}
|
||||||
|
- exit (0);
|
||||||
|
+ return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
EOF
|
||||||
|
diff --git a/configure.in b/configure.in
|
||||||
|
index 429677e87e99a303..0fbe252a717afb59 100644
|
||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -180,7 +180,7 @@ AC_CACHE_VAL(lrzsz_cv_sys_ftime_ok,
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <sys/timeb.h>
|
||||||
|
#include <stdio.h>
|
||||||
|
-main ()
|
||||||
|
+int main (void)
|
||||||
|
{
|
||||||
|
struct timeb s, slast;
|
||||||
|
int c = 0;
|
||||||
|
@@ -192,14 +192,14 @@ main ()
|
||||||
|
|| (s.time == slast.time && s.millitm < slast.millitm)) {
|
||||||
|
fprintf(stderr,"s: %ld, %ld, slast: %ld, %ld\n",
|
||||||
|
s.time,s.millitm, slast.time,slast.millitm);
|
||||||
|
- exit (1);
|
||||||
|
+ return 1;
|
||||||
|
}
|
||||||
|
if (s.time != slast.time)
|
||||||
|
++c;
|
||||||
|
slast.time = s.time;
|
||||||
|
slast.millitm = s.millitm;
|
||||||
|
}
|
||||||
|
- exit (0);
|
||||||
|
+ return 0;
|
||||||
|
}
|
||||||
|
],
|
||||||
|
lrzsz_cv_sys_ftime_ok=yes,
|
@ -0,0 +1,26 @@
|
|||||||
|
Use socklen_t as the length of the socket address (which is a bit of
|
||||||
|
an anachronism, considering the rest of the sources). The previous
|
||||||
|
code des not work on 64-bit big-endian architectures.
|
||||||
|
|
||||||
|
diff --git a/src/tcp.c b/src/tcp.c
|
||||||
|
index 137f94c37503abe9..69da8c9f8dff304b 100644
|
||||||
|
--- a/src/tcp.c
|
||||||
|
+++ b/src/tcp.c
|
||||||
|
@@ -56,7 +56,7 @@ tcp_server (char *buf)
|
||||||
|
struct sockaddr_in s;
|
||||||
|
struct sockaddr_in t;
|
||||||
|
int on=1;
|
||||||
|
- size_t len;
|
||||||
|
+ socklen_t len;
|
||||||
|
|
||||||
|
if ((sock = socket (AF_INET, SOCK_STREAM, IPPROTO_TCP)) < 0) {
|
||||||
|
error(1,errno,"socket");
|
||||||
|
@@ -91,7 +91,7 @@ tcp_accept (int d)
|
||||||
|
{
|
||||||
|
int so;
|
||||||
|
struct sockaddr_in s;
|
||||||
|
- size_t namelen;
|
||||||
|
+ socklen_t namelen;
|
||||||
|
int num=0;
|
||||||
|
|
||||||
|
namelen = sizeof(s);
|
@ -0,0 +1,290 @@
|
|||||||
|
Summary: The lrz and lsz modem communications programs
|
||||||
|
Name: lrzsz
|
||||||
|
Version: 0.12.20
|
||||||
|
Release: 65%{?dist}
|
||||||
|
License: GPL-2.0-or-later AND GPL-2.0-only
|
||||||
|
Source: http://www.ohse.de/uwe/releases/%{name}-%{version}.tar.gz
|
||||||
|
Patch1: lrzsz-0.12.20-glibc21.patch
|
||||||
|
Patch2: lrzsz-0.12.20.patch
|
||||||
|
Patch3: lrzsz-0.12.20-man.patch
|
||||||
|
Patch4: lrzsz-0.12.20-aarch64.patch
|
||||||
|
Patch5: lrzsz-configure-c99.patch
|
||||||
|
Patch6: lrzsz-c99.patch
|
||||||
|
Patch7: lrzsz-socklen.patch
|
||||||
|
Url: http://www.ohse.de/uwe/software/lrzsz.html
|
||||||
|
BuildRequires: gcc gettext
|
||||||
|
BuildRequires: make
|
||||||
|
|
||||||
|
%description
|
||||||
|
Lrzsz (consisting of lrz and lsz) is a cosmetically modified
|
||||||
|
zmodem/ymodem/xmodem package built from the public-domain version of
|
||||||
|
the rzsz package. Lrzsz was created to provide a working GNU
|
||||||
|
copylefted Zmodem solution for Linux systems.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
|
||||||
|
%patch1 -p1 -b .glibc21
|
||||||
|
%patch2 -p1 -b .crc
|
||||||
|
%patch3 -p1 -b .man
|
||||||
|
%patch4 -p1 -b .aarch64
|
||||||
|
%patch5 -p1
|
||||||
|
%patch6 -p1
|
||||||
|
%patch7 -p1
|
||||||
|
|
||||||
|
rm -f po/*.gmo
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --disable-pubdir \
|
||||||
|
--enable-syslog \
|
||||||
|
--program-transform-name=s/l//
|
||||||
|
|
||||||
|
%make_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%make_install prefix=%{buildroot}/usr \
|
||||||
|
datadir=%{buildroot}/usr/share
|
||||||
|
|
||||||
|
for m in rb rx; do ln -s rz.1 %{buildroot}%{_mandir}/man1/$m.1; done
|
||||||
|
for m in sb sx; do ln -s sz.1 %{buildroot}%{_mandir}/man1/$m.1; done
|
||||||
|
|
||||||
|
%find_lang %{name}
|
||||||
|
|
||||||
|
%files -f %{name}.lang
|
||||||
|
%{_bindir}/*
|
||||||
|
%{_mandir}/*/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 0.12.20-65
|
||||||
|
- Bump release for June 2024 mass rebuild
|
||||||
|
|
||||||
|
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-64
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-63
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Dec 18 2023 Florian Weimer <fweimer@redhat.com> - 0.12.20-62
|
||||||
|
- Fix socket length incompatibility (C compatibility issue)
|
||||||
|
|
||||||
|
* Tue Oct 31 2023 Tomas Korbar <tkorbar@redhat.com> - 0.12.20-61
|
||||||
|
- Add additional SPDX licenses found by scancode tool
|
||||||
|
|
||||||
|
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-60
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Mar 12 2023 Tomas Korbar <tkorbar@redhat.com> - 0.12.20-59
|
||||||
|
- Change the License tag to the SPDX format
|
||||||
|
|
||||||
|
* Fri Jan 27 2023 Florian Weimer <fweimer@redhat.com> - 0.12.20-58
|
||||||
|
- Fix C99 compatibility issues (#2164996)
|
||||||
|
|
||||||
|
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-57
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-56
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-55
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-54
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-53
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Aug 17 2020 Tomas Korbar <tkorbar@redhat.com> - 0.12.20-52
|
||||||
|
- Use make macros
|
||||||
|
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||||
|
|
||||||
|
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-51
|
||||||
|
- Second attempt - Rebuilt for
|
||||||
|
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-50
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-49
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-48
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-47
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Sep 12 2018 Miroslav Lichvar <mlichvar@redhat.com> 0.12.20-46
|
||||||
|
- add man page symlinks for sb, sx, rb, rx programs (#1611501)
|
||||||
|
|
||||||
|
* Fri Jul 20 2018 Miroslav Lichvar <mlichvar@redhat.com> 0.12.20-45
|
||||||
|
- add gcc to build requirements
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-44
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-43
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-42
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-41
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-40
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.20-39
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.20-38
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.12.20-37
|
||||||
|
- Rebuilt for Fedora 23 Change
|
||||||
|
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.20-36
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.20-35
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.20-34
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Mar 26 2013 Miroslav Lichvar <mlichvar@redhat.com> 0.12.20-33
|
||||||
|
- use recent config.sub and config.guess for aarch64 (#926093)
|
||||||
|
- remove obsolete macros
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.20-32
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.20-31
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.20-30
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Mar 07 2011 Miroslav Lichvar <mlichvar@redhat.com> 0.12.20-29
|
||||||
|
- fix typos in sz man page (#668900)
|
||||||
|
|
||||||
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.20-28
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.20-27
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.20-26
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 11 2009 Miroslav Lichvar <mlichvar@redhat.com> 0.12.20-25
|
||||||
|
- rebuild message catalogs (#485024)
|
||||||
|
- remove dot from summary
|
||||||
|
|
||||||
|
* Thu Aug 7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.12.20-24
|
||||||
|
- fix license tag
|
||||||
|
|
||||||
|
* Fri Feb 15 2008 Than Ngo <than@redhat.com> 0.12.20-23
|
||||||
|
- rebuilt against GCC 3.4
|
||||||
|
|
||||||
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.12.20-22.1
|
||||||
|
- rebuild
|
||||||
|
|
||||||
|
* Thu Jun 08 2006 Than Ngo <than@redhat.com> 0.12.20-22
|
||||||
|
- add BR on gettext #193513
|
||||||
|
|
||||||
|
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.12.20-21.2.1
|
||||||
|
- bump again for double-long bug on ppc(64)
|
||||||
|
|
||||||
|
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.12.20-21.2
|
||||||
|
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||||
|
|
||||||
|
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Sat Mar 05 2005 Than Ngo <than@redhat.com> 0.12.20-21
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Wed Feb 09 2005 Than Ngo <than@redhat.com> 0.12.20-20
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Fri Oct 11 2002 Than Ngo <than@redhat.com> 0.12.20-15
|
||||||
|
- Fixed a bug with 16 bit ZMODEM transfer, jordanc@censoft.com (bug #75473)
|
||||||
|
|
||||||
|
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Thu May 23 2002 Tim Powers <timp@redhat.com>
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Tue Feb 26 2002 Than Ngo <than@redhat.com> 0.12.20-12
|
||||||
|
- rebuild
|
||||||
|
|
||||||
|
* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Fri Aug 10 2001 Than Ngo <than@redhat.com> 0.12.20-10
|
||||||
|
- Copyright->License
|
||||||
|
- use %%find_lang
|
||||||
|
|
||||||
|
* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- Bump release + rebuild.
|
||||||
|
|
||||||
|
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
|
||||||
|
- automatic rebuild
|
||||||
|
|
||||||
|
* Sun Jun 18 2000 Than Ngo <than@redhat.de>
|
||||||
|
- use RPM macros
|
||||||
|
|
||||||
|
* Sat May 27 2000 Ngo Than <than@redhat.de>
|
||||||
|
- rebuild for 7.0
|
||||||
|
- cleanup specfile
|
||||||
|
- add Url
|
||||||
|
- put man pages to correct place
|
||||||
|
|
||||||
|
* Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
|
||||||
|
- rebuild for sparc baud rates > 38400.
|
||||||
|
|
||||||
|
* Sat Feb 05 2000 Preston Brown <pbrown@redhat.com>
|
||||||
|
- rebuild to compress man pages, get new description
|
||||||
|
|
||||||
|
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
|
||||||
|
- auto rebuild in the new build environment (release 2)
|
||||||
|
|
||||||
|
* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
|
||||||
|
- upgraded to 0.12.20, i18n translations included.
|
||||||
|
|
||||||
|
* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
|
||||||
|
- Injected new description and group.
|
||||||
|
|
||||||
|
* Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
|
||||||
|
- bumped spec number for initial rh 6.0 build
|
||||||
|
|
||||||
|
* Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
|
||||||
|
- build root
|
||||||
|
|
||||||
|
* Thu May 07 1998 Prospector System <bugs@redhat.com>
|
||||||
|
- translations modified for de, fr, tr
|
||||||
|
|
||||||
|
* Tue Oct 21 1997 Donnie Barnes <djb@redhat.com>
|
||||||
|
- spec file cleanups
|
||||||
|
|
||||||
|
* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
|
||||||
|
- built against glibc
|
||||||
|
|
||||||
|
* Wed Mar 5 1997 msf@redhat.com <Michael Fulbright>
|
||||||
|
- Upgraded to 0.12.14 and changed makefiles so gettext isnt built.
|
Loading…
Reference in new issue