Update to 2013.01.19

el8
Nicolas Chauvet 12 years ago
parent 9bb326ab9e
commit 223a23ad24

2
.gitignore vendored

@ -1 +1 @@
live.2012.10.18.tar.gz live.2013.01.19.tar.gz

@ -1,55 +0,0 @@
diff -up live/config.linux.shared live/config.linux
--- live/config.linux.shared 2010-01-16 04:04:54.000000000 +0100
+++ live/config.linux 2010-01-16 17:16:37.479611105 +0100
@@ -1,4 +1,4 @@
-COMPILE_OPTS = $(INCLUDES) -I. -O2 -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64
+COMPILE_OPTS = $(INCLUDES) -I. $(CFLAGS) -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64
C = c
C_COMPILER = cc
C_FLAGS = $(COMPILE_OPTS)
@@ -9,9 +9,9 @@ OBJ = o
LINK = c++ -o
LINK_OPTS = -L.
CONSOLE_LINK_OPTS = $(LINK_OPTS)
-LIBRARY_LINK = ar cr
-LIBRARY_LINK_OPTS =
-LIB_SUFFIX = a
+LIBRARY_LINK = c++ -o
+LIBRARY_LINK_OPTS = $(LINK_OPTS) -shared -Wl,-soname,$@.$(SO_VERSION) $(LIBADDS)
+LIB_SUFFIX = so
LIBS_FOR_CONSOLE_APPLICATION =
LIBS_FOR_GUI_APPLICATION =
EXE =
diff -up live/config.linux.static.shared live/config.linux.static
--- live/config.linux.static.shared 2010-01-16 17:16:50.562862926 +0100
+++ live/config.linux.static 2010-01-16 17:16:57.271866612 +0100
@@ -1,4 +1,4 @@
-COMPILE_OPTS = $(INCLUDES) -I. -O2 -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64
+COMPILE_OPTS = $(INCLUDES) -I. $(CFLAGS) -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64
C = c
C_COMPILER = cc
C_FLAGS = $(COMPILE_OPTS)
diff -up live/Makefile.tail.shared live/Makefile.tail
--- live/Makefile.tail.shared 2012-04-27 21:53:46.000000000 +0200
+++ live/Makefile.tail 2012-05-01 15:55:42.856780542 +0200
@@ -12,13 +12,13 @@
PROXY_SERVER_DIR = proxyServer
all:
- cd $(LIVEMEDIA_DIR) ; $(MAKE)
- cd $(GROUPSOCK_DIR) ; $(MAKE)
- cd $(USAGE_ENVIRONMENT_DIR) ; $(MAKE)
- cd $(BASIC_USAGE_ENVIRONMENT_DIR) ; $(MAKE)
- cd $(TESTPROGS_DIR) ; $(MAKE)
- cd $(MEDIA_SERVER_DIR) ; $(MAKE)
- cd $(PROXY_SERVER_DIR) ; $(MAKE)
+ cd $(LIVEMEDIA_DIR) ; C_FLAGS="$(C_FLAGS)" $(MAKE)
+ cd $(GROUPSOCK_DIR) ; C_FLAGS="$(C_FLAGS)" $(MAKE)
+ cd $(USAGE_ENVIRONMENT_DIR) ; C_FLAGS="$(C_FLAGS)" $(MAKE)
+ cd $(BASIC_USAGE_ENVIRONMENT_DIR) ; C_FLAGS="$(C_FLAGS)" $(MAKE)
+ cd $(TESTPROGS_DIR) ; C_FLAGS="$(C_FLAGS)" $(MAKE)
+ cd $(MEDIA_SERVER_DIR) ; C_FLAGS="$(C_FLAGS)" $(MAKE)
+ cd $(PROXY_SERVER_DIR) ; C_FLAGS="$(C_FLAGS)" $(MAKE)
clean:
cd $(LIVEMEDIA_DIR) ; $(MAKE) clean

@ -1,21 +1,15 @@
%global date 2012.10.18
%global live_soversion 0
Name: live555 Name: live555
Version: 0 Version: 2013.01.19
Release: 0.38.%{date}%{?dist} Release: 1%{?dist}
Summary: Live555.com streaming libraries Summary: Live555.com streaming libraries
Group: System Environment/Libraries Group: System Environment/Libraries
License: LGPLv2+ License: LGPLv2+
URL: http://live555.com/liveMedia/ URL: http://live555.com/liveMedia/
Source0: http://live555.com/liveMedia/public/live.%{date}.tar.gz Source0: http://live555.com/liveMedia/public/live.%{version}.tar.gz
Patch0: live.2012.04.27-shared.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Provides: live555date%{_isa} = %{date}
# Packages using live555 must Requires this: # Packages using live555 must Requires this:
#{?live555date:Requires: live555date%{_isa} = %{live555date}} #{?live555_version:Requires: live555%{?_isa} = %{live555_version}}
%description %description
@ -33,7 +27,7 @@ been used to add streaming support to existing media player applications.
%package devel %package devel
Summary: Development files for live555.com streaming libraries Summary: Development files for live555.com streaming libraries
Group: Development/Libraries Group: Development/Libraries
Requires: %{name} = %{version}-%{release} Requires: %{name}%{?_isa} = %{version}-%{release}
Obsoletes: live-devel < 0-0.19.2008.04.03 Obsoletes: live-devel < 0-0.19.2008.04.03
Provides: live-devel = %{version}-%{release} Provides: live-devel = %{version}-%{release}
@ -52,7 +46,7 @@ been used to add streaming support to existing media player applications.
%package tools %package tools
Summary: RTSP streaming tools using live555.com streaming libraries Summary: RTSP streaming tools using live555.com streaming libraries
Group: Applications/Multimedia Group: Applications/Multimedia
Requires: %{name} = %{version}-%{release} Requires: %{name}%{?_isa} = %{version}-%{release}
Obsoletes: live-tools < 0-0.19.2008.04.03 Obsoletes: live-tools < 0-0.19.2008.04.03
Provides: live-tools = %{version}-%{release} Provides: live-tools = %{version}-%{release}
@ -72,101 +66,45 @@ This package contains the live555.com streaming server
(live555MediaServer), the example programs (openRTSP, playSIP, sapWatch, (live555MediaServer), the example programs (openRTSP, playSIP, sapWatch,
vobStreamer) and a variety of test tools. vobStreamer) and a variety of test tools.
%package static
Summary: Static libraries for %{name}
Group: Development/Libraries
Requires: %{name}-devel = %{version}-%{release}
%description static
The %{name}-static package contains static libraries for
developing applications that use %{name}.
%prep %prep
%setup -q -n live %setup -q -n live
install -pm 0644 config.linux config.linux.static sed -i -e "s/-O2/$RPM_OPT_FLAGS/" \
%patch0 -p1 -b .shared config.linux-with-shared-libraries
%build %build
./genMakefiles %{_target_os}.static ./genMakefiles %{_target_os}-with-shared-libraries
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" make %{?_smp_mflags}
mv $(find BasicUsageEnvironment groupsock liveMedia UsageEnvironment -name "*.a" ) $(pwd)
make clean
./genMakefiles %{_target_os}
make CFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC" SO_VERSION="%{live_soversion}"
%install %install
rm -rf $RPM_BUILD_ROOT make install DESTDIR=$RPM_BUILD_ROOT PREFIX=%{_prefix} LIBDIR=%{_libdir}
install -dm 755 $RPM_BUILD_ROOT{%{_libdir},%{_bindir}}
for i in BasicUsageEnvironment groupsock liveMedia UsageEnvironment ; do
install -dm 755 $RPM_BUILD_ROOT%{_includedir}/$i
install -pm 644 $i/include/*.h* $RPM_BUILD_ROOT%{_includedir}/$i/
install -pm 644 lib${i}.a $RPM_BUILD_ROOT%{_libdir}/lib${i}.a
install -pm 755 $i/lib${i}.so $RPM_BUILD_ROOT%{_libdir}/lib${i}.so.%{date}
ln -sf lib${i}.so.%{date} $RPM_BUILD_ROOT%{_libdir}/lib${i}.so.%{live_soversion}
ln -sf lib${i}.so.%{date} $RPM_BUILD_ROOT%{_libdir}/lib${i}.so
done
install -pm755 mediaServer/live555MediaServer $RPM_BUILD_ROOT%{_bindir}
pushd testProgs
for i in \
MPEG2TransportStreamIndexer \
openRTSP \
playSIP \
sapWatch \
testAMRAudioStreamer \
testMP3Receiver \
testMP3Streamer \
testMPEG1or2AudioVideoStreamer \
testMPEG1or2AudioVideoToDarwin \
testMPEG1or2ProgramToTransportStream \
testMPEG1or2Splitter \
testMPEG1or2VideoReceiver \
testMPEG1or2VideoStreamer \
testMPEG2TransportStreamTrickPlay \
testMPEG2TransportStreamer \
testMPEG4VideoStreamer \
testMPEG4VideoToDarwin \
testOnDemandRTSPServer \
testRelay \
testWAVAudioStreamer \
vobStreamer \
; do
install -pm755 $i $RPM_BUILD_ROOT%{_bindir}
done
popd
#RPM Macros support #RPM Macros support
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.live555 << EOF cat > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.live555 << EOF
# live555 RPM Macros # live555 RPM Macros
%live555date %{date} %live555_version %{version}
EOF EOF
touch -r COPYING $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.live555 touch -r COPYING $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.live555
%clean
rm -rf $RPM_BUILD_ROOT
%post -p /sbin/ldconfig %post -p /sbin/ldconfig
%postun -p /sbin/ldconfig %postun -p /sbin/ldconfig
%files %files
%defattr(-,root,root,-)
%{_libdir}/libBasicUsageEnvironment.so.* %{_libdir}/libBasicUsageEnvironment.so.*
%{_libdir}/libgroupsock.so.* %{_libdir}/libgroupsock.so.*
%{_libdir}/libliveMedia.so.* %{_libdir}/libliveMedia.so.*
%{_libdir}/libUsageEnvironment.so.* %{_libdir}/libUsageEnvironment.so.*
%files tools %files tools
%defattr(-,root,root,-)
%{_bindir}/* %{_bindir}/*
%files devel %files devel
%defattr(-,root,root,-)
%doc COPYING README %doc COPYING README
%config %{_sysconfdir}/rpm/macros.live555 %config %{_sysconfdir}/rpm/macros.live555
%{_libdir}/libBasicUsageEnvironment.so %{_libdir}/libBasicUsageEnvironment.so
@ -178,14 +116,16 @@ rm -rf $RPM_BUILD_ROOT
%{_includedir}/liveMedia/ %{_includedir}/liveMedia/
%{_includedir}/UsageEnvironment/ %{_includedir}/UsageEnvironment/
%files static
%defattr(-,root,root,644)
%{_libdir}/libBasicUsageEnvironment*.a
%{_libdir}/libgroupsock*.a
%{_libdir}/libliveMedia*.a
%{_libdir}/libUsageEnvironment*.a
%changelog %changelog
* Sun Jan 20 2013 Nicolas Chauvet <kwizart@gmail.com> - 2013.01.19-1
- Update to 2013.01.19
- Spec file cleanup
- Drop upstreamed patches
- Drop static built, not usefull with standard options
- Rename the %%live555date macro to %%live555_version
Dependencies must use the later instead.
* Thu Oct 18 2012 Nicolas Chauvet <kwizart@gmail.com> - 0-0.38.2012.10.18 * Thu Oct 18 2012 Nicolas Chauvet <kwizart@gmail.com> - 0-0.38.2012.10.18
- Update to 2012.10.18 - Update to 2012.10.18

@ -1 +1 @@
19c0063758be0bad1f2d010d9d552c92 live.2012.10.18.tar.gz 9ceec6e8fe27c48c2616bbf8f366b42d live.2013.01.19.tar.gz

Loading…
Cancel
Save