commit
07450b431b
@ -0,0 +1,2 @@
|
||||
SOURCES/linphone-desktop-5.2.0.tar.gz
|
||||
SOURCES/ispell-05574fe160222c3d0b6283c1433c9b087271fad1.tar.gz
|
@ -0,0 +1,2 @@
|
||||
759db34bfe29341fef07fe06acb3dadb9792385c SOURCES/linphone-desktop-5.2.0.tar.gz
|
||||
d7539a546a73251425524d142d5c79117548de4b SOURCES/ispell-05574fe160222c3d0b6283c1433c9b087271fad1.tar.gz
|
@ -0,0 +1,25 @@
|
||||
From 49198f9497f53bcc7fc70c69774f1aeaf56e052e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jani=20V=C3=A4limaa?= <wally@mageia.org>
|
||||
Date: Mon, 1 Jan 2024 15:04:12 +0200
|
||||
Subject: [PATCH] Fix RPATH
|
||||
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 7a52815..3232cfd 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -235,7 +235,7 @@ if(NOT APPLE OR MONO_ARCH)
|
||||
if(APPLE)
|
||||
set(CMAKE_INSTALL_RPATH "@executable_path/../Frameworks")
|
||||
elseif(UNIX)
|
||||
- set(CMAKE_INSTALL_RPATH "$ORIGIN:$ORIGIN/lib64:$ORIGIN/../lib64:$ORIGIN/lib:$ORIGIN/../lib")
|
||||
+ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_FULL_LIBDIR}/linphone")
|
||||
endif()
|
||||
add_subdirectory("external/ispell")
|
||||
add_subdirectory("linphone-app")
|
||||
--
|
||||
2.43.0
|
||||
|
@ -0,0 +1,159 @@
|
||||
From 26ced637fb7bba2ae706977b98812cf6da88fd5d Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jani=20V=C3=A4limaa?= <wally@mageia.org>
|
||||
Date: Mon, 1 Jan 2024 12:32:50 +0200
|
||||
Subject: [PATCH] Fix build
|
||||
|
||||
---
|
||||
CMakeLists.txt | 1 +
|
||||
linphone-app/CMakeLists.txt | 31 ++++++++++---------
|
||||
.../linphone_package/CMakeLists.txt | 16 +++++-----
|
||||
3 files changed, 26 insertions(+), 22 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index d41da3c..7a52815 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -237,6 +237,7 @@ if(NOT APPLE OR MONO_ARCH)
|
||||
elseif(UNIX)
|
||||
set(CMAKE_INSTALL_RPATH "$ORIGIN:$ORIGIN/lib64:$ORIGIN/../lib64:$ORIGIN/lib:$ORIGIN/../lib")
|
||||
endif()
|
||||
+ add_subdirectory("external/ispell")
|
||||
add_subdirectory("linphone-app")
|
||||
endfunction()
|
||||
add_linphone_app()
|
||||
diff --git a/linphone-app/CMakeLists.txt b/linphone-app/CMakeLists.txt
|
||||
index d3e0e7b..648ab30 100644
|
||||
--- a/linphone-app/CMakeLists.txt
|
||||
+++ b/linphone-app/CMakeLists.txt
|
||||
@@ -24,13 +24,14 @@ cmake_minimum_required(VERSION 3.22)
|
||||
|
||||
|
||||
#Linphone targets
|
||||
-set(LINPHONE_PACKAGES LinphoneCxx Mediastreamer2 Belcard LibLinphone)
|
||||
+set(LINPHONE_PACKAGES LinphoneCxx Mediastreamer2 BelCard LibLinphone)
|
||||
|
||||
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
|
||||
|
||||
-find_package(BCToolbox)
|
||||
+find_package(BCToolbox CONFIG REQUIRED)
|
||||
if(NOT BCToolbox_FOUND)
|
||||
- find_package(bctoolbox CONFIG REQUIRED)
|
||||
+ message("BCToolbox not FOUND")
|
||||
+ find_package(bctoolbox)
|
||||
endif()
|
||||
if(NOT LINPHONEAPP_VERSION)
|
||||
bc_compute_full_version(LINPHONEAPP_VERSION)
|
||||
@@ -105,17 +106,18 @@ set(ENABLE_DB_STORAGE ON CACHE BOOLEAN "Enable Storage")
|
||||
|
||||
foreach(PACKAGE ${LINPHONE_PACKAGES})
|
||||
message(STATUS "Trying to find ${PACKAGE}")
|
||||
- find_package(${PACKAGE})
|
||||
+ find_package(${PACKAGE} CONFIG REQUIRED)
|
||||
if(NOT ${PACKAGE}_FOUND)
|
||||
- find_package(${PACKAGE} CONFIG REQUIRED)
|
||||
+ message("${PACKAGE] not FOUND")
|
||||
+ find_package(${PACKAGE})
|
||||
endif()
|
||||
endforeach()
|
||||
|
||||
-set(PLUGIN_TARGETS ${LinphoneCxx_TARGET})
|
||||
-set(APP_TARGETS ${LinphoneCxx_TARGET}
|
||||
+set(PLUGIN_TARGETS liblinphone++)
|
||||
+set(APP_TARGETS liblinphone++
|
||||
${BCToolbox_TARGET}#Logger/App
|
||||
${Mediastreamer2_TARGET}#MediastreamerUtils
|
||||
- ${Belcard_TARGET}#VCard Model
|
||||
+ ${BelCard_TARGET}#VCard Model
|
||||
${LibLinphone_TARGET})#MediastreamerUtils
|
||||
|
||||
####################################
|
||||
@@ -728,6 +730,7 @@ include_directories("${LINPHONE_OUTPUT_DIR}/include/OpenGL")
|
||||
include_directories("${LINPHONE_OUTPUT_DIR}/include/")
|
||||
include_directories("${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR}/")
|
||||
include_directories("${QTKEYCHAIN_OUTPUT_DIR}/include/")
|
||||
+include_directories("${CMAKE_CURRENT_SOURCE_DIR}/include/")
|
||||
if(NOT APPLE AND NOT WIN32)
|
||||
include_directories("${ISpell_BINARY_DIR}/include")
|
||||
endif ()
|
||||
@@ -837,20 +840,20 @@ add_dependencies(${APP_LIBRARY} update_translations ${APP_PLUGIN})
|
||||
set(TOOLS_DIR "${CMAKE_BINARY_DIR}/programs")
|
||||
set(LINPHONE_BUILDER_SIGNING_IDENTITY ${LINPHONE_BUILDER_SIGNING_IDENTITY})
|
||||
|
||||
-add_custom_command(TARGET ${APP_PLUGIN} POST_BUILD COMMAND ${CMAKE_COMMAND} -E make_directory "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/")
|
||||
-add_custom_command(TARGET ${APP_PLUGIN} POST_BUILD COMMAND ${CMAKE_COMMAND} -E copy_directory "${CMAKE_CURRENT_SOURCE_DIR}/include/" "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR}/")
|
||||
-add_custom_command(TARGET ${APP_PLUGIN} POST_BUILD COMMAND ${CMAKE_COMMAND} -E copy $<TARGET_FILE:${APP_PLUGIN}> "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/")
|
||||
-add_custom_command(TARGET ${APP_PLUGIN} POST_BUILD COMMAND ${CMAKE_COMMAND} -E copy $<TARGET_LINKER_FILE:${APP_PLUGIN}> "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/")
|
||||
+#add_custom_command(TARGET ${APP_PLUGIN} POST_BUILD COMMAND ${CMAKE_COMMAND} -E make_directory "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/")
|
||||
+#add_custom_command(TARGET ${APP_PLUGIN} POST_BUILD COMMAND ${CMAKE_COMMAND} -E copy_directory "${CMAKE_CURRENT_SOURCE_DIR}/include/" "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR}/")
|
||||
+#add_custom_command(TARGET ${APP_PLUGIN} POST_BUILD COMMAND ${CMAKE_COMMAND} -E copy $<TARGET_FILE:${APP_PLUGIN}> "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/")
|
||||
+#add_custom_command(TARGET ${APP_PLUGIN} POST_BUILD COMMAND ${CMAKE_COMMAND} -E copy $<TARGET_LINKER_FILE:${APP_PLUGIN}> "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/")
|
||||
#add_custom_command(TARGET ${TARGET_NAME} PRE_BUILD COMMAND ${CMAKE_COMMAND} -E copy "${CMAKE_CURRENT_SOURCE_DIR}/include/LinphoneApp/*" "${CMAKE_INSTALL_PREFIX}/include/LinphoneApp/")
|
||||
|
||||
#configure_file("${CMAKE_CURRENT_SOURCE_DIR}/include/*" "${CMAKE_INSTALL_PREFIX}/include/LinphoneApp/" COPYONLY)
|
||||
-install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/include" DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}")
|
||||
+install(DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/include" DESTINATION "${CMAKE_INSTALL_PREFIX}")
|
||||
|
||||
|
||||
add_subdirectory(build)
|
||||
add_subdirectory(cmake_builder/linphone_package)
|
||||
|
||||
-deployqt_hack(${TARGET_NAME} ${LINPHONE_QML_DIR})
|
||||
+#deployqt_hack(${TARGET_NAME} ${LINPHONE_QML_DIR})
|
||||
|
||||
|
||||
# ------------------------------------------------------------------------------
|
||||
diff --git a/linphone-app/cmake_builder/linphone_package/CMakeLists.txt b/linphone-app/cmake_builder/linphone_package/CMakeLists.txt
|
||||
index b4d6590..f441fd4 100644
|
||||
--- a/linphone-app/cmake_builder/linphone_package/CMakeLists.txt
|
||||
+++ b/linphone-app/cmake_builder/linphone_package/CMakeLists.txt
|
||||
@@ -274,7 +274,7 @@ else()# Not Windows and Apple
|
||||
endif()
|
||||
endforeach(item)
|
||||
endif()
|
||||
- install(FILES ${SHARED_LIBRARIES} DESTINATION "lib")
|
||||
+ install(FILES ${SHARED_LIBRARIES} DESTINATION "${LIBDIR}/linphone")
|
||||
endif()
|
||||
if( EXISTS "${LINPHONE_OUTPUT_DIR}/lib64/")
|
||||
file(GLOB SHARED_LIBRARIES "${LINPHONE_OUTPUT_DIR}/lib64/*.so*")
|
||||
@@ -286,7 +286,7 @@ else()# Not Windows and Apple
|
||||
endif()
|
||||
endforeach(item)
|
||||
endif()
|
||||
- install(FILES ${SHARED_LIBRARIES} DESTINATION "lib64")
|
||||
+ install(FILES ${SHARED_LIBRARIES} DESTINATION "${LIBDIR}/linphone")
|
||||
endif()
|
||||
install(DIRECTORY "${LINPHONE_OUTPUT_DIR}/${CMAKE_INSTALL_DATAROOTDIR}/" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}" USE_SOURCE_PERMISSIONS
|
||||
PATTERN "linphone" EXCLUDE
|
||||
@@ -324,9 +324,9 @@ else()# Not Windows and Apple
|
||||
install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/../../assets/icons/hicolor/${DIR}/apps/icon.png" DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/${DIR}/apps/" RENAME "${EXECUTABLE_NAME}.png")
|
||||
endforeach ()
|
||||
install(TARGETS ${APP_PLUGIN}
|
||||
- ARCHIVE DESTINATION "${LIBDIR}"
|
||||
- LIBRARY DESTINATION "${LIBDIR}"
|
||||
- RUNTIME DESTINATION "${LIBDIR}"
|
||||
+ ARCHIVE DESTINATION "${LIBDIR}/linphone"
|
||||
+ LIBRARY DESTINATION "${LIBDIR}/linphone"
|
||||
+ RUNTIME DESTINATION "${LIBDIR}/linphone"
|
||||
)
|
||||
# WEBVIEW
|
||||
if(ENABLE_APP_WEBVIEW)
|
||||
@@ -370,13 +370,13 @@ if (MSVC)
|
||||
endif ()
|
||||
|
||||
|
||||
-install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E copy_directory \"${CMAKE_INSTALL_PREFIX}/include/\" \"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR}/\")")
|
||||
+#install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E copy_directory \"${CMAKE_INSTALL_PREFIX}/include/\" \"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR}/\")")
|
||||
#install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E remove_directory \"${CMAKE_INSTALL_PREFIX}/include/\")")
|
||||
# move share
|
||||
-install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E copy_directory \"${CMAKE_INSTALL_PREFIX}/share/\" \"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATAROOTDIR}/\")")
|
||||
+#install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E copy_directory \"${CMAKE_INSTALL_PREFIX}/share/\" \"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATAROOTDIR}/\")")
|
||||
#install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E remove_directory \"${CMAKE_INSTALL_PREFIX}/share/\")")
|
||||
# move mkspecs
|
||||
-install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E copy_directory \"${CMAKE_INSTALL_PREFIX}/mkspecs/\" \"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATAROOTDIR}/\")")
|
||||
+#install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E copy_directory \"${CMAKE_INSTALL_PREFIX}/mkspecs/\" \"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATAROOTDIR}/\")")
|
||||
#install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E remove_directory \"${CMAKE_INSTALL_PREFIX}/mkspecs/\")")
|
||||
# remove other folders
|
||||
#install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E remove_directory \"${CMAKE_INSTALL_PREFIX}/cmake/\")")
|
||||
--
|
||||
2.43.0
|
||||
|
@ -0,0 +1,39 @@
|
||||
From 4a02bc4493de58fa3ca3ba9945aca338384f5037 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jani=20V=C3=A4limaa?= <wally@mageia.org>
|
||||
Date: Mon, 1 Jan 2024 12:25:18 +0200
|
||||
Subject: [PATCH] Use system CA Bundle
|
||||
|
||||
---
|
||||
linphone-app/src/app/paths/Paths.cpp | 2 +-
|
||||
linphone-app/src/utils/Constants.hpp | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/linphone-app/src/app/paths/Paths.cpp b/linphone-app/src/app/paths/Paths.cpp
|
||||
index 47abe5c..320a240 100644
|
||||
--- a/linphone-app/src/app/paths/Paths.cpp
|
||||
+++ b/linphone-app/src/app/paths/Paths.cpp
|
||||
@@ -163,7 +163,7 @@ static inline QString getAppFactoryConfigFilePath () {
|
||||
}
|
||||
|
||||
static inline QString getAppRootCaFilePath () {
|
||||
- QString rootca = getAppPackageDataDirPath() + Constants::PathRootCa;
|
||||
+ QString rootca = Constants::PathRootCa;
|
||||
if(Paths::filePathExists(rootca.toStdString())){// Packaged
|
||||
return rootca;
|
||||
}
|
||||
diff --git a/linphone-app/src/utils/Constants.hpp b/linphone-app/src/utils/Constants.hpp
|
||||
index d79ea2b..be3b238 100644
|
||||
--- a/linphone-app/src/utils/Constants.hpp
|
||||
+++ b/linphone-app/src/utils/Constants.hpp
|
||||
@@ -140,7 +140,7 @@ public:
|
||||
static constexpr char PathConfig[] = "/linphonerc";
|
||||
static constexpr char PathDatabase[] = "/linphone.db";
|
||||
static constexpr char PathFactoryConfig[] = "/" EXECUTABLE_NAME "/linphonerc-factory";
|
||||
- static constexpr char PathRootCa[] = "/linphone/rootca.pem";
|
||||
+ static constexpr char PathRootCa[] = "/etc/pki/tls/cert.pem";
|
||||
static constexpr char PathFriendsList[] = "/friends.db";
|
||||
static constexpr char PathLimeDatabase[] = "/x3dh.c25519.sqlite3";
|
||||
static constexpr char PathMessageHistoryList[] = "/message-history.db";
|
||||
--
|
||||
2.43.0
|
||||
|
@ -0,0 +1,191 @@
|
||||
%global ispell_rev 05574fe160222c3d0b6283c1433c9b087271fad1
|
||||
|
||||
Summary: Voice over IP Application
|
||||
Name: linphone-desktop
|
||||
Version: 5.2.0
|
||||
Release: 1%{?dist}.inferit
|
||||
|
||||
License: GPLv2+
|
||||
URL: https://www.linphone.org/
|
||||
Source0: https://github.com/BelledonneCommunications/linphone-desktop/archive/%{version}/linphone-desktop-%{?gitdate}%{!?gitdate:%version}.tar.%{?gitdate:xz}%{!?gitdate:gz}
|
||||
Source1: https://gitlab.linphone.org/BC/public/external/ispell/-/archive/%{ispell_rev}/ispell-%{ispell_rev}.tar.gz
|
||||
Patch1: 0001-Fix-build.patch
|
||||
Patch2: 0001-Use-system-CA-Bundle.patch
|
||||
Patch3: 0001-Fix-RPATH.patch
|
||||
|
||||
BuildRequires: git-core
|
||||
BuildRequires: ninja-build
|
||||
BuildRequires: cmake
|
||||
BuildRequires: cmake(BCToolbox)
|
||||
BuildRequires: cmake(BelCard)
|
||||
BuildRequires: cmake(LibLinphone)
|
||||
BuildRequires: cmake(Qt5)
|
||||
BuildRequires: cmake(Qt5Gui)
|
||||
BuildRequires: cmake(Qt5Quick)
|
||||
BuildRequires: cmake(Qt5QuickCompiler)
|
||||
BuildRequires: cmake(Qt5Widgets)
|
||||
BuildRequires: cmake(Qt5QuickControls2)
|
||||
BuildRequires: cmake(Qt5Svg)
|
||||
BuildRequires: cmake(Qt5LinguistTools)
|
||||
BuildRequires: cmake(Qt5Concurrent)
|
||||
BuildRequires: cmake(Qt5Test)
|
||||
BuildRequires: cmake(Qt5Qml)
|
||||
BuildRequires: cmake(Qt5Multimedia)
|
||||
BuildRequires: cmake(Qt5Core)
|
||||
BuildRequires: cmake(mediastreamer2)
|
||||
BuildRequires: cmake(Ortp)
|
||||
BuildRequires: cmake(BelleSIP)
|
||||
BuildRequires: cmake(jsoncpp)
|
||||
BuildRequires: pkgconfig(sqlite3)
|
||||
BuildRequires: pkgconfig(libxml-2.0)
|
||||
|
||||
Provides: linphone = %{version}-%{release}
|
||||
Obsoletes: linphone < 4.1.1
|
||||
Obsoletes: linphoneqt < 4.2.2
|
||||
|
||||
Provides: bundled(ispell) = 3.4.05
|
||||
|
||||
%description
|
||||
Linphone is a free VoIP and video softphone based on the SIP protocol.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{name}-%{?gitdate}%{!?gitdate:%version} -p1 -Sgit -a1
|
||||
|
||||
# Use CMake configs to find libs
|
||||
for f in BCToolbox Belcard LibLinphone LinphoneCxx Mediastreamer2; do
|
||||
rm -rf linphone-app/cmake/Find${f}.cmake
|
||||
done
|
||||
|
||||
# Missing submodule
|
||||
rm -rf external/ispell
|
||||
ln -sf ../ispell-%{ispell_rev} external/ispell
|
||||
|
||||
# Fool build system a bit to get proper version output with 'linphone -v'
|
||||
%{_bindir}/git tag -a %{version} -m "%{version}"
|
||||
|
||||
%build
|
||||
export CXXFLAGS="%{build_cxxflags} -Wno-deprecated-declarations"
|
||||
%cmake -GNinja \
|
||||
-DLINPHONEAPP_INSTALL_PREFIX:PATH=%{_prefix} \
|
||||
-DLINPHONE_QT_ONLY:BOOL=ON \
|
||||
-DENABLE_APP_PACKAGE_ROOTCA=OFF \
|
||||
-DENABLE_BUILD_VERBOSE:BOOL=ON \
|
||||
-DENABLE_UPDATE_CHECK:BOOL=OFF \
|
||||
-DENABLE_NON_FREE_CODECS:BOOL=OFF \
|
||||
-DENABLE_QT_KEYCHAIN:BOOL=OFF
|
||||
%cmake_build
|
||||
|
||||
%install
|
||||
%cmake_install
|
||||
|
||||
# Move to a better location
|
||||
mv %{buildroot}%{_libdir}/libISpell.so \
|
||||
%{buildroot}%{_libdir}/linphone/
|
||||
|
||||
# Not needed
|
||||
rm -rf %{buildroot}%{_bindir}/qt.conf
|
||||
rm -rf %{buildroot}%{_datadir}/linphone/rootca.pem
|
||||
|
||||
%files
|
||||
%license LICENSE*
|
||||
%doc README.md CHANGELOG.md
|
||||
%{_bindir}/linphone
|
||||
%{_libdir}/linphone/
|
||||
%{_datadir}/applications/linphone.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/linphone.{png,svg}
|
||||
%{_datadir}/linphone/
|
||||
%{_includedir}/LinphoneApp/
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 30 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 5.2.0-1R.inferit
|
||||
- Rebuilt for MSVSphere 9.4
|
||||
|
||||
* Thu May 30 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 5.2.4-1.inferit
|
||||
- Rebuilt for MSVSphere 9.4
|
||||
|
||||
* Mon Jan 01 2024 wally <wally> 5.2.0-0.4.mga10
|
||||
+ Revision: 2025753
|
||||
- new version 5.2.0
|
||||
- use bundled ispell 3.4.05
|
||||
|
||||
* Fri Jun 09 2023 wally <wally> 5.0.17-1.mga9
|
||||
+ Revision: 1961538
|
||||
- new version 5.0.17
|
||||
|
||||
* Sat Dec 24 2022 wally <wally> 5.0.3-1.mga9
|
||||
+ Revision: 1926404
|
||||
- new version 5.0.3
|
||||
|
||||
* Sun Dec 04 2022 wally <wally> 4.4.11-1.mga9
|
||||
+ Revision: 1917545
|
||||
- new version 4.4.11
|
||||
|
||||
* Wed Aug 24 2022 wally <wally> 4.4.8-2.mga9
|
||||
+ Revision: 1879895
|
||||
- use system CA bundle
|
||||
|
||||
* Tue Aug 23 2022 wally <wally> 4.4.8-1.mga9
|
||||
+ Revision: 1879739
|
||||
- new version 4.4.8
|
||||
+ umeabot <umeabot>
|
||||
- Mageia 9 Mass Rebuild
|
||||
|
||||
* Sun Aug 01 2021 wally <wally> 4.2.5-3.git20210616.1.mga9
|
||||
+ Revision: 1738438
|
||||
- update to latest git snapshot
|
||||
|
||||
* Sat Dec 19 2020 wally <wally> 4.2.5-1.mga8
|
||||
+ Revision: 1661360
|
||||
- new version 4.2.5
|
||||
|
||||
* Thu Dec 17 2020 umeabot <umeabot> 4.2.4-2.mga8
|
||||
+ Revision: 1658958
|
||||
- Rebuild for new Qt5
|
||||
|
||||
* Mon Nov 23 2020 wally <wally> 4.2.4-1.mga8
|
||||
+ Revision: 1648782
|
||||
- new version 4.2.4
|
||||
- rediff P1
|
||||
|
||||
* Tue Oct 20 2020 wally <wally> 4.2.3-1.mga8
|
||||
+ Revision: 1637394
|
||||
- new version 4.2.3
|
||||
|
||||
* Sat Oct 03 2020 wally <wally> 4.2.2-1.mga8
|
||||
+ Revision: 1632061
|
||||
- rename as linphone-desktop
|
||||
- new version 4.2.2
|
||||
- add patches via Arch to build without linphone-sdk
|
||||
|
||||
* Sat Feb 15 2020 daviddavid <daviddavid> 4.1.1-7.mga8
|
||||
+ Revision: 1525741
|
||||
- use new cmake macros
|
||||
+ umeabot <umeabot>
|
||||
- Mageia 8 Mass Rebuild
|
||||
|
||||
* Sun Mar 31 2019 umeabot <umeabot> 4.1.1-6.mga7
|
||||
+ Revision: 1383207
|
||||
- Qt5 Rebuild
|
||||
|
||||
* Sun Nov 18 2018 wally <wally> 4.1.1-5.mga7
|
||||
+ Revision: 1331060
|
||||
- add patches from upstream to fix crashes with Qt >= 5.11 (mga#23854)
|
||||
|
||||
* Sat Sep 08 2018 wally <wally> 4.1.1-4.mga7
|
||||
+ Revision: 1257841
|
||||
- rebuild for aarch64
|
||||
|
||||
* Mon Jan 01 2018 wally <wally> 4.1.1-3.mga7
|
||||
+ Revision: 1188877
|
||||
- add more Qt5 requires
|
||||
|
||||
* Mon Jan 01 2018 wally <wally> 4.1.1-2.mga7
|
||||
+ Revision: 1188871
|
||||
- add Qt5 requires
|
||||
|
||||
* Mon Jan 01 2018 wally <wally> 4.1.1-1.mga7
|
||||
+ Revision: 1188854
|
||||
- obsolete old GTK based linphone
|
||||
- imported package linphoneqt
|
||||
|
Loading…
Reference in new issue