new upstream release 0.1.4

f41
David Tardon 9 years ago
parent 4c0fa44ced
commit 949ad9a8d0

1
.gitignore vendored

@ -19,3 +19,4 @@
/libvisio-0.1.0.tar.xz /libvisio-0.1.0.tar.xz
/libvisio-0.1.1.tar.xz /libvisio-0.1.1.tar.xz
/libvisio-0.1.3.tar.xz /libvisio-0.1.3.tar.xz
/libvisio-0.1.4.tar.xz

@ -1,34 +0,0 @@
From 75a02c586f6ec49d4316f79004834250ef42b0e0 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Sat, 25 Jul 2015 15:11:19 +0200
Subject: [PATCH] fix test
The previous version only worked with libxml2 < 2.9.2, because of a bug
in handling nested elements of the same name.
Change-Id: I1368cedf5845895154806d4ecf427bfbed19165f
---
configure.ac | 4 ++++
src/test/importtest.cpp | 6 +++---
2 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/src/test/importtest.cpp b/src/test/importtest.cpp
index 8554309..0296380 100644
--- a/src/test/importtest.cpp
+++ b/src/test/importtest.cpp
@@ -272,9 +272,9 @@ void ImportTest::testVsdxImportBgColorFromTheme()
void ImportTest::testVsdxCharBgColor()
{
m_doc = parse("bgcolor.vsdx", m_buffer);
- assertXPathNoAttribute(m_doc, "/document/page/layer/textObject/paragraph/span", "background-color");
- assertXPath(m_doc, "/document/page/layer/layer[2]/textObject/paragraph/span", "background-color", "#9dbb61");
- assertXPath(m_doc, "/document/page/layer/layer[2]/layer[2]/textObject/paragraph/span", "background-color", "#9dbb61");
+ assertXPathNoAttribute(m_doc, "/document/page/layer[1]/textObject/paragraph/span", "background-color");
+ assertXPath(m_doc, "/document/page/layer[2]/textObject/paragraph/span", "background-color", "#9dbb61");
+ assertXPath(m_doc, "/document/page/layer[3]/textObject/paragraph/span", "background-color", "#9dbb61");
}
CPPUNIT_TEST_SUITE_REGISTRATION(ImportTest);
--
2.1.0

@ -1,8 +1,8 @@
%global apiversion 0.1 %global apiversion 0.1
Name: libvisio Name: libvisio
Version: 0.1.3 Version: 0.1.4
Release: 5%{?dist} Release: 1%{?dist}
Summary: A library for import of Microsoft Visio diagrams Summary: A library for import of Microsoft Visio diagrams
License: MPLv2.0 License: MPLv2.0
@ -20,8 +20,6 @@ BuildRequires: pkgconfig(librevenge-0.0)
BuildRequires: pkgconfig(libxml-2.0) >= 2.9.2 BuildRequires: pkgconfig(libxml-2.0) >= 2.9.2
BuildRequires: pkgconfig(zlib) BuildRequires: pkgconfig(zlib)
Patch0: 0001-fix-test.patch
%description %description
%{name} is library providing ability to interpret and import %{name} is library providing ability to interpret and import
Microsoft Visio diagrams into various applications. You can find it Microsoft Visio diagrams into various applications. You can find it
@ -117,6 +115,9 @@ make check %{?_smp_mflags}
%{_mandir}/man1/vss2xhtml.1* %{_mandir}/man1/vss2xhtml.1*
%changelog %changelog
* Wed Dec 23 2015 David Tardon <dtardon@redhat.com> - 0.1.4-1
- new upstream release
* Wed Oct 28 2015 David Tardon <dtardon@redhat.com> - 0.1.3-5 * Wed Oct 28 2015 David Tardon <dtardon@redhat.com> - 0.1.3-5
- rebuild for ICU 56.1 - rebuild for ICU 56.1

@ -1 +1 @@
fda521a18bbfccc5f034ea02119e7998 libvisio-0.1.3.tar.xz bf5f66ef14b789cd5824de8b31841867 libvisio-0.1.4.tar.xz

Loading…
Cancel
Save