epel9
Gwyn Ciesla 5 years ago
parent bb87ccccc7
commit f2873b77e1

@ -1,68 +0,0 @@
From c17d66e5dce011acef34435598eddf7122458b33 Mon Sep 17 00:00:00 2001
From: Jean-Francois Dockes <jf@dockes.org>
Date: Thu, 13 Dec 2018 18:39:43 +0100
Subject: [PATCH] Ensure that the samples use the same largefile options as the
library
Create a configuration file specific to the samples, to mimick what a
regular application would have to do.
---
.gitignore | 2 ++
configure.ac | 2 +-
upnp/sample/common/config_sample.h.in | 21 +++++++++++++++++++++
upnp/sample/common/sample_util.h | 1 +
4 files changed, 25 insertions(+), 1 deletion(-)
create mode 100644 upnp/sample/common/config_sample.h.in
diff --git a/configure.ac b/configure.ac
index 108ad7bf..670d3632 100644
--- a/configure.ac
+++ b/configure.ac
@@ -432,7 +432,7 @@ AC_CANONICAL_HOST
# libraries : it contains information on the configuration of the
# installed libraries.
#
-AC_CONFIG_HEADERS([autoconfig.h upnp/inc/upnpconfig.h])
+AC_CONFIG_HEADERS([autoconfig.h upnp/inc/upnpconfig.h upnp/sample/common/config_sample.h])
AX_SYS_LARGEFILE_SENSITIVE
if test "x$ac_cv_sys_largefile_sensitive" = "xyes"; then
diff --git a/upnp/sample/common/config_sample.h.in b/upnp/sample/common/config_sample.h.in
new file mode 100644
index 00000000..8fbc38e3
--- /dev/null
+++ b/upnp/sample/common/config_sample.h.in
@@ -0,0 +1,21 @@
+/*
+ * On systems where the size of off_t depends on compile flags, libupnp needs
+ * the programs which use it to be built with the same options as itself.
+ * This is checked at compile time, but the actual variables (such as
+ * _FILE_OFFSET_BITS) are not exported by the library (to avoid surprises in
+ * applications).
+ * A "normal" application would need to explicitely configure large file
+ * support depending on how libupnp was built, using its own configure
+ * routines. For the samples, we equivalently let the main libupnp configure
+ * create this file.
+ */
+
+/* Number of bits in a file offset, on hosts where this is settable. */
+#undef _FILE_OFFSET_BITS
+
+/* Define to 1 to make fseeko visible on some hosts (e.g. glibc 2.2). */
+#undef _LARGEFILE_SOURCE
+
+/* Define for large files, on AIX-style hosts. */
+#undef _LARGE_FILES
+
diff --git a/upnp/sample/common/sample_util.h b/upnp/sample/common/sample_util.h
index 2bca04ff..6d853efb 100644
--- a/upnp/sample/common/sample_util.h
+++ b/upnp/sample/common/sample_util.h
@@ -44,6 +44,7 @@
extern "C" {
#endif /* __cplusplus */
+#include "config_sample.h"
#include "ithread.h"
#include "ixml.h" /* for IXML_Document, IXML_Element */
#include "upnp.h" /* for Upnp_EventType */

@ -1,12 +0,0 @@
diff -up libupnp-1.8.4/configure.ac.nobump libupnp-1.8.4/configure.ac
--- libupnp-1.8.4/configure.ac.nobump 2018-10-25 16:54:52.000000000 +0200
+++ libupnp-1.8.4/configure.ac 2019-01-08 15:17:39.420358079 +0100
@@ -388,7 +388,7 @@ dnl #AC_SUBST([LT_VERSION_UPNP], [
dnl #
dnl ############################################################################
AC_SUBST([LT_VERSION_IXML], [10:1:0])
-AC_SUBST([LT_VERSION_UPNP], [13:0:0])
+AC_SUBST([LT_VERSION_UPNP], [12:0:2])
dnl ############################################################################
dnl # Repeating the algorithm to place it closer to the modificatin place:
dnl # - library code modified: revision++

@ -1,14 +1,12 @@
Version: 1.8.4 Version: 1.12.1
Summary: Universal Plug and Play (UPnP) SDK Summary: Universal Plug and Play (UPnP) SDK
Name: libupnp Name: libupnp
Release: 4%{?dist} Release: 1%{?dist}
License: BSD License: BSD
URL: https://sourceforge.net/projects/pupnp URL: https://sourceforge.net/projects/pupnp
Source: https://downloads.sourceforge.net/pupnp/%{name}-%{version}.tar.bz2 Source: https://downloads.sourceforge.net/pupnp/%{name}-%{version}.tar.bz2
Patch0: libupnp-1.8.4-nobump.patch
Patch1: 96.patch
BuildRequires: gcc autoconf automake BuildRequires: gcc
%description %description
@ -26,9 +24,6 @@ the UPnP SDK libraries.
%prep %prep
%setup -q %setup -q
%patch0 -p1
%patch1 -p1
autoreconf
%build %build
%configure \ %configure \
@ -51,8 +46,8 @@ sed -i.rpath 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
%files %files
%license COPYING %license COPYING
%doc THANKS %doc THANKS
%{_libdir}/libixml.so.10* %{_libdir}/libixml.so.11*
%{_libdir}/libupnp.so.10* %{_libdir}/libupnp.so.16*
%files devel %files devel
%{_includedir}/upnp/ %{_includedir}/upnp/
@ -61,6 +56,9 @@ sed -i.rpath 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
%{_libdir}/pkgconfig/libupnp.pc %{_libdir}/pkgconfig/libupnp.pc
%changelog %changelog
* Thu Jul 16 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.12.1-1
- 1.12.1
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.4-4 * Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.4-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (libupnp-1.8.4.tar.bz2) = 403d7b6408a33330fc59fbe6284cc7bca10a675c41b323bba6b9c6461c8a82fbb39f4a1a07d1a3b55f049c637830ebf21bd825cd6c2f4eb17265018ccee9cbb6 SHA512 (libupnp-1.12.1.tar.bz2) = f13833118d08fc05273dc65a12596854b937c505b20d82e58eb1c2e1fa35dba0cafd5799475e030f3c698069046cc5256e6ef5afe398680e7ea881df953b95e6

Loading…
Cancel
Save