Add missing dependencies for `autogen.sh`

- Update patch

The source tarball, unlike the release tarball, does not contain any
configure scripts. We need to generate these using `autogen.sh`, which
requires a few more dependencies.

Since we changed source, the patch needed revision, too.
epel10
Sandro 1 year ago
parent 58ec48a669
commit 034b7db1b8
No known key found for this signature in database
GPG Key ID: 68D0FF74FE9F382A

@ -1,8 +1,10 @@
--- libunibreak-4.0/src/Makefile.in.offline_checks 2016-12-14 16:29:12.000000000 -0800 diff --git a/src/Makefile.am b/src/Makefile.am
+++ libunibreak-4.0/src/Makefile.in 2018-08-28 19:12:22.097289204 -0700 index 7f4b585..d7a8ad1 100644
@@ -848,20 +848,11 @@ --- a/src/Makefile.am
cat ${srcdir}/graphemebreakdata1.tmpl tmp.txt ${srcdir}/graphemebreakdata2.tmpl >> ${srcdir}/graphemebreakdata.c +++ b/src/Makefile.am
rm tmp.txt tmp.txt.bak @@ -98,17 +98,8 @@ tests_CPPFLAGS = -I$(srcdir)
tests_LDADD = libunibreak.la
tests_DEPENDENCIES = libunibreak.la
-check: LineBreakTest.txt WordBreakTest.txt GraphemeBreakTest.txt $(check_PROGRAMS) -check: LineBreakTest.txt WordBreakTest.txt GraphemeBreakTest.txt $(check_PROGRAMS)
+check: $(check_PROGRAMS) +check: $(check_PROGRAMS)
@ -19,6 +21,3 @@
-GraphemeBreakTest.txt: -GraphemeBreakTest.txt:
- wget http://www.unicode.org/Public/UNIDATA/auxiliary/GraphemeBreakTest.txt - wget http://www.unicode.org/Public/UNIDATA/auxiliary/GraphemeBreakTest.txt
- -
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:

@ -27,6 +27,7 @@ Patch2: %{name}-4.0-remove_unused_var.patch
BuildRequires: gcc BuildRequires: gcc
BuildRequires: make BuildRequires: make
BuildRequires: automake, autoconf, libtool
Provides: liblinebreak = %{version}-%{release} Provides: liblinebreak = %{version}-%{release}
Obsoletes: liblinebreak < %{obsEVR} Obsoletes: liblinebreak < %{obsEVR}
@ -55,6 +56,7 @@ cp -p %{SOURCE1} %{SOURCE2} %{SOURCE3} src/
%build %build
./autogen.sh
%configure --disable-static %configure --disable-static
%make_build %make_build

Loading…
Cancel
Save