commit
c1f306ea67
@ -0,0 +1 @@
|
|||||||
|
SOURCES/libtool-2.4.7.tar.xz
|
@ -0,0 +1 @@
|
|||||||
|
0c90f1b046ea9cd7b32a4b5a6a9df4b46ddb637a SOURCES/libtool-2.4.7.tar.xz
|
@ -0,0 +1,35 @@
|
|||||||
|
From 414deacee0f564afdf2d7750450274c581330a59 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Fr=C3=A9d=C3=A9ric=20B=C3=A9rat?= <fberat@redhat.com>
|
||||||
|
Date: Wed, 21 Dec 2022 13:14:03 +0100
|
||||||
|
Subject: [PATCH] tests: Fix grep warning about stray \ before /
|
||||||
|
|
||||||
|
Recent version of grep emit a warning if stray \ is found before /.
|
||||||
|
This leads to the link-order test failure.
|
||||||
|
|
||||||
|
* tests/link-order.at: Remove unneeded \ before /
|
||||||
|
---
|
||||||
|
tests/link-order.at | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/tests/link-order.at b/tests/link-order.at
|
||||||
|
index 3f01a00d..a145347f 100644
|
||||||
|
--- a/tests/link-order.at
|
||||||
|
+++ b/tests/link-order.at
|
||||||
|
@@ -99,12 +99,12 @@ aix* | interix*) ;; # These systems have different path syntax
|
||||||
|
case $hardcode_direct$hardcode_direct_absolute in
|
||||||
|
yesno)
|
||||||
|
AT_CHECK([if $EGREP relinking stderr; then
|
||||||
|
- $EGREP " .*\/new\/lib/libb$shared_ext .*\/old\/lib/libcee$shared_ext" stdout
|
||||||
|
+ $EGREP " .*/new/lib/libb$shared_ext .*/old/lib/libcee$shared_ext" stdout
|
||||||
|
else :; fi], [0], [ignore], [], [echo "wrong link order"])
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
AT_CHECK([if $EGREP relinking stderr; then
|
||||||
|
- $EGREP " -L.*\/new\/lib -lb -L.*\/old\/lib -lcee" stdout
|
||||||
|
+ $EGREP " -L.*/new/lib -lb -L.*/old/lib -lcee" stdout
|
||||||
|
else :; fi], [0], [ignore], [], [echo "wrong link order"])
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
--
|
||||||
|
2.38.1
|
||||||
|
|
@ -0,0 +1,35 @@
|
|||||||
|
From f7e477ec085414991c8160c7394bfaf2b1425c67 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Karsten Hopp <karsten@fedoraproject.org>
|
||||||
|
Date: Wed, 29 Oct 2014 13:27:27 +0100
|
||||||
|
Subject: [PATCH] remove /lib64 and /usr/lib64 rpath
|
||||||
|
|
||||||
|
---
|
||||||
|
m4/libtool.m4 | 5 ++++-
|
||||||
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/m4/libtool.m4 b/m4/libtool.m4
|
||||||
|
index f796d7b..41dd20a 100644
|
||||||
|
--- a/m4/libtool.m4
|
||||||
|
+++ b/m4/libtool.m4
|
||||||
|
@@ -2866,6 +2866,9 @@ linux* | k*bsd*-gnu | kopensolaris*-gnu | gnu*)
|
||||||
|
# before this can be enabled.
|
||||||
|
hardcode_into_libs=yes
|
||||||
|
|
||||||
|
+ # Add ABI-specific directories to the system library path.
|
||||||
|
+ sys_lib_dlsearch_path_spec="/lib64 /usr/lib64 /lib /usr/lib"
|
||||||
|
+
|
||||||
|
# Ideally, we could use ldconfig to report *all* directores which are
|
||||||
|
# searched for libraries, however this is still not possible. Aside from not
|
||||||
|
# being certain /sbin/ldconfig is available, command
|
||||||
|
@@ -2874,7 +2877,7 @@ linux* | k*bsd*-gnu | kopensolaris*-gnu | gnu*)
|
||||||
|
# appending ld.so.conf contents (and includes) to the search path.
|
||||||
|
if test -f /etc/ld.so.conf; then
|
||||||
|
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \[$]2)); skip = 1; } { if (!skip) print \[$]0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||||
|
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||||
|
+ sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
|
||||||
|
fi
|
||||||
|
|
||||||
|
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||||
|
--
|
||||||
|
2.1.0
|
||||||
|
|
@ -0,0 +1,53 @@
|
|||||||
|
Enabling lto will result in failure during test phase, to be precise test 67 will cause it.
|
||||||
|
Compiler flags for this test (and most likely for rest of them) are inherited from actual build phase.
|
||||||
|
I'm not sure if this is expected.
|
||||||
|
|
||||||
|
Most distribution disables this test. We try to keep it by stripping lto flags for it.
|
||||||
|
|
||||||
|
Origin for this tests: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=391427
|
||||||
|
|
||||||
|
--- a/tests/link-order2.at 2015-01-16 19:52:04.000000000 +0100
|
||||||
|
+++ b/tests/link-order2_new.at 2021-11-30 02:01:09.574451906 +0100
|
||||||
|
@@ -47,6 +47,8 @@
|
||||||
|
AT_KEYWORDS([libtool])
|
||||||
|
AT_KEYWORDS([interactive])dnl running 'wrong' may cause a popup window.
|
||||||
|
|
||||||
|
+NO_LTO_CFLAGS=${CFLAGS/-flto*-ffat-lto-objects }
|
||||||
|
+
|
||||||
|
eval `$LIBTOOL --config | $EGREP '^(shlibpath_var|allow_undefined_flag)='`
|
||||||
|
|
||||||
|
undefined_setting=-no-undefined
|
||||||
|
@@ -89,12 +91,12 @@
|
||||||
|
EOF
|
||||||
|
|
||||||
|
for file in a0 a1 b; do
|
||||||
|
- $LIBTOOL --mode=compile $CC $CPPFLAGS $CFLAGS -c $file.c
|
||||||
|
+ $LIBTOOL --mode=compile $CC $CPPFLAGS $NO_LTO_CFLAGS -c $file.c
|
||||||
|
done
|
||||||
|
-$CC $CPPFLAGS $CFLAGS -c main.c
|
||||||
|
+$CC $CPPFLAGS $NO_LTO_CFLAGS -c main.c
|
||||||
|
|
||||||
|
# Build an old, installed library.
|
||||||
|
-$LIBTOOL --mode=link $CC $CFLAGS $LDFLAGS $static -o liba0.la a0.lo -rpath $deflibdir
|
||||||
|
+$LIBTOOL --mode=link $CC $NO_LTO_CFLAGS $LDFLAGS $static -o liba0.la a0.lo -rpath $deflibdir
|
||||||
|
$LIBTOOL --mode=install cp liba0.la $deflibdir/liba0.la
|
||||||
|
$LIBTOOL --mode=clean rm -f liba0.la
|
||||||
|
|
||||||
|
@@ -118,13 +120,13 @@
|
||||||
|
esac
|
||||||
|
test non-libtool,-static-libtool-libs = "$type_of_depdepl,$static" &&
|
||||||
|
static=-all-static
|
||||||
|
- $LIBTOOL --mode=link $CC $CFLAGS $LDFLAGS $static -o liba1.la a1.lo -rpath $libdir
|
||||||
|
- $LIBTOOL --mode=link $CC $CFLAGS $LDFLAGS $static -o libb.la b.lo liba1.la -rpath $libdir
|
||||||
|
- AT_CHECK([$LIBTOOL --mode=link $CC $CFLAGS $LDFLAGS $static -o main$EXEEXT main.$OBJEXT libb.la -la0],
|
||||||
|
+ $LIBTOOL --mode=link $CC $NO_LTO_CFLAGS $LDFLAGS $static -o liba1.la a1.lo -rpath $libdir
|
||||||
|
+ $LIBTOOL --mode=link $CC $NO_LTO_CFLAGS $LDFLAGS $static -o libb.la b.lo liba1.la -rpath $libdir
|
||||||
|
+ AT_CHECK([$LIBTOOL --mode=link $CC $NO_LTO_CFLAGS $LDFLAGS $static -o main$EXEEXT main.$OBJEXT libb.la -la0],
|
||||||
|
[], [ignore], [ignore])
|
||||||
|
LT_AT_EXEC_CHECK([./main])
|
||||||
|
# Now test that if we reverse the link order, the program fails.
|
||||||
|
- AT_CHECK([$LIBTOOL --mode=link $CC $CFLAGS $LDFLAGS $static -o wrong$EXEEXT main.$OBJEXT -la0 libb.la],
|
||||||
|
+ AT_CHECK([$LIBTOOL --mode=link $CC $NO_LTO_CFLAGS $LDFLAGS $static -o wrong$EXEEXT main.$OBJEXT -la0 libb.la],
|
||||||
|
[], [ignore], [ignore])
|
||||||
|
if test yes, != "$shared_fails,$static"; then
|
||||||
|
LT_AT_EXEC_CHECK([./wrong], [1], [], [ignore], [|| (exit 1)])
|
@ -0,0 +1,16 @@
|
|||||||
|
diff -r -U5 libtool-2.4.6.old/tests/demo.at libtool-2.4.6/tests/demo.at
|
||||||
|
--- libtool-2.4.6.old/tests/demo.at 2022-01-31 22:15:48.539557030 +0100
|
||||||
|
+++ libtool-2.4.6/tests/demo.at 2022-02-01 09:43:30.262092074 +0100
|
||||||
|
@@ -508,11 +508,11 @@
|
||||||
|
## ----------- ##
|
||||||
|
|
||||||
|
AT_SETUP([force non-PIC objects])
|
||||||
|
|
||||||
|
AT_CHECK([case $host in
|
||||||
|
-hppa*|x86_64*|s390*)
|
||||||
|
+hppa*|x86_64*|s390*|arm*)
|
||||||
|
# These hosts cannot use non-PIC shared libs
|
||||||
|
exit 77 ;;
|
||||||
|
*-solaris*|*-sunos*)
|
||||||
|
# Libtool does not build non-PIC shared libs on these hosts
|
||||||
|
exit 77 ;;
|
@ -0,0 +1,58 @@
|
|||||||
|
diff -r -U5 libtool-2.4.6/build-aux/ltmain.in libtool-2.4.6.new/build-aux/ltmain.in
|
||||||
|
--- libtool-2.4.6/build-aux/ltmain.in 2022-02-22 09:21:35.317958251 +0100
|
||||||
|
+++ libtool-2.4.6.new/build-aux/ltmain.in 2022-02-22 09:16:10.117571787 +0100
|
||||||
|
@@ -501,21 +501,14 @@
|
||||||
|
fi
|
||||||
|
|
||||||
|
# preserve --debug
|
||||||
|
test : = "$debug_cmd" || func_append preserve_args " --debug"
|
||||||
|
|
||||||
|
- case $host in
|
||||||
|
- # Solaris2 added to fix http://debbugs.gnu.org/cgi/bugreport.cgi?bug=16452
|
||||||
|
- # see also: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=59788
|
||||||
|
- *cygwin* | *mingw* | *pw32* | *cegcc* | *solaris2* | *os2*)
|
||||||
|
- # don't eliminate duplications in $postdeps and $predeps
|
||||||
|
- opt_duplicate_compiler_generated_deps=:
|
||||||
|
- ;;
|
||||||
|
- *)
|
||||||
|
- opt_duplicate_compiler_generated_deps=$opt_preserve_dup_deps
|
||||||
|
- ;;
|
||||||
|
- esac
|
||||||
|
+ # Keeping compiler generated duplicates in $postdeps and $predeps is not
|
||||||
|
+ # harmful, and is necessary in a majority of systems that use it to satisfy
|
||||||
|
+ # symbol dependencies.
|
||||||
|
+ opt_duplicate_compiler_generated_deps=:
|
||||||
|
|
||||||
|
$opt_help || {
|
||||||
|
# Sanity checks first:
|
||||||
|
func_check_version_match
|
||||||
|
|
||||||
|
diff -r -U5 libtool-2.4.6/build-aux/ltmain.sh libtool-2.4.6.new/build-aux/ltmain.sh
|
||||||
|
--- libtool-2.4.6/build-aux/ltmain.sh 2015-02-15 17:15:12.000000000 +0100
|
||||||
|
+++ libtool-2.4.6.new/build-aux/ltmain.sh 2022-02-22 09:16:44.783613061 +0100
|
||||||
|
@@ -2413,21 +2413,14 @@
|
||||||
|
fi
|
||||||
|
|
||||||
|
# preserve --debug
|
||||||
|
test : = "$debug_cmd" || func_append preserve_args " --debug"
|
||||||
|
|
||||||
|
- case $host in
|
||||||
|
- # Solaris2 added to fix http://debbugs.gnu.org/cgi/bugreport.cgi?bug=16452
|
||||||
|
- # see also: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=59788
|
||||||
|
- *cygwin* | *mingw* | *pw32* | *cegcc* | *solaris2* | *os2*)
|
||||||
|
- # don't eliminate duplications in $postdeps and $predeps
|
||||||
|
- opt_duplicate_compiler_generated_deps=:
|
||||||
|
- ;;
|
||||||
|
- *)
|
||||||
|
- opt_duplicate_compiler_generated_deps=$opt_preserve_dup_deps
|
||||||
|
- ;;
|
||||||
|
- esac
|
||||||
|
+ # Keeping compiler generated duplicates in $postdeps and $predeps is not
|
||||||
|
+ # harmful, and is necessary in a majority of systems that use it to satisfy
|
||||||
|
+ # symbol dependencies.
|
||||||
|
+ opt_duplicate_compiler_generated_deps=:
|
||||||
|
|
||||||
|
$opt_help || {
|
||||||
|
# Sanity checks first:
|
||||||
|
func_check_version_match
|
||||||
|
|
@ -0,0 +1,28 @@
|
|||||||
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
|
index 13dfc63..5c5603a 100644
|
||||||
|
--- a/Makefile.am
|
||||||
|
+++ b/Makefile.am
|
||||||
|
@@ -311,6 +311,23 @@ libtool: $(ltmain_sh) $(config_status) $(dotversion)
|
||||||
|
|
||||||
|
include libltdl/ltdl.mk
|
||||||
|
|
||||||
|
+libltdl_libltdl_la_CFLAGS = $(CUSTOM_LTDL_CFLAGS)
|
||||||
|
+libltdl_libltdl_la_LDFLAGS += $(CUSTOM_LTDL_LDFLAGS)
|
||||||
|
+
|
||||||
|
+libltdl_dlopen_la_LDFLAGS += $(CUSTOM_LTDL_LDFLAGS)
|
||||||
|
+libltdl_dld_link_la_LDFLAGS += $(CUSTOM_LTDL_LDFLAGS)
|
||||||
|
+libltdl_dyld_la_LDFLAGS += $(CUSTOM_LTDL_LDFLAGS)
|
||||||
|
+libltdl_load_add_on_la_LDFLAGS += $(CUSTOM_LTDL_LDFLAGS)
|
||||||
|
+libltdl_loadlibrary_la_LDFLAGS += $(CUSTOM_LTDL_LDFLAGS)
|
||||||
|
+libltdl_shl_load_la_LDFLAGS += $(CUSTOM_LTDL_LDFLAGS)
|
||||||
|
+
|
||||||
|
+libltdl_dlopen_la_CFLAGS = $(CUSTOM_LTDL_CFLAGS)
|
||||||
|
+libltdl_dld_link_la_CFLAGS = $(CUSTOM_LTDL_CFLAGS)
|
||||||
|
+libltdl_dyld_la_CFLAGS = $(CUSTOM_LTDL_CFLAGS)
|
||||||
|
+libltdl_load_add_on_la_CFLAGS = $(CUSTOM_LTDL_CFLAGS)
|
||||||
|
+libltdl_loadlibrary_la_CFLAGS = $(CUSTOM_LTDL_CFLAGS)
|
||||||
|
+libltdl_shl_load_la_CFLAGS = $(CUSTOM_LTDL_CFLAGS)
|
||||||
|
+
|
||||||
|
lt_aclocal_m4 = $(srcdir)/$(ltdl_dir)/aclocal.m4
|
||||||
|
lt_config_h_in = $(srcdir)/$(ltdl_dir)/config-h.in
|
||||||
|
lt_configure = $(srcdir)/$(ltdl_dir)/configure
|
@ -0,0 +1,20 @@
|
|||||||
|
Include <string.h> for the strcmp function. This improves C99
|
||||||
|
compiler compatibility because it avoids an implicit function
|
||||||
|
declaration.
|
||||||
|
|
||||||
|
Submitted upstream:
|
||||||
|
|
||||||
|
<https://lists.gnu.org/archive/html/libtool-patches/2023-01/msg00000.html>
|
||||||
|
|
||||||
|
diff --git a/tests/lt_dlopen_a.at b/tests/lt_dlopen_a.at
|
||||||
|
index 95f18a0df165d41d..d3948738e4199cc6 100644
|
||||||
|
--- a/tests/lt_dlopen_a.at
|
||||||
|
+++ b/tests/lt_dlopen_a.at
|
||||||
|
@@ -27,6 +27,7 @@ AT_KEYWORDS([libltdl lt_dlopen_a])
|
||||||
|
AT_DATA([main.c],
|
||||||
|
[[#include <ltdl.h>
|
||||||
|
#include <stdio.h>
|
||||||
|
+#include <string.h>
|
||||||
|
|
||||||
|
/* This dlopen() in the main executable should override any dlopen()s in
|
||||||
|
shared libraries etc.
|
@ -0,0 +1,40 @@
|
|||||||
|
diff -up libtool-2.4.6/Makefile.in.nodocs libtool-2.4.6/Makefile.in
|
||||||
|
--- libtool-2.4.6/Makefile.in.nodocs 2017-04-21 12:46:20.704300023 +0200
|
||||||
|
+++ libtool-2.4.6/Makefile.in 2017-04-21 12:46:42.696840234 +0200
|
||||||
|
@@ -313,12 +313,11 @@ MAKEINFOHTML = $(MAKEINFO) --html
|
||||||
|
AM_MAKEINFOHTMLFLAGS = $(AM_MAKEINFOFLAGS)
|
||||||
|
DVIPS = dvips
|
||||||
|
RECURSIVE_TARGETS = all-recursive check-recursive cscopelist-recursive \
|
||||||
|
- ctags-recursive dvi-recursive html-recursive info-recursive \
|
||||||
|
- install-data-recursive install-dvi-recursive \
|
||||||
|
- install-exec-recursive install-html-recursive \
|
||||||
|
- install-info-recursive install-pdf-recursive \
|
||||||
|
- install-ps-recursive install-recursive installcheck-recursive \
|
||||||
|
- installdirs-recursive pdf-recursive ps-recursive \
|
||||||
|
+ ctags-recursive \
|
||||||
|
+ install-data-recursive \
|
||||||
|
+ install-exec-recursive \
|
||||||
|
+ install-recursive installcheck-recursive \
|
||||||
|
+ installdirs-recursive \
|
||||||
|
tags-recursive uninstall-recursive
|
||||||
|
am__can_run_installinfo = \
|
||||||
|
case $$AM_UPDATE_INFO_DIR in \
|
||||||
|
@@ -361,8 +360,7 @@ am__define_uniq_tagged_files = \
|
||||||
|
ETAGS = etags
|
||||||
|
CTAGS = ctags
|
||||||
|
CSCOPE = cscope
|
||||||
|
-am__DIST_COMMON = $(dist_man1_MANS) $(doc_libtool_TEXINFOS) \
|
||||||
|
- $(srcdir)/Makefile.in $(srcdir)/config-h.in \
|
||||||
|
+am__DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/config-h.in \
|
||||||
|
$(srcdir)/libltdl/ltdl.mk $(top_srcdir)/build-aux/compile \
|
||||||
|
$(top_srcdir)/build-aux/config.guess \
|
||||||
|
$(top_srcdir)/build-aux/config.sub \
|
||||||
|
@@ -1973,7 +1971,7 @@ info: info-recursive
|
||||||
|
info-am: $(INFO_DEPS)
|
||||||
|
|
||||||
|
install-data-am: install-data-local install-includeHEADERS \
|
||||||
|
- install-info-am install-ltdlincludeHEADERS install-man
|
||||||
|
+ install-ltdlincludeHEADERS
|
||||||
|
|
||||||
|
install-dvi: install-dvi-recursive
|
||||||
|
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue