|
|
|
@ -240,8 +240,8 @@ diff -up ./tools/grid.py.orig ./tools/grid.py
|
|
|
|
|
assert os.path.exists(dataset_pathname),"dataset not found"
|
|
|
|
|
diff -up ./Makefile.orig ./Makefile
|
|
|
|
|
--- ./Makefile.orig 2007-11-06 23:32:49.000000000 +1000
|
|
|
|
|
+++ ./Makefile 2008-02-04 17:22:47.000000000 +1000
|
|
|
|
|
@@ -1,8 +1,46 @@
|
|
|
|
|
+++ ./Makefile 2008-02-05 11:00:21.000000000 +1000
|
|
|
|
|
@@ -1,8 +1,41 @@
|
|
|
|
|
CXX? = g++
|
|
|
|
|
CFLAGS = -Wall -O3
|
|
|
|
|
+MAKE = make
|
|
|
|
@ -259,21 +259,16 @@ diff -up ./Makefile.orig ./Makefile
|
|
|
|
|
|
|
|
|
|
+export INSTDIR
|
|
|
|
|
+
|
|
|
|
|
+PROCESSOR=$(shell /bin/uname -p)
|
|
|
|
|
+ifeq "${PROCESSOR}" "x86_64"
|
|
|
|
|
+X86_64=64
|
|
|
|
|
+else
|
|
|
|
|
+X86_64=
|
|
|
|
|
+endif
|
|
|
|
|
+IS_64=$(shell /bin/uname -i | awk '/64/ {print 64}')
|
|
|
|
|
+
|
|
|
|
|
+ifndef LIBDIR
|
|
|
|
|
+LIB_INSTDIR=${INSTDIR}/lib${X86_64}
|
|
|
|
|
+LIB_INSTDIR=${INSTDIR}/lib${IS_64}
|
|
|
|
|
+else
|
|
|
|
|
+LIB_INSTDIR=${INSTDIR}/..${LIBDIR}
|
|
|
|
|
+endif
|
|
|
|
|
+
|
|
|
|
|
+ifndef LIBDIR
|
|
|
|
|
+LIBDIR=/usr/lib${X86_64}
|
|
|
|
|
+LIBDIR=/usr/lib${IS_64}
|
|
|
|
|
+endif
|
|
|
|
|
+
|
|
|
|
|
+export LIBDIR
|
|
|
|
@ -289,7 +284,7 @@ diff -up ./Makefile.orig ./Makefile
|
|
|
|
|
svm-predict: svm-predict.c svm.o
|
|
|
|
|
$(CXX) $(CFLAGS) svm-predict.c svm.o -o svm-predict -lm
|
|
|
|
|
svm-train: svm-train.c svm.o
|
|
|
|
|
@@ -12,4 +50,61 @@ svm-scale: svm-scale.c
|
|
|
|
|
@@ -12,4 +45,61 @@ svm-scale: svm-scale.c
|
|
|
|
|
svm.o: svm.cpp svm.h
|
|
|
|
|
$(CXX) $(CFLAGS) -c svm.cpp
|
|
|
|
|
clean:
|
|
|
|
|