|
|
|
@ -1,6 +1,6 @@
|
|
|
|
|
diff -up ./Makefile.orig ./Makefile
|
|
|
|
|
--- ./Makefile.orig 2007-08-22 15:23:34.000000000 +1000
|
|
|
|
|
+++ ./Makefile 2007-08-27 15:48:58.000000000 +1000
|
|
|
|
|
--- ./Makefile.orig 2007-08-30 15:29:42.000000000 +1000
|
|
|
|
|
+++ ./Makefile 2007-08-30 15:30:25.000000000 +1000
|
|
|
|
|
@@ -1,7 +1,31 @@
|
|
|
|
|
CXXC = g++
|
|
|
|
|
CFLAGS = -Wall -O3
|
|
|
|
@ -81,15 +81,15 @@ diff -up ./Makefile.orig ./Makefile
|
|
|
|
|
+ ${MAKE} -C python clean
|
|
|
|
|
+
|
|
|
|
|
diff -up ./python/Makefile.orig ./python/Makefile
|
|
|
|
|
--- ./python/Makefile.orig 2007-08-27 11:11:38.000000000 +1000
|
|
|
|
|
+++ ./python/Makefile 2007-08-29 17:38:14.000000000 +1000
|
|
|
|
|
@@ -2,13 +2,19 @@ CC = g++
|
|
|
|
|
--- ./python/Makefile.orig 2007-08-30 15:29:49.000000000 +1000
|
|
|
|
|
+++ ./python/Makefile 2007-08-30 16:03:46.000000000 +1000
|
|
|
|
|
@@ -2,7 +2,14 @@ CC = g++
|
|
|
|
|
SWIG ?= swig
|
|
|
|
|
|
|
|
|
|
#Windows: see ../README ../Makefile.win
|
|
|
|
|
-PYTHON_INCLUDEDIR ?= /usr/include/python2.4
|
|
|
|
|
+PYTHON_VERSION=${shell python -V 2> /tmp/python.ver ; cat /tmp/python.ver | awk 'BEGIN {FS= "[ .]"} {printf("%s.%s",$$2,$$3)}'; rm -f /tmp/python.ver}
|
|
|
|
|
+
|
|
|
|
|
+PYTHON_TEMP:=${shell mktemp}
|
|
|
|
|
+PYTHON_VERSION:=${shell python -V 2> ${PYTHON_TEMP} ; cat ${PYTHON_TEMP} | awk 'BEGIN {FS= "[ .]"} {printf("%s.%s",$$2,$$3)}'; rm -f ${PYTHON_TEMP}}
|
|
|
|
|
+ifndef PYTHON_INCLUDEDIR
|
|
|
|
|
+
|
|
|
|
|
+PYTHON_INCLUDEDIR?= /usr/include/python${PYTHON_VERSION}
|
|
|
|
@ -99,13 +99,7 @@ diff -up ./python/Makefile.orig ./python/Makefile
|
|
|
|
|
|
|
|
|
|
CFLAGS = -O3 -I$(PYTHON_INCLUDEDIR) -I..
|
|
|
|
|
LDFLAGS = -shared
|
|
|
|
|
# Mac OS
|
|
|
|
|
# LDFLAGS = -framework Python -bundle
|
|
|
|
|
-
|
|
|
|
|
all: svmc.so
|
|
|
|
|
|
|
|
|
|
svmc.so: svmc_wrap.o svm.o
|
|
|
|
|
@@ -28,3 +34,19 @@ clean:
|
|
|
|
|
@@ -28,3 +35,19 @@ clean:
|
|
|
|
|
|
|
|
|
|
moreclean: clean
|
|
|
|
|
rm -f svmc_wrap.c
|
|
|
|
@ -126,8 +120,8 @@ diff -up ./python/Makefile.orig ./python/Makefile
|
|
|
|
|
+
|
|
|
|
|
+
|
|
|
|
|
diff -up ./tools/grid.py.orig ./tools/grid.py
|
|
|
|
|
--- ./tools/grid.py.orig 2007-08-28 11:48:03.000000000 +1000
|
|
|
|
|
+++ ./tools/grid.py 2007-08-28 11:58:22.000000000 +1000
|
|
|
|
|
--- ./tools/grid.py.orig 2007-08-30 15:30:17.000000000 +1000
|
|
|
|
|
+++ ./tools/grid.py 2007-08-30 15:30:25.000000000 +1000
|
|
|
|
|
@@ -11,7 +11,7 @@ from string import find, split, join, at
|
|
|
|
|
|
|
|
|
|
is_win32 = (sys.platform == 'win32')
|
|
|
|
@ -138,8 +132,8 @@ diff -up ./tools/grid.py.orig ./tools/grid.py
|
|
|
|
|
else:
|
|
|
|
|
# example for windows
|
|
|
|
|
diff -up ./tools/easy.py.orig ./tools/easy.py
|
|
|
|
|
--- ./tools/easy.py.orig 2007-08-28 11:47:53.000000000 +1000
|
|
|
|
|
+++ ./tools/easy.py 2007-08-28 12:13:58.000000000 +1000
|
|
|
|
|
--- ./tools/easy.py.orig 2007-08-30 15:30:04.000000000 +1000
|
|
|
|
|
+++ ./tools/easy.py 2007-08-30 15:30:25.000000000 +1000
|
|
|
|
|
@@ -11,10 +11,10 @@ if len(sys.argv) <= 1:
|
|
|
|
|
|
|
|
|
|
is_win32 = (sys.platform == 'win32')
|
|
|
|
@ -155,4 +149,3 @@ diff -up ./tools/easy.py.orig ./tools/easy.py
|
|
|
|
|
gnuplot_exe = "/usr/bin/gnuplot"
|
|
|
|
|
else:
|
|
|
|
|
# example for windows
|
|
|
|
|
diff -up ./tools/subset.py.orig ./tools/subset.py
|