@ -1,6 +1,6 @@
diff -up ./java/Makefile. bak ./java/Makefile
diff -up ./java/Makefile. orig ./java/Makefile
--- ./java/Makefile. bak 2009-02-18 10:41:04.000000000 +1000
--- ./java/Makefile. orig 2009-02-18 10:41:04.000000000 +1000
+++ ./java/Makefile 2009-0 4-03 15:13:40 .000000000 +1000
+++ ./java/Makefile 2009-0 9-16 13:44:31 .000000000 +1000
@@ -4,13 +4,22 @@ FILES = libsvm/svm.class libsvm/svm_mode
@@ -4,13 +4,22 @@ FILES = libsvm/svm.class libsvm/svm_mode
libsvm/svm_print_interface.class \
libsvm/svm_print_interface.class \
svm_train.class svm_predict.class svm_toy.class svm_scale.class
svm_train.class svm_predict.class svm_toy.class svm_scale.class
@ -51,17 +51,17 @@ diff -up ./java/Makefile.bak ./java/Makefile
dist: clean all
dist: clean all
rm *.class libsvm/*.class
rm *.class libsvm/*.class
diff -up ./java/test_applet.html. bak ./java/test_applet.html
diff -up ./java/test_applet.html. orig ./java/test_applet.html
--- ./java/test_applet.html. bak 2003-07-12 14:07:32.000000000 +1000
--- ./java/test_applet.html. orig 2003-07-12 14:07:32.000000000 +1000
+++ ./java/test_applet.html 2009-0 4-03 15:04:06 .000000000 +1000
+++ ./java/test_applet.html 2009-0 9-16 13:44:31 .000000000 +1000
@@ -1 +1,3 @@
@@ -1 +1,3 @@
-<APPLET code="svm_toy.class" archive="libsvm.jar" width=300 height=350></APPLET>
-<APPLET code="svm_toy.class" archive="libsvm.jar" width=300 height=350></APPLET>
+<html>
+<html>
+<applet code="svm_toy.class" archive="libsvm.jar" width=300 height=350></applet>
+<applet code="svm_toy.class" archive="libsvm.jar" width=300 height=350></applet>
+</html>
+</html>
diff -up ./Makefile. bak ./Makefile
diff -up ./Makefile. orig ./Makefile
--- ./Makefile. bak 2008-09-15 14:36:48.000000000 +1000
--- ./Makefile. orig 2008-09-15 14:36:48.000000000 +1000
+++ ./Makefile 2009-0 4-03 15:04:06 .000000000 +1000
+++ ./Makefile 2009-0 9-16 14:40:39 .000000000 +1000
@@ -1,11 +1,40 @@
@@ -1,11 +1,40 @@
CXX? = g++
CXX? = g++
-CFLAGS = -Wall -Wconversion -O3 -fPIC
-CFLAGS = -Wall -Wconversion -O3 -fPIC
@ -106,7 +106,7 @@ diff -up ./Makefile.bak ./Makefile
svm-predict: svm-predict.c svm.o
svm-predict: svm-predict.c svm.o
$(CXX) $(CFLAGS) svm-predict.c svm.o -o svm-predict -lm
$(CXX) $(CFLAGS) svm-predict.c svm.o -o svm-predict -lm
@@ -16,4 +45, 59 @@ svm-scale: svm-scale.c
@@ -16,4 +45, 6 5 @@ svm-scale: svm-scale.c
svm.o: svm.cpp svm.h
svm.o: svm.cpp svm.h
$(CXX) $(CFLAGS) -c svm.cpp
$(CXX) $(CFLAGS) -c svm.cpp
clean:
clean:
@ -117,7 +117,9 @@ diff -up ./Makefile.bak ./Makefile
+svm-python:
+svm-python:
+ ${MAKE} -C python
+ ${MAKE} -C python
+svm-java:
+svm-java:
+ifneq ("${NO_JAVA}","NO_JAVA")
+ ${MAKE} -C java
+ ${MAKE} -C java
+endif
+svm-toy-gtk:
+svm-toy-gtk:
+ ${MAKE} -C svm-toy/gtk
+ ${MAKE} -C svm-toy/gtk
+svm-toy-qt:
+svm-toy-qt:
@ -138,14 +140,16 @@ diff -up ./Makefile.bak ./Makefile
+ install -m 644 *.c ${INSTDIR}/share/libsvm/src
+ install -m 644 *.c ${INSTDIR}/share/libsvm/src
+ install -m 644 *.cpp ${INSTDIR}/share/libsvm/src
+ install -m 644 *.cpp ${INSTDIR}/share/libsvm/src
+ install -m 644 Makefile ${INSTDIR}/share/libsvm/src
+ install -m 644 Makefile ${INSTDIR}/share/libsvm/src
+ifneq ("${NO_JAVA}","NO_JAVA")
+ install -m 644 java/*.java ${INSTDIR}/share/libsvm/src/java
+ install -m 644 java/*.java ${INSTDIR}/share/libsvm/src/java
+ install -m 644 java/Makefile ${INSTDIR}/share/libsvm/src/java
+ install -m 644 java/Makefile ${INSTDIR}/share/libsvm/src/java
+ install -m 644 java/libsvm/*.java ${INSTDIR}/share/libsvm/src/java/libsvm
+ install -m 644 java/libsvm/*.java ${INSTDIR}/share/libsvm/src/java/libsvm
+ install -m 644 java/libsvm/*.m4 ${INSTDIR}/share/libsvm/src/java/libsvm
+ install -m 644 java/libsvm/*.m4 ${INSTDIR}/share/libsvm/src/java/libsvm
+# install package libsvm-python
+ ${MAKE} -C python install
+# install package libsvm-java
+# install package libsvm-java
+ ${MAKE} -C java install
+ ${MAKE} -C java install
+endif
+# install package libsvm-python
+ ${MAKE} -C python install
+# install package svm-toy
+# install package svm-toy
+ install -m 755 svm-toy/gtk/svm-toy-gtk ${INSTDIR}/bin
+ install -m 755 svm-toy/gtk/svm-toy-gtk ${INSTDIR}/bin
+ install -m 755 svm-toy/qt/svm-toy-qt ${INSTDIR}/bin
+ install -m 755 svm-toy/qt/svm-toy-qt ${INSTDIR}/bin
@ -162,14 +166,16 @@ diff -up ./Makefile.bak ./Makefile
+ rm -fr ${INSTDIR}/libsvm/src
+ rm -fr ${INSTDIR}/libsvm/src
+ rm -fr ${INSTDIR}/libsvm
+ rm -fr ${INSTDIR}/libsvm
+ ${MAKE} -C python uninstall
+ ${MAKE} -C python uninstall
+ifneq ("${NO_JAVA}","NO_JAVA")
+ ${MAKE} -C java uninstall
+ ${MAKE} -C java uninstall
+endif
+ rm -f ${INSTDIR}/bin/svm-toy-gtk
+ rm -f ${INSTDIR}/bin/svm-toy-gtk
+ rm -f ${INSTDIR}/bin/svm-toy-qt
+ rm -f ${INSTDIR}/bin/svm-toy-qt
+
+
+
+
diff -up ./python/Makefile. bak ./python/Makefile
diff -up ./python/Makefile. orig ./python/Makefile
--- ./python/Makefile. bak 2008-12-10 09:05:08.000000000 +1000
--- ./python/Makefile. orig 2008-12-10 09:05:08.000000000 +1000
+++ ./python/Makefile 2009-0 4-03 15:21:19 .000000000 +1000
+++ ./python/Makefile 2009-0 9-16 13:44:31 .000000000 +1000
@@ -2,9 +2,11 @@ CXX? = g++
@@ -2,9 +2,11 @@ CXX? = g++
SWIG ?= swig
SWIG ?= swig
@ -217,9 +223,9 @@ diff -up ./python/Makefile.bak ./python/Makefile
+uninstall:
+uninstall:
+ rm -fr ${LIBDIR}/python${PYTHON_VERSION}/site-packages/libsvm
+ rm -fr ${LIBDIR}/python${PYTHON_VERSION}/site-packages/libsvm
+
+
diff -up ./svm-toy/gtk/callbacks.cpp. bak ./svm-toy/gtk/callbacks.cpp
diff -up ./svm-toy/gtk/callbacks.cpp. orig ./svm-toy/gtk/callbacks.cpp
--- ./svm-toy/gtk/callbacks.cpp. bak 2006-03-04 17:40:12.000000000 +1000
--- ./svm-toy/gtk/callbacks.cpp. orig 2006-03-04 17:40:12.000000000 +1000
+++ ./svm-toy/gtk/callbacks.cpp 2009-0 4-03 15:04:06 .000000000 +1000
+++ ./svm-toy/gtk/callbacks.cpp 2009-0 9-16 13:44:31 .000000000 +1000
@@ -2,6 +2,7 @@
@@ -2,6 +2,7 @@
#include <stdio.h>
#include <stdio.h>
#include <ctype.h>
#include <ctype.h>
@ -228,9 +234,9 @@ diff -up ./svm-toy/gtk/callbacks.cpp.bak ./svm-toy/gtk/callbacks.cpp
#include "callbacks.h"
#include "callbacks.h"
#include "interface.h"
#include "interface.h"
#include "../../svm.h"
#include "../../svm.h"
diff -up ./svm-toy/gtk/Makefile. bak ./svm-toy/gtk/Makefile
diff -up ./svm-toy/gtk/Makefile. orig ./svm-toy/gtk/Makefile
--- ./svm-toy/gtk/Makefile. bak 2007-10-14 16:29:12.000000000 +1000
--- ./svm-toy/gtk/Makefile. orig 2007-10-14 16:29:12.000000000 +1000
+++ ./svm-toy/gtk/Makefile 2009-0 4-03 15:04:06 .000000000 +1000
+++ ./svm-toy/gtk/Makefile 2009-0 9-16 13:44:31 .000000000 +1000
@@ -2,21 +2,27 @@ CC? = gcc
@@ -2,21 +2,27 @@ CC? = gcc
CXX? = g++
CXX? = g++
CFLAGS = -Wall -O3 -g `gtk-config --cflags`
CFLAGS = -Wall -O3 -g `gtk-config --cflags`
@ -267,10 +273,10 @@ diff -up ./svm-toy/gtk/Makefile.bak ./svm-toy/gtk/Makefile
clean:
clean:
- rm -f *~ callbacks.o svm-toy main.o interface.o callbacks.o ../../svm.o
- rm -f *~ callbacks.o svm-toy main.o interface.o callbacks.o ../../svm.o
+ rm -f *~ callbacks.o svm-toy-gtk main.o interface.o callbacks.o
+ rm -f *~ callbacks.o svm-toy-gtk main.o interface.o callbacks.o
diff -up ./svm-toy/qt/Makefile. bak ./svm-toy/qt/Makefile
diff -up ./svm-toy/qt/Makefile. orig ./svm-toy/qt/Makefile
--- ./svm-toy/qt/Makefile. bak 2008-12-19 16:42:05.000000000 +1000
--- ./svm-toy/qt/Makefile. orig 2008-12-19 16:42:05.000000000 +1000
+++ ./svm-toy/qt/Makefile 2009-0 4-03 15:25:25 .000000000 +1000
+++ ./svm-toy/qt/Makefile 2009-0 9-16 13:44:31 .000000000 +1000
@@ -1,17 +1,2 0 @@
@@ -1,17 +1,2 1 @@
CXX? = g++
CXX? = g++
-CFLAGS = -Wall -O3 -I$(INCLUDE) -I$(INCLUDE)/QtGui -lQtGui
-CFLAGS = -Wall -O3 -I$(INCLUDE) -I$(INCLUDE)/QtGui -lQtGui
+CFLAGS = -Wall -O3
+CFLAGS = -Wall -O3
@ -279,10 +285,12 @@ diff -up ./svm-toy/qt/Makefile.bak ./svm-toy/qt/Makefile
+LIBS= -L${LOCAL_LIBDIR} -lsvm
+LIBS= -L${LOCAL_LIBDIR} -lsvm
+
+
INCLUDE = /usr/include/qt4
INCLUDE = /usr/include/qt4
MOC = /usr/bin/moc-qt4
-MOC = /usr/bin/moc-qt4
-svm-toy: svm-toy.cpp svm-toy.moc ../../svm.o
-svm-toy: svm-toy.cpp svm-toy.moc ../../svm.o
- $(CXX) $(CFLAGS) svm-toy.cpp ../../svm.o -o svm-toy
- $(CXX) $(CFLAGS) svm-toy.cpp ../../svm.o -o svm-toy
+MOC=${MOC_PATH}
+
+all: svm-toy-qt
+all: svm-toy-qt
+
+
+svm-toy-qt: svm-toy.cpp svm-toy.moc
+svm-toy-qt: svm-toy.cpp svm-toy.moc
@ -298,9 +306,9 @@ diff -up ./svm-toy/qt/Makefile.bak ./svm-toy/qt/Makefile
- rm -f *~ svm-toy svm-toy.moc ../../svm.o
- rm -f *~ svm-toy svm-toy.moc ../../svm.o
+ rm -f *~ svm-toy-qt svm-toy.moc ../../svm.o
+ rm -f *~ svm-toy-qt svm-toy.moc ../../svm.o
diff -up ./tools/easy.py. bak ./tools/easy.py
diff -up ./tools/easy.py. orig ./tools/easy.py
--- ./tools/easy.py. bak 2009-01-14 07:13:26.000000000 +1000
--- ./tools/easy.py. orig 2009-01-14 07:13:26.000000000 +1000
+++ ./tools/easy.py 2009-0 4-03 15:04:06 .000000000 +1000
+++ ./tools/easy.py 2009-0 9-16 13:44:31 .000000000 +1000
@@ -2,6 +2,7 @@
@@ -2,6 +2,7 @@
import sys
import sys
@ -324,9 +332,9 @@ diff -up ./tools/easy.py.bak ./tools/easy.py
gnuplot_exe = "/usr/bin/gnuplot"
gnuplot_exe = "/usr/bin/gnuplot"
else:
else:
# example for windows
# example for windows
diff -up ./tools/grid.py. bak ./tools/grid.py
diff -up ./tools/grid.py. orig ./tools/grid.py
--- ./tools/grid.py. bak 2008-08-08 20:41:11.000000000 +1000
--- ./tools/grid.py. orig 2008-08-08 20:41:11.000000000 +1000
+++ ./tools/grid.py 2009-0 4-03 15:04:06 .000000000 +1000
+++ ./tools/grid.py 2009-0 9-16 13:44:31 .000000000 +1000
@@ -11,7 +11,7 @@ from subprocess import *
@@ -11,7 +11,7 @@ from subprocess import *
is_win32 = (sys.platform == 'win32')
is_win32 = (sys.platform == 'win32')