Fix build error

epel8
Ding-Yi Chen 17 years ago
parent 085b892bdd
commit 95d9efdf40

@ -131,7 +131,7 @@ diff -up ./python/cross_validation.py.orig ./python/cross_validation.py
diff -up ./python/svm_test.py.orig ./python/svm_test.py diff -up ./python/svm_test.py.orig ./python/svm_test.py
diff -up ./python/Makefile.orig ./python/Makefile diff -up ./python/Makefile.orig ./python/Makefile
--- ./python/Makefile.orig 2007-11-06 23:32:49.000000000 +1000 --- ./python/Makefile.orig 2007-11-06 23:32:49.000000000 +1000
+++ ./python/Makefile 2008-02-04 16:49:05.000000000 +1000 +++ ./python/Makefile 2008-02-05 09:37:16.000000000 +1000
@@ -2,9 +2,16 @@ CXX? = g++ @@ -2,9 +2,16 @@ CXX? = g++
SWIG ?= swig SWIG ?= swig
@ -386,7 +386,7 @@ diff -up ./svm-toy/qt/Makefile.orig ./svm-toy/qt/Makefile
rm -f *~ svm-toy svm-toy.moc ../../svm.o rm -f *~ svm-toy svm-toy.moc ../../svm.o
diff -up ./svm-toy/gtk/Makefile.orig ./svm-toy/gtk/Makefile diff -up ./svm-toy/gtk/Makefile.orig ./svm-toy/gtk/Makefile
--- ./svm-toy/gtk/Makefile.orig 2008-02-04 15:44:19.000000000 +1000 --- ./svm-toy/gtk/Makefile.orig 2008-02-04 15:44:19.000000000 +1000
+++ ./svm-toy/gtk/Makefile 2008-02-04 17:19:37.000000000 +1000 +++ ./svm-toy/gtk/Makefile 2008-02-05 09:33:08.000000000 +1000
@@ -1,22 +1,25 @@ @@ -1,22 +1,25 @@
CC? = gcc CC? = gcc
CXX? = g++ CXX? = g++
@ -415,11 +415,20 @@ diff -up ./svm-toy/gtk/Makefile.orig ./svm-toy/gtk/Makefile
- $(CXX) $(CFLAGS) -c callbacks.cpp - $(CXX) $(CFLAGS) -c callbacks.cpp
+ $(CXX) $(COPT) -c callbacks.cpp + $(CXX) $(COPT) -c callbacks.cpp
-../../svm.o: ../../svm.o:
- cd ../..; make svm.o cd ../..; make svm.o
+#../../svm.o:
+# cd ../..; make svm.o
clean: clean:
- rm -f *~ callbacks.o svm-toy main.o interface.o callbacks.o ../../svm.o - rm -f *~ callbacks.o svm-toy main.o interface.o callbacks.o ../../svm.o
+ rm -f *~ callbacks.o svm-toy main.o interface.o callbacks.o + rm -f *~ callbacks.o svm-toy main.o interface.o callbacks.o
diff -up ./svm-toy/gtk/callbacks.cpp.orig ./svm-toy/gtk/callbacks.cpp
--- ./svm-toy/gtk/callbacks.cpp.orig 2008-02-05 09:43:28.000000000 +1000
+++ ./svm-toy/gtk/callbacks.cpp 2008-02-05 09:43:42.000000000 +1000
@@ -2,6 +2,7 @@
#include <stdio.h>
#include <ctype.h>
#include <list>
+#include <stdlib.h>
#include "callbacks.h"
#include "interface.h"
#include "../../svm.h"

@ -1,6 +1,6 @@
Name: libsvm Name: libsvm
Version: 2.85 Version: 2.85
Release: 0%{?dist} Release: 1%{?dist}
Summary: A Library for Support Vector Machines Summary: A Library for Support Vector Machines
Group: Development/Libraries Group: Development/Libraries
@ -163,6 +163,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog %changelog
* Mon Feb 04 2008 Ding-Yi Chen <dchen@redhat.com> - 2.85-1
- Fix build error
* Mon Feb 04 2008 Ding-Yi Chen <dchen@redhat.com> - 2.85-0 * Mon Feb 04 2008 Ding-Yi Chen <dchen@redhat.com> - 2.85-0
- Upgrade to 2.85 - Upgrade to 2.85
- Include guide.pdf in main package - Include guide.pdf in main package

Loading…
Cancel
Save