|
|
@ -1,3 +1,4 @@
|
|
|
|
|
|
|
|
diff -up ./Makefile.orig ./Makefile
|
|
|
|
--- ./Makefile.orig 2007-08-22 15:23:34.000000000 +1000
|
|
|
|
--- ./Makefile.orig 2007-08-22 15:23:34.000000000 +1000
|
|
|
|
+++ ./Makefile 2007-08-27 15:48:58.000000000 +1000
|
|
|
|
+++ ./Makefile 2007-08-27 15:48:58.000000000 +1000
|
|
|
|
@@ -1,7 +1,31 @@
|
|
|
|
@@ -1,7 +1,31 @@
|
|
|
@ -33,7 +34,7 @@
|
|
|
|
|
|
|
|
|
|
|
|
svm-predict: svm-predict.c svm.o
|
|
|
|
svm-predict: svm-predict.c svm.o
|
|
|
|
$(CXXC) $(CFLAGS) svm-predict.c svm.o -o svm-predict -lm
|
|
|
|
$(CXXC) $(CFLAGS) svm-predict.c svm.o -o svm-predict -lm
|
|
|
|
@@ -11,5 +35,45 @@
|
|
|
|
@@ -11,5 +35,45 @@ svm-scale: svm-scale.c
|
|
|
|
$(CXXC) $(CFLAGS) svm-scale.c -o svm-scale
|
|
|
|
$(CXXC) $(CFLAGS) svm-scale.c -o svm-scale
|
|
|
|
svm.o: svm.cpp svm.h
|
|
|
|
svm.o: svm.cpp svm.h
|
|
|
|
$(CXXC) $(CFLAGS) -c svm.cpp
|
|
|
|
$(CXXC) $(CFLAGS) -c svm.cpp
|
|
|
@ -79,14 +80,15 @@
|
|
|
|
rm -f *~ svm.o svm-train svm-predict svm-scale
|
|
|
|
rm -f *~ svm.o svm-train svm-predict svm-scale
|
|
|
|
+ ${MAKE} -C python clean
|
|
|
|
+ ${MAKE} -C python clean
|
|
|
|
+
|
|
|
|
+
|
|
|
|
|
|
|
|
diff -up ./python/Makefile.orig ./python/Makefile
|
|
|
|
--- ./python/Makefile.orig 2007-08-27 11:11:38.000000000 +1000
|
|
|
|
--- ./python/Makefile.orig 2007-08-27 11:11:38.000000000 +1000
|
|
|
|
+++ ./python/Makefile 2007-08-28 11:15:18.000000000 +1000
|
|
|
|
+++ ./python/Makefile 2007-08-29 17:10:28.000000000 +1000
|
|
|
|
@@ -2,13 +2,19 @@
|
|
|
|
@@ -2,13 +2,19 @@ CC = g++
|
|
|
|
SWIG ?= swig
|
|
|
|
SWIG ?= swig
|
|
|
|
|
|
|
|
|
|
|
|
#Windows: see ../README ../Makefile.win
|
|
|
|
#Windows: see ../README ../Makefile.win
|
|
|
|
-PYTHON_INCLUDEDIR ?= /usr/include/python2.4
|
|
|
|
-PYTHON_INCLUDEDIR ?= /usr/include/python2.4
|
|
|
|
+PYTHON_VERSION=${shell python -V 2> python.ver ; cat python.ver | awk 'BEGIN {FS= "[ .]"} {printf("%s.%s",$$2,$$3)}'; rm -f python.ver}
|
|
|
|
+PYTHON_VERSION=${shell python -V 2> python.ver ; cat python.ver | /bin/awk 'BEGIN {FS= "[ .]"} {printf("%s.%s",$$2,$$3)}'; rm -f python.ver}
|
|
|
|
+
|
|
|
|
+
|
|
|
|
+ifndef PYTHON_INCLUDEDIR
|
|
|
|
+ifndef PYTHON_INCLUDEDIR
|
|
|
|
+
|
|
|
|
+
|
|
|
@ -103,7 +105,7 @@
|
|
|
|
all: svmc.so
|
|
|
|
all: svmc.so
|
|
|
|
|
|
|
|
|
|
|
|
svmc.so: svmc_wrap.o svm.o
|
|
|
|
svmc.so: svmc_wrap.o svm.o
|
|
|
|
@@ -28,3 +34,19 @@
|
|
|
|
@@ -28,3 +34,19 @@ clean:
|
|
|
|
|
|
|
|
|
|
|
|
moreclean: clean
|
|
|
|
moreclean: clean
|
|
|
|
rm -f svmc_wrap.c
|
|
|
|
rm -f svmc_wrap.c
|
|
|
@ -123,9 +125,10 @@
|
|
|
|
+
|
|
|
|
+
|
|
|
|
+
|
|
|
|
+
|
|
|
|
+
|
|
|
|
+
|
|
|
|
|
|
|
|
diff -up ./tools/grid.py.orig ./tools/grid.py
|
|
|
|
--- ./tools/grid.py.orig 2007-08-28 11:48:03.000000000 +1000
|
|
|
|
--- ./tools/grid.py.orig 2007-08-28 11:48:03.000000000 +1000
|
|
|
|
+++ ./tools/grid.py 2007-08-28 11:58:22.000000000 +1000
|
|
|
|
+++ ./tools/grid.py 2007-08-28 11:58:22.000000000 +1000
|
|
|
|
@@ -11,7 +11,7 @@
|
|
|
|
@@ -11,7 +11,7 @@ from string import find, split, join, at
|
|
|
|
|
|
|
|
|
|
|
|
is_win32 = (sys.platform == 'win32')
|
|
|
|
is_win32 = (sys.platform == 'win32')
|
|
|
|
if not is_win32:
|
|
|
|
if not is_win32:
|
|
|
@ -134,9 +137,10 @@
|
|
|
|
gnuplot_exe = "/usr/bin/gnuplot"
|
|
|
|
gnuplot_exe = "/usr/bin/gnuplot"
|
|
|
|
else:
|
|
|
|
else:
|
|
|
|
# example for windows
|
|
|
|
# example for windows
|
|
|
|
|
|
|
|
diff -up ./tools/easy.py.orig ./tools/easy.py
|
|
|
|
--- ./tools/easy.py.orig 2007-08-28 11:47:53.000000000 +1000
|
|
|
|
--- ./tools/easy.py.orig 2007-08-28 11:47:53.000000000 +1000
|
|
|
|
+++ ./tools/easy.py 2007-08-28 12:13:58.000000000 +1000
|
|
|
|
+++ ./tools/easy.py 2007-08-28 12:13:58.000000000 +1000
|
|
|
|
@@ -11,10 +11,10 @@
|
|
|
|
@@ -11,10 +11,10 @@ if len(sys.argv) <= 1:
|
|
|
|
|
|
|
|
|
|
|
|
is_win32 = (sys.platform == 'win32')
|
|
|
|
is_win32 = (sys.platform == 'win32')
|
|
|
|
if not is_win32:
|
|
|
|
if not is_win32:
|
|
|
@ -151,3 +155,4 @@
|
|
|
|
gnuplot_exe = "/usr/bin/gnuplot"
|
|
|
|
gnuplot_exe = "/usr/bin/gnuplot"
|
|
|
|
else:
|
|
|
|
else:
|
|
|
|
# example for windows
|
|
|
|
# example for windows
|
|
|
|
|
|
|
|
diff -up ./tools/subset.py.orig ./tools/subset.py
|
|
|
|