|
|
@ -82,13 +82,13 @@ diff -up ./Makefile.orig ./Makefile
|
|
|
|
+
|
|
|
|
+
|
|
|
|
diff -up ./python/Makefile.orig ./python/Makefile
|
|
|
|
diff -up ./python/Makefile.orig ./python/Makefile
|
|
|
|
--- ./python/Makefile.orig 2007-08-27 11:11:38.000000000 +1000
|
|
|
|
--- ./python/Makefile.orig 2007-08-27 11:11:38.000000000 +1000
|
|
|
|
+++ ./python/Makefile 2007-08-29 17:10:28.000000000 +1000
|
|
|
|
+++ ./python/Makefile 2007-08-29 17:38:14.000000000 +1000
|
|
|
|
@@ -2,13 +2,19 @@ CC = g++
|
|
|
|
@@ -2,13 +2,19 @@ CC = g++
|
|
|
|
SWIG ?= swig
|
|
|
|
SWIG ?= swig
|
|
|
|
|
|
|
|
|
|
|
|
#Windows: see ../README ../Makefile.win
|
|
|
|
#Windows: see ../README ../Makefile.win
|
|
|
|
-PYTHON_INCLUDEDIR ?= /usr/include/python2.4
|
|
|
|
-PYTHON_INCLUDEDIR ?= /usr/include/python2.4
|
|
|
|
+PYTHON_VERSION=${shell python -V 2> python.ver ; cat python.ver | /bin/awk 'BEGIN {FS= "[ .]"} {printf("%s.%s",$$2,$$3)}'; rm -f python.ver}
|
|
|
|
+PYTHON_VERSION=${shell python -V 2> /tmp/python.ver ; cat /tmp/python.ver | awk 'BEGIN {FS= "[ .]"} {printf("%s.%s",$$2,$$3)}'; rm -f /tmp/python.ver}
|
|
|
|
+
|
|
|
|
+
|
|
|
|
+ifndef PYTHON_INCLUDEDIR
|
|
|
|
+ifndef PYTHON_INCLUDEDIR
|
|
|
|
+
|
|
|
|
+
|
|
|
|