update to 1.2.7 (#632916)

- avoid multilib conflict on libssh2-docs
- avoid build failure in mock with SELinux in the enforcing mode
  (#558964)
epel9
Kamil Dudka 15 years ago
parent a6bc831ff0
commit 9936af47e1

1
.gitignore vendored

@ -1 +1,2 @@
libssh2-1.2.4.tar.gz libssh2-1.2.4.tar.gz
/libssh2-1.2.7.tar.gz

@ -0,0 +1,7 @@
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
iEYEABECAAYFAkxq+yUACgkQeOEcayedXJG20ACeMdXVfOb0uopARLRRxVdZ3y4/
a5EAn2lxpeDn1L6JMtdYtJQT19hjfL1T
=eefQ
-----END PGP SIGNATURE-----

@ -1,5 +1,5 @@
Name: libssh2 Name: libssh2
Version: 1.2.4 Version: 1.2.7
Release: 1%{?dist} Release: 1%{?dist}
Summary: A library implementing the SSH2 protocol Summary: A library implementing the SSH2 protocol
@ -51,6 +51,11 @@ for i in ChangeLog NEWS ; do
mv new $i mv new $i
done done
# make it possible to launch OpenSSH server for testing purposes
chcon -t initrc_exec_t tests/ssh2.sh || :
chcon -Rt etc_t tests/etc || :
chcon -t sshd_key_t tests/etc/{host,user} || :
%build %build
%configure --disable-static --enable-shared %configure --disable-static --enable-shared
@ -68,6 +73,9 @@ find %{buildroot} -name '*.la' -exec rm -f {} +
find example/ -type d -name .deps -exec rm -rf {} + find example/ -type d -name .deps -exec rm -rf {} +
find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} + find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} +
# avoid multilib conflict on libssh2-docs
mv -v example/Makefile example/Makefile.%{_arch}
%check %check
# sshd/loopback test fails under local build, with selinux enforcing # sshd/loopback test fails under local build, with selinux enforcing
%{?_without_sshd_tests:echo "Skipping sshd tests" ; echo "exit 0" > tests/ssh2.sh } %{?_without_sshd_tests:echo "Skipping sshd tests" ; echo "exit 0" > tests/ssh2.sh }
@ -100,6 +108,11 @@ rm -rf %{buildroot}
%{_libdir}/pkgconfig/* %{_libdir}/pkgconfig/*
%changelog %changelog
* Tue Oct 12 2010 Kamil Dudka <kdudka@redhat.com> 1.2.7-1
- update to 1.2.7 (#632916)
- avoid multilib conflict on libssh2-docs
- avoid build failure in mock with SELinux in the enforcing mode (#558964)
* Fri Mar 12 2010 Chris Weyl <cweyl@alumni.drew.edu> 1.2.4-1 * Fri Mar 12 2010 Chris Weyl <cweyl@alumni.drew.edu> 1.2.4-1
- update to 1.2.4 - update to 1.2.4
- drop old patch0 - drop old patch0

@ -1 +1 @@
4d65a66d5f232e5bb1d05b311e43d46d libssh2-1.2.4.tar.gz a5d78344886f1282e4008c09bf568076 libssh2-1.2.7.tar.gz

@ -1,13 +0,0 @@
diff --git a/src/transport.c b/src/transport.c
index 19efdf2..d9a38ca 100644
--- a/src/transport.c
+++ b/src/transport.c
@@ -626,7 +626,7 @@ send_existing(LIBSSH2_SESSION * session, unsigned char *data,
p->osent += rc; /* we sent away this much data */
- return PACKET_NONE;
+ return p->osent < data_len ? PACKET_EAGAIN : PACKET_NONE;
}
/*
Loading…
Cancel
Save