parent
96ee0c2356
commit
cea1aa5751
@ -0,0 +1,50 @@
|
|||||||
|
--- src/gaiageo/gg_transform.c.old 2019-09-03 10:01:50.670929280 +0100
|
||||||
|
+++ src/gaiageo/gg_transform.c 2019-09-03 10:02:30.536398827 +0100
|
||||||
|
@@ -55,6 +55,7 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifndef OMIT_PROJ /* including PROJ.4 */
|
||||||
|
+#define ACCEPT_USE_OF_DEPRECATED_PROJ_API_H
|
||||||
|
#include <proj_api.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
--- src/connection_cache/alloc_cache.c.old 2019-09-03 10:03:58.207630616 +0100
|
||||||
|
+++ src/connection_cache/alloc_cache.c 2019-09-03 10:04:09.921062403 +0100
|
||||||
|
@@ -81,6 +81,7 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifndef OMIT_PROJ /* including PROJ.4 */
|
||||||
|
+#define ACCEPT_USE_OF_DEPRECATED_PROJ_API_H
|
||||||
|
#include <proj_api.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
--- src/spatialite/spatialite.c.old 2019-09-03 10:04:48.569487084 +0100
|
||||||
|
+++ src/spatialite/spatialite.c 2019-09-03 10:05:12.491368904 +0100
|
||||||
|
@@ -121,6 +121,7 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifndef OMIT_PROJ /* including PROJ.4 */
|
||||||
|
+#define ACCEPT_USE_OF_DEPRECATED_PROJ_API_H
|
||||||
|
#include <proj_api.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
--- test/check_sql_stmt.c.old 2019-09-03 10:05:46.449620693 +0100
|
||||||
|
+++ test/check_sql_stmt.c 2019-09-03 10:05:56.143978052 +0100
|
||||||
|
@@ -67,6 +67,7 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifndef OMIT_PROJ /* only if PROJ is supported */
|
||||||
|
+#define ACCEPT_USE_OF_DEPRECATED_PROJ_API_H
|
||||||
|
#include <proj_api.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
--- src/gaiageo/gg_geodesic.c.old 2019-09-03 10:08:27.783280716 +0100
|
||||||
|
+++ src/gaiageo/gg_geodesic.c 2019-09-03 10:08:41.073741627 +0100
|
||||||
|
@@ -65,6 +65,7 @@
|
||||||
|
#include <spatialite_private.h>
|
||||||
|
|
||||||
|
#ifndef OMIT_PROJ
|
||||||
|
+#define ACCEPT_USE_OF_DEPRECATED_PROJ_API_H
|
||||||
|
#include <proj_api.h>
|
||||||
|
#if defined(PJ_VERSION) && PJ_VERSION >= 490
|
||||||
|
/* Enable new proj.4's geodesic distance */
|
@ -0,0 +1,10 @@
|
|||||||
|
--- configure.ac.old 2019-09-03 09:58:34.566700370 +0100
|
||||||
|
+++ configure.ac 2019-09-03 09:58:42.465991559 +0100
|
||||||
|
@@ -217,7 +217,6 @@
|
||||||
|
[--enable-proj], [enables PROJ.4 inclusion [default=yes]])],
|
||||||
|
[], [enable_proj=yes])
|
||||||
|
if test x"$enable_proj" != "xno"; then
|
||||||
|
- AC_CHECK_HEADERS(proj_api.h,, [AC_MSG_ERROR([cannot find proj_api.h, bailing out])])
|
||||||
|
AC_SEARCH_LIBS(pj_init_plus,proj,,AC_MSG_ERROR(['libproj' is required but it doesn't seem to be installed on this system.]),-lm)
|
||||||
|
AC_SEARCH_LIBS(pj_init_ctx,proj,,AC_MSG_ERROR(['libproj' is required but the version on this system does not support the required features (Version 4.8.0 or later is needed).]),-lm)
|
||||||
|
else
|
Loading…
Reference in new issue