Initial package

epel9
Neal Gompa 2 years ago
parent 80b93a9bf8
commit 480b24397b

1
.gitignore vendored

@ -0,0 +1 @@
/librist-v0.2.7.tar.gz

@ -0,0 +1,28 @@
From 809390b3b75a259a704079d0fb4d8f1b5f7fa956 Mon Sep 17 00:00:00 2001
From: Alexandre Janniaux <ajanni@videolabs.io>
Date: Fri, 8 Apr 2022 11:08:39 +0200
Subject: [PATCH] meson.build: fix reference to libcjson pc file
Debian is using cJSON from github.com/DaveGamble/cJSON, as well as
archlinux and homebrew, which is shipping a libcjson.pc file. Only
ubuntu is using a different version not including the .pc file.
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index a777806..0ed8201 100755
--- a/meson.build
+++ b/meson.build
@@ -156,7 +156,7 @@ endif
#On ubuntu cjson does not come with pkgconfig files, hence the extended checking.
if not builtin_cjson
- cjson_lib = dependency('cJSON', required: false)
+ cjson_lib = dependency('libcjson', required: false)
if not cjson_lib.found()
cjson_lib = cc.find_library('cjson', required: required_library, has_headers: ['cjson/cJSON.h'])
if not cjson_lib.found()
--
2.38.1

@ -0,0 +1,102 @@
%global somajor 4
Name: librist
Version: 0.2.7
Release: 1%{?dist}
Summary: Library for Reliable Internet Stream Transport (RIST) protocol
# Everything used is BSD-2-Clause except getopt-shim, which is ISC as well
License: BSD-2-Clause and ISC
URL: https://code.videolan.org/rist/librist
Source0: %{url}/-/archive/v%{version}/librist-v%{version}.tar.gz
# Backport from upstream
## From: https://code.videolan.org/rist/librist/-/commit/809390b3b75a259a704079d0fb4d8f1b5f7fa956
Patch0001: 0001-meson.build-fix-reference-to-libcjson-pc-file.patch
BuildRequires: gcc
BuildRequires: meson
BuildRequires: ninja-build
BuildRequires: libcmocka-devel
BuildRequires: mbedtls-devel
BuildRequires: pkgconfig(libcjson)
%description
A library that can be used to speak the RIST protocol (as defined by Video
Services Forum (VSF) Technical Recommendations TR-06-1 and TR-06-2).
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%package doc
Summary: Technical documentation for %{name}
BuildArch: noarch
%description doc
The %{name}-doc package contains technical documentation for
developing applications that use %{name}.
%package -n rist-tools
Summary: User tools for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description -n rist-tools
This package contains the user tools for the RIST protocol library.
%prep
%autosetup -n %{name}-v%{version} -p1
%build
%meson
%meson_build
%install
%meson_install
# Strip unwanted executable bits
chmod -x %{buildroot}%{_includedir}/%{name}/*.h
chmod -x docs/*
# Install documentation
mkdir -p %{buildroot}%{_docdir}/%{name}
cp -av docs/* %{buildroot}%{_docdir}/%{name}
%check
%meson_test
%files
%doc README.md CONTRIBUTING.md
%license COPYING
%{_libdir}/*.so.%{somajor}{,.*}
%files devel
%{_includedir}/%{name}/
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%files doc
%license COPYING
# Co-own with librist package
%dir %{_docdir}/%{name}
%doc %{_docdir}/%{name}/VSF_TR-06-1.pdf
%doc %{_docdir}/%{name}/VSF_TR-06-2.pdf
%doc %{_docdir}/%{name}/librist_logo.png
%files -n rist-tools
%{_bindir}/rist*
%changelog
* Wed Feb 15 2023 Neal Gompa <ngompa@fedoraproject.org> - 0.2.7-1
- Initial package

@ -0,0 +1 @@
SHA512 (librist-v0.2.7.tar.gz) = fa4e1aea75206781d062d350410e2f4e095e52191d22fb1882ec779ca13845294d00b5e4f06f04573eb8945ec280c304c96c1607622e978a241c5086b7d0a831
Loading…
Cancel
Save