parent
cf7004f009
commit
cd34bce066
@ -0,0 +1,68 @@
|
|||||||
|
From 0a5a7727e34787b7f1ee6e1e5e07aeb13bdf9ed5 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Robert Nagy <robert@openbsd.org>
|
||||||
|
Date: Mon, 20 Jun 2011 11:43:55 +0200
|
||||||
|
Subject: [PATCH 1/2] correctly build GTK systray icon
|
||||||
|
|
||||||
|
the setting was lost during move the GNU make
|
||||||
|
|
||||||
|
Signed-off-by: Petr Mladek <pmladek@suse.cz>
|
||||||
|
---
|
||||||
|
sfx2/Library_qstart.mk | 7 +++++++
|
||||||
|
sfx2/Library_sfx.mk | 9 +++++++++
|
||||||
|
sfx2/source/appl/shutdownicon.cxx | 2 +-
|
||||||
|
3 files changed, 17 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/sfx2/Library_qstart.mk b/sfx2/Library_qstart.mk
|
||||||
|
index 0709f60..e46a581 100755
|
||||||
|
--- a/sfx2/Library_qstart.mk
|
||||||
|
+++ b/sfx2/Library_qstart.mk
|
||||||
|
@@ -44,6 +44,13 @@ $(eval $(call gb_Library_set_defs,qstart_gtk,\
|
||||||
|
-DENABLE_QUICKSTART_APPLET \
|
||||||
|
))
|
||||||
|
|
||||||
|
+ifeq ($(ENABLE_SYSTRAY_GTK),TRUE)
|
||||||
|
+$(eval $(call gb_Library_set_defs,qstart_gtk,\
|
||||||
|
+ $$(DEFS) \
|
||||||
|
+ -DENABLE_SYSTRAY_GTK \
|
||||||
|
+))
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
$(eval $(call gb_Library_set_cflags,qstart_gtk,\
|
||||||
|
$$(CFLAGS) \
|
||||||
|
$(filter-out -I%,$(GTK_CFLAGS)) \
|
||||||
|
diff --git a/sfx2/Library_sfx.mk b/sfx2/Library_sfx.mk
|
||||||
|
index 4d2396b..c9ec52c 100755
|
||||||
|
--- a/sfx2/Library_sfx.mk
|
||||||
|
+++ b/sfx2/Library_sfx.mk
|
||||||
|
@@ -56,6 +56,15 @@ $(eval $(call gb_Library_set_defs,sfx,\
|
||||||
|
-DSFX2_DLLIMPLEMENTATION \
|
||||||
|
))
|
||||||
|
|
||||||
|
+ifeq ($(ENABLE_SYSTRAY_GTK),TRUE)
|
||||||
|
+$(eval $(call gb_Library_set_defs,sfx,\
|
||||||
|
+ $$(DEFS) \
|
||||||
|
+ -DENABLE_QUICKSTART_APPLET \
|
||||||
|
+ -DENABLE_SYSTRAY_GTK \
|
||||||
|
+ -DPLUGIN_NAME=libqstart_gtk$(gb_Library_OOOEXT) \
|
||||||
|
+))
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
$(eval $(call gb_Library_add_linked_libs,sfx,\
|
||||||
|
comphelper \
|
||||||
|
cppu \
|
||||||
|
diff --git a/sfx2/source/appl/shutdownicon.cxx b/sfx2/source/appl/shutdownicon.cxx
|
||||||
|
index 36dd915..6cab935 100644
|
||||||
|
--- a/sfx2/source/appl/shutdownicon.cxx
|
||||||
|
+++ b/sfx2/source/appl/shutdownicon.cxx
|
||||||
|
@@ -90,7 +90,7 @@ extern "C" { static void SAL_CALL thisModule() {} }
|
||||||
|
# endif
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#if defined(UNX) && defined(ENABLE_SYSTRAY_GTK)
|
||||||
|
+#if defined(UNX) && defined(ENABLE_SYSTRAY_GTK) && !defined(PLUGIN_NAME)
|
||||||
|
#define PLUGIN_NAME "libqstart_gtkli.so"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
--
|
||||||
|
1.7.5.4
|
||||||
|
|
Loading…
Reference in new issue