drop ICEing function under x86

f41
Caolán McNamara 3 years ago
parent 053b3d3d24
commit 96695ed6dd

@ -1,14 +1,14 @@
From bc39839446e13e31ad4e95943446c08876853eb9 Mon Sep 17 00:00:00 2001 From 9ef5a52faecf9118ef46582911f537fd3b6efaad Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com> From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Thu, 3 Feb 2022 14:29:21 +0000 Date: Thu, 3 Feb 2022 14:29:21 +0000
Subject: [PATCH 2/2] split out function to explore i686 ICE Subject: [PATCH] disable ICEing function under x86
Change-Id: I75afe56b248236f30a96876e2aed96f5dd887df1 Change-Id: I75afe56b248236f30a96876e2aed96f5dd887df1
--- ---
sc/Library_sc.mk | 1 + sc/Library_sc.mk | 1 +
sc/source/core/tool/bahttext.cxx | 238 +++++++++++++++++++++++++++++++ sc/source/core/tool/bahttext.cxx | 243 +++++++++++++++++++++++++++++++
sc/source/core/tool/interpr2.cxx | 181 ----------------------- sc/source/core/tool/interpr2.cxx | 181 -----------------------
3 files changed, 239 insertions(+), 181 deletions(-) 3 files changed, 244 insertions(+), 181 deletions(-)
create mode 100644 sc/source/core/tool/bahttext.cxx create mode 100644 sc/source/core/tool/bahttext.cxx
diff --git a/sc/Library_sc.mk b/sc/Library_sc.mk diff --git a/sc/Library_sc.mk b/sc/Library_sc.mk
@ -25,10 +25,10 @@ index 936ca33901ee..f31bbd3f5f8c 100644
sc/source/core/tool/cellform \ sc/source/core/tool/cellform \
diff --git a/sc/source/core/tool/bahttext.cxx b/sc/source/core/tool/bahttext.cxx diff --git a/sc/source/core/tool/bahttext.cxx b/sc/source/core/tool/bahttext.cxx
new file mode 100644 new file mode 100644
index 000000000000..76b99973271d index 000000000000..307a92e39c7c
--- /dev/null --- /dev/null
+++ b/sc/source/core/tool/bahttext.cxx +++ b/sc/source/core/tool/bahttext.cxx
@@ -0,0 +1,238 @@ @@ -0,0 +1,243 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */ +/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/* +/*
+ * This file is part of the LibreOffice project. + * This file is part of the LibreOffice project.
@ -58,6 +58,10 @@ index 000000000000..76b99973271d
+using namespace com::sun::star; +using namespace com::sun::star;
+using namespace formula; +using namespace formula;
+ +
+#if defined(X86)
+void ScInterpreter::ScBahtText() {}
+#else
+
+// BAHTTEXT +// BAHTTEXT
+#define UTF8_TH_0 "\340\270\250\340\270\271\340\270\231\340\270\242\340\271\214" +#define UTF8_TH_0 "\340\270\250\340\270\271\340\270\231\340\270\242\340\271\214"
+#define UTF8_TH_1 "\340\270\253\340\270\231\340\270\266\340\271\210\340\270\207" +#define UTF8_TH_1 "\340\270\253\340\270\231\340\270\266\340\271\210\340\270\207"
@ -265,6 +269,7 @@ index 000000000000..76b99973271d
+ +
+ PushString(OStringToOUString(aText.makeStringAndClear(), RTL_TEXTENCODING_UTF8)); + PushString(OStringToOUString(aText.makeStringAndClear(), RTL_TEXTENCODING_UTF8));
+} +}
+#endif
+ +
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */ +/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/sc/source/core/tool/interpr2.cxx b/sc/source/core/tool/interpr2.cxx diff --git a/sc/source/core/tool/interpr2.cxx b/sc/source/core/tool/interpr2.cxx

@ -251,7 +251,7 @@ Patch5: 0001-the-fedora-kacst-book-fonts-2.0-26-does-have-these-w.patch
Patch6: 0001-Avoid-calling-AVX-code-in-library-static-initializat.patch Patch6: 0001-Avoid-calling-AVX-code-in-library-static-initializat.patch
Patch7: 0001-yet-another-naieve-font-reliant-test.patch Patch7: 0001-yet-another-naieve-font-reliant-test.patch
# see if ICE still happens # see if ICE still happens
Patch8: 0001-split-out-function-to-explore-i686-ICE.patch Patch8: 0001-disable-ICEing-function-under-x86.patch
# not upstreamed # not upstreamed
Patch500: 0001-disable-libe-book-support.patch Patch500: 0001-disable-libe-book-support.patch
@ -1466,7 +1466,9 @@ done
%check %check
# TEMP for gcc 12: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104007 # TEMP for gcc 12: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104007
rm -rf hwpfilter/qa/cppunit/data/fail/skipblock-1.hwp rm -rf hwpfilter/qa/cppunit/data/fail/skipblock-1.hwp
%ifnarch %{ix86}
make unitcheck slowcheck make unitcheck slowcheck
%endif
# we don't need this anymore # we don't need this anymore
rm -f %{buildroot}%{baseinstdir}/program/classes/smoketest.jar rm -f %{buildroot}%{baseinstdir}/program/classes/smoketest.jar

Loading…
Cancel
Save