parent
921bb24a95
commit
6b3829519f
@ -1,70 +0,0 @@
|
|||||||
From c3afc3ba94500f726475adc895de6c92814ae8bb Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stephan Bergmann <sbergman@redhat.com>
|
|
||||||
Date: Fri, 8 Jul 2022 16:47:01 +0200
|
|
||||||
Subject: [PATCH] rhbz#2104545: Only call utl::IsYounger when its result is
|
|
||||||
actually used
|
|
||||||
|
|
||||||
...as it may be expensive, or even throw (uncaught) exceptions (as apparently
|
|
||||||
happened at rhbz#2104545, throwing some css::uno::RuntimeException while aMedObj
|
|
||||||
was an sftp URL).
|
|
||||||
|
|
||||||
The two branches in the if statement's condition that will now potentially call
|
|
||||||
physObjIsOlder are disjoint (one for aMedObj being a file URL, the other for
|
|
||||||
aMedObj being any WebDAV-related URL), so there is no chance that this change
|
|
||||||
accidentally causes utl::IsYounger to be called more often than it used to be
|
|
||||||
called.
|
|
||||||
|
|
||||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/136904
|
|
||||||
Tested-by: Jenkins
|
|
||||||
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
|
|
||||||
(cherry picked from commit 27ffdcf096a7e9863489599dd80528b088d1e9b8)
|
|
||||||
Conflicts:
|
|
||||||
sfx2/source/view/viewfrm.cxx
|
|
||||||
|
|
||||||
Change-Id: I29a5f18a12a8b83ec603366db26451175b5622c9
|
|
||||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/136909
|
|
||||||
Tested-by: Jenkins
|
|
||||||
Reviewed-by: Michael Stahl <michael.stahl@allotropia.de>
|
|
||||||
---
|
|
||||||
sfx2/source/view/viewfrm.cxx | 11 +++++++----
|
|
||||||
1 file changed, 7 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/sfx2/source/view/viewfrm.cxx b/sfx2/source/view/viewfrm.cxx
|
|
||||||
index ecae96b5d945..7f3bf1a6bcc2 100644
|
|
||||||
--- a/sfx2/source/view/viewfrm.cxx
|
|
||||||
+++ b/sfx2/source/view/viewfrm.cxx
|
|
||||||
@@ -270,6 +270,11 @@ bool AskPasswordToModify_Impl( const uno::Reference< task::XInteractionHandler >
|
|
||||||
|
|
||||||
return bResult;
|
|
||||||
}
|
|
||||||
+
|
|
||||||
+bool physObjIsOlder(INetURLObject const & aMedObj, INetURLObject const & aPhysObj) {
|
|
||||||
+ return ::utl::UCBContentHelper::IsYounger(aMedObj.GetMainURL( INetURLObject::DecodeMechanism::NONE),
|
|
||||||
+ aPhysObj.GetMainURL( INetURLObject::DecodeMechanism::NONE ) );
|
|
||||||
+}
|
|
||||||
}
|
|
||||||
|
|
||||||
void SfxViewFrame::ExecReload_Impl( SfxRequest& rReq )
|
|
||||||
@@ -438,8 +443,6 @@ void SfxViewFrame::ExecReload_Impl( SfxRequest& rReq )
|
|
||||||
// etag tells that the cache representation (e.g. in LO) is different from the one on the server,
|
|
||||||
// but tells nothing about the age
|
|
||||||
// Details at this link: http://tools.ietf.org/html/rfc4918#section-15, section 15.7
|
|
||||||
- bool bPhysObjIsYounger = ::utl::UCBContentHelper::IsYounger( aMedObj.GetMainURL( INetURLObject::DecodeMechanism::NONE ),
|
|
||||||
- aPhysObj.GetMainURL( INetURLObject::DecodeMechanism::NONE ) );
|
|
||||||
bool bIsWebDAV = aMedObj.isAnyKnownWebDAVScheme();
|
|
||||||
|
|
||||||
// tdf#118938 Reload the document when the user enters the editing password,
|
|
||||||
@@ -447,8 +450,8 @@ void SfxViewFrame::ExecReload_Impl( SfxRequest& rReq )
|
|
||||||
if ( ( !bNeedsReload && ( ( aMedObj.GetProtocol() == INetProtocol::File &&
|
|
||||||
( aMedObj.getFSysPath( FSysStyle::Detect ) != aPhysObj.getFSysPath( FSysStyle::Detect )
|
|
||||||
|| bPasswordEntered ) &&
|
|
||||||
- !bPhysObjIsYounger )
|
|
||||||
- || ( bIsWebDAV && !bPhysObjIsYounger )
|
|
||||||
+ !physObjIsOlder(aMedObj, aPhysObj) )
|
|
||||||
+ || ( bIsWebDAV && !physObjIsOlder(aMedObj, aPhysObj) )
|
|
||||||
|| ( pMed->IsRemote() && !bIsWebDAV ) ) )
|
|
||||||
|| pVersionItem )
|
|
||||||
// <- tdf#82744
|
|
||||||
--
|
|
||||||
2.36.1
|
|
||||||
|
|
@ -1,26 +0,0 @@
|
|||||||
From d0805b6732c0fe3168d144928cec1c59c2711211 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
|
||||||
Date: Sun, 6 Mar 2022 23:19:08 +0000
|
|
||||||
Subject: [PATCH] s390x canvas test fails
|
|
||||||
|
|
||||||
Change-Id: I7ac059aa19dd348f4e9c567445aff8f066c867b4
|
|
||||||
---
|
|
||||||
canvas/Module_canvas.mk | 4 ----
|
|
||||||
1 file changed, 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/canvas/Module_canvas.mk b/canvas/Module_canvas.mk
|
|
||||||
index 0ca3c4c9bfe0..f62d7ef46299 100644
|
|
||||||
--- a/canvas/Module_canvas.mk
|
|
||||||
+++ b/canvas/Module_canvas.mk
|
|
||||||
@@ -49,8 +49,4 @@ $(eval $(call gb_Module_add_targets,canvas,\
|
|
||||||
))
|
|
||||||
endif
|
|
||||||
|
|
||||||
-$(eval $(call gb_Module_add_check_targets,canvas,\
|
|
||||||
- CppunitTest_canvas_test \
|
|
||||||
-))
|
|
||||||
-
|
|
||||||
# vim: set noet sw=4 ts=4:
|
|
||||||
--
|
|
||||||
2.35.1
|
|
||||||
|
|
File diff suppressed because it is too large
Load Diff
@ -1,35 +0,0 @@
|
|||||||
From 9fcb36d5ebb53f398c48024a1babcc36fc9625f3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
|
||||||
Date: Sat, 5 Mar 2022 21:42:33 +0000
|
|
||||||
Subject: [PATCH] workaround x86 ICE with gcc 12
|
|
||||||
|
|
||||||
Change-Id: I5c31cf31bf676fde4440e46e532595237cc41bab
|
|
||||||
---
|
|
||||||
sc/source/core/tool/interpr2.cxx | 4 ++++
|
|
||||||
1 file changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/sc/source/core/tool/interpr2.cxx b/sc/source/core/tool/interpr2.cxx
|
|
||||||
index 6525f2a6784b..fd3aba045487 100644
|
|
||||||
--- a/sc/source/core/tool/interpr2.cxx
|
|
||||||
+++ b/sc/source/core/tool/interpr2.cxx
|
|
||||||
@@ -3421,6 +3421,9 @@ void lclAppendBlock( OStringBuffer& rText, sal_Int32 nValue )
|
|
||||||
|
|
||||||
} // namespace
|
|
||||||
|
|
||||||
+#if defined(X86)
|
|
||||||
+void ScInterpreter::ScBahtText() {}
|
|
||||||
+#else
|
|
||||||
void ScInterpreter::ScBahtText()
|
|
||||||
{
|
|
||||||
sal_uInt8 nParamCount = GetByte();
|
|
||||||
@@ -3487,6 +3490,7 @@ void ScInterpreter::ScBahtText()
|
|
||||||
|
|
||||||
PushString( OStringToOUString(aText.makeStringAndClear(), RTL_TEXTENCODING_UTF8) );
|
|
||||||
}
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
void ScInterpreter::ScGetPivotData()
|
|
||||||
{
|
|
||||||
--
|
|
||||||
2.35.1
|
|
||||||
|
|
Loading…
Reference in new issue