parent
bf7805c84f
commit
542cdfd10b
@ -1,25 +0,0 @@
|
||||
From b2d583e88ac53aafe96e71eb9b1068f6014100b7 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Thu, 21 Jun 2012 12:14:39 +0200
|
||||
Subject: [PATCH] disable failing check
|
||||
|
||||
Change-Id: I746cd1178c40c78127e04dbc1876de052794bd57
|
||||
---
|
||||
sdext/Module_sdext.mk | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/sdext/Module_sdext.mk b/sdext/Module_sdext.mk
|
||||
index 6280984..ffafa6b 100644
|
||||
--- a/sdext/Module_sdext.mk
|
||||
+++ b/sdext/Module_sdext.mk
|
||||
@@ -50,7 +50,6 @@ $(eval $(call gb_Module_add_targets,sdext,\
|
||||
))
|
||||
|
||||
$(eval $(call gb_Module_add_check_targets,sdext,\
|
||||
- CppunitTest_pdfimport \
|
||||
))
|
||||
endif
|
||||
|
||||
--
|
||||
1.7.10.2
|
||||
|
@ -0,0 +1,50 @@
|
||||
From bb6a12caede53029ecb99810f2f58daae4e11af7 Mon Sep 17 00:00:00 2001
|
||||
From: Rene Engelhard <rene@debian.org>
|
||||
Date: Wed, 31 Oct 2012 18:00:18 +0100
|
||||
Subject: [PATCH] fix sdext build with poppler >= 0.19.x
|
||||
|
||||
Change-Id: I655e8e15c7f7a8c292b3a1820ee48c29e847d05a
|
||||
---
|
||||
configure.ac | 3 ---
|
||||
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 4 +++-
|
||||
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 8 +++++---
|
||||
3 files changed, 8 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
index 77a9aa6..7adc487 100644
|
||||
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
@@ -489,7 +489,9 @@ void PDFOutDev::endPage()
|
||||
printf("endPage\n");
|
||||
}
|
||||
|
||||
-#if POPPLER_CHECK_VERSION(0, 17, 0)
|
||||
+#if POPPLER_CHECK_VERSION(0, 19, 0)
|
||||
+void PDFOutDev::processLink(AnnotLink *link)
|
||||
+#elif POPPLER_CHECK_VERSION(0, 17, 0)
|
||||
void PDFOutDev::processLink(AnnotLink *link, Catalog *)
|
||||
#else
|
||||
void PDFOutDev::processLink(Link* link, Catalog*)
|
||||
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
index 0a19b9a..e5e48fc 100644
|
||||
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
@@ -189,10 +189,12 @@ namespace pdfi
|
||||
// virtual void cvtDevToUser(double dx, double dy, double *ux, double *uy);
|
||||
// virtual void cvtUserToDev(double ux, double uy, int *dx, int *dy);
|
||||
|
||||
- #if POPPLER_CHECK_VERSION(0, 17, 0)
|
||||
- virtual void processLink(AnnotLink *link, Catalog *catalog);
|
||||
- #else
|
||||
//----- link borders
|
||||
+ #if POPPLER_CHECK_VERSION(0, 19, 0)
|
||||
+ virtual void processLink(AnnotLink *link);
|
||||
+ #elif POPPLER_CHECK_VERSION(0, 17, 0)
|
||||
+ virtual void processLink(AnnotLink *link, Catalog *catalog);
|
||||
+ #else
|
||||
virtual void processLink(Link *link, Catalog *catalog);
|
||||
#endif
|
||||
|
||||
--
|
||||
1.7.11.7
|
||||
|
Loading…
Reference in new issue