add build fix for s390

f41
David Tardon 12 years ago
parent 6222204cf7
commit 450ebbb2ce

@ -0,0 +1,43 @@
From f2937da20c88ac9dae1c579d29bf9125e49eadac Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Thu, 30 May 2013 16:12:22 +0200
Subject: [PATCH] don't run autogen.sh if building from tarballs
Change-Id: Idaf56719a5c1d42de62a4945b47f4a2d377b3dd3
(cherry picked from commit 40ae8f365b2c30a37a9fb22aabd4858f519665ed)
Signed-off-by: David Tardon <dtardon@redhat.com>
---
Makefile.in | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index 26a00ad..ac9d1b4 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -16,12 +16,16 @@ endif
SHELL=/usr/bin/env bash
SRCDIR := @SRC_ROOT@
BUILDDIR := @BUILDDIR@
-
-# Next 'if' means:
-# If you want to make something more than help clean distclean,
-# and make has not yet restarted itself..
-# ..run autogen.sh if needed and force make to restart itself.
-ifeq (,$(MAKE_RESTARTS)$(if $(filter-out help clean distclean,$(MAKECMDGOALS)),,T))
+GIT_BUILD := $(if $(wildcard $(SRCDIR)/.git),T)
+
+# Run autogen.sh if needed and force make to restart itself.
+# ... but there are several cases where we do not want to run
+# autogen.sh:
+# 1. if we are building from tarballs, not git checkout (I do not
+# think packagers would ever want that. I certainly do not.)
+# 2. if we are making help, clean or distclean, because they do not
+# need updated configuration
+ifeq (,$(MAKE_RESTARTS)$(if $(GIT_BUILD),,T)$(if $(filter-out help clean distclean,$(MAKECMDGOALS)),,T))
.PHONY : force-restart
Makefile: $(BUILDDIR)/config_host.mk force-restart
--
1.8.2.1

@ -43,7 +43,7 @@ Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.0
Release: 2%{?libo_prerelease}%{?dist}
Release: 3%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and Artistic and MPLv2.0
Group: Applications/Productivity
URL: http://www.documentfoundation.org/develop
@ -249,6 +249,7 @@ Patch16: 0001-rhbz-961460-Don-t-needlessly-pass-URLs-through-INetU.patch
Patch17: 0001-do-not-build-LibreOffice_Test.patch
Patch18: 0001-disable-failing-perf-test.patch
Patch19: 0001-fix-syntax-errors-in-python-wizards.patch
Patch20: 0001-don-t-run-autogen.sh-if-building-from-tarballs.patch
%define instdir %{_libdir}
%define baseinstdir %{instdir}/libreoffice
@ -987,6 +988,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch17 -p1 -b .do-not-build-LibreOffice_Test.patch
%patch18 -p1 -b .disable-failing-perf-test.patch
%patch19 -p1 -b .fix-syntax-errors-in-python-wizards.patch
%patch20 -p1 -b .don-t-run-autogen.sh-if-building-from-tarballs.patch
# TODO: check this
# these are horribly incomplete--empty translations and copied english
@ -2050,6 +2052,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Thu May 30 2013 David Tardon <dtardon@redhat.com> - 1:4.1.0.0-3.beta1
- build fix for s390
* Fri May 24 2013 David Tardon <dtardon@redhat.com> - 1:4.1.0.0-2.beta1
- 4.1.0 beta1

Loading…
Cancel
Save