You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
libreoffice/0001-don-t-run-autogen.sh-i...

44 lines
1.5 KiB

From f2937da20c88ac9dae1c579d29bf9125e49eadac Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Thu, 30 May 2013 16:12:22 +0200
Subject: [PATCH] don't run autogen.sh if building from tarballs
Change-Id: Idaf56719a5c1d42de62a4945b47f4a2d377b3dd3
(cherry picked from commit 40ae8f365b2c30a37a9fb22aabd4858f519665ed)
Signed-off-by: David Tardon <dtardon@redhat.com>
---
Makefile.in | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index 26a00ad..ac9d1b4 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -16,12 +16,16 @@ endif
SHELL=/usr/bin/env bash
SRCDIR := @SRC_ROOT@
BUILDDIR := @BUILDDIR@
-
-# Next 'if' means:
-# If you want to make something more than help clean distclean,
-# and make has not yet restarted itself..
-# ..run autogen.sh if needed and force make to restart itself.
-ifeq (,$(MAKE_RESTARTS)$(if $(filter-out help clean distclean,$(MAKECMDGOALS)),,T))
+GIT_BUILD := $(if $(wildcard $(SRCDIR)/.git),T)
+
+# Run autogen.sh if needed and force make to restart itself.
+# ... but there are several cases where we do not want to run
+# autogen.sh:
+# 1. if we are building from tarballs, not git checkout (I do not
+# think packagers would ever want that. I certainly do not.)
+# 2. if we are making help, clean or distclean, because they do not
+# need updated configuration
+ifeq (,$(MAKE_RESTARTS)$(if $(GIT_BUILD),,T)$(if $(filter-out help clean distclean,$(MAKECMDGOALS)),,T))
.PHONY : force-restart
Makefile: $(BUILDDIR)/config_host.mk force-restart
--
1.8.2.1