parent
f7141c84d8
commit
3ad712428f
@ -1,352 +0,0 @@
|
||||
From 85da04887089580fa7551b57f740c6a62507dae1 Mon Sep 17 00:00:00 2001
|
||||
From: Stephan Bergmann <sbergman@redhat.com>
|
||||
Date: Mon, 9 Aug 2021 23:07:12 +0200
|
||||
Subject: [PATCH] Missing includes for libstdc++ 12
|
||||
|
||||
(for std::unique_ptr, with recent libstdc++ 12 trunk)
|
||||
|
||||
Change-Id: I61b7823dd740ea7cdfe0d7403a50ac73b24d1c4e
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/120229
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
|
||||
(cherry picked from commit 43542cc07ee110abe25a1e176238fd6d921d593b)
|
||||
---
|
||||
chart2/source/view/inc/PlottingPositionHelper.hxx | 4 ++++
|
||||
compilerplugins/clang/test/unusedfields.cxx | 1 +
|
||||
connectivity/source/inc/java/tools.hxx | 4 ++++
|
||||
extensions/source/propctrlr/handlerhelper.hxx | 1 +
|
||||
filter/source/xsltdialog/xmlfilterjar.hxx | 1 +
|
||||
forms/source/component/EventThread.hxx | 1 +
|
||||
forms/source/xforms/propertysetbase.hxx | 1 +
|
||||
fpicker/source/office/contentenumeration.hxx | 4 ++++
|
||||
framework/inc/uielement/toolbarwrapper.hxx | 2 ++
|
||||
include/oox/crypto/StrongEncryptionDataSpace.hxx | 4 ++++
|
||||
include/sfx2/sidebar/SidebarPanelBase.hxx | 4 ++++
|
||||
include/svtools/imageresourceaccess.hxx | 4 ++++
|
||||
include/vcl/BitmapBuffer.hxx | 4 ++++
|
||||
include/vcl/filter/PngImageReader.hxx | 4 ++++
|
||||
shell/source/backends/kf5be/kf5backend.cxx | 2 ++
|
||||
sot/source/unoolestorage/xolesimplestorage.hxx | 2 ++
|
||||
starmath/inc/token.hxx | 1 +
|
||||
.../textconversiondlgs/chinese_translation_unodialog.hxx | 4 ++++
|
||||
sw/source/uibase/docvw/OverlayRanges.hxx | 1 +
|
||||
sw/source/uibase/docvw/ShadowOverlayObject.hxx | 4 ++++
|
||||
xmlsecurity/source/gpg/SecurityEnvironment.hxx | 3 +++
|
||||
xmlsecurity/source/helper/ooxmlsecparser.hxx | 1 +
|
||||
xmlsecurity/source/helper/xsecparser.hxx | 1 +
|
||||
23 files changed, 58 insertions(+)
|
||||
|
||||
diff --git a/chart2/source/view/inc/PlottingPositionHelper.hxx b/chart2/source/view/inc/PlottingPositionHelper.hxx
|
||||
index 0962868b0f31..d687cb902453 100644
|
||||
--- a/chart2/source/view/inc/PlottingPositionHelper.hxx
|
||||
+++ b/chart2/source/view/inc/PlottingPositionHelper.hxx
|
||||
@@ -18,6 +18,10 @@
|
||||
*/
|
||||
#pragma once
|
||||
|
||||
+#include <sal/config.h>
|
||||
+
|
||||
+#include <memory>
|
||||
+
|
||||
#include <chartview/ExplicitScaleValues.hxx>
|
||||
|
||||
#include <basegfx/range/b2drectangle.hxx>
|
||||
diff --git a/compilerplugins/clang/test/unusedfields.cxx b/compilerplugins/clang/test/unusedfields.cxx
|
||||
index 5305b4aec964..6ff9189eab27 100644
|
||||
--- a/compilerplugins/clang/test/unusedfields.cxx
|
||||
+++ b/compilerplugins/clang/test/unusedfields.cxx
|
||||
@@ -14,6 +14,7 @@
|
||||
// expected-no-diagnostics
|
||||
#else
|
||||
|
||||
+#include <memory>
|
||||
#include <vector>
|
||||
#include <ostream>
|
||||
#include <com/sun/star/uno/Any.hxx>
|
||||
diff --git a/connectivity/source/inc/java/tools.hxx b/connectivity/source/inc/java/tools.hxx
|
||||
index bc9759fa9a88..44a35ecee3f9 100644
|
||||
--- a/connectivity/source/inc/java/tools.hxx
|
||||
+++ b/connectivity/source/inc/java/tools.hxx
|
||||
@@ -19,6 +19,10 @@
|
||||
|
||||
#pragma once
|
||||
|
||||
+#include <sal/config.h>
|
||||
+
|
||||
+#include <memory>
|
||||
+
|
||||
#include <com/sun/star/beans/PropertyValue.hpp>
|
||||
#include <com/sun/star/uno/Sequence.h>
|
||||
|
||||
diff --git a/extensions/source/propctrlr/handlerhelper.hxx b/extensions/source/propctrlr/handlerhelper.hxx
|
||||
index a53a24a9256f..1d32db9c0573 100644
|
||||
--- a/extensions/source/propctrlr/handlerhelper.hxx
|
||||
+++ b/extensions/source/propctrlr/handlerhelper.hxx
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <com/sun/star/beans/PropertyAttribute.hpp>
|
||||
#include <com/sun/star/beans/Optional.hpp>
|
||||
|
||||
+#include <memory>
|
||||
#include <vector>
|
||||
|
||||
namespace weld { class Builder; class Widget; class Window; }
|
||||
diff --git a/filter/source/xsltdialog/xmlfilterjar.hxx b/filter/source/xsltdialog/xmlfilterjar.hxx
|
||||
index 6f02e5f99de0..1d8e52fc3e18 100644
|
||||
--- a/filter/source/xsltdialog/xmlfilterjar.hxx
|
||||
+++ b/filter/source/xsltdialog/xmlfilterjar.hxx
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <com/sun/star/lang/XSingleServiceFactory.hpp>
|
||||
#include <com/sun/star/uno/XComponentContext.hpp>
|
||||
|
||||
+#include <memory>
|
||||
#include <vector>
|
||||
|
||||
class filter_info_impl;
|
||||
diff --git a/forms/source/component/EventThread.hxx b/forms/source/component/EventThread.hxx
|
||||
index be9e9696734e..20aff73113db 100644
|
||||
--- a/forms/source/component/EventThread.hxx
|
||||
+++ b/forms/source/component/EventThread.hxx
|
||||
@@ -21,6 +21,7 @@
|
||||
|
||||
#include <sal/config.h>
|
||||
|
||||
+#include <memory>
|
||||
#include <vector>
|
||||
|
||||
#include <com/sun/star/lang/XEventListener.hpp>
|
||||
diff --git a/forms/source/xforms/propertysetbase.hxx b/forms/source/xforms/propertysetbase.hxx
|
||||
index bb27f8460fea..969253a04d62 100644
|
||||
--- a/forms/source/xforms/propertysetbase.hxx
|
||||
+++ b/forms/source/xforms/propertysetbase.hxx
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <com/sun/star/beans/PropertyAttribute.hpp>
|
||||
|
||||
#include <map>
|
||||
+#include <memory>
|
||||
|
||||
namespace com::sun::star::uno {
|
||||
class Any;
|
||||
diff --git a/fpicker/source/office/contentenumeration.hxx b/fpicker/source/office/contentenumeration.hxx
|
||||
index 9dcfae687883..bc2180c53c47 100644
|
||||
--- a/fpicker/source/office/contentenumeration.hxx
|
||||
+++ b/fpicker/source/office/contentenumeration.hxx
|
||||
@@ -19,6 +19,10 @@
|
||||
|
||||
#pragma once
|
||||
|
||||
+#include <sal/config.h>
|
||||
+
|
||||
+#include <memory>
|
||||
+
|
||||
#include <com/sun/star/ucb/XCommandEnvironment.hpp>
|
||||
#include <salhelper/thread.hxx>
|
||||
#include <ucbhelper/content.hxx>
|
||||
diff --git a/framework/inc/uielement/toolbarwrapper.hxx b/framework/inc/uielement/toolbarwrapper.hxx
|
||||
index 55142f98d500..da90455b21da 100644
|
||||
--- a/framework/inc/uielement/toolbarwrapper.hxx
|
||||
+++ b/framework/inc/uielement/toolbarwrapper.hxx
|
||||
@@ -25,6 +25,8 @@
|
||||
#include <com/sun/star/ui/XUIFunctionListener.hpp>
|
||||
#include <com/sun/star/uno/XComponentContext.hpp>
|
||||
|
||||
+#include <memory>
|
||||
+
|
||||
namespace weld
|
||||
{
|
||||
class Builder;
|
||||
diff --git a/include/oox/crypto/StrongEncryptionDataSpace.hxx b/include/oox/crypto/StrongEncryptionDataSpace.hxx
|
||||
index 59be5c9832a0..cd7156515ab3 100644
|
||||
--- a/include/oox/crypto/StrongEncryptionDataSpace.hxx
|
||||
+++ b/include/oox/crypto/StrongEncryptionDataSpace.hxx
|
||||
@@ -11,6 +11,10 @@
|
||||
#ifndef INCLUDED_OOX_CRYPTO_STRONGENCRYPTINDATASPACE_HXX
|
||||
#define INCLUDED_OOX_CRYPTO_STRONGENCRYPTINDATASPACE_HXX
|
||||
|
||||
+#include <sal/config.h>
|
||||
+
|
||||
+#include <memory>
|
||||
+
|
||||
#include <cppuhelper/implbase.hxx>
|
||||
#include <com/sun/star/lang/XServiceInfo.hpp>
|
||||
#include <com/sun/star/packages/XPackageEncryption.hpp>
|
||||
diff --git a/include/sfx2/sidebar/SidebarPanelBase.hxx b/include/sfx2/sidebar/SidebarPanelBase.hxx
|
||||
index 971e286ca74f..8164244e796a 100644
|
||||
--- a/include/sfx2/sidebar/SidebarPanelBase.hxx
|
||||
+++ b/include/sfx2/sidebar/SidebarPanelBase.hxx
|
||||
@@ -18,6 +18,10 @@
|
||||
*/
|
||||
#pragma once
|
||||
|
||||
+#include <sal/config.h>
|
||||
+
|
||||
+#include <memory>
|
||||
+
|
||||
#include <sfx2/dllapi.h>
|
||||
|
||||
#include <cppuhelper/compbase.hxx>
|
||||
diff --git a/include/svtools/imageresourceaccess.hxx b/include/svtools/imageresourceaccess.hxx
|
||||
index d7e8a5629b11..ccb5b6b69bce 100644
|
||||
--- a/include/svtools/imageresourceaccess.hxx
|
||||
+++ b/include/svtools/imageresourceaccess.hxx
|
||||
@@ -19,6 +19,10 @@
|
||||
|
||||
#pragma once
|
||||
|
||||
+#include <sal/config.h>
|
||||
+
|
||||
+#include <memory>
|
||||
+
|
||||
#include <config_options.h>
|
||||
#include <svtools/svtdllapi.h>
|
||||
|
||||
diff --git a/include/vcl/BitmapBuffer.hxx b/include/vcl/BitmapBuffer.hxx
|
||||
index 79f202cdfa2d..7468cb987f95 100644
|
||||
--- a/include/vcl/BitmapBuffer.hxx
|
||||
+++ b/include/vcl/BitmapBuffer.hxx
|
||||
@@ -20,6 +20,10 @@
|
||||
#ifndef INCLUDED_VCL_BITMAPBUFFER_HXX
|
||||
#define INCLUDED_VCL_BITMAPBUFFER_HXX
|
||||
|
||||
+#include <sal/config.h>
|
||||
+
|
||||
+#include <memory>
|
||||
+
|
||||
#include <vcl/dllapi.h>
|
||||
#include <vcl/BitmapPalette.hxx>
|
||||
#include <vcl/ColorMask.hxx>
|
||||
diff --git a/include/vcl/filter/PngImageReader.hxx b/include/vcl/filter/PngImageReader.hxx
|
||||
index 2615fd961bd4..bbb5b7c8d672 100644
|
||||
--- a/include/vcl/filter/PngImageReader.hxx
|
||||
+++ b/include/vcl/filter/PngImageReader.hxx
|
||||
@@ -11,6 +11,10 @@
|
||||
#ifndef INCLUDED_VCL_FILTER_PNGIMAGEREADER_HXX
|
||||
#define INCLUDED_VCL_FILTER_PNGIMAGEREADER_HXX
|
||||
|
||||
+#include <sal/config.h>
|
||||
+
|
||||
+#include <memory>
|
||||
+
|
||||
#include <vcl/dllapi.h>
|
||||
|
||||
#include <com/sun/star/uno/Reference.hxx>
|
||||
diff --git a/shell/source/backends/kf5be/kf5backend.cxx b/shell/source/backends/kf5be/kf5backend.cxx
|
||||
index 47c829dc5f9b..e448c124d88a 100644
|
||||
--- a/shell/source/backends/kf5be/kf5backend.cxx
|
||||
+++ b/shell/source/backends/kf5be/kf5backend.cxx
|
||||
@@ -19,6 +19,8 @@
|
||||
|
||||
#include <sal/config.h>
|
||||
|
||||
+#include <memory>
|
||||
+
|
||||
#include <QtWidgets/QApplication>
|
||||
|
||||
#include <boost/noncopyable.hpp>
|
||||
diff --git a/sot/source/unoolestorage/xolesimplestorage.hxx b/sot/source/unoolestorage/xolesimplestorage.hxx
|
||||
index ef0214ba61c3..2ec9f715d873 100644
|
||||
--- a/sot/source/unoolestorage/xolesimplestorage.hxx
|
||||
+++ b/sot/source/unoolestorage/xolesimplestorage.hxx
|
||||
@@ -22,6 +22,8 @@
|
||||
|
||||
#include <sal/config.h>
|
||||
|
||||
+#include <memory>
|
||||
+
|
||||
#include <com/sun/star/embed/XOLESimpleStorage.hpp>
|
||||
#include <com/sun/star/lang/XServiceInfo.hpp>
|
||||
#include <cppuhelper/implbase.hxx>
|
||||
diff --git a/starmath/inc/token.hxx b/starmath/inc/token.hxx
|
||||
index e38b3e5afb5a..808195dca9d3 100644
|
||||
--- a/starmath/inc/token.hxx
|
||||
+++ b/starmath/inc/token.hxx
|
||||
@@ -35,6 +35,7 @@
|
||||
|
||||
// std imports
|
||||
#include <cassert>
|
||||
+#include <memory>
|
||||
#include <vector>
|
||||
#include <stack>
|
||||
#include <tuple>
|
||||
diff --git a/svx/source/unodialogs/textconversiondlgs/chinese_translation_unodialog.hxx b/svx/source/unodialogs/textconversiondlgs/chinese_translation_unodialog.hxx
|
||||
index 8d2e29f1317a..dbfae4d74697 100644
|
||||
--- a/svx/source/unodialogs/textconversiondlgs/chinese_translation_unodialog.hxx
|
||||
+++ b/svx/source/unodialogs/textconversiondlgs/chinese_translation_unodialog.hxx
|
||||
@@ -19,6 +19,10 @@
|
||||
|
||||
#pragma once
|
||||
|
||||
+#include <sal/config.h>
|
||||
+
|
||||
+#include <memory>
|
||||
+
|
||||
#include <com/sun/star/awt/XWindow.hpp>
|
||||
#include <com/sun/star/beans/XPropertySet.hpp>
|
||||
#include <com/sun/star/lang/XInitialization.hpp>
|
||||
diff --git a/sw/source/uibase/docvw/OverlayRanges.hxx b/sw/source/uibase/docvw/OverlayRanges.hxx
|
||||
index e086b8462ea2..829f0c4001dc 100644
|
||||
--- a/sw/source/uibase/docvw/OverlayRanges.hxx
|
||||
+++ b/sw/source/uibase/docvw/OverlayRanges.hxx
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <svx/sdr/overlay/overlayobject.hxx>
|
||||
#include <basegfx/range/b2drange.hxx>
|
||||
|
||||
+#include <memory>
|
||||
#include <vector>
|
||||
|
||||
class SwView;
|
||||
diff --git a/sw/source/uibase/docvw/ShadowOverlayObject.hxx b/sw/source/uibase/docvw/ShadowOverlayObject.hxx
|
||||
index df8e27009f5e..cd612f7ce50e 100644
|
||||
--- a/sw/source/uibase/docvw/ShadowOverlayObject.hxx
|
||||
+++ b/sw/source/uibase/docvw/ShadowOverlayObject.hxx
|
||||
@@ -19,6 +19,10 @@
|
||||
|
||||
#pragma once
|
||||
|
||||
+#include <sal/config.h>
|
||||
+
|
||||
+#include <memory>
|
||||
+
|
||||
#include <svx/sdr/overlay/overlayobject.hxx>
|
||||
|
||||
class SwView;
|
||||
diff --git a/xmlsecurity/source/gpg/SecurityEnvironment.hxx b/xmlsecurity/source/gpg/SecurityEnvironment.hxx
|
||||
index 83b4f38b41c8..262578682274 100644
|
||||
--- a/xmlsecurity/source/gpg/SecurityEnvironment.hxx
|
||||
+++ b/xmlsecurity/source/gpg/SecurityEnvironment.hxx
|
||||
@@ -10,6 +10,9 @@
|
||||
#pragma once
|
||||
|
||||
#include <sal/config.h>
|
||||
+
|
||||
+#include <memory>
|
||||
+
|
||||
#include <rtl/ustring.hxx>
|
||||
#include <cppuhelper/implbase.hxx>
|
||||
|
||||
diff --git a/xmlsecurity/source/helper/ooxmlsecparser.hxx b/xmlsecurity/source/helper/ooxmlsecparser.hxx
|
||||
index 4f11302ff765..9193d7b7e180 100644
|
||||
--- a/xmlsecurity/source/helper/ooxmlsecparser.hxx
|
||||
+++ b/xmlsecurity/source/helper/ooxmlsecparser.hxx
|
||||
@@ -16,6 +16,7 @@
|
||||
|
||||
#include <xmloff/namespacemap.hxx>
|
||||
|
||||
+#include <memory>
|
||||
#include <stack>
|
||||
|
||||
class XSecController;
|
||||
diff --git a/xmlsecurity/source/helper/xsecparser.hxx b/xmlsecurity/source/helper/xsecparser.hxx
|
||||
index 86f6154ddc93..0e0ee8291f65 100644
|
||||
--- a/xmlsecurity/source/helper/xsecparser.hxx
|
||||
+++ b/xmlsecurity/source/helper/xsecparser.hxx
|
||||
@@ -26,6 +26,7 @@
|
||||
|
||||
#include <xmloff/namespacemap.hxx>
|
||||
|
||||
+#include <memory>
|
||||
#include <stack>
|
||||
|
||||
class XMLSignatureHelper;
|
||||
--
|
||||
2.33.1
|
||||
|
@ -1,135 +0,0 @@
|
||||
From 5db8b1c97bcbc80d2ed904ab40cafe1267a9848c Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Wed, 15 Dec 2021 12:46:24 +0000
|
||||
Subject: [PATCH] annocheck warning about missing .note.gnu.property section
|
||||
|
||||
copy and paste recommendation from:
|
||||
https://sourceware.org/annobin/annobin.html/Test-cf-protection.html
|
||||
|
||||
and adapt like:
|
||||
https://github.com/openssl/openssl/commit/51994e505dbb1cd0dd76869ec962e2948b77b585
|
||||
where https://bugs.ruby-lang.org/attachments/8962 is similar
|
||||
|
||||
Intel docs have "The ENDBR32 and ENDBR64 (collectively ENDBRANCH) are
|
||||
two new instructions that are used to mark valid indirect CALL/JMP
|
||||
target locations in the program."
|
||||
|
||||
Change-Id: Ie867c263a888763db4478720ba189c9ec6cc974d
|
||||
---
|
||||
.../source/cpp_uno/gcc3_linux_intel/call.s | 16 ++++++++++++++++
|
||||
.../source/cpp_uno/gcc3_linux_x86-64/call.s | 19 +++++++++++++++++++
|
||||
config_host.mk.in | 1 +
|
||||
configure.ac | 14 ++++++++++++++
|
||||
solenv/gbuild/platform/com_GCC_class.mk | 1 +
|
||||
5 files changed, 51 insertions(+)
|
||||
|
||||
diff --git a/bridges/source/cpp_uno/gcc3_linux_intel/call.s b/bridges/source/cpp_uno/gcc3_linux_intel/call.s
|
||||
index 6be583247733..0a5870defcf3 100644
|
||||
--- a/bridges/source/cpp_uno/gcc3_linux_intel/call.s
|
||||
+++ b/bridges/source/cpp_uno/gcc3_linux_intel/call.s
|
||||
@@ -290,3 +290,19 @@ privateSnippetExecutorClass:
|
||||
.align 4
|
||||
.LEFDEc:
|
||||
.section .note.GNU-stack,"",@progbits
|
||||
+ .section .note.gnu.property,"a"
|
||||
+ .p2align 2
|
||||
+ .long 1f - 0f
|
||||
+ .long 4f - 1f
|
||||
+ .long 5
|
||||
+0:
|
||||
+ .string "GNU"
|
||||
+1:
|
||||
+ .p2align 2
|
||||
+ .long 0xc0000002
|
||||
+ .long 3f - 2f
|
||||
+2:
|
||||
+ .long 0x3
|
||||
+3:
|
||||
+ .p2align 2
|
||||
+4:
|
||||
diff --git a/bridges/source/cpp_uno/gcc3_linux_x86-64/call.s b/bridges/source/cpp_uno/gcc3_linux_x86-64/call.s
|
||||
index 447ac0cecfdd..2e9346dff8a0 100644
|
||||
--- a/bridges/source/cpp_uno/gcc3_linux_x86-64/call.s
|
||||
+++ b/bridges/source/cpp_uno/gcc3_linux_x86-64/call.s
|
||||
@@ -22,6 +22,9 @@
|
||||
.type privateSnippetExecutor, @function
|
||||
privateSnippetExecutor:
|
||||
.LFB3:
|
||||
+#if defined(END_BRANCH_INS_SUPPORT)
|
||||
+ endbr64
|
||||
+#endif
|
||||
pushq %rbp
|
||||
.LCFI0:
|
||||
movq %rsp, %rbp
|
||||
@@ -115,3 +118,19 @@ privateSnippetExecutor:
|
||||
.align 8
|
||||
.LEFDE1:
|
||||
.section .note.GNU-stack,"",@progbits
|
||||
+ .section .note.gnu.property,"a"
|
||||
+ .p2align 3
|
||||
+ .long 1f - 0f
|
||||
+ .long 4f - 1f
|
||||
+ .long 5
|
||||
+0:
|
||||
+ .string "GNU"
|
||||
+1:
|
||||
+ .p2align 3
|
||||
+ .long 0xc0000002
|
||||
+ .long 3f - 2f
|
||||
+2:
|
||||
+ .long 0x3
|
||||
+3:
|
||||
+ .p2align 3
|
||||
+4:
|
||||
diff --git a/config_host.mk.in b/config_host.mk.in
|
||||
index 0fe4fd84cd41..c78eabd54d09 100644
|
||||
--- a/config_host.mk.in
|
||||
+++ b/config_host.mk.in
|
||||
@@ -262,6 +262,7 @@ export GTK4_CFLAGS=$(gb_SPACE)@GTK4_CFLAGS@
|
||||
export GTK4_LIBS=$(gb_SPACE)@GTK4_LIBS@
|
||||
export USING_X11=@USING_X11@
|
||||
export HAMCREST_JAR=@HAMCREST_JAR@
|
||||
+export HAVE_ASM_END_BRANCH_INS_SUPPORT=@HAVE_ASM_END_BRANCH_INS_SUPPORT@
|
||||
export HAVE_BROKEN_GCC_WMAYBE_UNINITIALIZED=@HAVE_BROKEN_GCC_WMAYBE_UNINITIALIZED@
|
||||
export HAVE_BROKEN_GCC_WSTRINGOP_OVERFLOW=@HAVE_BROKEN_GCC_WSTRINGOP_OVERFLOW@
|
||||
export HAVE_CLANG_DEBUG_INFO_KIND_CONSTRUCTOR=@HAVE_CLANG_DEBUG_INFO_KIND_CONSTRUCTOR@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 06d7901c7c79..0400bd390e8c 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -7927,6 +7927,20 @@ _ACEOF
|
||||
|
||||
CPPFLAGS="$save_CPPFLAGS"
|
||||
|
||||
+ AC_MSG_CHECKING([if CET endbranch is recognized])
|
||||
+cat > endbr.s <<_ACEOF
|
||||
+endbr32
|
||||
+_ACEOF
|
||||
+ HAVE_ASM_END_BRANCH_INS_SUPPORT=
|
||||
+ if $CXX -c endbr.s -o endbr.o >/dev/null 2>&5; then
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+ HAVE_ASM_END_BRANCH_INS_SUPPORT=TRUE
|
||||
+ else
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ fi
|
||||
+ rm -f endbr.s endbr.o
|
||||
+ AC_SUBST(HAVE_ASM_END_BRANCH_INS_SUPPORT)
|
||||
+
|
||||
AC_LANG_POP([C++])
|
||||
fi
|
||||
|
||||
diff --git a/solenv/gbuild/platform/com_GCC_class.mk b/solenv/gbuild/platform/com_GCC_class.mk
|
||||
index c29e2a979fd9..e2056abf9682 100644
|
||||
--- a/solenv/gbuild/platform/com_GCC_class.mk
|
||||
+++ b/solenv/gbuild/platform/com_GCC_class.mk
|
||||
@@ -44,6 +44,7 @@ $(call gb_Helper_abbreviate_dirs,\
|
||||
-x assembler-with-cpp \
|
||||
$(gb_LTOFLAGS) \
|
||||
$(gb_AFLAGS) \
|
||||
+ $(if $(HAVE_ASM_END_BRANCH_INS_SUPPORT),-DEND_BRANCH_INS_SUPPORT) \
|
||||
-c $(3) \
|
||||
-o $(1)) \
|
||||
$(INCLUDE) && \
|
||||
--
|
||||
2.33.1
|
||||
|
@ -1,111 +0,0 @@
|
||||
From 748a9fd3a8e90e52a126190dbe0d97da6e0941ff Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Wed, 11 Aug 2021 20:55:14 +0100
|
||||
Subject: [PATCH] make --with-idlc-cpp=cpp work for gcc cpp as a ucpp
|
||||
replacement
|
||||
|
||||
e.g. the example of
|
||||
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1524638
|
||||
has the same output .urd using cpp with these flags as ucpp created
|
||||
|
||||
Change-Id: Iadfd2deba7d365c66c3260fd6736c031987e107c
|
||||
---
|
||||
config_host.mk.in | 1 +
|
||||
configure.ac | 14 ++++++++++++++
|
||||
idlc/Executable_idlc.mk | 8 ++++++++
|
||||
idlc/source/idlccompile.cxx | 8 ++++++++
|
||||
4 files changed, 31 insertions(+)
|
||||
|
||||
diff --git a/config_host.mk.in b/config_host.mk.in
|
||||
index 58ca1d1c14fb..6810660067b0 100644
|
||||
--- a/config_host.mk.in
|
||||
+++ b/config_host.mk.in
|
||||
@@ -635,6 +635,7 @@ export SYSTEM_RHINO=@SYSTEM_RHINO@
|
||||
export SYSTEM_SERF=@SYSTEM_SERF@
|
||||
export SYSTEM_STAROFFICE=@SYSTEM_STAROFFICE@
|
||||
export SYSTEM_UCPP=@SYSTEM_UCPP@
|
||||
+export SYSTEM_UCPP_IS_GCC=@SYSTEM_UCPP_IS_GCC@
|
||||
export SYSTEM_VISIO=@SYSTEM_VISIO@
|
||||
export SYSTEM_WPD=@SYSTEM_WPD@
|
||||
export SYSTEM_WPG=@SYSTEM_WPG@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 3d2bf7e24555..ac226fd46ace 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -8807,9 +8807,22 @@ dnl ===================================================================
|
||||
dnl Check for C preprocessor to use
|
||||
dnl ===================================================================
|
||||
AC_MSG_CHECKING([which C preprocessor to use in idlc])
|
||||
+SYSTEM_UCPP_IS_GCC=
|
||||
if test -n "$with_idlc_cpp"; then
|
||||
AC_MSG_RESULT([$with_idlc_cpp])
|
||||
AC_PATH_PROG(SYSTEM_UCPP, $with_idlc_cpp)
|
||||
+ AC_MSG_CHECKING([if $with_idlc_cpp is GCC CPP])
|
||||
+ # ucpp will accept -v (to output version), warn about the others as unknown
|
||||
+ # and return 1 (due to -v)
|
||||
+ # gcc will accept -v (as verbose), --version (to output version) and -nostdinc
|
||||
+ # and return 0 (due to --version ) if all options are supported
|
||||
+ $SYSTEM_UCPP -v --version -nostdinc >/dev/null 2>/dev/null
|
||||
+ if test $? -eq 0; then
|
||||
+ SYSTEM_UCPP_IS_GCC=TRUE
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+ else
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ fi
|
||||
else
|
||||
AC_MSG_RESULT([ucpp])
|
||||
AC_MSG_CHECKING([which ucpp tp use])
|
||||
@@ -8822,6 +8835,7 @@ else
|
||||
fi
|
||||
fi
|
||||
AC_SUBST(SYSTEM_UCPP)
|
||||
+AC_SUBST(SYSTEM_UCPP_IS_GCC)
|
||||
|
||||
dnl ===================================================================
|
||||
dnl Check for epm (not needed for Windows)
|
||||
diff --git a/idlc/Executable_idlc.mk b/idlc/Executable_idlc.mk
|
||||
index e194e9049c77..f2f79dcb8911 100644
|
||||
--- a/idlc/Executable_idlc.mk
|
||||
+++ b/idlc/Executable_idlc.mk
|
||||
@@ -35,10 +35,18 @@ $(eval $(call gb_Executable_add_scanners,idlc,\
|
||||
))
|
||||
|
||||
ifneq (,$(SYSTEM_UCPP))
|
||||
+
|
||||
$(eval $(call gb_Executable_add_defs,idlc,\
|
||||
-DSYSTEM_UCPP \
|
||||
-DUCPP=\"file://$(SYSTEM_UCPP)\" \
|
||||
))
|
||||
+
|
||||
+ifneq ($(SYSTEM_UCPP_IS_GCC),)
|
||||
+$(eval $(call gb_Executable_add_defs,idlc,\
|
||||
+ -DSYSTEM_UCPP_IS_GCC \
|
||||
+))
|
||||
+endif
|
||||
+
|
||||
endif
|
||||
|
||||
$(eval $(call gb_Executable_add_exception_objects,idlc,\
|
||||
diff --git a/idlc/source/idlccompile.cxx b/idlc/source/idlccompile.cxx
|
||||
index bf3325d6821a..1902d63e0cad 100644
|
||||
--- a/idlc/source/idlccompile.cxx
|
||||
+++ b/idlc/source/idlccompile.cxx
|
||||
@@ -237,7 +237,15 @@ sal_Int32 compileFile(const OString * pathname)
|
||||
::std::vector< OUString> lCppArgs;
|
||||
lCppArgs.emplace_back("-DIDL");
|
||||
lCppArgs.emplace_back("-C");
|
||||
+#ifdef SYSTEM_UCPP_IS_GCC
|
||||
+ // -nostdinc Do not search the standard system directories for header files
|
||||
+ lCppArgs.emplace_back("-nostdinc");
|
||||
+ // with gcc cpp, even when not explicitly including anything, /usr/include/stdc-predef.h
|
||||
+ // gets inserted without -nostdinc
|
||||
+#else
|
||||
+ // -zI Do not use the standard (compile-time) include path.
|
||||
lCppArgs.emplace_back("-zI");
|
||||
+#endif
|
||||
|
||||
Options* pOptions = idlc()->getOptions();
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
Loading…
Reference in new issue