parent
9a3ef125e5
commit
3821c37f07
@ -1,44 +0,0 @@
|
||||
From 9f68be99919871283238e4a12940d9581d724af2 Mon Sep 17 00:00:00 2001
|
||||
From: David Ostrovsky <david@ostrovsky.org>
|
||||
Date: Thu, 4 May 2017 19:14:13 +0200
|
||||
Subject: [PATCH] Use gcd from boost::math::gcd
|
||||
|
||||
According to the documentation "Run-time GCD & LCM Determination": [1],
|
||||
gcd should be consumed from boost::math::gcd.
|
||||
|
||||
[1] <http://www.boost.org/doc/libs/1_64_0/libs/math/doc/html/math_toolkit/run_time.html>
|
||||
|
||||
Change-Id: I026a4e8ead75399765eb73fa5434a57958676383
|
||||
Reviewed-on: https://gerrit.libreoffice.org/37260
|
||||
Tested-by: Jenkins <ci@libreoffice.org>
|
||||
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
|
||||
---
|
||||
tools/source/generic/fract.cxx | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tools/source/generic/fract.cxx b/tools/source/generic/fract.cxx
|
||||
index bc9bef467e86..afcb2e60ba42 100644
|
||||
--- a/tools/source/generic/fract.cxx
|
||||
+++ b/tools/source/generic/fract.cxx
|
||||
@@ -30,6 +30,7 @@
|
||||
#include <algorithm>
|
||||
#include <cmath>
|
||||
|
||||
+#include <boost/math/common_factor_rt.hpp>
|
||||
#include <boost/rational.hpp>
|
||||
|
||||
template<typename T>
|
||||
@@ -180,8 +181,8 @@ namespace
|
||||
T den = r.denominator();
|
||||
|
||||
// Avoid overflow and preserve normalization
|
||||
- T gcd1 = boost::integer::gcd(i.numerator(), den);
|
||||
- T gcd2 = boost::integer::gcd(num, i.denominator());
|
||||
+ T gcd1 = boost::math::gcd(i.numerator(), den);
|
||||
+ T gcd2 = boost::math::gcd(num, i.denominator());
|
||||
|
||||
bool fail = false;
|
||||
fail |= o3tl::checked_multiply(i.numerator() / gcd1, num / gcd2, num);
|
||||
--
|
||||
2.12.2
|
||||
|
@ -1,25 +0,0 @@
|
||||
From e60b045a77cc058d1c48fe78b8329b272993a853 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Fri, 5 May 2017 09:55:52 +0200
|
||||
Subject: [PATCH] add missing dep on dir
|
||||
|
||||
Change-Id: I3bf9077e0d4fdb39ffc93e8acd972e2dbc3537e4
|
||||
---
|
||||
postprocess/CustomTarget_images.mk | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/postprocess/CustomTarget_images.mk b/postprocess/CustomTarget_images.mk
|
||||
index 4ea776509866..87b5faefb6ed 100644
|
||||
--- a/postprocess/CustomTarget_images.mk
|
||||
+++ b/postprocess/CustomTarget_images.mk
|
||||
@@ -16,6 +16,7 @@ helpimages_DIR := $(call gb_CustomTarget_get_workdir,helpcontent2/source/auxilia
|
||||
$(eval $(call gb_CustomTarget_register_targets,postprocess/images,\
|
||||
$(foreach theme,$(WITH_THEMES),images_$(theme).zip) \
|
||||
commandimagelist.ilst \
|
||||
+ sourceimagelist.ilst \
|
||||
sorted.lst \
|
||||
))
|
||||
|
||||
--
|
||||
2.12.2
|
||||
|
@ -1,32 +0,0 @@
|
||||
From 6f53cf281eb3c13fc516ff79decb70b2a87a96d0 Mon Sep 17 00:00:00 2001
|
||||
From: Markus Mohrhard <markus.mohrhard@googlemail.com>
|
||||
Date: Sat, 29 Apr 2017 05:11:40 +0200
|
||||
Subject: [PATCH] apparently the executable does not need pdfium directly
|
||||
anymore
|
||||
|
||||
Change-Id: If7ec9a18603005791ff948c7ecfddc5010ac88fe
|
||||
Reviewed-on: https://gerrit.libreoffice.org/37091
|
||||
Tested-by: Jenkins <ci@libreoffice.org>
|
||||
Reviewed-by: Markus Mohrhard <markus.mohrhard@googlemail.com>
|
||||
---
|
||||
xmlsecurity/Executable_pdfverify.mk | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/xmlsecurity/Executable_pdfverify.mk b/xmlsecurity/Executable_pdfverify.mk
|
||||
index 9a67a785983a..11c22d1d7ea6 100644
|
||||
--- a/xmlsecurity/Executable_pdfverify.mk
|
||||
+++ b/xmlsecurity/Executable_pdfverify.mk
|
||||
@@ -11,10 +11,6 @@ $(eval $(call gb_Executable_Executable,pdfverify))
|
||||
|
||||
$(eval $(call gb_Executable_use_sdk_api,pdfverify))
|
||||
|
||||
-$(eval $(call gb_Executable_use_externals,pdfverify,\
|
||||
- pdfium \
|
||||
-))
|
||||
-
|
||||
$(eval $(call gb_Executable_set_include,pdfverify,\
|
||||
$$(INCLUDE) \
|
||||
-I$(SRCDIR)/xmlsecurity/inc \
|
||||
--
|
||||
2.12.2
|
||||
|
Loading…
Reference in new issue