upgrade to 7.2.5

f41
Caolán McNamara 3 years ago
parent 5e42048a0f
commit 2f5722c55e

12
.gitignore vendored

@ -6,9 +6,9 @@
/f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf /f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
/libreoffice-multiliblauncher.sh /libreoffice-multiliblauncher.sh
/dtoa-20180411.tgz /dtoa-20180411.tgz
/libreoffice-7.2.4.1.tar.xz /libreoffice-7.2.5.2.tar.xz
/libreoffice-7.2.4.1.tar.xz.asc /libreoffice-7.2.5.2.tar.xz.asc
/libreoffice-help-7.2.4.1.tar.xz /libreoffice-help-7.2.5.2.tar.xz
/libreoffice-help-7.2.4.1.tar.xz.asc /libreoffice-help-7.2.5.2.tar.xz.asc
/libreoffice-translations-7.2.4.1.tar.xz /libreoffice-translations-7.2.5.2.tar.xz
/libreoffice-translations-7.2.4.1.tar.xz.asc /libreoffice-translations-7.2.5.2.tar.xz.asc

@ -0,0 +1,135 @@
From 5db8b1c97bcbc80d2ed904ab40cafe1267a9848c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Wed, 15 Dec 2021 12:46:24 +0000
Subject: [PATCH] annocheck warning about missing .note.gnu.property section
copy and paste recommendation from:
https://sourceware.org/annobin/annobin.html/Test-cf-protection.html
and adapt like:
https://github.com/openssl/openssl/commit/51994e505dbb1cd0dd76869ec962e2948b77b585
where https://bugs.ruby-lang.org/attachments/8962 is similar
Intel docs have "The ENDBR32 and ENDBR64 (collectively ENDBRANCH) are
two new instructions that are used to mark valid indirect CALL/JMP
target locations in the program."
Change-Id: Ie867c263a888763db4478720ba189c9ec6cc974d
---
.../source/cpp_uno/gcc3_linux_intel/call.s | 16 ++++++++++++++++
.../source/cpp_uno/gcc3_linux_x86-64/call.s | 19 +++++++++++++++++++
config_host.mk.in | 1 +
configure.ac | 14 ++++++++++++++
solenv/gbuild/platform/com_GCC_class.mk | 1 +
5 files changed, 51 insertions(+)
diff --git a/bridges/source/cpp_uno/gcc3_linux_intel/call.s b/bridges/source/cpp_uno/gcc3_linux_intel/call.s
index 6be583247733..0a5870defcf3 100644
--- a/bridges/source/cpp_uno/gcc3_linux_intel/call.s
+++ b/bridges/source/cpp_uno/gcc3_linux_intel/call.s
@@ -290,3 +290,19 @@ privateSnippetExecutorClass:
.align 4
.LEFDEc:
.section .note.GNU-stack,"",@progbits
+ .section .note.gnu.property,"a"
+ .p2align 2
+ .long 1f - 0f
+ .long 4f - 1f
+ .long 5
+0:
+ .string "GNU"
+1:
+ .p2align 2
+ .long 0xc0000002
+ .long 3f - 2f
+2:
+ .long 0x3
+3:
+ .p2align 2
+4:
diff --git a/bridges/source/cpp_uno/gcc3_linux_x86-64/call.s b/bridges/source/cpp_uno/gcc3_linux_x86-64/call.s
index 447ac0cecfdd..2e9346dff8a0 100644
--- a/bridges/source/cpp_uno/gcc3_linux_x86-64/call.s
+++ b/bridges/source/cpp_uno/gcc3_linux_x86-64/call.s
@@ -22,6 +22,9 @@
.type privateSnippetExecutor, @function
privateSnippetExecutor:
.LFB3:
+#if defined(END_BRANCH_INS_SUPPORT)
+ endbr64
+#endif
pushq %rbp
.LCFI0:
movq %rsp, %rbp
@@ -115,3 +118,19 @@ privateSnippetExecutor:
.align 8
.LEFDE1:
.section .note.GNU-stack,"",@progbits
+ .section .note.gnu.property,"a"
+ .p2align 3
+ .long 1f - 0f
+ .long 4f - 1f
+ .long 5
+0:
+ .string "GNU"
+1:
+ .p2align 3
+ .long 0xc0000002
+ .long 3f - 2f
+2:
+ .long 0x3
+3:
+ .p2align 3
+4:
diff --git a/config_host.mk.in b/config_host.mk.in
index 0fe4fd84cd41..c78eabd54d09 100644
--- a/config_host.mk.in
+++ b/config_host.mk.in
@@ -262,6 +262,7 @@ export GTK4_CFLAGS=$(gb_SPACE)@GTK4_CFLAGS@
export GTK4_LIBS=$(gb_SPACE)@GTK4_LIBS@
export USING_X11=@USING_X11@
export HAMCREST_JAR=@HAMCREST_JAR@
+export HAVE_ASM_END_BRANCH_INS_SUPPORT=@HAVE_ASM_END_BRANCH_INS_SUPPORT@
export HAVE_BROKEN_GCC_WMAYBE_UNINITIALIZED=@HAVE_BROKEN_GCC_WMAYBE_UNINITIALIZED@
export HAVE_BROKEN_GCC_WSTRINGOP_OVERFLOW=@HAVE_BROKEN_GCC_WSTRINGOP_OVERFLOW@
export HAVE_CLANG_DEBUG_INFO_KIND_CONSTRUCTOR=@HAVE_CLANG_DEBUG_INFO_KIND_CONSTRUCTOR@
diff --git a/configure.ac b/configure.ac
index 06d7901c7c79..0400bd390e8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7927,6 +7927,20 @@ _ACEOF
CPPFLAGS="$save_CPPFLAGS"
+ AC_MSG_CHECKING([if CET endbranch is recognized])
+cat > endbr.s <<_ACEOF
+endbr32
+_ACEOF
+ HAVE_ASM_END_BRANCH_INS_SUPPORT=
+ if $CXX -c endbr.s -o endbr.o >/dev/null 2>&5; then
+ AC_MSG_RESULT([yes])
+ HAVE_ASM_END_BRANCH_INS_SUPPORT=TRUE
+ else
+ AC_MSG_RESULT([no])
+ fi
+ rm -f endbr.s endbr.o
+ AC_SUBST(HAVE_ASM_END_BRANCH_INS_SUPPORT)
+
AC_LANG_POP([C++])
fi
diff --git a/solenv/gbuild/platform/com_GCC_class.mk b/solenv/gbuild/platform/com_GCC_class.mk
index c29e2a979fd9..e2056abf9682 100644
--- a/solenv/gbuild/platform/com_GCC_class.mk
+++ b/solenv/gbuild/platform/com_GCC_class.mk
@@ -44,6 +44,7 @@ $(call gb_Helper_abbreviate_dirs,\
-x assembler-with-cpp \
$(gb_LTOFLAGS) \
$(gb_AFLAGS) \
+ $(if $(HAVE_ASM_END_BRANCH_INS_SUPPORT),-DEND_BRANCH_INS_SUPPORT) \
-c $(3) \
-o $(1)) \
$(INCLUDE) && \
--
2.33.1

@ -1,5 +1,5 @@
# download path contains version without the last (fourth) digit # download path contains version without the last (fourth) digit
%global libo_version 7.2.4 %global libo_version 7.2.5
# Should contain .alphaX / .betaX, if this is pre-release (actually # Should contain .alphaX / .betaX, if this is pre-release (actually
# pre-RC) version. The pre-release string is part of tarball file names, # pre-RC) version. The pre-release string is part of tarball file names,
# so we need a way to define it easily at one place. # so we need a way to define it easily at one place.
@ -49,8 +49,8 @@
Summary: Free Software Productivity Suite Summary: Free Software Productivity Suite
Name: libreoffice Name: libreoffice
Epoch: 1 Epoch: 1
Version: %{libo_version}.1 Version: %{libo_version}.2
Release: 2%{?libo_prerelease}%{?dist} Release: 1%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and MPLv2.0 and CC0 License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and MPLv2.0 and CC0
URL: http://www.libreoffice.org/ URL: http://www.libreoffice.org/
@ -250,6 +250,7 @@ Patch2: 0001-Resolves-rhbz-1432468-disable-opencl-by-default.patch
# backported # backported
Patch3: 0001-make-with-idlc-cpp-cpp-work-for-gcc-cpp-as-a-ucpp-re.patch Patch3: 0001-make-with-idlc-cpp-cpp-work-for-gcc-cpp-as-a-ucpp-re.patch
Patch4: 0001-Revert-tdf-101630-gdrive-support-w-oAuth-and-Drive-A.patch Patch4: 0001-Revert-tdf-101630-gdrive-support-w-oAuth-and-Drive-A.patch
Patch5: 0001-annocheck-warning-about-missing-.note.gnu.property-s.patch
# not upstreamed # not upstreamed
Patch500: 0001-disable-libe-book-support.patch Patch500: 0001-disable-libe-book-support.patch
@ -2246,6 +2247,9 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor &>/dev/null || :
%{_includedir}/LibreOfficeKit %{_includedir}/LibreOfficeKit
%changelog %changelog
* Thu Jan 06 2022 Caolán McNamara <caolanm@redhat.com> - 1:7.2.5.2-1
- upgrade to 7.2.5
* Mon Dec 13 2021 Caolán McNamara <caolanm@redhat.com> - 1:7.2.4.1-2 * Mon Dec 13 2021 Caolán McNamara <caolanm@redhat.com> - 1:7.2.4.1-2
- Resolves: rhbz#2028991 fix insert, object, QR code - Resolves: rhbz#2028991 fix insert, object, QR code

@ -6,9 +6,9 @@ SHA512 (a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip) = 2d3835f7ac356805025
SHA512 (f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf) = 6a6d131dad5191614950a49323ae6d9385afe331983c1c85fde82ce6ee816051d95dde9ef90658b8f0a8a0a21754e72ff724bf41f6b96c046b7b4c2660f7095b SHA512 (f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf) = 6a6d131dad5191614950a49323ae6d9385afe331983c1c85fde82ce6ee816051d95dde9ef90658b8f0a8a0a21754e72ff724bf41f6b96c046b7b4c2660f7095b
SHA512 (libreoffice-multiliblauncher.sh) = db532afdf5000bc66f9e02c7d0ab586468466f63f8f0bdb204832581e8277c5c59f688fa096548d642411cb8c46e8de4a744676b4e624c075262cfd6945138cd SHA512 (libreoffice-multiliblauncher.sh) = db532afdf5000bc66f9e02c7d0ab586468466f63f8f0bdb204832581e8277c5c59f688fa096548d642411cb8c46e8de4a744676b4e624c075262cfd6945138cd
SHA512 (dtoa-20180411.tgz) = 722aa814c33a34bfffe6c0201b0035cc3b65854a0ba9ae2f51620a89d68019353e2c306651b35bca337186b22b2e9865ef3c5e3df8e9328006f882e4577f8c85 SHA512 (dtoa-20180411.tgz) = 722aa814c33a34bfffe6c0201b0035cc3b65854a0ba9ae2f51620a89d68019353e2c306651b35bca337186b22b2e9865ef3c5e3df8e9328006f882e4577f8c85
SHA512 (libreoffice-7.2.4.1.tar.xz) = 3193edbd9d162fc0b2f69e072719e4c9fb8242f6851caf101fe973e33db8440e80722bc11da410eb155de4550ed42552645f7c1a3361584a0c1cc816e4a04aaa SHA512 (libreoffice-7.2.5.2.tar.xz) = a84682597e10fabb8c1605b785510fa5fe861f3056f61bd01513e1de6ebdb8a343d254af063cd977e4379348ad28d8a457989b3d42014f1c18d5d85626f6dfe8
SHA512 (libreoffice-7.2.4.1.tar.xz.asc) = 0a958b984f390c9ac0bc7579bd207c5eea8d9914db466f0954f92201752648ca626cc3492640686b74ae94068fe39cf3c52c88a28e4a64c5a89cca2e8756c928 SHA512 (libreoffice-7.2.5.2.tar.xz.asc) = 22a2e1b5c459dd848c1287eb3ae7bcf727f50ddf7c5baf59096628ca0c3a5881a4eb1e62a45c7dc97460da8c3d0e634a2e6f81742bdde75a491fec276cf38cc7
SHA512 (libreoffice-help-7.2.4.1.tar.xz) = 132554fc3ec6c5699ed47355e993630006c48b093fe5affe505ae8292edca8764a28e5d9806658d3227d6f13226a27d8dfb38b6aa5041f92f078ba6de04b199d SHA512 (libreoffice-help-7.2.5.2.tar.xz) = 70ffcb1a96637dabd9a658151d2b88a92dd8a89cd396609339ec5470b93fbc2ae589a434b4f09d22fc8ad515369a646dd8040c33e6a91977dd7158f57cd48e00
SHA512 (libreoffice-help-7.2.4.1.tar.xz.asc) = 0030dfc9e8135da4efaa9a9815b0855e2a95868b7ef786a0fae764c8c0063882f311567433038c329068807173324d0a39c1069a0784c72e35a884c70403c5ac SHA512 (libreoffice-help-7.2.5.2.tar.xz.asc) = 47625fa54daf039a485c1416f1db5972f8c5c4c416122794d869508d1590e2b1740350ac04e1c4e4e67edba24eed765dec86bd8665c3ca744c0dd284b2376b88
SHA512 (libreoffice-translations-7.2.4.1.tar.xz) = fe978e95a295a9a0d129128cfc54de655de07e6a8152a6c04016b03132c3b33dac194f423a3ddb1cb5800f90ceb431c2ce31f37be373497969aae5bd63e3c270 SHA512 (libreoffice-translations-7.2.5.2.tar.xz) = d0d2eddef7873b41c86e4c219416f5ceabf4d171b1bc8383b01025623710df86fcb6d30904b06d94c4c2d64306b79a96b4ca3a949c8e59d6c2c24cddc1ae1301
SHA512 (libreoffice-translations-7.2.4.1.tar.xz.asc) = 46b431947e332f8b3b09636272634c1a3e03a9a6c7f3a6d8de5ed09ded9fe4ed797fb4e300daae5fda3523935d7241f5672f1f7d2de900538b63cb4f7c8fc714 SHA512 (libreoffice-translations-7.2.5.2.tar.xz.asc) = b50c5b95b61c6c0d159b006846e9b86e35b261c523cbb45d05f72b693506d548f2fab8a021973b30aa9307e92be4f20de92cdf3caad7f495c2c04ba6a726c6ff

Loading…
Cancel
Save