Remove test exclusions for aarch64

f41
Mattia Verga 1 year ago
parent a89d19d498
commit 256e9ad7ec

@ -1,33 +0,0 @@
From 52792b066bc98ae2a0813f5713756aff47a17910 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Thu, 19 Jan 2023 19:50:35 +0000
Subject: [PATCH] aarch64 failing here
Change-Id: I5f9b28814424cb3c490308875182ea675ec73866
---
sw/qa/extras/htmlimport/htmlimport.cxx | 2 ++
1 file changed, 2 insertions(+)
diff --git a/sw/qa/extras/htmlimport/htmlimport.cxx b/sw/qa/extras/htmlimport/htmlimport.cxx
index c97d4e4cbde4..7ff74bd32d02 100644
--- a/sw/qa/extras/htmlimport/htmlimport.cxx
+++ b/sw/qa/extras/htmlimport/htmlimport.cxx
@@ -299,6 +299,7 @@ CPPUNIT_TEST_FIXTURE(HtmlImportTest, testTableBorder1px)
CPPUNIT_ASSERT_MESSAGE("Missing cell right border", aBorder.InnerLineWidth > 0);
}
+#if 0
CPPUNIT_TEST_FIXTURE(HtmlImportTest, testOutlineLevel)
{
createSwWebDoc("outline-level.html");
@@ -307,6 +308,7 @@ CPPUNIT_TEST_FIXTURE(HtmlImportTest, testOutlineLevel)
CPPUNIT_ASSERT_EQUAL(static_cast<sal_Int32>(1),
getProperty<sal_Int32>(getParagraph(1), "OutlineLevel"));
}
+#endif
CPPUNIT_TEST_FIXTURE(HtmlImportTest, testReqIfBr)
{
--
2.39.0

@ -58,7 +58,7 @@ Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.3
Release: 3%{?libo_prerelease}%{?dist}
Release: 4%{?libo_prerelease}%{?dist}
# default new files are: MPLv2
# older files are typically: MPLv2 incorporating work under ASLv2
# nlpsolver is: LGPLv3
@ -270,8 +270,6 @@ Patch2: 0001-Resolves-rhbz-1432468-disable-opencl-by-default.patch
# backported
Patch3: 0001-Revert-tdf-101630-gdrive-support-w-oAuth-and-Drive-A.patch
Patch4: 0001-default-to-sifr-for-gnome-light-mode.patch
# TODO investigate these
Patch5: 0001-aarch64-failing-here.patch
# backported
Patch8: 0001-Only-pass-I.-arguments-to-g-ir-scanner-by-using-pkg-.patch
Patch9: 0001-Adapt-test-code-to-cURL-8.2.0.patch
@ -1027,8 +1025,7 @@ sed -i -e /CppunitTest_dbaccess_hsqldb_test/d dbaccess/Module_dbaccess.mk
sed -i -e s/CppunitTest_dbaccess_RowSetClones// dbaccess/Module_dbaccess.mk
%endif
%ifarch aarch64
sed -i -e /CppunitTest_sc_addin_functions_test/d sc/Module_sc.mk
sed -i -e /CppunitTest_sc_statistical_functions_test/d sc/Module_sc.mk
# Nothing to do
%endif
%ifarch s390x
sed -i -e /CppunitTest_sc_array_functions_test/d sc/Module_sc.mk
@ -2261,6 +2258,9 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor &>/dev/null || :
%{_includedir}/LibreOfficeKit
%changelog
* Sun Aug 27 2023 Mattia Verga <mattia.verga@proton.me> - 1:7.6.0.3-4
- Remove test exclusions from aarch64
* Wed Aug 23 2023 Mattia Verga <mattia.verga@proton.me> - 1:7.6.0.3-3
- Disable other failing tests under s390x
- Add patch to fix FTB under ppc64le

Loading…
Cancel
Save