what *is* it with this stupid compiler

f41
Caolán McNamara 14 years ago
parent e0360bb547
commit 1def0c7148

@ -87,6 +87,7 @@ Patch12: 0001-Removed-duplicate-code-block-mis-merge-prolly.patch
Patch13: 7de0b88ce2dd932915894385b54be1897d5ee053.zip
Patch14: 0001-Resolves-rhbz-695509-crash-in-RefreshDocumentLB.patch
Patch15: 0001-bubble-down-configure-test-findings-on-visibility.patch
Patch16: vbahelper.visibility.patch
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
%define instdir %{_libdir}
@ -706,6 +707,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
unzip -o %{PATCH13}
%patch14 -p1 -b .rhbz695509-crash-in-RefreshDocumentLB.patch
%patch15 -p1 -b .bubble-down-configure-test-findings-on-visibility.patch
%patch16 -p1 -b .vbahelper.visibility.patch
%build
echo build start time is `date`, diskspace: `df -h . | tail -n 1`

@ -0,0 +1,23 @@
--- vbahelper/inc/vbahelper/vbacollectionimpl.hxx 2011-01-28 20:27:51.507604173 +0000
+++ vbahelper/inc/vbahelper/vbacollectionimpl.hxx 2011-01-28 20:28:26.230045727 +0000
@@ -238,7 +238,7 @@
// including a HelperInterface implementation
template< typename Ifc1 >
-class ScVbaCollectionBase : public InheritedHelperInterfaceImpl< Ifc1 >
+class VBAHELPER_DLLPUBLIC ScVbaCollectionBase : public InheritedHelperInterfaceImpl< Ifc1 >
{
typedef InheritedHelperInterfaceImpl< Ifc1 > BaseColBase;
protected:
--- sc/source/ui/vba/makefile.mk 2011-02-16 14:11:02.798305236 +0000
+++ sc/source/ui/vba/makefile.mk 2011-02-16 14:11:33.039643954 +0000
@@ -117,6 +117,9 @@
$(SLO)$/vbaworksheets.obj \
$(SLO)$/vbawsfunction.obj
+EXCEPTIONSNOOPTFILES=\
+ $(SLO)$/vbasheetobjects.obj
+
.ENDIF
# --- Targets ------------------------------------------------------
Loading…
Cancel
Save