bubble down configure test findings on visibility

f41
Caolán McNamara 14 years ago
parent 903c5dac6b
commit e0360bb547

@ -0,0 +1,61 @@
From e33537190f7a57ddcfe1382d330fa5d28581f16b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Mon, 18 Apr 2011 09:01:37 +0100
Subject: [PATCH] bubble down configure test findings on visibility
---
solenv/gbuild/platform/unxgcc.mk | 22 ++++++++++++++++++----
1 files changed, 18 insertions(+), 4 deletions(-)
diff --git a/solenv/gbuild/platform/unxgcc.mk b/solenv/gbuild/platform/unxgcc.mk
index 11a0205..b58e4ba 100755
--- a/solenv/gbuild/platform/unxgcc.mk
+++ b/solenv/gbuild/platform/unxgcc.mk
@@ -59,7 +59,6 @@ endif
gb_COMPILERDEFS := \
-D$(COM) \
- -DHAVE_GCC_VISIBILITY_FEATURE \
-DCPPU_ENV=gcc3 \
-DGXX_INCLUDE_PATH=$(GXX_INCLUDE_PATH) \
@@ -71,7 +70,6 @@ gb_CFLAGS := \
-fPIC \
-fmessage-length=0 \
-fno-common \
- -fvisibility=hidden \
-pipe \
gb_CXXFLAGS := \
@@ -85,10 +83,26 @@ gb_CXXFLAGS := \
-fPIC \
-fmessage-length=0 \
-fno-common \
- -fvisibility-inlines-hidden \
- -fvisibility=hidden \
-pipe \
+ifeq ($(HAVE_GCC_VISIBILITY_FEATURE),TRUE)
+gb_COMPILERDEFS += \
+ -DHAVE_GCC_VISIBILITY_FEATURE \
+
+gb_CFLAGS += \
+ -fvisibility=hidden
+
+gb_CXXFLAGS += \
+ -fvisibility=hidden \
+
+ifneq ($(HAVE_GCC_VISIBILITY_BROKEN),TRUE)
+gb_CXXFLAGS += \
+ -fvisibility-inlines-hidden \
+
+endif
+
+endif
+
gb_CCVER := $(shell $(gb_CC) -dumpversion | $(gb_AWK) -F. -- '{ print $$1*10000+$$2*100+$$3 }')
gb_StrictAliasingUnsafe := $(shell expr $(gb_CCVER) \< 40600)
--
1.7.4.2

@ -86,6 +86,7 @@ Patch11: kde4configure.patch
Patch12: 0001-Removed-duplicate-code-block-mis-merge-prolly.patch
Patch13: 7de0b88ce2dd932915894385b54be1897d5ee053.zip
Patch14: 0001-Resolves-rhbz-695509-crash-in-RefreshDocumentLB.patch
Patch15: 0001-bubble-down-configure-test-findings-on-visibility.patch
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
%define instdir %{_libdir}
@ -704,6 +705,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch12 -p1 -b .Removed-duplicate-code-block-mis-merge-prolly.patch
unzip -o %{PATCH13}
%patch14 -p1 -b .rhbz695509-crash-in-RefreshDocumentLB.patch
%patch15 -p1 -b .bubble-down-configure-test-findings-on-visibility.patch
%build
echo build start time is `date`, diskspace: `df -h . | tail -n 1`
@ -2027,8 +2029,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%{basisinstdir}/program/kde-open-url
%changelog
* Sun Apr 17 2011 Caolán McNamara <caolanm@redhat.com> 3.3.99.1-2-UNBUILT
* Mon Apr 18 2011 Caolán McNamara <caolanm@redhat.com> 3.3.99.1-2
- Resolves: rhbz#695509 crash in RefreshDocumentLB
- bubble down configure test findings on visibility
* Tue Apr 11 2011 Caolán McNamara <caolanm@redhat.com> 3.3.99.1-1
- 3.4 beta1

Loading…
Cancel
Save