latest version

f41
Caolán McNamara 4 years ago
parent 9ae6461681
commit 148d9d28b0

12
.gitignore vendored

@ -6,9 +6,9 @@
/884ed41809687c3e168fc7c19b16585149ff058eca79acbf3ee784f6630704cc-opens___.ttf
/libreoffice-multiliblauncher.sh
/dtoa-20180411.tgz
/libreoffice-7.0.2.2.tar.xz
/libreoffice-7.0.2.2.tar.xz.asc
/libreoffice-help-7.0.2.2.tar.xz
/libreoffice-help-7.0.2.2.tar.xz.asc
/libreoffice-translations-7.0.2.2.tar.xz
/libreoffice-translations-7.0.2.2.tar.xz.asc
/libreoffice-7.0.3.1.tar.xz
/libreoffice-7.0.3.1.tar.xz.asc
/libreoffice-help-7.0.3.1.tar.xz
/libreoffice-help-7.0.3.1.tar.xz.asc
/libreoffice-translations-7.0.3.1.tar.xz
/libreoffice-translations-7.0.3.1.tar.xz.asc

@ -1,4 +1,4 @@
From a332f53a202d90e99d5159f53f59381bb5f8e4c8 Mon Sep 17 00:00:00 2001
From 2f11e4247b6332b06a5b23c33207fa10767244a6 Mon Sep 17 00:00:00 2001
From: Thierry Vignaud <thierry.vignaud@gmail.com>
Date: Thu, 30 Jan 2020 11:19:20 +0000
Subject: [PATCH] fix detecting qrcodegen
@ -10,25 +10,25 @@ Change-Id: Ib945b57420083489273cefc5655eb50932b5a3f8
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 7e1ca6d..a6eeec6 100644
index 5a14369..ebd1b55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10235,7 +10235,7 @@ if test "$with_system_qrcodegen" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_QRCODEGEN=TRUE
AC_LANG_PUSH([C++])
- AC_CHECK_HEADER(qrcodegen/QrCode.hpp, [],
+ AC_CHECK_HEADER(qrcodegencpp/QrCode.hpp, [],
[AC_MSG_ERROR(qrcodegen headers not found.)], [#include <stdexcept>])
AC_CHECK_LIB([qrcodegencpp], [main], [:],
[ AC_MSG_ERROR(qrcodegen C++ library not found.) ], [])
@@ -10250,7 +10250,7 @@ else
AC_MSG_RESULT([external])
SYSTEM_QRCODEGEN=TRUE
AC_LANG_PUSH([C++])
- AC_CHECK_HEADER(qrcodegen/QrCode.hpp, [],
+ AC_CHECK_HEADER(qrcodegencpp/QrCode.hpp, [],
[AC_MSG_ERROR(qrcodegen headers not found.)], [#include <stdexcept>])
AC_CHECK_LIB([qrcodegencpp], [main], [:],
[ AC_MSG_ERROR(qrcodegen C++ library not found.) ], [])
diff --git a/cui/source/dialogs/QrCodeGenDialog.cxx b/cui/source/dialogs/QrCodeGenDialog.cxx
index 85ed930..0850db5 100644
index 7f3f6a8..b79a356 100644
--- a/cui/source/dialogs/QrCodeGenDialog.cxx
+++ b/cui/source/dialogs/QrCodeGenDialog.cxx
@@ -18,7 +18,7 @@
#include <vcl/svapp.hxx>
@@ -19,7 +19,7 @@
#if ENABLE_QRCODEGEN
#if defined(SYSTEM_QRCODEGEN)
-#include <qrcodegen/QrCode.hpp>
+#include <qrcodegencpp/QrCode.hpp>

@ -1,5 +1,5 @@
# download path contains version without the last (fourth) digit
%global libo_version 7.0.2
%global libo_version 7.0.3
# Should contain .alphaX / .betaX, if this is pre-release (actually
# pre-RC) version. The pre-release string is part of tarball file names,
# so we need a way to define it easily at one place.
@ -49,8 +49,8 @@
Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.2
Release: 3%{?libo_prerelease}%{?dist}
Version: %{libo_version}.1
Release: 1%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and MPLv2.0 and CC0
URL: http://www.libreoffice.org/
@ -2233,6 +2233,9 @@ done
%{_includedir}/LibreOfficeKit
%changelog
* Thu Oct 29 2020 Caolán McNamara <caolanm@redhat.com> - 1:7.0.3.2-1
- latest version
* Sun Oct 25 2020 Caolán McNamara <caolanm@redhat.com> - 1:7.0.2.2-3
- Resolves: rhbz#1891326 suggest package install of the best pt-* langpack

@ -7,9 +7,9 @@ SHA512 (0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz) = b9c02d63e9b47a838d
SHA512 (884ed41809687c3e168fc7c19b16585149ff058eca79acbf3ee784f6630704cc-opens___.ttf) = ce7e23e750f2c6f7ff2e590cc8941caa18eaae2727c9ca31313ab72ab19278055bd9393d38b0b5b685594e2f04ee15cb83b3bbb25d09665fe7383d7f26bf2ae8
SHA512 (libreoffice-multiliblauncher.sh) = db532afdf5000bc66f9e02c7d0ab586468466f63f8f0bdb204832581e8277c5c59f688fa096548d642411cb8c46e8de4a744676b4e624c075262cfd6945138cd
SHA512 (dtoa-20180411.tgz) = 722aa814c33a34bfffe6c0201b0035cc3b65854a0ba9ae2f51620a89d68019353e2c306651b35bca337186b22b2e9865ef3c5e3df8e9328006f882e4577f8c85
SHA512 (libreoffice-7.0.2.2.tar.xz) = f0f54562f42ec9274e81a0fc898f90328053e02e8554b62a3cd2f0f79bce794528d1113102c3d5d9744fee712c869dba990e9466a1a31b3cfb716c12d7db6552
SHA512 (libreoffice-7.0.2.2.tar.xz.asc) = ec7a2c9035d88138e6391d1d3dbfd631bde7724a404c07002fa6d1372dd81786266659ca48228b91f0f2bd54b857e99786e2924fbc80735bcfdac5bcecdce9b1
SHA512 (libreoffice-help-7.0.2.2.tar.xz) = bd9e307eeb7a4f971a3f0aeaa2f372fc9b5b5c13fa08bb844e848d518f88425003a0608b362c4c9568e85c65eeedd817e0530816854be4ecb06dc1d7b2e06574
SHA512 (libreoffice-help-7.0.2.2.tar.xz.asc) = 19898e230f78cb889a3c1842027af36644f993793fde76b6751ad45ba39f25d812ab5afae1477711c1993b26ffca8d1006db990e51a97701edb5f7b2e83a9bbb
SHA512 (libreoffice-translations-7.0.2.2.tar.xz) = 54d49a8c8bf3897dbfc706683993f8accc0921d11226bca5224c731f490bf1d35ee48484acb1bb60907c2417dec2867bf39ae6e5c23e851ca754dfa02c64f0ee
SHA512 (libreoffice-translations-7.0.2.2.tar.xz.asc) = 972d752e4e83678e5b1bd591c2a74a22f1d789cddeb75ec06bb49e7b7ea0e1f9b3e41131b9b9828eab4f50528548d7b9ad2fa169607d6bf013d725fe2ba643d1
SHA512 (libreoffice-7.0.3.1.tar.xz) = 1680b5166ead7ca521130f7d23cb2bd73d3d4f801f94c9a3ab0066fb7763ced3c01d89fbe1b7a79a1826bcfd6ebcd3ce5fb3014ab6583034f08ed25969ab5f36
SHA512 (libreoffice-7.0.3.1.tar.xz.asc) = 70b3199448a75132b4f5293f69204a8c79fb5ce38a8020a1e3abec53af7703c9de788bbe47523a54974fdc705796fc2bc92ec6e12d7d36dbfb65948b0e01fc5d
SHA512 (libreoffice-help-7.0.3.1.tar.xz) = 1acbc7575da99ce0a09a3092a8612f47c432ffd8d4b6029c885c782a857c6b0812bb2eee3873b0cdfa41ee42f84a0843c3d06109ccb651b5bba5ade1a6725a78
SHA512 (libreoffice-help-7.0.3.1.tar.xz.asc) = dce1a06bdd857722e0b722377ae287435b9fa38df0acb83ebca8fd7bcd71d9ead057604fafec1e6aa4cb8cd25a2d78866a26eab6c3be6dacac276acfbb8187ce
SHA512 (libreoffice-translations-7.0.3.1.tar.xz) = ad9e081a233f9dc53028b4ac913d503bd88ba4c0a3e8325008b6c64cf845dc1724e77ad04d37b5c4b594548f2429cd9a554cdcbbdf454d1797d1c41271a52192
SHA512 (libreoffice-translations-7.0.3.1.tar.xz.asc) = ab260da507cc8396884d6ec7084a765a82b25f427ce82a569a701e3706462fed13680c3eb1fb8285e2253061ad61829954710ce60d3cda0d05eb23f87a1d540b

Loading…
Cancel
Save