add support for aarch64

f41
David Tardon 11 years ago
parent 72deb2ea93
commit 4d1b2719ca

@ -0,0 +1,13 @@
diff --git a/configure b/configure
index 65e7d48..c85e89d 100755
--- a/configure
+++ b/configure
@@ -15335,7 +15335,7 @@ $as_echo_n "checking for boostlib >= $boost_lib_version_req... " >&6; }
libsubdirs="lib"
ax_arch=`uname -m`
- if test $ax_arch = x86_64 -o $ax_arch = ppc64 -o $ax_arch = s390x -o $ax_arch = sparc64; then
+ if test $ax_arch = x86_64 -o $ax_arch = aarch64 -o $ax_arch = ppc64 -o $ax_arch = s390x -o $ax_arch = sparc64; then
libsubdirs="lib64 lib lib64"
fi

@ -2,7 +2,7 @@
Name: liborcus Name: liborcus
Version: 0.5.1 Version: 0.5.1
Release: 5%{?dist} Release: 6%{?dist}
Summary: Standalone file import filter library for spreadsheet documents Summary: Standalone file import filter library for spreadsheet documents
Group: System Environment/Libraries Group: System Environment/Libraries
@ -13,6 +13,8 @@ Source: http://kohei.us/files/orcus/src/%{name}-%{version}.tar.bz2
BuildRequires: boost-devel BuildRequires: boost-devel
BuildRequires: zlib-devel BuildRequires: zlib-devel
Patch0: add-aarch64.patch
%description %description
%{name} is a standalone file import filter library for spreadsheet %{name} is a standalone file import filter library for spreadsheet
documents. Currently under development are ODS, XLSX and CSV import documents. Currently under development are ODS, XLSX and CSV import
@ -37,6 +39,8 @@ Tools for working with %{name}.
%prep %prep
%setup -q %setup -q
%patch0 -p1
# fix build of orcus-zip-dump # fix build of orcus-zip-dump
sed -i -e 's/orcus_zip_dump_LDADD = /& $(BOOST_SYSTEM_LIB) /' \ sed -i -e 's/orcus_zip_dump_LDADD = /& $(BOOST_SYSTEM_LIB) /' \
src/Makefile.in src/Makefile.in
@ -88,6 +92,9 @@ make check %{?_smp_mflags}
%{_bindir}/orcus-zip-dump %{_bindir}/orcus-zip-dump
%changelog %changelog
* Wed Jan 22 2014 David Tardon <dtardon@redhat.com> - 0.5.1-6
- add support for aarch64
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-5 * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

Loading…
Cancel
Save