commit
db94aa5d79
@ -0,0 +1,2 @@
|
|||||||
|
SOURCES/openmp-14.0.6.src.tar.xz
|
||||||
|
SOURCES/tstellar-gpg-key.asc
|
@ -0,0 +1,2 @@
|
|||||||
|
647f1db43c1bb3b8b7c947dd54a1c3d247685d68 SOURCES/openmp-14.0.6.src.tar.xz
|
||||||
|
b8d2648a01d36ed0186fd2c5af325fd28797f9a0 SOURCES/tstellar-gpg-key.asc
|
@ -0,0 +1,27 @@
|
|||||||
|
From f2c9c1c9cda831a4305e2dc8899d630ed727353a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tom Stellard <tstellar@redhat.com>
|
||||||
|
Date: Tue, 16 May 2017 11:52:19 -0400
|
||||||
|
Subject: [PATCH] [PATCH][openmp] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a
|
||||||
|
cache variable when bulding standalone
|
||||||
|
|
||||||
|
This way it can be overriden on the command line.
|
||||||
|
---
|
||||||
|
openmp/runtime/src/CMakeLists.txt | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.txt
|
||||||
|
index 822f9ca..583a3c3 100644
|
||||||
|
--- a/openmp/runtime/src/CMakeLists.txt
|
||||||
|
+++ b/openmp/runtime/src/CMakeLists.txt
|
||||||
|
@@ -346,7 +346,7 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
|
||||||
|
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
|
||||||
|
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
|
||||||
|
if(${OPENMP_STANDALONE_BUILD})
|
||||||
|
- set(LIBOMP_HEADERS_INSTALL_PATH "${CMAKE_INSTALL_INCLUDEDIR}")
|
||||||
|
+ set(LIBOMP_HEADERS_INSTALL_PATH include CACHE PATH "Install path for OpenMP headers")
|
||||||
|
else()
|
||||||
|
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})
|
||||||
|
set(LIBOMP_HEADERS_INSTALL_PATH "${OPENMP_INSTALL_LIBDIR}/clang/${CLANG_VERSION}/include")
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
@ -0,0 +1,15 @@
|
|||||||
|
import tempfile
|
||||||
|
|
||||||
|
compiler = '%(libomp_compiler)s' % lit_config.params
|
||||||
|
config.test_filecheck = '%(bindir)s/FileCheck' % lit_config.params
|
||||||
|
config.omp_header_directory = '%(includedir)s' % lit_config.params
|
||||||
|
config.libomp_obj_root = tempfile.mkdtemp()
|
||||||
|
config.library_dir = '%(libdir)s' % lit_config.params
|
||||||
|
test_root = '%(libomp_test_root)s' % lit_config.params
|
||||||
|
|
||||||
|
# Lit will default to the compiler used to build openmp, which is gcc, but we
|
||||||
|
# want to run the tests using clang.
|
||||||
|
config.test_compiler_features = ['clang']
|
||||||
|
config.test_c_compiler = 'clang'
|
||||||
|
config.test_cxx_compiler = 'clang++'
|
||||||
|
lit_config.load_config(config, '%(libomp_test_root)s/lit.cfg' % lit_config.params)
|
Binary file not shown.
@ -0,0 +1,59 @@
|
|||||||
|
#!/usr/bin/bash
|
||||||
|
|
||||||
|
usage() {
|
||||||
|
echo "usage: `basename $0` [OPTIONS]"
|
||||||
|
echo " --threads NUM The number of threads to use for running tests."
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
threads_arg=''
|
||||||
|
|
||||||
|
while [ $# -gt 0 ]; do
|
||||||
|
case $1 in
|
||||||
|
--threads)
|
||||||
|
shift
|
||||||
|
threads_arg="--threads $1"
|
||||||
|
;;
|
||||||
|
--multilib-arch)
|
||||||
|
shift
|
||||||
|
ARCH=$1
|
||||||
|
;;
|
||||||
|
* )
|
||||||
|
echo "unknown option: $1"
|
||||||
|
echo ""
|
||||||
|
usage
|
||||||
|
exit 1
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
shift
|
||||||
|
done
|
||||||
|
|
||||||
|
|
||||||
|
set -xe
|
||||||
|
|
||||||
|
if [ -z "$ARCH" ]; then
|
||||||
|
ARCH=`rpm --eval '%_arch'`
|
||||||
|
fi
|
||||||
|
|
||||||
|
case $ARCH in
|
||||||
|
arm)
|
||||||
|
;&
|
||||||
|
i686)
|
||||||
|
LIB_DIR="/usr/lib/"
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
LIB_DIR="/usr/lib64/"
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
BIN_DIR="/usr/bin/"
|
||||||
|
INCLUDE_DIR="/usr/include/"
|
||||||
|
|
||||||
|
lit $threads_arg -v \
|
||||||
|
--config-prefix $ARCH \
|
||||||
|
-Dlibomp_compiler=clang \
|
||||||
|
-Dbindir=$BIN_DIR \
|
||||||
|
-Dlibdir=$LIB_DIR \
|
||||||
|
-Dincludedir=$INCLUDE_DIR \
|
||||||
|
-Dlibomp_test_root=/usr/share/libomp/src/runtime/test \
|
||||||
|
/usr/share/libomp/src/runtime/test
|
@ -0,0 +1,379 @@
|
|||||||
|
%global libomp_version 14.0.6
|
||||||
|
#global rc_ver 1
|
||||||
|
%global libomp_srcdir openmp-%{libomp_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
|
|
||||||
|
|
||||||
|
%ifarch ppc64le
|
||||||
|
%global libomp_arch ppc64
|
||||||
|
%else
|
||||||
|
%global libomp_arch %{_arch}
|
||||||
|
%endif
|
||||||
|
|
||||||
|
Name: libomp
|
||||||
|
Version: %{libomp_version}%{?rc_ver:~rc%{rc_ver}}
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: OpenMP runtime for clang
|
||||||
|
|
||||||
|
License: NCSA
|
||||||
|
URL: http://openmp.llvm.org
|
||||||
|
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{libomp_version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz
|
||||||
|
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{libomp_version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz.sig
|
||||||
|
Source2: tstellar-gpg-key.asc
|
||||||
|
Source3: run-lit-tests
|
||||||
|
Source4: lit.fedora.cfg.py
|
||||||
|
|
||||||
|
Patch0: 0001-PATCH-openmp-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: cmake
|
||||||
|
BuildRequires: ninja-build
|
||||||
|
BuildRequires: elfutils-libelf-devel
|
||||||
|
BuildRequires: perl
|
||||||
|
BuildRequires: perl-Data-Dumper
|
||||||
|
BuildRequires: perl-Encode
|
||||||
|
BuildRequires: libffi-devel
|
||||||
|
|
||||||
|
# For gpg source verification
|
||||||
|
BuildRequires: gnupg2
|
||||||
|
|
||||||
|
# libomptarget needs the llvm cmake files
|
||||||
|
BuildRequires: llvm-devel
|
||||||
|
|
||||||
|
Requires: elfutils-libelf%{?isa}
|
||||||
|
|
||||||
|
# libomp does not support s390x.
|
||||||
|
ExcludeArch: s390x
|
||||||
|
|
||||||
|
%description
|
||||||
|
OpenMP runtime for clang.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: OpenMP header files
|
||||||
|
Requires: clang-resource-filesystem%{?isa} = %{version}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
OpenMP header files.
|
||||||
|
|
||||||
|
%package test
|
||||||
|
Summary: OpenMP regression tests
|
||||||
|
Requires: %{name}%{?isa} = %{version}-%{release}
|
||||||
|
Requires: %{name}-devel%{?isa} = %{version}-%{release}
|
||||||
|
Requires: clang
|
||||||
|
Requires: llvm
|
||||||
|
Requires: gcc
|
||||||
|
Requires: gcc-c++
|
||||||
|
Requires: python3-lit
|
||||||
|
|
||||||
|
%description test
|
||||||
|
OpenMP regression tests
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||||
|
%autosetup -n %{libomp_srcdir} -p2
|
||||||
|
|
||||||
|
%build
|
||||||
|
# LTO causes build failures in this package. Disable LTO for now
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1988155
|
||||||
|
%define _lto_cflags %{nil}
|
||||||
|
|
||||||
|
%cmake -GNinja \
|
||||||
|
-DLIBOMP_INSTALL_ALIASES=OFF \
|
||||||
|
-DLLVM_DIR=%{_libdir}/cmake/llvm \
|
||||||
|
-DLIBOMP_HEADERS_INSTALL_PATH:PATH=%{_libdir}/clang/%{libomp_version}/include \
|
||||||
|
%if 0%{?__isa_bits} == 64
|
||||||
|
-DOPENMP_LIBDIR_SUFFIX=64 \
|
||||||
|
%else
|
||||||
|
-DOPENMP_LIBDIR_SUFFIX= \
|
||||||
|
%endif
|
||||||
|
-DCMAKE_SKIP_RPATH:BOOL=ON
|
||||||
|
|
||||||
|
%cmake_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cmake_install
|
||||||
|
|
||||||
|
# Test package setup
|
||||||
|
%global libomp_srcdir %{_datadir}/libomp/src/
|
||||||
|
%global libomp_testdir %{libomp_srcdir}/runtime/test/
|
||||||
|
%global lit_cfg %{libomp_testdir}/%{_arch}.site.cfg.py
|
||||||
|
%global lit_fedora_cfg %{_datadir}/libomp/lit.fedora.cfg.py
|
||||||
|
|
||||||
|
install -d %{buildroot}%{libomp_srcdir}/runtime
|
||||||
|
cp -R runtime/test %{buildroot}%{libomp_srcdir}/runtime
|
||||||
|
cp -R runtime/src %{buildroot}%{libomp_srcdir}/runtime
|
||||||
|
|
||||||
|
# Generate lit config files. Strip off the last line that initiates the
|
||||||
|
# test run, so we can customize the configuration.
|
||||||
|
head -n -1 %{_vpath_builddir}/runtime/test/lit.site.cfg >> %{buildroot}%{lit_cfg}
|
||||||
|
|
||||||
|
# Install custom fedora config file
|
||||||
|
cp %{SOURCE4} %{buildroot}%{lit_fedora_cfg}
|
||||||
|
|
||||||
|
# Patch lit config files to load custom fedora config
|
||||||
|
echo "lit_config.load_config(config, '%{lit_fedora_cfg}')" >> %{buildroot}%{lit_cfg}
|
||||||
|
|
||||||
|
# Install test script
|
||||||
|
install -d %{buildroot}%{_libexecdir}/tests/libomp
|
||||||
|
install -m 0755 %{SOURCE3} %{buildroot}%{_libexecdir}/tests/libomp
|
||||||
|
|
||||||
|
# Remove static libraries with equivalent shared libraries
|
||||||
|
rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
||||||
|
|
||||||
|
%check
|
||||||
|
%cmake_build --target check-openmp
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license LICENSE.TXT
|
||||||
|
%{_libdir}/libomp.so
|
||||||
|
%{_libdir}/libompd.so
|
||||||
|
%ifnarch %{arm}
|
||||||
|
%{_libdir}/libarcher.so
|
||||||
|
%endif
|
||||||
|
%ifnarch %{ix86} %{arm}
|
||||||
|
%{_libdir}/libomptarget.rtl.amdgpu.so
|
||||||
|
%{_libdir}/libomptarget.rtl.cuda.so
|
||||||
|
%{_libdir}/libomptarget.rtl.%{libomp_arch}.so
|
||||||
|
%endif
|
||||||
|
%{_libdir}/libomptarget.so
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_libdir}/clang/%{libomp_version}/include/omp.h
|
||||||
|
%{_libdir}/cmake/openmp/FindOpenMPTarget.cmake
|
||||||
|
%ifnarch %{arm}
|
||||||
|
%{_libdir}/clang/%{libomp_version}/include/omp-tools.h
|
||||||
|
%{_libdir}/clang/%{libomp_version}/include/ompt.h
|
||||||
|
# FIXME: This is probably wrong. Seems like LIBOMP_HEADERS_INSTALL may
|
||||||
|
# not be respected.
|
||||||
|
%{_includedir}/ompt-multiplex.h
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files test
|
||||||
|
%{_datadir}/libomp
|
||||||
|
%{_libexecdir}/tests/libomp/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Mar 15 2023 MSVSphere Packaging Team <packager@msvsphere.ru> - 14.0.6-1
|
||||||
|
- Rebuilt for MSVSphere 9.1.
|
||||||
|
|
||||||
|
* Wed Jul 20 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.6-1
|
||||||
|
- 14.0.6 Release
|
||||||
|
|
||||||
|
* Tue Jun 21 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.5-1
|
||||||
|
- 14.0.5 Release
|
||||||
|
|
||||||
|
* Mon Apr 25 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-1
|
||||||
|
- 14.0.0 Release
|
||||||
|
|
||||||
|
* Thu Feb 03 2022 Tom Stellard <tstellar@redhat.com> - 13.0.1-1
|
||||||
|
- 13.0.1 Release
|
||||||
|
|
||||||
|
* Tue Oct 12 2021 Timm Bäder <tbaeder@redhat.com> 13.0.0-1
|
||||||
|
- Release 13.0.0
|
||||||
|
|
||||||
|
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 12.0.1-2
|
||||||
|
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||||
|
Related: rhbz#1991688
|
||||||
|
|
||||||
|
* Tue Jul 13 2021 Tom Stellard <tstellar@redhat.com> - 12.0.1-1
|
||||||
|
- 12.0.1 Release
|
||||||
|
|
||||||
|
* Fri Apr 16 2021 Tom Stellard <tstellar@redhat.com> - 12.0.0-1
|
||||||
|
- 12.0.0 Release
|
||||||
|
|
||||||
|
* Thu Apr 08 2021 sguelton@redhat.com - 12.0.0-0.7.rc5
|
||||||
|
- New upstream release candidate
|
||||||
|
|
||||||
|
* Fri Apr 02 2021 sguelton@redhat.com - 12.0.0-0.6.rc4
|
||||||
|
- New upstream release candidate
|
||||||
|
|
||||||
|
* Wed Mar 31 2021 Jonathan Wakely <jwakely@redhat.com> - 12.0.0-0.5.rc3
|
||||||
|
- Rebuilt for removed libstdc++ symbols (#1937698)
|
||||||
|
|
||||||
|
* Thu Mar 11 2021 sguelton@redhat.com - 12.0.0-0.4.rc3
|
||||||
|
- LLVM 12.0.0 rc3
|
||||||
|
|
||||||
|
* Tue Mar 09 2021 sguelton@redhat.com - 12.0.0-0.3.rc2
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Wed Feb 24 2021 sguelton@redhat.com - 12.0.0-0.2.rc2
|
||||||
|
- 12.0.0-rc2 release
|
||||||
|
|
||||||
|
* Mon Feb 22 2021 sguelton@redhat.com - 12.0.0-0.1.rc1
|
||||||
|
- 12.0.0-rc1 release
|
||||||
|
|
||||||
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 11.1.0-0.3.rc2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 22 2021 Serge Guelton - 11.1.0-0.2.rc2
|
||||||
|
- llvm 11.1.0-rc2 release
|
||||||
|
|
||||||
|
* Thu Jan 14 2021 Serge Guelton - 11.1.0-0.1.rc1
|
||||||
|
- 11.1.0-rc1 release
|
||||||
|
|
||||||
|
* Wed Jan 06 2021 Serge Guelton - 11.0.1-3
|
||||||
|
- LLVM 11.0.1 final
|
||||||
|
|
||||||
|
* Tue Dec 22 2020 sguelton@redhat.com - 11.0.1-2.rc2
|
||||||
|
- llvm 11.0.1-rc2
|
||||||
|
|
||||||
|
* Tue Dec 01 2020 sguelton@redhat.com - 11.0.1-1.rc1
|
||||||
|
- llvm 11.0.1-rc1
|
||||||
|
|
||||||
|
* Wed Oct 28 2020 Tom Stellard <tstellar@redhat.com> - 11.0.0-2
|
||||||
|
- Replace clang-devel dependency with clang-resource-filesystem
|
||||||
|
|
||||||
|
* Thu Oct 15 2020 sguelton@redhat.com - 11.0.0-1
|
||||||
|
- Fix NVR
|
||||||
|
|
||||||
|
* Mon Oct 12 2020 sguelton@redhat.com - 11.0.0-0.5
|
||||||
|
- llvm 11.0.0 - final release
|
||||||
|
|
||||||
|
* Thu Oct 08 2020 sguelton@redhat.com - 11.0.0-0.4.rc6
|
||||||
|
- 11.0.0-rc6
|
||||||
|
|
||||||
|
* Fri Oct 02 2020 sguelton@redhat.com - 11.0.0-0.3.rc5
|
||||||
|
- 11.0.0-rc5 Release
|
||||||
|
|
||||||
|
* Sun Sep 27 2020 sguelton@redhat.com - 11.0.0-0.2.rc3
|
||||||
|
- Fix NVR
|
||||||
|
|
||||||
|
* Thu Sep 24 2020 sguelton@redhat.com - 11.0.0-0.1.rc3
|
||||||
|
- 11.0.0-rc3 Release
|
||||||
|
|
||||||
|
* Tue Sep 01 2020 sguelton@redhat.com - 11.0.0-0.1.rc2
|
||||||
|
- 11.0.0-rc2 Release
|
||||||
|
|
||||||
|
* Mon Aug 10 2020 Tom Stellard <tstellar@redhat.com> - 11.0.0-0.1.rc1
|
||||||
|
- 11.0.0-rc1 Release
|
||||||
|
|
||||||
|
* Mon Aug 10 2020 sguelton@redhat.com - 10.0.0-8
|
||||||
|
- Make gcc dependency explicit, see https://fedoraproject.org/wiki/Packaging:C_and_C%2B%2B#BuildRequires_and_Requires
|
||||||
|
- use %%license macro
|
||||||
|
|
||||||
|
* Sat Aug 08 2020 Jeff Law <releng@fedoraproject.org> - 10.0.0-7
|
||||||
|
- Disable LTO for now
|
||||||
|
|
||||||
|
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 10.0.0-6
|
||||||
|
- Second attempt - Rebuilt for
|
||||||
|
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 10.0.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 20 2020 sguelton@redhat.com - 10.0.0-4
|
||||||
|
- Use modern cmake macro
|
||||||
|
- Use gnupg verify
|
||||||
|
|
||||||
|
* Tue Jun 16 2020 sguelton@redhat.com - 10.0.0-3
|
||||||
|
- Add Requires: libomp = %{version}-%{release} to libomp-test to avoid
|
||||||
|
the need to test interoperability between the various combinations of old
|
||||||
|
and new subpackages.
|
||||||
|
|
||||||
|
* Mon Jun 01 2020 sguelton@redhat.com - 10.0.0-2
|
||||||
|
- Add Requires: libomp-devel = %{version}-%{release} to libomp-test to avoid
|
||||||
|
the need to test interoperability between the various combinations of old
|
||||||
|
and new subpackages.
|
||||||
|
|
||||||
|
* Mon Mar 30 2020 sguelton@redhat.com - 10.0.0-1
|
||||||
|
- 10.0.0 final
|
||||||
|
|
||||||
|
* Wed Mar 25 2020 sguelton@redhat.com - 10.0.0-0.6.rc6
|
||||||
|
- 10.0.0 rc6
|
||||||
|
|
||||||
|
* Fri Mar 20 2020 sguelton@redhat.com - 10.0.0-0.5.rc5
|
||||||
|
- 10.0.0 rc5
|
||||||
|
|
||||||
|
* Sun Mar 15 2020 sguelton@redhat.com - 10.0.0-0.4.rc4
|
||||||
|
- 10.0.0 rc4
|
||||||
|
|
||||||
|
* Thu Mar 05 2020 sguelton@redhat.com - 10.0.0-0.3.rc3
|
||||||
|
- 10.0.0 rc3
|
||||||
|
|
||||||
|
* Fri Feb 14 2020 sguelton@redhat.com - 10.0.0-0.2.rc2
|
||||||
|
- 10.0.0 rc2
|
||||||
|
|
||||||
|
* Fri Jan 31 2020 sguelton@redhat.com - 10.0.0-0.1.rc1
|
||||||
|
- 10.0.0 rc1
|
||||||
|
|
||||||
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 9.0.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Dec 19 2019 Tom Stellard <tstellar@redhat.com> - 9.0.1-1
|
||||||
|
- 9.0.1 Release
|
||||||
|
|
||||||
|
* Thu Sep 19 2019 Tom Stellard <tstellar@redhat.com> - 9.0.0-1
|
||||||
|
- 9.0.0 Release
|
||||||
|
|
||||||
|
* Thu Aug 22 2019 Tom Stellard <tstellar@redhat.com> - 9.0.0-0.1.rc3
|
||||||
|
- 9.0.0-rc3 Release
|
||||||
|
|
||||||
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.0.0-2.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Apr 25 2019 Tom Stellard <tstellar@redhat.com> - 8.0.0-2
|
||||||
|
- Simplify libomp-test package
|
||||||
|
|
||||||
|
* Wed Mar 20 2019 sguelton@redhat.com - 8.0.0-1
|
||||||
|
- 8.0.0 final
|
||||||
|
|
||||||
|
* Tue Mar 12 2019 sguelton@redhat.com - 8.0.0-0.3.rc4
|
||||||
|
- 8.0.0 Release candidate 4
|
||||||
|
|
||||||
|
* Mon Feb 11 2019 sguelton@redhat.com - 8.0.0-0.2.rc2
|
||||||
|
- 8.0.0 Release candidate 2
|
||||||
|
|
||||||
|
* Mon Feb 11 2019 sguelton@redhat.com - 8.0.0-0.1.rc1
|
||||||
|
- 8.0.0 Release candidate 1
|
||||||
|
|
||||||
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 7.0.1-1.1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Dec 17 2018 sguelton@redhat.com - 7.0.1-1
|
||||||
|
- 7.0.1 Release
|
||||||
|
|
||||||
|
* Wed Sep 12 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-1
|
||||||
|
- 7.0.1 Release
|
||||||
|
|
||||||
|
* Wed Sep 12 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-0.2.rc3
|
||||||
|
- 7.0.0-rc3 Release
|
||||||
|
|
||||||
|
* Tue Aug 14 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-0.1.rc1
|
||||||
|
- 7.0.1-rc1 Release
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 02 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-2
|
||||||
|
- Add -threads option to runtest.sh
|
||||||
|
|
||||||
|
* Thu Jun 28 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-1
|
||||||
|
- 6.0.1 Release
|
||||||
|
|
||||||
|
* Fri May 11 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-0.1.rc1
|
||||||
|
- 6.0.1-rc1 Release
|
||||||
|
|
||||||
|
* Wed Mar 28 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-3
|
||||||
|
- Add test package
|
||||||
|
|
||||||
|
* Wed Mar 28 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-2
|
||||||
|
- Enable libomptarget plugins
|
||||||
|
|
||||||
|
* Fri Mar 09 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-1
|
||||||
|
- 6.0.0 Release
|
||||||
|
|
||||||
|
* Tue Feb 13 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-0.3.rc2
|
||||||
|
- 6.0.0-rc2 Release
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.0-0.2.rc1
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 25 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-0.1.rc1
|
||||||
|
- 6.0.0-rc1 Release
|
||||||
|
|
||||||
|
* Thu Dec 21 2017 Tom Stellard <tstellar@redhat.com> - 5.0.1-1
|
||||||
|
- 5.0.1 Release.
|
||||||
|
|
||||||
|
* Mon May 15 2017 Tom Stellard <tstellar@redhat.com> - 5.0.0-1
|
||||||
|
- Initial version.
|
Loading…
Reference in new issue