import libomp-15.0.7-1.el9

c9 imports/c9/libomp-15.0.7-1.el9
CentOS Sources 2 years ago committed by MSVSphere Packaging Team
parent 9f518d056d
commit 7891d81657

4
.gitignore vendored

@ -1,2 +1,2 @@
SOURCES/openmp-14.0.6.src.tar.xz SOURCES/openmp-15.0.7.src.tar.xz
SOURCES/tstellar-gpg-key.asc SOURCES/release-keys.asc

@ -1,2 +1,2 @@
647f1db43c1bb3b8b7c947dd54a1c3d247685d68 SOURCES/openmp-14.0.6.src.tar.xz d8a0b4314a65a4ad3a82fbcbc59876cfcf09c95b SOURCES/openmp-15.0.7.src.tar.xz
b8d2648a01d36ed0186fd2c5af325fd28797f9a0 SOURCES/tstellar-gpg-key.asc 347bdd5ee6d6b93c9644c268511815912c0fb2dc SOURCES/release-keys.asc

@ -1,27 +0,0 @@
From f2c9c1c9cda831a4305e2dc8899d630ed727353a Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Tue, 16 May 2017 11:52:19 -0400
Subject: [PATCH] [PATCH][openmp] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a
cache variable when bulding standalone
This way it can be overriden on the command line.
---
openmp/runtime/src/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.txt
index 822f9ca..583a3c3 100644
--- a/openmp/runtime/src/CMakeLists.txt
+++ b/openmp/runtime/src/CMakeLists.txt
@@ -346,7 +346,7 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
if(${OPENMP_STANDALONE_BUILD})
- set(LIBOMP_HEADERS_INSTALL_PATH "${CMAKE_INSTALL_INCLUDEDIR}")
+ set(LIBOMP_HEADERS_INSTALL_PATH include CACHE PATH "Install path for OpenMP headers")
else()
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})
set(LIBOMP_HEADERS_INSTALL_PATH "${OPENMP_INSTALL_LIBDIR}/clang/${CLANG_VERSION}/include")
--
1.8.3.1

@ -1,6 +1,8 @@
%global libomp_version 14.0.6 %global toolchain gcc
#global rc_ver 1
%global libomp_srcdir openmp-%{libomp_version}%{?rc_ver:rc%{rc_ver}}.src %global maj_ver 15
%global libomp_version %{maj_ver}.0.7
%global libomp_srcdir openmp-%{libomp_version}.src
%ifarch ppc64le %ifarch ppc64le
@ -10,22 +12,21 @@
%endif %endif
Name: libomp Name: libomp
Version: %{libomp_version}%{?rc_ver:~rc%{rc_ver}} Version: %{libomp_version}
Release: 1%{?dist} Release: 1%{?dist}
Summary: OpenMP runtime for clang Summary: OpenMP runtime for clang
License: NCSA License: NCSA
URL: http://openmp.llvm.org URL: http://openmp.llvm.org
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{libomp_version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{libomp_version}/%{libomp_srcdir}.tar.xz
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{libomp_version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz.sig Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{libomp_version}/%{libomp_srcdir}.tar.xz.sig
Source2: tstellar-gpg-key.asc Source2: release-keys.asc
Source3: run-lit-tests Source3: run-lit-tests
Source4: lit.fedora.cfg.py Source4: lit.fedora.cfg.py
Patch0: 0001-PATCH-openmp-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-.patch BuildRequires: clang
# For clang-offload-packager
BuildRequires: gcc BuildRequires: clang-tools-extra
BuildRequires: gcc-c++
BuildRequires: cmake BuildRequires: cmake
BuildRequires: ninja-build BuildRequires: ninja-build
BuildRequires: elfutils-libelf-devel BuildRequires: elfutils-libelf-devel
@ -50,6 +51,7 @@ OpenMP runtime for clang.
%package devel %package devel
Summary: OpenMP header files Summary: OpenMP header files
Requires: %{name}%{?isa} = %{version}-%{release}
Requires: clang-resource-filesystem%{?isa} = %{version} Requires: clang-resource-filesystem%{?isa} = %{version}
%description devel %description devel
@ -61,8 +63,6 @@ Requires: %{name}%{?isa} = %{version}-%{release}
Requires: %{name}-devel%{?isa} = %{version}-%{release} Requires: %{name}-devel%{?isa} = %{version}-%{release}
Requires: clang Requires: clang
Requires: llvm Requires: llvm
Requires: gcc
Requires: gcc-c++
Requires: python3-lit Requires: python3-lit
%description test %description test
@ -73,14 +73,17 @@ OpenMP regression tests
%autosetup -n %{libomp_srcdir} -p2 %autosetup -n %{libomp_srcdir} -p2
%build %build
# LTO causes build failures in this package. Disable LTO for now
# https://bugzilla.redhat.com/show_bug.cgi?id=1988155 %if "%toolchain" == "gcc"
# Building openmp with LTO fails with GCC but works with Clang
%define _lto_cflags %{nil} %define _lto_cflags %{nil}
%endif
%cmake -GNinja \ %cmake -GNinja \
-DLIBOMP_INSTALL_ALIASES=OFF \ -DLIBOMP_INSTALL_ALIASES=OFF \
-DCMAKE_MODULE_PATH=%{_libdir}/cmake/llvm \
-DLLVM_DIR=%{_libdir}/cmake/llvm \ -DLLVM_DIR=%{_libdir}/cmake/llvm \
-DLIBOMP_HEADERS_INSTALL_PATH:PATH=%{_libdir}/clang/%{libomp_version}/include \ -DCMAKE_INSTALL_INCLUDEDIR=%{_libdir}/clang/%{libomp_version}/include \
%if 0%{?__isa_bits} == 64 %if 0%{?__isa_bits} == 64
-DOPENMP_LIBDIR_SUFFIX=64 \ -DOPENMP_LIBDIR_SUFFIX=64 \
%else %else
@ -132,11 +135,11 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
%{_libdir}/libarcher.so %{_libdir}/libarcher.so
%endif %endif
%ifnarch %{ix86} %{arm} %ifnarch %{ix86} %{arm}
%{_libdir}/libomptarget.rtl.amdgpu.so %{_libdir}/libomptarget.rtl.amdgpu.so.%{maj_ver}
%{_libdir}/libomptarget.rtl.cuda.so %{_libdir}/libomptarget.rtl.cuda.so.%{maj_ver}
%{_libdir}/libomptarget.rtl.%{libomp_arch}.so %{_libdir}/libomptarget.rtl.%{libomp_arch}.so.%{maj_ver}
%endif %endif
%{_libdir}/libomptarget.so %{_libdir}/libomptarget.so.%{maj_ver}
%files devel %files devel
%{_libdir}/clang/%{libomp_version}/include/omp.h %{_libdir}/clang/%{libomp_version}/include/omp.h
@ -144,16 +147,35 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
%ifnarch %{arm} %ifnarch %{arm}
%{_libdir}/clang/%{libomp_version}/include/omp-tools.h %{_libdir}/clang/%{libomp_version}/include/omp-tools.h
%{_libdir}/clang/%{libomp_version}/include/ompt.h %{_libdir}/clang/%{libomp_version}/include/ompt.h
# FIXME: This is probably wrong. Seems like LIBOMP_HEADERS_INSTALL may %{_libdir}/clang/%{libomp_version}/include/ompt-multiplex.h
# not be respected.
%{_includedir}/ompt-multiplex.h
%endif %endif
%ifnarch %{ix86} %{arm}
%{_libdir}/libomptarget.rtl.amdgpu.so
%{_libdir}/libomptarget.rtl.cuda.so
%{_libdir}/libomptarget.rtl.%{libomp_arch}.so
%{_libdir}/libomptarget.devicertl.a
%{_libdir}/libomptarget-amdgpu-*.bc
%{_libdir}/libomptarget-nvptx-*.bc
%endif
%{_libdir}/libomptarget.so
%files test %files test
%{_datadir}/libomp %{_datadir}/libomp
%{_libexecdir}/tests/libomp/ %{_libexecdir}/tests/libomp/
%changelog %changelog
* Mon Jan 16 2023 Konrad Kleine <kkleine@redhat.com> - 15.0.7-1
- Update to LLVM 15.0.7
* Fri Dec 09 2022 Konrad Kleine <kkleine@redhat.com> - 15.0.6-1
- 15.0.6 Release
* Fri Oct 28 2022 Konrad Kleine <kkleine@redhat.com> - 15.0.1-2
- Build libomp runtime library with gcc
* Thu Sep 29 2022 Konrad Kleine <kkleine@redhat.com> - 15.0.1-1
- 15.0.1 Release
* Wed Jul 20 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.6-1 * Wed Jul 20 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.6-1
- 14.0.6 Release - 14.0.6 Release
@ -264,12 +286,12 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
- Use gnupg verify - Use gnupg verify
* Tue Jun 16 2020 sguelton@redhat.com - 10.0.0-3 * Tue Jun 16 2020 sguelton@redhat.com - 10.0.0-3
- Add Requires: libomp = %{version}-%{release} to libomp-test to avoid - Add Requires: libomp = %%{version}-%%{release} to libomp-test to avoid
the need to test interoperability between the various combinations of old the need to test interoperability between the various combinations of old
and new subpackages. and new subpackages.
* Mon Jun 01 2020 sguelton@redhat.com - 10.0.0-2 * Mon Jun 01 2020 sguelton@redhat.com - 10.0.0-2
- Add Requires: libomp-devel = %{version}-%{release} to libomp-test to avoid - Add Requires: libomp-devel = %%{version}-%%{release} to libomp-test to avoid
the need to test interoperability between the various combinations of old the need to test interoperability between the various combinations of old
and new subpackages. and new subpackages.

Loading…
Cancel
Save