Merge branch 'master' of ssh://pkgs.fedoraproject.org/rpms/libkscreen-qt5

epel9
Rex Dieter 9 years ago
commit a68e1a81a9

@ -0,0 +1,60 @@
diff -up libkscreen-5.6.4/autotests/CMakeLists.txt.than libkscreen-5.6.4/autotests/CMakeLists.txt
--- libkscreen-5.6.4/autotests/CMakeLists.txt.than 2016-05-24 17:08:06.186036831 +0200
+++ libkscreen-5.6.4/autotests/CMakeLists.txt 2016-05-24 17:08:28.144385812 +0200
@@ -1,7 +1,5 @@
add_definitions(-DTEST_DATA="${CMAKE_CURRENT_SOURCE_DIR}/configs/")
-include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_SOURCE_DIR}/tests/kwayland/)
-
macro(KSCREEN_ADD_TEST)
foreach(_testname ${ARGN})
set(test_SRCS ${_testname}.cpp ${KSCREEN_WAYLAND_SRCS})
@@ -25,16 +23,6 @@ set(KSCREEN_WAYLAND_LIBS
KF5::WaylandServer KF5::WaylandClient
)
-# For WaylandConfigReader and TestServer
-set(KSCREEN_WAYLAND_SRCS
- ${CMAKE_SOURCE_DIR}/tests/kwayland/waylandconfigreader.cpp
- ${CMAKE_SOURCE_DIR}/tests/kwayland/waylandtestserver.cpp
-)
-include_directories(${CMAKE_CURRENT_SOURCE_DIR}/../backends/kwayland)
-
-kscreen_add_test(testkwaylandbackend)
-kscreen_add_test(testkwaylandconfig)
-
set(KSCREEN_WAYLAND_LIBS "")
set(KSCREEN_WAYLAND_SRCS "")
diff -up libkscreen-5.6.4/backends/CMakeLists.txt.than libkscreen-5.6.4/backends/CMakeLists.txt
--- libkscreen-5.6.4/backends/CMakeLists.txt.than 2016-05-24 17:02:59.142120753 +0200
+++ libkscreen-5.6.4/backends/CMakeLists.txt 2016-05-24 17:03:05.579930820 +0200
@@ -1,6 +1,5 @@
add_subdirectory(fake)
add_subdirectory(qscreen)
-add_subdirectory(kwayland)
if(${XCB_RANDR_FOUND})
message(STATUS "Will build xrandr backend.")
diff -up libkscreen-5.6.4/CMakeLists.txt.than libkscreen-5.6.4/CMakeLists.txt
--- libkscreen-5.6.4/CMakeLists.txt.than 2016-05-24 17:03:58.179375794 +0200
+++ libkscreen-5.6.4/CMakeLists.txt 2016-05-24 17:04:13.841911809 +0200
@@ -19,10 +19,6 @@ include(CheckCXXCompilerFlag)
set(REQUIRED_QT_VERSION 5.2.0)
find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Core DBus Gui Test X11Extras)
-# Wayland backend
-find_package(KF5Wayland CONFIG REQUIRED)
-add_feature_info("KF5Wayland" KF5Wayland_FOUND "Required for building libkscreen's KWayland backend")
-
# xrandr backend
find_package(XCB COMPONENTS XCB RANDR)
diff -up libkscreen-5.6.4/tests/CMakeLists.txt.than libkscreen-5.6.4/tests/CMakeLists.txt
--- libkscreen-5.6.4/tests/CMakeLists.txt.than 2016-05-24 17:07:03.588887505 +0200
+++ libkscreen-5.6.4/tests/CMakeLists.txt 2016-05-24 17:07:11.074666792 +0200
@@ -1,4 +1,2 @@
add_executable(printconfig testplugandplay.cpp testpnp.cpp)
target_link_libraries(printconfig Qt5::Gui KF5::Screen)
-
-add_subdirectory(kwayland)

@ -3,7 +3,7 @@
Name: libkscreen-qt5 Name: libkscreen-qt5
Summary: KDE display configuration library Summary: KDE display configuration library
Version: 5.6.4 Version: 5.6.4
Release: 1%{?dist} Release: 2%{?dist}
License: GPLv2+ License: GPLv2+
URL: https://quickgit.kde.org/?p=%{base_name}.git URL: https://quickgit.kde.org/?p=%{base_name}.git
@ -15,6 +15,7 @@ URL: https://quickgit.kde.org/?p=%{base_name}.git
%global stable stable %global stable stable
%endif %endif
Source0: http://download.kde.org/%{stable}/plasma/%{version}/%{base_name}-%{version}.tar.xz Source0: http://download.kde.org/%{stable}/plasma/%{version}/%{base_name}-%{version}.tar.xz
Patch1: libkscreen-5.6.4-rhel-nowayland.patch
%global majmin_ver %(echo %{version} | cut -d. -f1,2) %global majmin_ver %(echo %{version} | cut -d. -f1,2)
@ -23,7 +24,9 @@ Source0: http://download.kde.org/%{stable}/plasma/%{version}/%{base_name}
BuildRequires: extra-cmake-modules BuildRequires: extra-cmake-modules
BuildRequires: kf5-rpm-macros BuildRequires: kf5-rpm-macros
%if 0%{?fedora}
BuildRequires: kf5-kwayland-devel >= %{majmin_ver} BuildRequires: kf5-kwayland-devel >= %{majmin_ver}
%endif
BuildRequires: libX11-devel BuildRequires: libX11-devel
BuildRequires: libxcb-devel BuildRequires: libxcb-devel
BuildRequires: libXrandr-devel BuildRequires: libXrandr-devel
@ -53,8 +56,10 @@ developing applications that use %{name}.
%prep %prep
%autosetup -n %{base_name}-%{version} -p1 %setup -n %{base_name}-%{version}
%if 0%{?rhel}
%patch1 -p1 -b .nowayland
%endif
%build %build
mkdir %{_target_platform} mkdir %{_target_platform}
@ -90,6 +95,9 @@ make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%changelog %changelog
* Wed May 25 2016 Than Ngo <than@redhat.com> - 5.6.4-2
- disable wayland for epel7
* Sat May 14 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.4-1 * Sat May 14 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.4-1
- 5.6.4 - 5.6.4

Loading…
Cancel
Save