commit
e1d03d2782
@ -0,0 +1 @@
|
|||||||
|
SOURCES/v1.12.1.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
5ccac411a412732f7bbbc07e8b12b7daad855aa7 SOURCES/v1.12.1.tar.gz
|
@ -0,0 +1,34 @@
|
|||||||
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
|
index 8144c12..cee45ba 100644
|
||||||
|
--- a/Makefile.am
|
||||||
|
+++ b/Makefile.am
|
||||||
|
@@ -1,6 +1,10 @@
|
||||||
|
ACLOCAL_AMFLAGS = -I m4
|
||||||
|
|
||||||
|
-SUBDIRS = include libjwt examples tests dist
|
||||||
|
+SUBDIRS = include libjwt
|
||||||
|
+if BUILD_EXAMPLES
|
||||||
|
+SUBDIRS += examples
|
||||||
|
+endif
|
||||||
|
+SUBDIRS += tests dist
|
||||||
|
|
||||||
|
include $(top_srcdir)/doxygen.mk
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 4aa1de8..e0e9008 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -20,6 +20,13 @@ AS_IF([test "x$with_openssl" != "xno"], [
|
||||||
|
AM_CONDITIONAL([HAVE_OPENSSL], [false])
|
||||||
|
])
|
||||||
|
|
||||||
|
+AC_ARG_WITH([examples],
|
||||||
|
+ AS_HELP_STRING([--without-examples], [do not build example programs]),
|
||||||
|
+ [],
|
||||||
|
+ [with_examples=yes])
|
||||||
|
+
|
||||||
|
+AM_CONDITIONAL([BUILD_EXAMPLES], [test "x$with_examples" != "xno"])
|
||||||
|
+
|
||||||
|
PKG_CHECK_MODULES([JANSSON], [jansson >= 2.0])
|
||||||
|
PKG_CHECK_MODULES([CHECK], [check >= 0.9.4], [true], [true])
|
||||||
|
|
@ -0,0 +1,89 @@
|
|||||||
|
Name: libjwt
|
||||||
|
Version: 1.12.1
|
||||||
|
Release: 11%{?dist}
|
||||||
|
Summary: A Javascript Web Token library in C
|
||||||
|
|
||||||
|
License: MPLv2.0
|
||||||
|
URL: https://github.com/benmcollins/libjwt
|
||||||
|
Source0: https://github.com/benmcollins/libjwt/archive/v%{version}.tar.gz
|
||||||
|
|
||||||
|
Patch0: without_examples.patch
|
||||||
|
|
||||||
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: automake
|
||||||
|
BuildRequires: jansson-devel
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: libtool
|
||||||
|
BuildRequires: make
|
||||||
|
BuildRequires: openssl-devel
|
||||||
|
|
||||||
|
%description
|
||||||
|
A Javascript Web Token library in C
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup
|
||||||
|
autoreconf -i
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --disable-static --without-examples
|
||||||
|
%make_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%make_install
|
||||||
|
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license LICENSE
|
||||||
|
%doc *.md
|
||||||
|
%{_libdir}/*.so.1*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc *.md
|
||||||
|
%{_includedir}/jwt.h
|
||||||
|
%{_libdir}/libjwt.so
|
||||||
|
%{_libdir}/pkgconfig/libjwt.pc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Aug 29 2024 Eduard Basov <ebasov@msvsphere-os.ru> - 1.12.1-11
|
||||||
|
- Rebuilt for MSVSphere 9.4
|
||||||
|
|
||||||
|
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.1-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.1-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 1.12.1-9
|
||||||
|
- Rebuilt with OpenSSL 3.0.0
|
||||||
|
|
||||||
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.1-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Apr 18 2021 Philip Kovacs <pkfed@fedoraproject.org> - 1.12.1-7
|
||||||
|
- Remove examples from build
|
||||||
|
|
||||||
|
* Tue Apr 13 2021 Philip Kovacs <pkfed@fedoraproject.org> - 1.12.1-6
|
||||||
|
- Fix canonical changelog dates
|
||||||
|
|
||||||
|
* Tue Apr 13 2021 Philip Kovacs <pkfed@fedoraproject.org> - 1.12.1-5
|
||||||
|
- Build for EPEL7/8
|
||||||
|
|
||||||
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Nov 7 2020 Jared K. Smith <jsmith@fedoraproject.org> - 1.12.1-3
|
||||||
|
- More minor fixes for package review
|
||||||
|
|
||||||
|
* Tue Nov 3 2020 Jared K. Smith <jsmith@fedoraproject.org> - 1.12.1-2
|
||||||
|
- Update dependencies for package review
|
||||||
|
|
||||||
|
* Thu Oct 29 2020 Jared K. Smith <jsmith@fedoraproject.org> - 1.12.1-1
|
||||||
|
- Initial packaging
|
Loading…
Reference in new issue