Initial import (#728737)
parent
f05cb7708a
commit
2eae250e1c
@ -0,0 +1 @@
|
|||||||
|
/libinstpatch-1.0.0-svn386.tar.bz2
|
@ -0,0 +1,21 @@
|
|||||||
|
diff -rupN libinstpatch-1.0.0.old/CMakeLists.txt libinstpatch-1.0.0/CMakeLists.txt
|
||||||
|
--- libinstpatch-1.0.0.old/CMakeLists.txt 2010-11-08 18:12:26.000000000 -0500
|
||||||
|
+++ libinstpatch-1.0.0/CMakeLists.txt 2011-08-06 14:40:44.000000000 -0400
|
||||||
|
@@ -144,14 +144,14 @@ configure_file ( ${CMAKE_SOURCE_DIR}/lib
|
||||||
|
if ( UNIX OR MINGW )
|
||||||
|
# pkg-config support
|
||||||
|
set ( prefix "${CMAKE_INSTALL_PREFIX}" )
|
||||||
|
- set ( exec_prefix "\${prefix}" )
|
||||||
|
+ set ( exec_prefix "${CMAKE_INSTALL_PREFIX}" )
|
||||||
|
if (LIB_INSTALL_DIR STREQUAL ${CMAKE_INSTALL_PREFIX}/lib)
|
||||||
|
set(LIBINSTPATCH_INSTALL_DIR ${LIB_INSTALL_DIR}${LIB_SUFFIX})
|
||||||
|
else (LIB_INSTALL_DIR STREQUAL ${CMAKE_INSTALL_PREFIX}/lib)
|
||||||
|
set(LIBINSTPATCH_INSTALL_DIR ${LIB_INSTALL_DIR})
|
||||||
|
endif (LIB_INSTALL_DIR STREQUAL ${CMAKE_INSTALL_PREFIX}/lib)
|
||||||
|
- set ( libdir "\${exec_prefix}/${LIBINSTPATCH_INSTALL_DIR}" )
|
||||||
|
- set ( includedir "\${prefix}/${INCLUDE_INSTALL_DIR}" )
|
||||||
|
+ set ( libdir "${LIBINSTPATCH_INSTALL_DIR}" )
|
||||||
|
+ set ( includedir "${INCLUDE_INSTALL_DIR}" )
|
||||||
|
configure_file ( libinstpatch-1.0.pc.in
|
||||||
|
${CMAKE_BINARY_DIR}/libinstpatch-1.0.pc IMMEDIATE @ONLY )
|
||||||
|
install ( FILES ${CMAKE_BINARY_DIR}/libinstpatch-1.0.pc
|
@ -0,0 +1,37 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
# $1 - revision number to checkout.
|
||||||
|
: ${1?"You must either provide desired revision number \"X\" to checkout: `basename $0` X
|
||||||
|
or fetch the latest revision by: `basename $0` latest"}
|
||||||
|
|
||||||
|
set -e
|
||||||
|
|
||||||
|
tmp=$(mktemp -d)
|
||||||
|
|
||||||
|
trap cleanup EXIT
|
||||||
|
cleanup() {
|
||||||
|
set +e
|
||||||
|
[ -z "$tmp" -o ! -d "$tmp" ] || rm -rf "$tmp"
|
||||||
|
}
|
||||||
|
|
||||||
|
unset CDPATH
|
||||||
|
pwd=$(pwd)
|
||||||
|
name=libinstpatch
|
||||||
|
version=1.0.0
|
||||||
|
|
||||||
|
if [[ $1 == "latest" ]] ; then
|
||||||
|
revision=HEAD
|
||||||
|
else
|
||||||
|
revision=$1
|
||||||
|
fi
|
||||||
|
|
||||||
|
pushd "$tmp" >/dev/null
|
||||||
|
echo "Fetching SVN revision: $1"
|
||||||
|
svn export -r$revision https://swami.svn.sourceforge.net/svnroot/swami/trunk/$name $name-$version |tee $name.stdout
|
||||||
|
revision=$(cat $name.stdout|grep "Exported revision"|sed 's|[^0-9]*||g')
|
||||||
|
echo "Fetched SVN revision: $revision"
|
||||||
|
rm -f $name.stdout
|
||||||
|
|
||||||
|
tar jcf "$pwd"/$name-$version-svn$revision.tar.bz2 $name-$version
|
||||||
|
echo "Written: $name-$version-svn$revision.tar.bz2"
|
||||||
|
popd >/dev/null
|
@ -0,0 +1,87 @@
|
|||||||
|
Name: libinstpatch
|
||||||
|
Summary: MIDI instrument patch library
|
||||||
|
Version: 1.0.0
|
||||||
|
Release: 3.20110806svn386%{?dist}
|
||||||
|
URL: http://www.swamiproject.org/
|
||||||
|
License: LGPLv2+
|
||||||
|
# Fetch source via
|
||||||
|
# sh libinstpatch-snapshot.sh 386
|
||||||
|
Source0: libinstpatch-%{version}-svn386.tar.bz2
|
||||||
|
# script to download sources and make tarball from svn
|
||||||
|
Source1: libinstpatch-snapshot.sh
|
||||||
|
# .pc file fixes. Patch sent upstream via their mailing list
|
||||||
|
Patch0: libinstpatch-cmake-fixes.patch
|
||||||
|
|
||||||
|
BuildRequires: cmake
|
||||||
|
BuildRequires: glib2-devel
|
||||||
|
BuildRequires: libsndfile-devel
|
||||||
|
|
||||||
|
|
||||||
|
%description
|
||||||
|
libInstPatch stands for lib-Instrument-Patch and is a library for processing
|
||||||
|
digital sample based MIDI instrument "patch" files. The types of files
|
||||||
|
libInstPatch supports are used for creating instrument sounds for wavetable
|
||||||
|
synthesis. libInstPatch provides an object framework (based on GObject) to load
|
||||||
|
patch files into, which can then be edited, converted, compressed and saved.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development package for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
Requires: glib2-devel
|
||||||
|
Requires: libsndfile-devel
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package includes the development libraries and header files for
|
||||||
|
%{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1 -b .pkgconfig
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
mkdir -p %{_target_platform}
|
||||||
|
pushd %{_target_platform}
|
||||||
|
%{cmake} ..
|
||||||
|
popd
|
||||||
|
|
||||||
|
make %{?_smp_mflags} -C %{_target_platform}
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
make install DESTDIR=%{buildroot} -C %{_target_platform}
|
||||||
|
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc AUTHORS ChangeLog COPYING NEWS README
|
||||||
|
%{_libdir}/%{name}*.so.*
|
||||||
|
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc examples/create_sf2.c
|
||||||
|
%{_includedir}/%{name}*
|
||||||
|
%{_libdir}/%{name}*.so
|
||||||
|
%{_libdir}/pkgconfig/%{name}*.pc
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Aug 07 2011 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> - 1.0.0-3.20110806svn386
|
||||||
|
- Include the COPYING file. oops.
|
||||||
|
- Fix main package Requires of the devel package
|
||||||
|
|
||||||
|
* Sat Aug 06 2011 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> - 1.0.0-2.20110806svn386
|
||||||
|
- Update to svn after upstream accepted our build patches, switched to cmake and fixed the licensing
|
||||||
|
- Prepare for submission for review
|
||||||
|
|
||||||
|
* Wed Oct 27 2010 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> - 1.0.0-1
|
||||||
|
- Update to 1.0.0
|
||||||
|
|
||||||
|
* Thu Mar 26 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> - 1.0.0-0.1.297svn
|
||||||
|
- Initial Fedora build
|
Loading…
Reference in new issue