- fix the problem with #include_next

epel9
jorton 16 years ago
parent 09160e91d1
commit 19af422163

@ -0,0 +1,12 @@
diff -urp libidn-0.6.14.orig/lib/Makefile.am libidn-0.6.14/lib/Makefile.am
--- libidn-0.6.14.orig/lib/Makefile.am 2007-05-31 06:31:00.000000000 -0400
+++ libidn-0.6.14/lib/Makefile.am 2008-12-16 00:25:12.000000000 -0500
@@ -37,7 +37,7 @@ nodist_include_HEADERS = $(idn_int)
idn-int.h:
if test -n "$(STDINT_H)"; then \
- cp gl/stdint.h idn-int.h; \
+ sed -e s/include_next/include/ gl/stdint.h > idn-int.h; \
else \
echo '#include <stdint.h>' > idn-int.h; \
fi

@ -1,11 +1,12 @@
Summary: Internationalized Domain Name support library Summary: Internationalized Domain Name support library
Name: libidn Name: libidn
Version: 0.6.14 Version: 0.6.14
Release: 8 Release: 9
URL: http://www.gnu.org/software/libidn/ URL: http://www.gnu.org/software/libidn/
License: LGPLv2+ License: LGPLv2+
Source0: http://josefsson.org/libidn/releases/libidn-%{version}.tar.gz Source0: http://josefsson.org/libidn/releases/libidn-%{version}.tar.gz
Patch0: libidn-0.6.14-aconf262.patch Patch0: libidn-0.6.14-aconf262.patch
Patch1: libidn-0.6.14-include-next.patch
Group: System Environment/Libraries Group: System Environment/Libraries
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: pkgconfig, gettext, libtool, autoconf BuildRequires: pkgconfig, gettext, libtool, autoconf
@ -33,6 +34,7 @@ developing programs which use the GNU libidn library.
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b .aconf262 %patch0 -p1 -b .aconf262
%patch1 -p1 -b .include-next-fix
# Name directory sections consistently in the info file, #209491 # Name directory sections consistently in the info file, #209491
sed -i '/^INFO-DIR-SECTION/{s/GNU Libraries/Libraries/;s/GNU utilities/Utilities/;}' doc/libidn.info sed -i '/^INFO-DIR-SECTION/{s/GNU Libraries/Libraries/;s/GNU utilities/Utilities/;}' doc/libidn.info
@ -42,7 +44,9 @@ mv iconv.tmp doc/libidn.info
%build %build
# Must re-bootstrap to get multilib-aware libtool # Must re-bootstrap to get multilib-aware libtool
autoreconf libtoolize --force --copy
aclocal -I m4 -I gl/m4 -I lib/gl/m4
autoheader && autoconf && automake
%configure --disable-csharp --disable-static --libdir=/%{_lib} %configure --disable-csharp --disable-static --libdir=/%{_lib}
make %{?_smp_mflags} make %{?_smp_mflags}
@ -110,6 +114,9 @@ rm -rf %{buildroot}
%{_mandir}/man3/* %{_mandir}/man3/*
%changelog %changelog
* Mon Dec 29 2008 Kedar Sovani <kedars@marvell.com> 0.6.14-9
- fix the problem with #include_next
* Tue Jun 10 2008 Joe Orton <jorton@redhat.com> 0.6.14-8 * Tue Jun 10 2008 Joe Orton <jorton@redhat.com> 0.6.14-8
- fix build with latest autoconf (#449440) - fix build with latest autoconf (#449440)

Loading…
Cancel
Save