commit
abcc492fc5
@ -0,0 +1 @@
|
|||||||
|
SOURCES/libica-4.3.0.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
e7f7a7f714c793496294a5f865ad23d4c48866f9 SOURCES/libica-4.3.0.tar.gz
|
@ -0,0 +1,83 @@
|
|||||||
|
From daad2a867cff48a7c4322716917d63538b083284 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||||
|
Date: Tue, 25 Sep 2018 13:44:32 +0200
|
||||||
|
Subject: [libica PATCH] add build note to assembler sources
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
When distros use the annobin compiler plugin [1], they have complete overview
|
||||||
|
what compiler flags were used for compilation and they are able to perform
|
||||||
|
security checks on the produced binaries. Compiling assembler source can't
|
||||||
|
provide this kind of information by default, so we need the explicit
|
||||||
|
-Wa,--generate-missing-build-notes=yes option during build. When the option is
|
||||||
|
missing, then the annocheck tool reports "GAPS" in the resulting binary.
|
||||||
|
|
||||||
|
binutils >= 2.31 or older with backport is needed
|
||||||
|
|
||||||
|
[1] https://fedoraproject.org/wiki/Changes/Annobin
|
||||||
|
|
||||||
|
Signed-off-by: Dan Horák <dan@danny.cz>
|
||||||
|
---
|
||||||
|
configure.ac | 4 ++++
|
||||||
|
libica.spec | 2 +-
|
||||||
|
src/Makefile.am | 4 ++--
|
||||||
|
3 files changed, 7 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 958371c..b8d0e42 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -113,12 +113,16 @@ if test "x$enable_coverage" = xno && test "x$enable_debug" = xno && test "x$enab
|
||||||
|
FLAGS="$FLAGS -O3 -D_FORTIFY_SOURCE=2"
|
||||||
|
fi
|
||||||
|
|
||||||
|
+# check if assembler can generate missing build notes, binutils >= 2.31 or older with backport is needed
|
||||||
|
+AX_CHECK_COMPILE_FLAG([-Wa,--generate-missing-build-notes=yes], [ICA_ASFLAGS="-Wa,--generate-missing-build-notes=yes"])
|
||||||
|
+
|
||||||
|
# restore cmdline flags (ignore PROG_AS/PROG_CC defaults)
|
||||||
|
CFLAGS="$cmdline_CFLAGS"
|
||||||
|
CCASFLAGS="$cmdline_CFLAGS"
|
||||||
|
|
||||||
|
AC_SUBST([FLAGS], $FLAGS)
|
||||||
|
AC_SUBST([LIBS], $LIBS)
|
||||||
|
+AC_SUBST([ICA_ASFLAGS], $ICA_ASFLAGS)
|
||||||
|
AC_CONFIG_FILES([Makefile doc/Makefile include/Makefile src/Makefile test/Makefile])
|
||||||
|
AC_OUTPUT
|
||||||
|
|
||||||
|
diff --git a/libica.spec b/libica.spec
|
||||||
|
index d71890a..e51430e 100644
|
||||||
|
--- a/libica.spec
|
||||||
|
+++ b/libica.spec
|
||||||
|
@@ -9,7 +9,7 @@ URL: https://github.com/opencryptoki/libica
|
||||||
|
Source0: %{name}-%{version}.tar.gz
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
-BuildRequires: autoconf automake libtool openssl-devel
|
||||||
|
+BuildRequires: autoconf automake libtool openssl-devel autoconf-archive
|
||||||
|
|
||||||
|
%description
|
||||||
|
Interface library on Linux for IBM System z to utilize CPACF
|
||||||
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||||
|
index c630048..1b5ec71 100644
|
||||||
|
--- a/src/Makefile.am
|
||||||
|
+++ b/src/Makefile.am
|
||||||
|
@@ -31,13 +31,13 @@ SOURCES_common = ica_api.c init.c icastats_shared.c s390_rsa.c \
|
||||||
|
include/rng.h
|
||||||
|
|
||||||
|
libica_la_CFLAGS = ${CFLAGS_common} -DLIBNAME=\"libica\"
|
||||||
|
-libica_la_CCASFLAGS = ${AM_CFLAGS}
|
||||||
|
+libica_la_CCASFLAGS = ${AM_CFLAGS} ${ICA_ASFLAGS}
|
||||||
|
libica_la_LIBADD = ${LIBS_common}
|
||||||
|
libica_la_LDFLAGS = ${LDFLAGS_common}
|
||||||
|
libica_la_SOURCES = ${SOURCES_common}
|
||||||
|
|
||||||
|
libica_cex_la_CFLAGS = ${CFLAGS_common} -DNO_CPACF -DLIBNAME=\"libica-cex\"
|
||||||
|
-libica_cex_la_CCASFLAGS = ${AM_CFLAGS}
|
||||||
|
+libica_cex_la_CCASFLAGS = ${AM_CFLAGS} ${ICA_ASFLAGS}
|
||||||
|
libica_cex_la_LIBADD = ${LIBS_common}
|
||||||
|
libica_cex_la_LDFLAGS = ${LDFLAGS_common}
|
||||||
|
libica_cex_la_SOURCES = ${SOURCES_common}
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
@ -0,0 +1,130 @@
|
|||||||
|
From 49d619ea05743a3df6b9bf8160aaa0b4306118db Mon Sep 17 00:00:00 2001
|
||||||
|
From: Holger Dengler <dengler@linux.ibm.com>
|
||||||
|
Date: Tue, 16 Apr 2024 14:18:23 +0200
|
||||||
|
Subject: [PATCH 1/2] test: disable CEX usage in OpenSSL for all tests
|
||||||
|
|
||||||
|
OpenSSL supports CEX exploitation since version v3.2.x. Libica and its
|
||||||
|
testcases use OpenSSL as helper and fallback, so disable the CEX
|
||||||
|
acceleration for all tests.
|
||||||
|
|
||||||
|
If the environment variable is already set, use it as is without
|
||||||
|
modifying it. In this case, it is up to the user to choose the right
|
||||||
|
settings.
|
||||||
|
|
||||||
|
Fixes: Issue #126
|
||||||
|
Link: https://github.com/opencryptoki/libica/issues/126
|
||||||
|
Signed-off-by: Holger Dengler <dengler@linux.ibm.com>
|
||||||
|
---
|
||||||
|
test/Makefile.am | 6 +++++-
|
||||||
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/test/Makefile.am b/test/Makefile.am
|
||||||
|
index 76d4f15..e56b256 100644
|
||||||
|
--- a/test/Makefile.am
|
||||||
|
+++ b/test/Makefile.am
|
||||||
|
@@ -61,10 +61,14 @@ TESTS += \
|
||||||
|
${top_builddir}/src/internal_tests/ec_internal_test
|
||||||
|
endif
|
||||||
|
|
||||||
|
+# disable OpenSSL CEX usage for all tests
|
||||||
|
+OPENSSL_s390xcap ?= nocex
|
||||||
|
+
|
||||||
|
TEST_EXTENSIONS = .sh .pl
|
||||||
|
TESTS_ENVIRONMENT = export LD_LIBRARY_PATH=${builddir}/../src/.libs/:$$LD_LIBRARY_PATH \
|
||||||
|
PATH=${builddir}/../src/:$$PATH \
|
||||||
|
- LIBICA_TESTDATA=${srcdir}/testdata/;
|
||||||
|
+ LIBICA_TESTDATA=${srcdir}/testdata/ \
|
||||||
|
+ OPENSSL_s390xcap=${OPENSSL_s390xcap};
|
||||||
|
AM_CFLAGS = @FLAGS@ -DNO_SW_FALLBACKS -I${srcdir}/../include/ -I${srcdir}/../src/include/
|
||||||
|
LDADD = @LIBS@ ${top_builddir}/src/.libs/libica.so -lcrypto -lpthread
|
||||||
|
|
||||||
|
--
|
||||||
|
2.45.1
|
||||||
|
|
||||||
|
|
||||||
|
From d3a7542e7eb45c22066ecb1be62480dde41fd544 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Joerg Schmidbauer <jschmidb@de.ibm.com>
|
||||||
|
Date: Wed, 24 Apr 2024 10:44:26 +0200
|
||||||
|
Subject: [PATCH 2/2] Bugfix: correct rc handling with s390_pcc function
|
||||||
|
|
||||||
|
Signed-off-by: Joerg Schmidbauer <jschmidb@de.ibm.com>
|
||||||
|
---
|
||||||
|
src/include/s390_aes.h | 2 +-
|
||||||
|
src/include/s390_cmac.h | 2 +-
|
||||||
|
src/include/s390_crypto.h | 23 +++++++++++++----------
|
||||||
|
3 files changed, 15 insertions(+), 12 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/include/s390_aes.h b/src/include/s390_aes.h
|
||||||
|
index 6252dde..a6ff27b 100644
|
||||||
|
--- a/src/include/s390_aes.h
|
||||||
|
+++ b/src/include/s390_aes.h
|
||||||
|
@@ -674,7 +674,7 @@ static inline int s390_aes_xts_parm(unsigned long function_code,
|
||||||
|
|
||||||
|
memset(&parm_block.keys, 0, key_size);
|
||||||
|
|
||||||
|
- if (rc >= 0) {
|
||||||
|
+ if (rc == 0) {
|
||||||
|
memcpy(xts_parm, parm_block.xts_parameter,
|
||||||
|
sizeof(ica_aes_vector_t));
|
||||||
|
return 0;
|
||||||
|
diff --git a/src/include/s390_cmac.h b/src/include/s390_cmac.h
|
||||||
|
index 76b9cca..f19c069 100644
|
||||||
|
--- a/src/include/s390_cmac.h
|
||||||
|
+++ b/src/include/s390_cmac.h
|
||||||
|
@@ -161,7 +161,7 @@ static inline int s390_cmac_hw(unsigned long fc,
|
||||||
|
/* calculate final block (last/full) */
|
||||||
|
rc = s390_pcc(fc, pb_lookup.base);
|
||||||
|
memset(pb_lookup.keys, 0, key_size);
|
||||||
|
- if (rc < 0)
|
||||||
|
+ if (rc != 0)
|
||||||
|
return EIO;
|
||||||
|
|
||||||
|
_stats_increment(fc, ALGO_HW, ENCRYPT);
|
||||||
|
diff --git a/src/include/s390_crypto.h b/src/include/s390_crypto.h
|
||||||
|
index f34241f..f11eacb 100644
|
||||||
|
--- a/src/include/s390_crypto.h
|
||||||
|
+++ b/src/include/s390_crypto.h
|
||||||
|
@@ -244,27 +244,30 @@ void s390_crypto_switches_init(void);
|
||||||
|
|
||||||
|
/**
|
||||||
|
* s390_pcc:
|
||||||
|
- * @func: the function code passed to KM; see s390_pcc_functions
|
||||||
|
+ * @func: the function code passed to PCC; see s390_pcc_functions
|
||||||
|
* @param: address of parameter block; see POP for details on each func
|
||||||
|
*
|
||||||
|
* Executes the PCC operation of the CPU.
|
||||||
|
*
|
||||||
|
- * Returns -1 for failure, 0 for the query func, number of processed
|
||||||
|
- * bytes for encryption/decryption funcs
|
||||||
|
+ * Returns condition code of the PCC instruction
|
||||||
|
*/
|
||||||
|
static inline int s390_pcc(unsigned long func, void *param)
|
||||||
|
{
|
||||||
|
register unsigned long r0 asm("0") = (unsigned long)func;
|
||||||
|
register unsigned long r1 asm("1") = (unsigned long)param;
|
||||||
|
+ char cc;
|
||||||
|
|
||||||
|
- asm volatile (
|
||||||
|
- "0: .long %[opc] << 16\n"
|
||||||
|
- " brc 1,0b\n"
|
||||||
|
- :
|
||||||
|
- : [fc] "d" (r0), [param] "a" (r1), [opc] "i" (0xb92c)
|
||||||
|
- : "cc", "memory");
|
||||||
|
+ asm volatile(
|
||||||
|
+ "0: .insn rre,%[opc] << 16,0,0\n" /* PCC opcode */
|
||||||
|
+ " brc 1,0b\n" /* handle partial completion */
|
||||||
|
+ " ipm %[cc]\n"
|
||||||
|
+ " srl %[cc],28\n"
|
||||||
|
+ : [cc] "=d" (cc)
|
||||||
|
+ : [func] "d" (r0), [param] "a" (r1), [opc] "i" (0xb92c)
|
||||||
|
+ : "cc", "memory"
|
||||||
|
+ );
|
||||||
|
|
||||||
|
- return 0;
|
||||||
|
+ return cc;
|
||||||
|
}
|
||||||
|
|
||||||
|
/**
|
||||||
|
--
|
||||||
|
2.45.1
|
||||||
|
|
@ -0,0 +1,399 @@
|
|||||||
|
%global with_fips 1
|
||||||
|
|
||||||
|
Summary: Library for accessing ICA hardware crypto on IBM z Systems
|
||||||
|
Name: libica
|
||||||
|
Version: 4.3.0
|
||||||
|
Release: 3%{?dist}
|
||||||
|
License: CPL-1.0
|
||||||
|
URL: https://github.com/opencryptoki/
|
||||||
|
Source0: https://github.com/opencryptoki/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
|
# annotate assembler source
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1630582
|
||||||
|
# https://github.com/opencryptoki/libica/pull/24
|
||||||
|
Patch0: %{name}-4.0.0-annotate.patch
|
||||||
|
# post GA fixes
|
||||||
|
Patch1: %{name}-%{version}-fixes.patch
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: openssl-devel
|
||||||
|
BuildRequires: openssl
|
||||||
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: automake
|
||||||
|
BuildRequires: libtool
|
||||||
|
BuildRequires: autoconf-archive
|
||||||
|
BuildRequires: perl(FindBin)
|
||||||
|
BuildRequires: perl(lib)
|
||||||
|
BuildRequires: make
|
||||||
|
ExclusiveArch: s390 s390x
|
||||||
|
|
||||||
|
%description
|
||||||
|
A library of functions and utilities for accessing ICA hardware crypto on
|
||||||
|
IBM z Systems.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development tools for programs to access ICA hardware crypto on IBM z Systems
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: openssl-devel
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The libica-devel package contains the header files and static
|
||||||
|
libraries necessary for developing programs accessing ICA hardware crypto on
|
||||||
|
IBM z Systems.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1
|
||||||
|
|
||||||
|
sh ./bootstrap.sh
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
# FIPS openssl config is not needed on RHEL/Fedora
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=2084097
|
||||||
|
CPPFLAGS=-DNO_FIPS_CONFIG_LOAD
|
||||||
|
export CPPFLAGS
|
||||||
|
%configure --disable-static \
|
||||||
|
%if %{with_fips}
|
||||||
|
--enable-fips
|
||||||
|
%else
|
||||||
|
--disable-fips
|
||||||
|
%endif
|
||||||
|
%make_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%make_install
|
||||||
|
rm %{buildroot}%{_libdir}/libica*.la
|
||||||
|
rm %{buildroot}%{_pkgdocdir}/{INSTALL,README.md}
|
||||||
|
|
||||||
|
|
||||||
|
%check
|
||||||
|
# mock doesn't provide the device, so check here
|
||||||
|
# https://github.com/rpm-software-management/mock/issues/33
|
||||||
|
if [ -c /dev/hwrng -o -c /dev/prandom ]; then
|
||||||
|
make check
|
||||||
|
fi
|
||||||
|
|
||||||
|
%if %{with_fips}
|
||||||
|
%define __spec_install_post \
|
||||||
|
%{?__debug_package:%{__debug_install_post}} \
|
||||||
|
%{__arch_install_post} \
|
||||||
|
%{__os_install_post} \
|
||||||
|
make fipsinstall DESTDIR=%{buildroot}
|
||||||
|
%{nil}
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc AUTHORS LICENSE ChangeLog
|
||||||
|
%{_bindir}/icainfo
|
||||||
|
%{_bindir}/icainfo-cex
|
||||||
|
%{_bindir}/icastats
|
||||||
|
%if %{with_fips}
|
||||||
|
%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9
|
||||||
|
# openssl 3.0 is available since Fedora 36 and RHEL 9
|
||||||
|
%exclude %{_sysconfdir}/libica/openssl3-fips.cnf
|
||||||
|
%endif
|
||||||
|
%{_libdir}/.libica.*.hmac
|
||||||
|
%{_libdir}/.libica-cex.*.hmac
|
||||||
|
%endif
|
||||||
|
%{_libdir}/libica.so.*
|
||||||
|
%{_libdir}/libica-cex.so.*
|
||||||
|
%{_mandir}/man1/icainfo.1*
|
||||||
|
%{_mandir}/man1/icainfo-cex.1*
|
||||||
|
%{_mandir}/man1/icastats.1*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_includedir}/*
|
||||||
|
%{_libdir}/libica.so
|
||||||
|
%{_libdir}/libica-cex.so
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Jun 25 2024 Dan Horák <dan[at]danny.cz> - 4.3.0-3
|
||||||
|
- add post GA fixes
|
||||||
|
- Resolves: RHEL-24117
|
||||||
|
|
||||||
|
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 4.3.0-2
|
||||||
|
- Bump release for June 2024 mass rebuild
|
||||||
|
|
||||||
|
* Wed Jan 31 2024 Dan Horák <dan[at]danny.cz> - 4.3.0-1
|
||||||
|
- updated to 4.3.0
|
||||||
|
|
||||||
|
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.3-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.3-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Oct 27 2023 Dan Horák <dan[at]danny.cz> - 4.2.3-2
|
||||||
|
- fix selfcheck in FIPS mode (RHEL-9918)
|
||||||
|
|
||||||
|
* Thu Sep 21 2023 Dan Horák <dan[at]danny.cz> - 4.2.3-1
|
||||||
|
- updated to 4.2.3
|
||||||
|
|
||||||
|
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri May 19 2023 Dan Horák <dan[at]danny.cz> - 4.2.2-1
|
||||||
|
- updated to 4.2.2
|
||||||
|
|
||||||
|
* Mon Feb 06 2023 Dan Horák <dan[at]danny.cz> - 4.2.1-1
|
||||||
|
- updated to 4.2.1
|
||||||
|
|
||||||
|
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Dec 15 2022 Dan Horák <dan[at]danny.cz> - 4.2.0-1
|
||||||
|
- updated to 4.2.0
|
||||||
|
|
||||||
|
* Tue Oct 11 2022 Dan Horák <dan[at]danny.cz> - 4.1.1-1
|
||||||
|
- updated to 4.1.1
|
||||||
|
|
||||||
|
* Fri Sep 30 2022 Dan Horák <dan[at]danny.cz> - 4.1.0-1
|
||||||
|
- updated to 4.1.0
|
||||||
|
|
||||||
|
* Tue Aug 16 2022 Dan Horák <dan[at]danny.cz> - 4.0.3-1
|
||||||
|
- updated to 4.0.3
|
||||||
|
|
||||||
|
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jun 24 2022 Dan Horák <dan[at]danny.cz> - 4.0.2-1
|
||||||
|
- updated to 4.0.2
|
||||||
|
|
||||||
|
* Mon May 16 2022 Dan Horák <dan[at]danny.cz> - 4.0.1-2
|
||||||
|
- FIPS specific openssl config is not required in RHEL/Fedora
|
||||||
|
|
||||||
|
* Tue Feb 08 2022 Dan Horák <dan[at]danny.cz> - 4.0.1-1
|
||||||
|
- updated to 4.0.1
|
||||||
|
|
||||||
|
* Tue Feb 01 2022 Dan Horák <dan[at]danny.cz> - 4.0.0-3
|
||||||
|
- post GA fixes
|
||||||
|
|
||||||
|
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 13 2022 Dan Horák <dan[at]danny.cz> - 4.0.0-1
|
||||||
|
- updated to 4.0.0
|
||||||
|
|
||||||
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.8.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 02 2021 Dan Horák <dan[at]danny.cz> - 3.8.0-4
|
||||||
|
- re-enable FIPS support
|
||||||
|
|
||||||
|
* Mon May 31 2021 Dan Horák <dan[at]danny.cz> - 3.8.0-3
|
||||||
|
- disable FIPS support (broken)
|
||||||
|
|
||||||
|
* Mon May 24 2021 Dan Horák <dan[at]danny.cz> - 3.8.0-2
|
||||||
|
- conditionalize FIPS support
|
||||||
|
|
||||||
|
* Fri May 21 2021 Dan Horák <dan[at]danny.cz> - 3.8.0-1
|
||||||
|
- updated to 3.8.0
|
||||||
|
|
||||||
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 22 2020 Dan Horák <dan[at]danny.cz> - 3.7.0-3
|
||||||
|
- Use make macros (taken from PR#1 by <tstellar at redhat.com>)
|
||||||
|
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||||
|
|
||||||
|
* Wed Jul 15 2020 Dan Horák <dan[at]danny.cz> - 3.7.0-2
|
||||||
|
- fix FIPS integrity validation (#1857130)
|
||||||
|
|
||||||
|
* Fri May 15 2020 Dan Horák <dan[at]danny.cz> - 3.7.0-1
|
||||||
|
- updated to 3.7.0
|
||||||
|
|
||||||
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.6.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Nov 26 2019 Dan Horák <dan[at]danny.cz> - 3.6.1-1
|
||||||
|
- updated to 3.6.1
|
||||||
|
|
||||||
|
* Mon Sep 02 2019 Dan Horák <dan[at]danny.cz> - 3.6.0-1
|
||||||
|
- updated to 3.6.0
|
||||||
|
|
||||||
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.5.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Apr 24 2019 Dan Horák <dan[at]danny.cz> - 3.5.0-1
|
||||||
|
- updated to 3.5.0
|
||||||
|
|
||||||
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Nov 16 2018 Dan Horák <dan[at]danny.cz> - 3.4.0-1
|
||||||
|
- updated to 3.4.0
|
||||||
|
|
||||||
|
* Fri Sep 21 2018 Dan Horák <dan[at]danny.cz> - 3.3.3-4
|
||||||
|
- annotate assembler file (#1630582)
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.3-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 13 2018 Dan Horák <dan[at]danny.cz> - 3.3.3-2
|
||||||
|
- fix executable stack in assembler code
|
||||||
|
|
||||||
|
* Tue Jun 12 2018 Dan Horák <dan[at]danny.cz> - 3.3.3-1
|
||||||
|
- updated to 3.3.3
|
||||||
|
|
||||||
|
* Tue Apr 17 2018 Dan Horák <dan[at]danny.cz> - 3.3.2-1
|
||||||
|
- updated to 3.3.2
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Sep 25 2017 Dan Horák <dan[at]danny.cz> - 3.2.0-1
|
||||||
|
- updated to 3.2.0
|
||||||
|
|
||||||
|
* Mon Sep 11 2017 Dan Horák <dan[at]danny.cz> - 3.1.1-1
|
||||||
|
- updated to 3.1.1
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Apr 18 2017 Dan Horák <dan[at]danny.cz> - 3.0.2-3
|
||||||
|
- update BR
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 18 2017 Dan Horák <dan[at]danny.cz> - 3.0.2-1
|
||||||
|
- updated to 3.0.2
|
||||||
|
|
||||||
|
* Fri Jan 13 2017 Dan Horák <dan[at]danny.cz> - 3.0.1-2
|
||||||
|
- check for /dev/prandom before running the test-suite
|
||||||
|
|
||||||
|
* Fri Jan 13 2017 Dan Horák <dan[at]danny.cz> - 3.0.1-1
|
||||||
|
- updated to 3.0.1
|
||||||
|
|
||||||
|
* Tue Apr 12 2016 Dan Horák <dan[at]danny.cz> - 2.6.2-1
|
||||||
|
- updated to 2.6.2
|
||||||
|
|
||||||
|
* Thu Mar 17 2016 Dan Horák <dan[at]danny.cz> - 2.6.1-1
|
||||||
|
- updated to 2.6.1
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.2-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Sep 01 2014 Dan Horák <dan[at]danny.cz> - 2.4.2-1
|
||||||
|
- updated to 2.4.2
|
||||||
|
|
||||||
|
* Wed Jun 11 2014 Dan Horák <dan[at]danny.cz> - 2.3.0-5
|
||||||
|
- fix build with recent kernels
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Mar 14 2014 Dan Horák <dan[at]danny.cz> - 2.3.0-3
|
||||||
|
- add post release fix (#1066014)
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri May 03 2013 Dan Horák <dan[at]danny.cz> - 2.3.0-1
|
||||||
|
- updated to 2.3.0
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Aug 17 2012 Dan Horák <dan[at]danny.cz> - 2.2.0-1
|
||||||
|
- updated to 2.2.0
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 16 2012 Dan Horák <dan[at]danny.cz> - 2.1.1-1
|
||||||
|
- updated to 2.1.1
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 07 2011 Dan Horák <dan[at]danny.cz> - 2.1.0-1
|
||||||
|
- updated to 2.1.0 with soname set back to 2.0
|
||||||
|
|
||||||
|
* Mon Apr 11 2011 Dan Horák <dan[at]danny.cz> - 2.0.6-1
|
||||||
|
- updated to 2.0.6
|
||||||
|
|
||||||
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 12 2011 Dan Horák <dan[at]danny.cz> - 2.0.4-1
|
||||||
|
- Do not use sigill to wrap all HW instructions (#665401)
|
||||||
|
- updated to 2.0.4
|
||||||
|
|
||||||
|
* Tue Nov 9 2010 Dan Horák <dhorak@redhat.com> - 2.0.3-3
|
||||||
|
- Fix the return value of old_api_sha_test() in libica_sha1_test (#624005)
|
||||||
|
- Use the right buffer length when operating in 32-bit mode (#640035)
|
||||||
|
- Resolves: #624005, #640035
|
||||||
|
|
||||||
|
* Fri May 21 2010 Dan Horák <dan[at]danny.cz> - 2.0.3-2
|
||||||
|
- rebuilt with -fno-strict-aliasing (#593779)
|
||||||
|
- Resolves: #593779
|
||||||
|
|
||||||
|
* Thu Apr 22 2010 Dan Horák <dan[at]danny.cz> - 2.0.3-1
|
||||||
|
- updated to 2.0.3 (#582607)
|
||||||
|
- Resolves: #582607
|
||||||
|
|
||||||
|
* Mon Apr 12 2010 Dan Horák <dan[at]danny.cz> - 2.0.2-3
|
||||||
|
- add SIGILL handler for add_entropy (#581520)
|
||||||
|
- Resolves: #581520
|
||||||
|
|
||||||
|
* Tue Feb 16 2010 Dan Horák <dan[at]danny.cz> - 2.0.2-2
|
||||||
|
- dropped the utils sub-package
|
||||||
|
- Related: #543948
|
||||||
|
|
||||||
|
* Tue Dec 08 2009 Dennis Gregorovic <dgregor@redhat.com> - 2.0.2-1.1
|
||||||
|
- Rebuilt for RHEL 6
|
||||||
|
|
||||||
|
* Mon Aug 17 2009 Dan Horák <dan[at]danny.cz> - 2.0.2-1
|
||||||
|
- update to 2.0.2
|
||||||
|
|
||||||
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Apr 1 2009 Dan Horák <dan[at]danny.cz> - 2.0.1-1
|
||||||
|
- update to 2.0.1
|
||||||
|
|
||||||
|
* Mon Mar 23 2009 Dan Horák <dan[at]danny.cz> - 2.0-1
|
||||||
|
- update to 2.0
|
||||||
|
- spec file cleanup before submitting to Fedora
|
||||||
|
|
||||||
|
* Sun Sep 14 2008 Phil Knirsch <pknirsch@redhat.com> - 1.3.7-8.el5
|
||||||
|
- Added the icainfo tool to libica (#439484)
|
||||||
|
|
||||||
|
* Tue Apr 01 2008 Phil Knirsch <pknirsch@redhat.com> - 1.3.7-7.el5
|
||||||
|
- Fixed build of libica with latest AES & SHA feature (#439390)
|
||||||
|
|
||||||
|
* Tue Jan 15 2008 Phil Knirsch <pknirsch@redhat.com> - 1.3.7-6.el5
|
||||||
|
- Added Software Support for CP Assist Instructions AES & SHA (#318971)
|
||||||
|
|
||||||
|
* Thu Nov 23 2006 Phil Knirsch <pknirsch@redhat.com> - 1.3.7-5.el5
|
||||||
|
- Fixed requires bug where devel packages would get wrong arch lib (#215908)
|
||||||
|
|
||||||
|
* Fri Oct 13 2006 Phil Knirsch <pknirsch@redhat.com> - 1.3.7-4
|
||||||
|
- Fixed bug where libica fails to initialize when no crypto hardware is
|
||||||
|
available (#210504)
|
||||||
|
- Only build libica for s390(x), really only needed there.
|
||||||
|
|
||||||
|
* Fri Sep 08 2006 Phil Knirsch <pknirsch@redhat.com> - 1.3.7-3
|
||||||
|
- Build for other archs as well due to openCryptoki requirement (#184631)
|
||||||
|
|
||||||
|
* Fri Jul 14 2006 Tim Powers <timp@redhat.com> - 1.3.7-2
|
||||||
|
- rebuild
|
||||||
|
|
||||||
|
* Tue Jun 13 2006 Phil Knirsch <pknirsch@redhat.com> - 1.3.7-1
|
||||||
|
- Update to libica-1.3.7 final
|
||||||
|
- Fixed build on latest devel tree
|
||||||
|
|
||||||
|
* Tue Apr 04 2006 Phil Knirsch <pknirsch@redhat.com> - 1.3.6-rc3-1
|
||||||
|
- Initial package.
|
Loading…
Reference in new issue