commit
da9e291b63
@ -0,0 +1 @@
|
|||||||
|
SOURCES/libgdither-0.6.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
8727600550401c22ba9ec7a24e1ab6d2c02cee9a SOURCES/libgdither-0.6.tar.gz
|
@ -0,0 +1,52 @@
|
|||||||
|
diff -up libgdither-0.6/Makefile.default libgdither-0.6/Makefile
|
||||||
|
--- libgdither-0.6/Makefile.default 2005-07-24 22:19:30.000000000 +0200
|
||||||
|
+++ libgdither-0.6/Makefile 2008-06-10 20:05:01.000000000 +0200
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
VERSION = 0.6
|
||||||
|
-PREFIX = /usr/local
|
||||||
|
-CFLAGS = -Wall -g -I. -O3 -funroll-loops -finline-limit=9999999 -ffast-math -malign-double -march=`uname -m` -fPIC
|
||||||
|
+PREFIX = /usr
|
||||||
|
+CFLAGS = $(INIT_CFLAGS) -I. -ffast-math -fPIC
|
||||||
|
|
||||||
|
TARDIR = libgdither-$(VERSION)
|
||||||
|
|
||||||
|
@@ -10,20 +10,22 @@ gdither.o: gdither.c gdither.h gdither_t
|
||||||
|
$(CC) $(CFLAGS) -c gdither.c
|
||||||
|
|
||||||
|
libgdither.so: gdither.o
|
||||||
|
- $(CC) -shared gdither.o -o libgdither.so
|
||||||
|
+ $(CC) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0
|
||||||
|
|
||||||
|
libgdither.pc: libgdither.pc.in Makefile
|
||||||
|
sed -e 's|@VERSION@|$(VERSION)|' -e 's|@PREFIX@|$(PREFIX)|' \
|
||||||
|
libgdither.pc.in > libgdither.pc
|
||||||
|
|
||||||
|
install: all
|
||||||
|
- install -d $(PREFIX)/lib/
|
||||||
|
- install libgdither.so $(PREFIX)/lib/
|
||||||
|
- install -d $(PREFIX)/include/
|
||||||
|
- install gdither.h $(PREFIX)/include/
|
||||||
|
- install gdither_types.h $(PREFIX)/include/
|
||||||
|
- install -d $(PREFIX)/lib/pkgconfig/
|
||||||
|
- install libgdither.pc $(PREFIX)/lib/pkgconfig/
|
||||||
|
+ mkdir -p $(DESTDIR)$(LIBDIR)
|
||||||
|
+ install -pm 0755 libgdither.so* $(DESTDIR)$(LIBDIR)
|
||||||
|
+ ln -s libgdither.so.1.0 $(DESTDIR)$(LIBDIR)/libgdither.so.1
|
||||||
|
+ ln -s libgdither.so.1.0 $(DESTDIR)$(LIBDIR)/libgdither.so
|
||||||
|
+ mkdir -p $(DESTDIR)$(PREFIX)/include/libgdither
|
||||||
|
+ install -pm 0644 gdither.h $(DESTDIR)$(PREFIX)/include/libgdither
|
||||||
|
+ install -pm 0644 gdither_types.h $(DESTDIR)$(PREFIX)/include/libgdither
|
||||||
|
+ mkdir -p $(DESTDIR)$(LIBDIR)/pkgconfig/
|
||||||
|
+ install -pm 0644 libgdither.pc $(DESTDIR)$(LIBDIR)/pkgconfig/
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -f *.o *.so
|
||||||
|
diff -up libgdither-0.6/libgdither.pc.default libgdither-0.6/libgdither.pc
|
||||||
|
--- libgdither-0.6/libgdither.pc.default 2005-07-24 22:19:30.000000000 +0200
|
||||||
|
+++ libgdither-0.6/libgdither.pc 2008-06-10 20:04:09.000000000 +0200
|
||||||
|
@@ -6,4 +6,4 @@ Name: libgdither
|
||||||
|
Version: 0.6
|
||||||
|
Description: A library for applying dithering to PCM audio sources
|
||||||
|
Libs: -L${libdir} -lgdither -lm
|
||||||
|
-Cflags: -I${includedir}
|
||||||
|
+Cflags: -I${includedir}/libgdither
|
@ -0,0 +1,13 @@
|
|||||||
|
diff -ur libgdither-0.6/gdither.c libgdither/gdither.c
|
||||||
|
--- libgdither-0.6/gdither.c 2005-07-24 22:19:30.000000000 +0200
|
||||||
|
+++ libgdither/gdither.c 2008-04-20 13:43:33.000000000 +0200
|
||||||
|
@@ -342,7 +342,7 @@
|
||||||
|
for (i=0; (i + pos) < length && i < GDITHER_CONV_BLOCK; i++) {
|
||||||
|
conv[i] = x[pos + i];
|
||||||
|
}
|
||||||
|
- gdither_runf(s, channel, i, conv, ycast + s->channels * step);
|
||||||
|
+ gdither_runf(s, channel, i, conv, ycast + pos * step);
|
||||||
|
pos += i;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
@ -0,0 +1,11 @@
|
|||||||
|
--- libgdither-0.6/Makefile 2018-04-10 18:23:46.000822954 +0200
|
||||||
|
+++ libgdither-0.6/Makefile 2018-04-10 18:25:25.783013273 +0200
|
||||||
|
@@ -10,7 +10,7 @@
|
||||||
|
$(CC) $(CFLAGS) -c gdither.c
|
||||||
|
|
||||||
|
libgdither.so: gdither.o
|
||||||
|
- $(CC) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0
|
||||||
|
+ $(CC) $(LDFLAGS) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0
|
||||||
|
|
||||||
|
libgdither.pc: libgdither.pc.in Makefile
|
||||||
|
sed -e 's|@VERSION@|$(VERSION)|' -e 's|@PREFIX@|$(PREFIX)|' \
|
@ -0,0 +1,157 @@
|
|||||||
|
Name: libgdither
|
||||||
|
Version: 0.6
|
||||||
|
Release: 26%{?dist}
|
||||||
|
Summary: Library for applying dithering to PCM audio sources
|
||||||
|
|
||||||
|
License: GPLv2+
|
||||||
|
URL: http://plugin.org.uk/libgdither/README
|
||||||
|
Source0: http://plugin.org.uk/libgdither/libgdither-%{version}.tar.gz
|
||||||
|
Patch0: libgdither-0.6-default.patch
|
||||||
|
Patch1: libgdither-0.6-gavl.patch
|
||||||
|
Patch2: libgdither-0.6-ldflags.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: fftw-devel >= 3.0.0
|
||||||
|
BuildRequires: make
|
||||||
|
|
||||||
|
|
||||||
|
%description
|
||||||
|
Libgdither is a GPL'd library library for performing audio dithering on
|
||||||
|
PCM samples. The dithering process should be carried out before reducing
|
||||||
|
the bit width of PCM audio data (eg. float to 16 bit int conversions) to
|
||||||
|
preserve audio quality.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1 -b .default
|
||||||
|
%patch1 -p1 -b .gavl_fix
|
||||||
|
%patch2 -p1 -b .ldflags
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
export INIT_CFLAGS="${RPM_OPT_FLAGS}"
|
||||||
|
export LDFLAGS="%{build_ldflags}"
|
||||||
|
export PREFIX="%{_prefix}"
|
||||||
|
%make_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%make_install PREFIX=%{_prefix} LIBDIR=%{_libdir}
|
||||||
|
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||||
|
|
||||||
|
sed -i -e 's|/usr/local|%{_prefix}|g' \
|
||||||
|
$RPM_BUILD_ROOT%{_libdir}/pkgconfig/libgdither.pc
|
||||||
|
sed -i -e 's|%{_prefix}/lib|%{_libdir}|' \
|
||||||
|
$RPM_BUILD_ROOT%{_libdir}/pkgconfig/libgdither.pc
|
||||||
|
|
||||||
|
%check
|
||||||
|
make test CFLAGS="%{optflags} -Werror --std=c99 -I%{_builddir}/%{?buildsubdir}"
|
||||||
|
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc README
|
||||||
|
%license COPYING
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_includedir}/libgdither/
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_libdir}/pkgconfig/libgdither.pc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Jan 10 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.6-26
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-26
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-25
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-24
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-23
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-22
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-21
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun May 26 2019 David King <amigadave@amigadave.com> - 0.6-20
|
||||||
|
- Pass through PREFIX to build system
|
||||||
|
|
||||||
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-19
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 17 2018 Nicolas Chauvet <kwizart@gmail.com> - 0.6-18
|
||||||
|
- Refresh spec file
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-17
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Apr 10 2018 Rafael Santos <rdossant@redhat.com> - 0.6-16
|
||||||
|
- Use Fedora standard linker flags (bug #1548657)
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-15
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-14
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-13
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-12
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jun 27 2008 kwizart < kwizart at gmail.com > - 0.6-1
|
||||||
|
- Backport patch from gavl
|
||||||
|
|
||||||
|
* Mon Jun 16 2008 kwizart < kwizart at gmail.com > - 0.6-0
|
||||||
|
- Initial package
|
Loading…
Reference in new issue