import libgdither-0.6-26.el9

i9 changed/i9/libgdither-0.6-26.el9
Arkady L. Shane 1 year ago
parent 7978e2dc0f
commit bd7b6f90fa
Signed by: tigro
GPG Key ID: 9C7900103E1C4F8B

@ -1 +1 @@
8727600550401c22ba9ec7a24e1ab6d2c02cee9a SOURCES/libgdither-0.6.tar.gz 8727600550401c22ba9ec7a24e1ab6d2c02cee9a SOURCES/libgdither-0.6.tar.gz

@ -1,19 +1,10 @@
diff -up libgdither-0.6/Makefile.ldflags libgdither-0.6/Makefile --- libgdither-0.6/Makefile 2018-04-10 18:23:46.000822954 +0200
--- libgdither-0.6/Makefile.ldflags 2018-10-13 15:01:35.228468070 -0400 +++ libgdither-0.6/Makefile 2018-04-10 18:25:25.783013273 +0200
+++ libgdither-0.6/Makefile 2018-10-13 15:07:29.070561578 -0400 @@ -10,7 +10,7 @@
@@ -4,13 +4,13 @@ CFLAGS = $(INIT_CFLAGS) -I. -ffast-math
TARDIR = libgdither-$(VERSION)
-all: libgdither.so
+all: libgdither.so.1.0
gdither.o: gdither.c gdither.h gdither_types_internal.h
$(CC) $(CFLAGS) -c gdither.c $(CC) $(CFLAGS) -c gdither.c
-libgdither.so: gdither.o libgdither.so: gdither.o
- $(CC) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0 - $(CC) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0
+libgdither.so.1.0: gdither.o
+ $(CC) $(LDFLAGS) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0 + $(CC) $(LDFLAGS) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0
libgdither.pc: libgdither.pc.in Makefile libgdither.pc: libgdither.pc.in Makefile

@ -1,9 +1,8 @@
Name: libgdither Name: libgdither
Version: 0.6 Version: 0.6
Release: 17%{?dist} Release: 26%{?dist}
Summary: Library for applying dithering to PCM audio sources Summary: Library for applying dithering to PCM audio sources
Group: System Environment/Libraries
License: GPLv2+ License: GPLv2+
URL: http://plugin.org.uk/libgdither/README URL: http://plugin.org.uk/libgdither/README
Source0: http://plugin.org.uk/libgdither/libgdither-%{version}.tar.gz Source0: http://plugin.org.uk/libgdither/libgdither-%{version}.tar.gz
@ -11,7 +10,9 @@ Patch0: libgdither-0.6-default.patch
Patch1: libgdither-0.6-gavl.patch Patch1: libgdither-0.6-gavl.patch
Patch2: libgdither-0.6-ldflags.patch Patch2: libgdither-0.6-ldflags.patch
BuildRequires: gcc-c++
BuildRequires: fftw-devel >= 3.0.0 BuildRequires: fftw-devel >= 3.0.0
BuildRequires: make
%description %description
@ -23,9 +24,7 @@ preserve audio quality.
%package devel %package devel
Summary: Development files for %{name} Summary: Development files for %{name}
Group: Development/Libraries Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{name} = %{version}-%{release}
Requires: pkgconfig
%description devel %description devel
The %{name}-devel package contains libraries and header files for The %{name}-devel package contains libraries and header files for
@ -42,14 +41,12 @@ developing applications that use %{name}.
%build %build
export INIT_CFLAGS="${RPM_OPT_FLAGS}" export INIT_CFLAGS="${RPM_OPT_FLAGS}"
export LDFLAGS="%{build_ldflags}" export LDFLAGS="%{build_ldflags}"
make %{?_smp_mflags} export PREFIX="%{_prefix}"
%make_build
%install %install
rm -rf $RPM_BUILD_ROOT %make_install PREFIX=%{_prefix} LIBDIR=%{_libdir}
export INIT_CFLAGS="${RPM_OPT_FLAGS}"
export LDFLAGS="%{build_ldflags}"
make install DESTDIR=$RPM_BUILD_ROOT LIBDIR=%{_libdir}
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';' find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
sed -i -e 's|/usr/local|%{_prefix}|g' \ sed -i -e 's|/usr/local|%{_prefix}|g' \
@ -58,31 +55,55 @@ sed -i -e 's|%{_prefix}/lib|%{_libdir}|' \
$RPM_BUILD_ROOT%{_libdir}/pkgconfig/libgdither.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libgdither.pc
%check %check
export INIT_CFLAGS="${RPM_OPT_FLAGS}" make test CFLAGS="%{optflags} -Werror --std=c99 -I%{_builddir}/%{?buildsubdir}"
export LDFLAGS="%{build_ldflags}"
make test CFLAGS="${RPM_OPT_FLAGS} -Werror --std=c99 -I%{_builddir}/%{?buildsubdir}"
%post -p /sbin/ldconfig %ldconfig_scriptlets
%postun -p /sbin/ldconfig
%files %files
%defattr(-,root,root,-) %doc README
%doc COPYING README %license COPYING
%{_libdir}/*.so.* %{_libdir}/*.so.*
%files devel %files devel
%defattr(-,root,root,-)
%{_includedir}/libgdither/ %{_includedir}/libgdither/
%{_libdir}/*.so %{_libdir}/*.so
%{_libdir}/pkgconfig/libgdither.pc %{_libdir}/pkgconfig/libgdither.pc
%changelog %changelog
* Sat Oct 13 2018 Ray Strode <rstrode@redhat.com> - 0.6-17 * Sun Nov 19 2023 Arkady L. Shane <ashejn@msvsphere.ru> - 0.6-26
- Address annocheck failures - Rebuilt for MSVSphere 9.2
Resolves: #1630581
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-26
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-25
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-24
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-23
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-22
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-21
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sun May 26 2019 David King <amigadave@amigadave.com> - 0.6-20
- Pass through PREFIX to build system
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Jul 17 2018 Nicolas Chauvet <kwizart@gmail.com> - 0.6-18
- Refresh spec file
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Tue Apr 10 2018 Rafael Santos <rdossant@redhat.com> - 0.6-16 * Tue Apr 10 2018 Rafael Santos <rdossant@redhat.com> - 0.6-16
- Use Fedora standard linker flags (bug #1548657) - Use Fedora standard linker flags (bug #1548657)

Loading…
Cancel
Save