parent
acf6852aa4
commit
870df1b3cc
@ -0,0 +1 @@
|
|||||||
|
libgdither-0.6.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
libgdither-0_6-1_fc8_kwizart:HEAD:libgdither-0.6-1.fc8.kwizart.src.rpm:1237919148
|
@ -0,0 +1,52 @@
|
|||||||
|
diff -up libgdither-0.6/Makefile.default libgdither-0.6/Makefile
|
||||||
|
--- libgdither-0.6/Makefile.default 2005-07-24 22:19:30.000000000 +0200
|
||||||
|
+++ libgdither-0.6/Makefile 2008-06-10 20:05:01.000000000 +0200
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
VERSION = 0.6
|
||||||
|
-PREFIX = /usr/local
|
||||||
|
-CFLAGS = -Wall -g -I. -O3 -funroll-loops -finline-limit=9999999 -ffast-math -malign-double -march=`uname -m` -fPIC
|
||||||
|
+PREFIX = /usr
|
||||||
|
+CFLAGS = $(INIT_CFLAGS) -I. -ffast-math -fPIC
|
||||||
|
|
||||||
|
TARDIR = libgdither-$(VERSION)
|
||||||
|
|
||||||
|
@@ -10,20 +10,22 @@ gdither.o: gdither.c gdither.h gdither_t
|
||||||
|
$(CC) $(CFLAGS) -c gdither.c
|
||||||
|
|
||||||
|
libgdither.so: gdither.o
|
||||||
|
- $(CC) -shared gdither.o -o libgdither.so
|
||||||
|
+ $(CC) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0
|
||||||
|
|
||||||
|
libgdither.pc: libgdither.pc.in Makefile
|
||||||
|
sed -e 's|@VERSION@|$(VERSION)|' -e 's|@PREFIX@|$(PREFIX)|' \
|
||||||
|
libgdither.pc.in > libgdither.pc
|
||||||
|
|
||||||
|
install: all
|
||||||
|
- install -d $(PREFIX)/lib/
|
||||||
|
- install libgdither.so $(PREFIX)/lib/
|
||||||
|
- install -d $(PREFIX)/include/
|
||||||
|
- install gdither.h $(PREFIX)/include/
|
||||||
|
- install gdither_types.h $(PREFIX)/include/
|
||||||
|
- install -d $(PREFIX)/lib/pkgconfig/
|
||||||
|
- install libgdither.pc $(PREFIX)/lib/pkgconfig/
|
||||||
|
+ mkdir -p $(DESTDIR)$(LIBDIR)
|
||||||
|
+ install -pm 0755 libgdither.so* $(DESTDIR)$(LIBDIR)
|
||||||
|
+ ln -s libgdither.so.1.0 $(DESTDIR)$(LIBDIR)/libgdither.so.1
|
||||||
|
+ ln -s libgdither.so.1.0 $(DESTDIR)$(LIBDIR)/libgdither.so
|
||||||
|
+ mkdir -p $(DESTDIR)$(PREFIX)/include/libgdither
|
||||||
|
+ install -pm 0644 gdither.h $(DESTDIR)$(PREFIX)/include/libgdither
|
||||||
|
+ install -pm 0644 gdither_types.h $(DESTDIR)$(PREFIX)/include/libgdither
|
||||||
|
+ mkdir -p $(DESTDIR)$(LIBDIR)/pkgconfig/
|
||||||
|
+ install -pm 0644 libgdither.pc $(DESTDIR)$(LIBDIR)/pkgconfig/
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -f *.o *.so
|
||||||
|
diff -up libgdither-0.6/libgdither.pc.default libgdither-0.6/libgdither.pc
|
||||||
|
--- libgdither-0.6/libgdither.pc.default 2005-07-24 22:19:30.000000000 +0200
|
||||||
|
+++ libgdither-0.6/libgdither.pc 2008-06-10 20:04:09.000000000 +0200
|
||||||
|
@@ -6,4 +6,4 @@ Name: libgdither
|
||||||
|
Version: 0.6
|
||||||
|
Description: A library for applying dithering to PCM audio sources
|
||||||
|
Libs: -L${libdir} -lgdither -lm
|
||||||
|
-Cflags: -I${includedir}
|
||||||
|
+Cflags: -I${includedir}/libgdither
|
@ -0,0 +1,13 @@
|
|||||||
|
diff -ur libgdither-0.6/gdither.c libgdither/gdither.c
|
||||||
|
--- libgdither-0.6/gdither.c 2005-07-24 22:19:30.000000000 +0200
|
||||||
|
+++ libgdither/gdither.c 2008-04-20 13:43:33.000000000 +0200
|
||||||
|
@@ -342,7 +342,7 @@
|
||||||
|
for (i=0; (i + pos) < length && i < GDITHER_CONV_BLOCK; i++) {
|
||||||
|
conv[i] = x[pos + i];
|
||||||
|
}
|
||||||
|
- gdither_runf(s, channel, i, conv, ycast + s->channels * step);
|
||||||
|
+ gdither_runf(s, channel, i, conv, ycast + pos * step);
|
||||||
|
pos += i;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
@ -0,0 +1,84 @@
|
|||||||
|
Name: libgdither
|
||||||
|
Version: 0.6
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Library for applying dithering to PCM audio sources
|
||||||
|
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
License: GPLv2+
|
||||||
|
URL: http://plugin.org.uk/libgdither/README
|
||||||
|
Source0: http://plugin.org.uk/libgdither/libgdither-%{version}.tar.gz
|
||||||
|
Patch0: libgdither-0.6-default.patch
|
||||||
|
Patch1: libgdither-0.6-gavl.patch
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
BuildRequires: fftw-devel >= 3.0.0
|
||||||
|
|
||||||
|
|
||||||
|
%description
|
||||||
|
Libgdither is a GPL'd library library for performing audio dithering on
|
||||||
|
PCM samples. The dithering process should be carried out before reducing
|
||||||
|
the bit width of PCM audio data (eg. float to 16 bit int conversions) to
|
||||||
|
preserve audio quality.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1 -b .default
|
||||||
|
%patch1 -p1 -b .gavl_fix
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
export INIT_CFLAGS="${RPM_OPT_FLAGS}"
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
make install DESTDIR=$RPM_BUILD_ROOT LIBDIR=%{_libdir}
|
||||||
|
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||||
|
|
||||||
|
sed -i -e 's|/usr/local|%{_prefix}|g' \
|
||||||
|
$RPM_BUILD_ROOT%{_libdir}/pkgconfig/libgdither.pc
|
||||||
|
sed -i -e 's|%{_prefix}/lib|%{_libdir}|' \
|
||||||
|
$RPM_BUILD_ROOT%{_libdir}/pkgconfig/libgdither.pc
|
||||||
|
|
||||||
|
%check
|
||||||
|
make test CFLAGS="${RPM_OPT_FLAGS} -Werror --std=c99 -I%{_builddir}/%{?buildsubdir}"
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%doc COPYING README
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_includedir}/libgdither/
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_libdir}/pkgconfig/libgdither.pc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Jun 27 2008 kwizart < kwizart at gmail.com > - 0.6-1
|
||||||
|
- Backport patch from gavl
|
||||||
|
|
||||||
|
* Mon Jun 16 2008 kwizart < kwizart at gmail.com > - 0.6-0
|
||||||
|
- Initial package
|
Loading…
Reference in new issue