parent
34aed70142
commit
36c6164a2d
@ -0,0 +1 @@
|
|||||||
|
libesmtp-1.0.3r1.tar.bz2
|
@ -0,0 +1,103 @@
|
|||||||
|
diff -ru -x '*.lo' -x '*.o' libesmtp-1.0.3r1-orig/configure.in libesmtp-1.0.3r1/configure.in
|
||||||
|
--- libesmtp-1.0.3r1-orig/configure.in 2004-04-21 10:21:32.000000000 +0200
|
||||||
|
+++ libesmtp-1.0.3r1/configure.in 2005-05-26 23:34:19.000000000 +0200
|
||||||
|
@@ -56,7 +56,7 @@
|
||||||
|
dnl Miscellaneous stuff
|
||||||
|
dnl #########################################################################
|
||||||
|
|
||||||
|
-EXTRA_CFLAGS=""
|
||||||
|
+AM_CFLAGS=""
|
||||||
|
case $host_vendor-$host_os in
|
||||||
|
sun*)
|
||||||
|
AC_DEFINE(__EXTENSIONS__,1,[Sun's netdb.h needs this for getaddrinfo])
|
||||||
|
@@ -79,13 +79,13 @@
|
||||||
|
enable_more_warnings=yes)
|
||||||
|
|
||||||
|
if test "$GCC" = "yes" -a "$enable_more_warnings" != "no"; then
|
||||||
|
- EXTRA_CFLAGS="$EXTRA_CFLAGS \
|
||||||
|
+ AM_CFLAGS="$AM_CFLAGS \
|
||||||
|
-Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes \
|
||||||
|
-Wstrict-prototypes -Wnested-externs -Wpointer-arith \
|
||||||
|
-Wbad-function-cast -Wcast-align"
|
||||||
|
fi
|
||||||
|
if test "$GCC" = "yes" -a "$enable_more_warnings" = "picky"; then
|
||||||
|
- EXTRA_CFLAGS="$EXTRA_CFLAGS -fno-builtin -W -Werror -Wwrite-strings \
|
||||||
|
+ $AM_CFLAGS="$AM_CFLAGS -fno-builtin -W -Werror -Wwrite-strings \
|
||||||
|
-Wcast-qual"
|
||||||
|
fi
|
||||||
|
|
||||||
|
@@ -538,7 +538,7 @@
|
||||||
|
dnl #########################################################################
|
||||||
|
|
||||||
|
AC_REPLACE_FUNCS(strdup strcasecmp strncasecmp memrchr)
|
||||||
|
-AC_CHECK_FUNCS(strtol uname gethostname)
|
||||||
|
+AC_CHECK_FUNCS(strtol uname gethostname snprintf vsnprintf)
|
||||||
|
AC_SEARCH_LIBS(socket, socket)
|
||||||
|
|
||||||
|
dnl Conditional check for functions needed in threaded code
|
||||||
|
@@ -582,9 +582,7 @@
|
||||||
|
AC_SUBST(DIST_PLUGINS)
|
||||||
|
AC_SUBST(LIBTOOL_DEPS)
|
||||||
|
AC_SUBST(LIBS)
|
||||||
|
-AC_SUBST(CFLAGS)
|
||||||
|
-AC_SUBST(EXTRA_CFLAGS)
|
||||||
|
-AC_SUBST(CC)
|
||||||
|
+AC_SUBST(AM_CFLAGS)
|
||||||
|
AC_SUBST(RANLIB)
|
||||||
|
AC_SUBST(subdirs)
|
||||||
|
|
||||||
|
diff -ru -x '*.lo' -x '*.o' libesmtp-1.0.3r1-orig/crammd5/Makefile.am libesmtp-1.0.3r1/crammd5/Makefile.am
|
||||||
|
--- libesmtp-1.0.3r1-orig/crammd5/Makefile.am 2001-10-17 11:15:27.000000000 +0200
|
||||||
|
+++ libesmtp-1.0.3r1/crammd5/Makefile.am 2005-05-26 23:28:15.000000000 +0200
|
||||||
|
@@ -3,7 +3,6 @@
|
||||||
|
libdir = @plugindir@
|
||||||
|
|
||||||
|
INCLUDES = -I@srcdir@
|
||||||
|
-CFLAGS = @CFLAGS@ @EXTRA_CFLAGS@
|
||||||
|
|
||||||
|
lib_LTLIBRARIES = sasl-cram-md5.la
|
||||||
|
|
||||||
|
diff -ru -x '*.lo' -x '*.o' libesmtp-1.0.3r1-orig/login/Makefile.am libesmtp-1.0.3r1/login/Makefile.am
|
||||||
|
--- libesmtp-1.0.3r1-orig/login/Makefile.am 2001-10-17 09:18:00.000000000 +0200
|
||||||
|
+++ libesmtp-1.0.3r1/login/Makefile.am 2005-05-26 23:28:12.000000000 +0200
|
||||||
|
@@ -5,7 +5,6 @@
|
||||||
|
INCLUDES = -I@srcdir@
|
||||||
|
|
||||||
|
lib_LTLIBRARIES = sasl-login.la
|
||||||
|
-CFLAGS = @CFLAGS@ @EXTRA_CFLAGS@
|
||||||
|
|
||||||
|
sasl_login_la_SOURCES = client-login.c
|
||||||
|
sasl_login_la_LDFLAGS = -module -avoid-version
|
||||||
|
diff -ru -x '*.lo' -x '*.o' libesmtp-1.0.3r1-orig/Makefile.am libesmtp-1.0.3r1/Makefile.am
|
||||||
|
--- libesmtp-1.0.3r1-orig/Makefile.am 2003-01-22 09:45:23.000000000 +0100
|
||||||
|
+++ libesmtp-1.0.3r1/Makefile.am 2005-05-26 23:28:20.000000000 +0200
|
||||||
|
@@ -4,7 +4,6 @@
|
||||||
|
INCLUDES = -I$(srcdir) $(VERSION_FLAGS)
|
||||||
|
SUBDIRS = @subdirs@ @SASL_PLUGINS@
|
||||||
|
DIST_SUBDIRS = @subdirs@ @DIST_PLUGINS@
|
||||||
|
-CFLAGS = @CFLAGS@ @EXTRA_CFLAGS@
|
||||||
|
|
||||||
|
lib_LTLIBRARIES = libesmtp.la
|
||||||
|
|
||||||
|
diff -ru -x '*.lo' -x '*.o' libesmtp-1.0.3r1-orig/ntlm/Makefile.am libesmtp-1.0.3r1/ntlm/Makefile.am
|
||||||
|
--- libesmtp-1.0.3r1-orig/ntlm/Makefile.am 2002-05-31 15:35:47.000000000 +0200
|
||||||
|
+++ libesmtp-1.0.3r1/ntlm/Makefile.am 2005-05-26 23:28:08.000000000 +0200
|
||||||
|
@@ -3,7 +3,6 @@
|
||||||
|
libdir = @plugindir@
|
||||||
|
|
||||||
|
INCLUDES = -I@srcdir@
|
||||||
|
-CFLAGS = @CFLAGS@ @EXTRA_CFLAGS@
|
||||||
|
|
||||||
|
lib_LTLIBRARIES = sasl-ntlm.la
|
||||||
|
|
||||||
|
diff -ru -x '*.lo' -x '*.o' libesmtp-1.0.3r1-orig/plain/Makefile.am libesmtp-1.0.3r1/plain/Makefile.am
|
||||||
|
--- libesmtp-1.0.3r1-orig/plain/Makefile.am 2001-10-17 09:18:08.000000000 +0200
|
||||||
|
+++ libesmtp-1.0.3r1/plain/Makefile.am 2005-05-26 23:28:04.000000000 +0200
|
||||||
|
@@ -3,7 +3,6 @@
|
||||||
|
libdir = @plugindir@
|
||||||
|
|
||||||
|
INCLUDES = -I@srcdir@
|
||||||
|
-CFLAGS = @CFLAGS@ @EXTRA_CFLAGS@
|
||||||
|
|
||||||
|
lib_LTLIBRARIES = sasl-plain.la
|
||||||
|
|
@ -0,0 +1,150 @@
|
|||||||
|
%define plugindir %{_libdir}/esmtp-plugins
|
||||||
|
|
||||||
|
Summary: SMTP client library
|
||||||
|
Name: libesmtp
|
||||||
|
Version: 1.0.3r1
|
||||||
|
Release: 3
|
||||||
|
License: LGPL
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
Source: http://www.stafford.uklinux.net/libesmtp/%{name}-%{version}.tar.bz2
|
||||||
|
Patch1: libesmtp-build.patch
|
||||||
|
URL: http://www.stafford.uklinux.net/libesmtp/
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
BuildRequires: openssl-devel pkgconfig automake libtool
|
||||||
|
|
||||||
|
%description
|
||||||
|
LibESMTP is a library to manage posting (or submission of) electronic
|
||||||
|
mail using SMTP to a preconfigured Mail Transport Agent (MTA) such as
|
||||||
|
Exim. It may be used as part of a Mail User Agent (MUA) or another
|
||||||
|
program that must be able to post electronic mail but where mail
|
||||||
|
functionality is not the program's primary purpose.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Headers and development libraries for libESMTP
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
LibESMTP is a library to manage posting (or submission of) electronic
|
||||||
|
mail using SMTP to a preconfigured Mail Transport Agent (MTA) such as
|
||||||
|
Exim.
|
||||||
|
|
||||||
|
The libesmtp-devel package contains headers and development libraries
|
||||||
|
necessary for building programs against libesmtp.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch1 -p1 -b .build
|
||||||
|
|
||||||
|
%build
|
||||||
|
#we run auto* because the distributed configure script is inferior.
|
||||||
|
libtoolize --force
|
||||||
|
aclocal
|
||||||
|
autoconf
|
||||||
|
autoheader
|
||||||
|
automake --gnu --add-missing --copy
|
||||||
|
|
||||||
|
if pkg-config openssl ; then
|
||||||
|
export CFLAGS="$CFLAGS $RPM_OPT_FLAGS `pkg-config --cflags openssl`"
|
||||||
|
export CPPFLAGS="$CPPFLAGS `pkg-config --cflags-only-I openssl`"
|
||||||
|
export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
|
||||||
|
fi
|
||||||
|
%configure --with-auth-plugin-dir=%{plugindir} --enable-pthreads \
|
||||||
|
--enable-require-all-recipients --enable-debug \
|
||||||
|
--enable-etrn
|
||||||
|
make
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
make DESTDIR=$RPM_BUILD_ROOT install
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
|
||||||
|
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%doc AUTHORS COPYING COPYING.GPL NEWS Notes README
|
||||||
|
%{_libdir}/libesmtp.so.*
|
||||||
|
%{plugindir}
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/libesmtp-config
|
||||||
|
%{_prefix}/include/*
|
||||||
|
%{_libdir}/libesmtp.so
|
||||||
|
%{_libdir}/libesmtp.a
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Jun 12 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-3
|
||||||
|
- Add libesmtp-build.patch - fix building under FC4.
|
||||||
|
|
||||||
|
* Thu Sep 30 2004 Miloslav Trmac <mitr@redhat.com> - 1.0.3r1-2
|
||||||
|
- Include libesmtp-config in libesmtp-devel (#125426, patch by Robert Scheck)
|
||||||
|
|
||||||
|
* Tue Jul 13 2004 John Dennis <jdennis@redhat.com> 1.0.3r1-1
|
||||||
|
- bring up to latest upstream release
|
||||||
|
|
||||||
|
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 1.0.2-1
|
||||||
|
- upgrade to 1.0.2 (#113894)
|
||||||
|
|
||||||
|
* Fri Oct 3 2003 Bill Nottingham <notting@redhat.com> 1.0.1-1
|
||||||
|
- update to 1.0.1, rebuild to fix some broken 64-bit libs
|
||||||
|
|
||||||
|
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.8.12-4
|
||||||
|
- include compilation flags for openssl as defined for pkg-config
|
||||||
|
- don't blow up on compile because key schedules aren't arrays
|
||||||
|
|
||||||
|
* Tue Nov 5 2002 Bill Nottingham <notting@redhat.com> 0.8.12-3
|
||||||
|
- build on various platforms
|
||||||
|
|
||||||
|
* Tue Jul 23 2002 Bill Nottingham <notting@redhat.com> 0.8.12-2
|
||||||
|
- fix broken lib (no pthread dependency)
|
||||||
|
|
||||||
|
* Mon Jun 24 2002 Bill Nottingham <notting@redhat.com> 0.8.12-1
|
||||||
|
- update to 0.8.12
|
||||||
|
|
||||||
|
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Thu May 23 2002 Tim Powers <timp@redhat.com>
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Thu Aug 30 2001 Bill Nottingham <notting@redhat.com>
|
||||||
|
- fix assertion failure when sending mail (#52940)
|
||||||
|
|
||||||
|
* Mon Aug 20 2001 Bill Nottingham <notting@redhat.com>
|
||||||
|
- update to 0.8.4 (fixes CRAM-MD5, #52097)
|
||||||
|
|
||||||
|
* Mon Jul 30 2001 Bill Nottingham <notting@redhat.com>
|
||||||
|
- don't enable starttls (not fully tested, at request of author)
|
||||||
|
|
||||||
|
* Wed Jul 24 2001 Bill Nottingham <notting@redhat.com>
|
||||||
|
- rebuild, openssl weirdness
|
||||||
|
|
||||||
|
* Mon Jul 23 2001 Bill Nottingham <notting@redhat.com>
|
||||||
|
- initial build, clean up included spec file
|
||||||
|
- add %post/%postun
|
Loading…
Reference in new issue