Update to 1.3.0

epel8
Nicolas Chauvet 9 years ago
parent c82477fe22
commit 47cb31ed1d

@ -1,28 +0,0 @@
commit 09f9fad68e34975f8a90de564f3f12820947f22e
Author: Jean-Paul Saman <jpsaman@videolan.org>
Date: Mon Sep 8 12:27:07 2014 +0200
configure.ac: specify -Werror on debug builds only.
diff --git a/configure.ac b/configure.ac
index 66e5fec..2585a8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,7 @@ dnl store CFLAGS from user
CFLAGS_save="${CFLAGS}"
dnl add features to CFLAGS
-CFLAGS_dist="-Wall -Werror --std=gnu99 -D_GNU_SOURCE"
+CFLAGS_dist="-Wall -std=gnu99 -D_GNU_SOURCE"
CFLAGS_dist="${CFLAGS_dist} -Wpointer-arith -Wcast-align -Wstrict-prototypes -Wshadow -Waggregate-return -Wmissing-prototypes -Wnested-externs -Wsign-compare"
dnl check the operating system
@@ -52,7 +52,7 @@ AC_ARG_ENABLE(debug,
esac],[debug=false])
if test "$debug" = "true"
then
- CFLAGS_dist="${CFLAGS_dist} -ggdb3"
+ CFLAGS_dist="${CFLAGS_dist} -Werror -ggdb3"
fi
dnl --enable-gcc-sanitize

@ -1,24 +0,0 @@
From 5058ea22730a67f03dd253dce89d513bc430bfb6 Mon Sep 17 00:00:00 2001
From: =?utf8?q?Rafa=C3=ABl=20Carr=C3=A9?= <funman@videolan.org>
Date: Fri, 5 Sep 2014 12:11:49 +0200
Subject: [PATCH] dr_50: fix off-by-6
---
src/descriptors/dr_50.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/descriptors/dr_50.c b/src/descriptors/dr_50.c
index a2e491c..9933b08 100644
--- a/src/descriptors/dr_50.c
+++ b/src/descriptors/dr_50.c
@@ -70,7 +70,7 @@ dvbpsi_component_dr_t* dvbpsi_DecodeComponentDr(dvbpsi_descriptor_t * p_descript
if (p_descriptor->i_length > 6)
{
p_decoded->i_text_length = p_descriptor->i_length - 6;
- p_decoded->i_text = calloc(p_decoded->i_text_length - 6, sizeof(uint8_t));
+ p_decoded->i_text = calloc(1, p_decoded->i_text_length);
if (!p_decoded->i_text)
{
free(p_decoded);
--
1.7.10.4

@ -1,16 +1,11 @@
#global pre _pre3
%global _default_patch_fuzz 3
Summary: Library for MPEG TS and DVB PSI tables decoding and generation
Name: libdvbpsi
Version: 1.2.0
Release: 3%{?pre}%{?dist}
Version: 1.3.0
Release: 1%{?pre}%{?dist}
License: LGPLv2+
Group: System Environment/Libraries
URL: http://www.videolan.org/developers/libdvbpsi.html
Source0: http://download.videolan.org/pub/libdvbpsi/%{version}/%{name}-%{version}%{?pre}.tar.bz2
Patch0: libdvbpsi-backport-werror_on_debug.patch
Patch1: libdvbpsi-calloc.patch
BuildRequires: graphviz doxygen
BuildRequires: libtool
@ -32,8 +27,6 @@ This package contains development files for %{name}
%prep
%setup -q -n %{name}-%{version}%{?pre}
%patch0 -p1
%patch1 -p1
autoreconf -vif
@ -63,6 +56,9 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
%changelog
* Sat Oct 24 2015 Nicolas Chauvet <kwizart@gmail.com> - 1.3.0-1
- Update to 1.3.0
* Sat Oct 24 2015 Nicolas Chauvet <kwizart@gmail.com> - 1.2.0-3
- backport patch - rfbz#3729

Loading…
Cancel
Save