parent
9759e0d2e1
commit
b069330dd9
@ -1,137 +0,0 @@
|
|||||||
Make sure that the asm files don't incorrectly trigger an executable
|
|
||||||
stack marking in the final shared library. That's bad, mmmkay.
|
|
||||||
|
|
||||||
Upstream has already fixed this in their cvs.
|
|
||||||
|
|
||||||
--- libdv/dct_block_mmx.S
|
|
||||||
+++ libdv/dct_block_mmx.S
|
|
||||||
@@ -1217,3 +1217,7 @@ _dv_dct_block_mmx_postscale_248:
|
|
||||||
popl %esi
|
|
||||||
popl %ebp
|
|
||||||
ret
|
|
||||||
+
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/dct_block_mmx_x86_64.S
|
|
||||||
+++ libdv/dct_block_mmx_x86_64.S
|
|
||||||
@@ -1207,3 +1207,7 @@ _dv_dct_block_mmx_x86_64_postscale_248:
|
|
||||||
pop %r12
|
|
||||||
|
|
||||||
ret
|
|
||||||
+
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/encode_x86.S
|
|
||||||
+++ libdv/encode_x86.S
|
|
||||||
@@ -611,3 +611,6 @@ _dv_need_dct_248_mmx_rows:
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/encode_x86_64.S
|
|
||||||
+++ libdv/encode_x86_64.S
|
|
||||||
@@ -612,3 +612,6 @@ _dv_need_dct_248_mmx_x86_64_rows:
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/idct_block_mmx.S
|
|
||||||
+++ libdv/idct_block_mmx.S
|
|
||||||
@@ -649,3 +649,6 @@ x0:
|
|
||||||
.long 0,0
|
|
||||||
.align 8
|
|
||||||
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/idct_block_mmx_x86_64.S
|
|
||||||
+++ libdv/idct_block_mmx_x86_64.S
|
|
||||||
@@ -654,3 +654,6 @@ x0:
|
|
||||||
.long 0,0
|
|
||||||
.align 8
|
|
||||||
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/quant_x86.S
|
|
||||||
+++ libdv/quant_x86.S
|
|
||||||
@@ -458,3 +458,6 @@ _dv_quant_x86:
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/quant_x86_64.S
|
|
||||||
+++ libdv/quant_x86_64.S
|
|
||||||
@@ -463,3 +463,6 @@ _dv_quant_x86_64:
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/rgbtoyuv.S
|
|
||||||
+++ libdv/rgbtoyuv.S
|
|
||||||
@@ -1451,3 +1451,6 @@ video_copy_ntsc_c_block_mmx_loop:
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/rgbtoyuv_x86_64.S
|
|
||||||
+++ libdv/rgbtoyuv_x86_64.S
|
|
||||||
@@ -1391,3 +1391,6 @@ video_copy_ntsc_c_block_mmx_loop:
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/transpose_x86.S
|
|
||||||
+++ libdv/transpose_x86.S
|
|
||||||
@@ -190,3 +190,7 @@ popl %esi
|
|
||||||
popl %ebp
|
|
||||||
|
|
||||||
ret $0
|
|
||||||
+
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/transpose_x86_64.S
|
|
||||||
+++ libdv/transpose_x86_64.S
|
|
||||||
@@ -190,3 +190,7 @@ all_done_ready_to_exit:
|
|
||||||
pop %r12
|
|
||||||
|
|
||||||
ret $0
|
|
||||||
+
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/vlc_x86.S
|
|
||||||
+++ libdv/vlc_x86.S
|
|
||||||
@@ -587,3 +587,7 @@ mod_12:
|
|
||||||
.align 16
|
|
||||||
const_f_0_0_0:
|
|
||||||
.short 0xffff,0,0,0
|
|
||||||
+
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
||||||
--- libdv/vlc_x86_64.S
|
|
||||||
+++ libdv/vlc_x86_64.S
|
|
||||||
@@ -673,3 +673,7 @@ mod_12:
|
|
||||||
.align 16
|
|
||||||
const_f_0_0_0:
|
|
||||||
.short 0xffff,0,0,0
|
|
||||||
+
|
|
||||||
+#ifdef __ELF__
|
|
||||||
+.section .note.GNU-stack,"",@progbits
|
|
||||||
+#endif
|
|
@ -1,22 +0,0 @@
|
|||||||
We now need to explicitly link to libraries that we use because we can no
|
|
||||||
longer depend on our dependencies to pull them in for us. See
|
|
||||||
http://fedoraproject.org/wiki/UnderstandingDSOLinkChange
|
|
||||||
|
|
||||||
--- libdv-1.0.0/playdv/#Makefile.am~ 2010-02-15 14:49:06.000000000 -0500
|
|
||||||
+++ libdv-1.0.0/playdv/Makefile.am 2010-02-15 14:49:06.000000000 -0500
|
|
||||||
@@ -15,4 +15,4 @@ bin_PROGRAMS= playdv
|
|
||||||
noinst_HEADERS= display.h oss.h
|
|
||||||
|
|
||||||
playdv_SOURCES= playdv.c display.c display.h oss.c
|
|
||||||
-playdv_LDADD= $(SDL_LIBS) $(GTK_LIBS) $(XV_LIB) ../libdv/libdv.la $(POPT_LIB)
|
|
||||||
+playdv_LDADD= $(SDL_LIBS) $(GTK_LIBS) $(XV_LIB) ../libdv/libdv.la $(POPT_LIB) -lX11 -lXext
|
|
||||||
--- libdv-1.0.0/Makefile.orig.am 2006-08-06 22:10:42.000000000 +0200
|
|
||||||
+++ libdv-1.0.0/Makefile.am 2016-08-01 12:31:11.622234099 +0200
|
|
||||||
@@ -5,6 +5,7 @@
|
|
||||||
endif
|
|
||||||
|
|
||||||
SUBDIRS = libdv encodedv $(gtk_subdirs)
|
|
||||||
+ACLOCAL_AMFLAGS = -I m4
|
|
||||||
|
|
||||||
AUX_DIST = $(ac_aux_dir)/config.guess \
|
|
||||||
$(ac_aux_dir)/config.sub \
|
|
@ -1,28 +0,0 @@
|
|||||||
--- libdv-1.0.0/configure.ac.orig 2007-01-19 15:48:43.000000000 -0500
|
|
||||||
+++ libdv-1.0.0/configure.ac 2007-01-19 15:50:08.000000000 -0500
|
|
||||||
@@ -1,12 +1,14 @@
|
|
||||||
dnl Process this file with autoconf to produce a configure script.
|
|
||||||
-AC_INIT(libdv/parse.c)
|
|
||||||
+AC_INIT(libdv, 1.0.0)
|
|
||||||
+AC_CONFIG_SRCDIR(libdv/parse.c)
|
|
||||||
+AC_CONFIG_MACRO_DIRS([m4])
|
|
||||||
dnl AC_CONFIG_AUX_DIR(config)
|
|
||||||
AM_CONFIG_HEADER(config.h)
|
|
||||||
|
|
||||||
RPM_RELEASE=1
|
|
||||||
AC_CANONICAL_HOST
|
|
||||||
AC_CANONICAL_TARGET
|
|
||||||
-AM_INIT_AUTOMAKE(libdv, 1.0.0)
|
|
||||||
+AM_INIT_AUTOMAKE
|
|
||||||
|
|
||||||
AM_MAINTAINER_MODE
|
|
||||||
AC_LIBTOOL_PICMODE(no)
|
|
||||||
@@ -164,7 +164,7 @@
|
|
||||||
dnl Checks for libraries.
|
|
||||||
have_gtk="false"
|
|
||||||
if $use_gtk; then
|
|
||||||
- REQUIRES='glib >= 1.2.4 gtk+ >= 1.2.4'
|
|
||||||
+ REQUIRES='glib-2.0 >= 2.1.0 gtk+-x11-2.0 >= 2.1.0'
|
|
||||||
PKG_CHECK_MODULES(GTK,$REQUIRES,have_gtk="true",have_gtk="false")
|
|
||||||
AC_DEFINE(HAVE_GTK)
|
|
||||||
fi
|
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue