commit
3604b3ea38
@ -0,0 +1 @@
|
||||
SOURCES/libdmtx-0.7.5.tar.gz
|
@ -0,0 +1 @@
|
||||
5a9742e7f74e8d1c154a212b3b0f37a740b6f0f2 SOURCES/libdmtx-0.7.5.tar.gz
|
@ -0,0 +1,36 @@
|
||||
diff -up libdmtx-0.7.5/test/multi_test/Makefile.am.std libdmtx-0.7.5/test/multi_test/Makefile.am
|
||||
--- libdmtx-0.7.5/test/multi_test/Makefile.am.std 2018-04-06 13:14:23.000000000 +0200
|
||||
+++ libdmtx-0.7.5/test/multi_test/Makefile.am 2018-04-06 13:14:27.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-AM_CPPFLAGS = -Wshadow -Wall -pedantic -ansi
|
||||
+AM_CPPFLAGS = -Wshadow -Wall -pedantic -std=c99
|
||||
|
||||
check_PROGRAMS = multi_test
|
||||
|
||||
diff -up libdmtx-0.7.5/test/rotate_test/Makefile.am.std libdmtx-0.7.5/test/rotate_test/Makefile.am
|
||||
--- libdmtx-0.7.5/test/rotate_test/Makefile.am.std 2018-04-06 13:14:13.000000000 +0200
|
||||
+++ libdmtx-0.7.5/test/rotate_test/Makefile.am 2018-04-06 13:14:18.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-AM_CPPFLAGS = -Wshadow -Wall -pedantic -ansi
|
||||
+AM_CPPFLAGS = -Wshadow -Wall -pedantic -std=c99
|
||||
|
||||
check_PROGRAMS = rotate_test
|
||||
|
||||
diff -up libdmtx-0.7.5/test/simple_test/Makefile.am.std libdmtx-0.7.5/test/simple_test/Makefile.am
|
||||
--- libdmtx-0.7.5/test/simple_test/Makefile.am.std 2018-04-06 13:13:59.000000000 +0200
|
||||
+++ libdmtx-0.7.5/test/simple_test/Makefile.am 2018-04-06 13:14:04.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-AM_CPPFLAGS = -Wshadow -Wall -pedantic -ansi
|
||||
+AM_CPPFLAGS = -Wshadow -Wall -pedantic -std=c99
|
||||
|
||||
check_PROGRAMS = simple_test
|
||||
|
||||
diff -up libdmtx-0.7.5/test/unit_test/Makefile.am.std libdmtx-0.7.5/test/unit_test/Makefile.am
|
||||
--- libdmtx-0.7.5/test/unit_test/Makefile.am.std 2018-04-06 13:13:41.000000000 +0200
|
||||
+++ libdmtx-0.7.5/test/unit_test/Makefile.am 2018-04-06 13:13:53.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-AM_CPPFLAGS = -Wshadow -Wall -pedantic -ansi
|
||||
+AM_CPPFLAGS = -Wshadow -Wall -pedantic -std=c99
|
||||
|
||||
check_PROGRAMS = unit_test
|
||||
|
@ -0,0 +1,11 @@
|
||||
diff -up libdmtx-0.7.5/test/simple_test/simple_test.c.math libdmtx-0.7.5/test/simple_test/simple_test.c
|
||||
--- libdmtx-0.7.5/test/simple_test/simple_test.c.math 2018-04-06 13:19:44.000000000 +0200
|
||||
+++ libdmtx-0.7.5/test/simple_test/simple_test.c 2018-04-06 13:19:52.000000000 +0200
|
||||
@@ -18,6 +18,7 @@
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
#include <assert.h>
|
||||
+#include <math.h>
|
||||
#include <dmtx.h>
|
||||
|
||||
int
|
@ -0,0 +1,29 @@
|
||||
diff -up libdmtx-0.7.5/test/simple_test/simple_test.c.size_t libdmtx-0.7.5/test/simple_test/simple_test.c
|
||||
--- libdmtx-0.7.5/test/simple_test/simple_test.c.size_t 2018-04-06 13:16:35.000000000 +0200
|
||||
+++ libdmtx-0.7.5/test/simple_test/simple_test.c 2018-04-06 13:17:14.000000000 +0200
|
||||
@@ -58,9 +58,9 @@ main(int argc, char *argv[])
|
||||
|
||||
dmtxEncodeDestroy(&enc);
|
||||
|
||||
- fprintf(stdout, "width: \"%d\"\n", width);
|
||||
- fprintf(stdout, "height: \"%d\"\n", height);
|
||||
- fprintf(stdout, "bpp: \"%d\"\n", bytesPerPixel);
|
||||
+ fprintf(stdout, "width: \"%zd\"\n", width);
|
||||
+ fprintf(stdout, "height: \"%zd\"\n", height);
|
||||
+ fprintf(stdout, "bpp: \"%zd\"\n", bytesPerPixel);
|
||||
|
||||
for (int i=0; i<width*height; i++){
|
||||
fprintf(stdout, "%d", (pxl[i*3])==0);
|
||||
@@ -81,9 +81,9 @@ main(int argc, char *argv[])
|
||||
if(reg != NULL) {
|
||||
msg = dmtxDecodeMatrixRegion(dec, reg, DmtxUndefined);
|
||||
|
||||
- fprintf(stdout, "msg->arraySize : \"%d\"\n", msg->arraySize );
|
||||
- fprintf(stdout, "msg->codeSize : \"%d\"\n", msg->codeSize );
|
||||
- fprintf(stdout, "msg->outputSize: \"%d\"\n", msg->outputSize);
|
||||
+ fprintf(stdout, "msg->arraySize : \"%zd\"\n", msg->arraySize );
|
||||
+ fprintf(stdout, "msg->codeSize : \"%zd\"\n", msg->codeSize );
|
||||
+ fprintf(stdout, "msg->outputSize: \"%zd\"\n", msg->outputSize);
|
||||
int oned = sqrt(msg->arraySize);
|
||||
for (int i=0; i<msg->arraySize; i++){
|
||||
fprintf(stdout, " %c.", msg->array[i]);
|
@ -0,0 +1,193 @@
|
||||
Name: libdmtx
|
||||
Version: 0.7.5
|
||||
Release: 8%{?dist}
|
||||
Summary: Library for working with Data Matrix 2D bar-codes
|
||||
|
||||
License: BSD
|
||||
# http://www.libdmtx.org/ doesn't work any more
|
||||
# outdated info is still at http://libdmtx.sourceforge.net/
|
||||
URL: https://github.com/dmtx
|
||||
Source0: https://github.com/dmtx/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
# https://github.com/dmtx/libdmtx/pull/13
|
||||
Patch0: libdmtx-0.7.5-c99.patch
|
||||
# https://github.com/dmtx/libdmtx/pull/14
|
||||
Patch1: libdmtx-0.7.5-size_t.patch
|
||||
# https://github.com/dmtx/libdmtx/pull/12
|
||||
Patch2: libdmtx-0.7.5-math.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libtool
|
||||
BuildRequires: make
|
||||
|
||||
# obsolete language bindings we can't provide any more
|
||||
Obsoletes: php-libdmtx < 0.7.4
|
||||
Obsoletes: python-libdmtx < 0.7.4
|
||||
Obsoletes: ruby-libdmtx < 0.7.4
|
||||
|
||||
|
||||
%description
|
||||
libdmtx is open source software for reading and writing Data Matrix 2D
|
||||
bar-codes on Linux, Unix, OS X, Windows, and mobile devices. At its core
|
||||
libdmtx is a shared library, allowing C/C++ programs to use its capabilities
|
||||
without restrictions or overhead.
|
||||
|
||||
The included utility programs, dmtxread and dmtxwrite, provide the official
|
||||
interface to libdmtx from the command line, and also serve as a good reference
|
||||
for programmers who wish to write their own programs that interact with
|
||||
libdmtx. All of the software in the libdmtx package is distributed under
|
||||
the LGPLv2 and can be used freely under these terms.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and header files for
|
||||
developing applications that use %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
./autogen.sh
|
||||
|
||||
|
||||
%build
|
||||
%configure --disable-static
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||
|
||||
|
||||
%check
|
||||
make check
|
||||
pushd test
|
||||
for t in simple
|
||||
do
|
||||
./${t}_test/${t}_test
|
||||
done
|
||||
popd
|
||||
|
||||
|
||||
%files
|
||||
%license LICENSE
|
||||
%doc AUTHORS ChangeLog KNOWNBUG README README.linux TODO
|
||||
%{_libdir}/%{name}.so.*
|
||||
|
||||
%files devel
|
||||
%doc
|
||||
%{_includedir}/*
|
||||
%{_libdir}/%{name}.so
|
||||
%{_libdir}/pkgconfig/%{name}.pc
|
||||
%{_mandir}/man3/%{name}.3*
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Jan 14 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.7.5-8
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.5-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.5-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.5-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.5-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.5-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Fri Apr 06 2018 Dan Horák <dan[at]danny.cz> - 0.7.5-1
|
||||
- updated to 0.7.5
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.4-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Mar 03 2017 Dan Horák <dan[at]danny.cz> - 0.7.4-1
|
||||
- updated to 0.7.4
|
||||
- dropped out-dated language bindings
|
||||
- split utils into own package
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.2-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-20
|
||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.2-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Jan 12 2016 Vít Ondruch <vondruch@redhat.com> - 0.7.2-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.3
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Jan 17 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 0.7.2-16
|
||||
- Rebuild for https://fedoraproject.org/wiki/Changes/Ruby_2.2
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu Apr 24 2014 Vít Ondruch <vondruch@redhat.com> - 0.7.2-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.1
|
||||
|
||||
* Tue Apr 01 2014 Dan Horák <dan@danny.cz> - 0.7.2-12
|
||||
- rebuilt for ImageMagick soname bump
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue Mar 19 2013 Vít Ondruch <vondruch@redhat.com> - 0.7.2-10
|
||||
- Rebuild for https://fedoraproject.org/wiki/Features/Ruby_2.0.0
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sun Mar 04 2012 Dan Horák <dan[at]danny.cz> - 0.7.2-7
|
||||
- rebuilt for ImageMagick soname bump
|
||||
|
||||
* Wed Feb 08 2012 Dan Horák <dan[at]danny.cz> - 0.7.2-6
|
||||
- fix build with php 5.4 and ruby 1.9.3
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Nov 17 2010 Dan Horák <dan[at]danny.cz> 0.7.2-3
|
||||
- updated license for the php subpackage
|
||||
- run few tests
|
||||
|
||||
* Sat May 29 2010 Dan Horák <dan[at]danny.cz> 0.7.2-2
|
||||
- added language bindigs
|
||||
|
||||
* Wed Feb 3 2010 Dan Horák <dan[at]danny.cz> 0.7.2-1
|
||||
- initial Fedora version
|
Loading…
Reference in new issue