remove -Werror flag to fix build on fedora 31+

epel9
Fabio Valentini 5 years ago
parent f006a4ec21
commit 3f1b706008
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -0,0 +1,52 @@
diff --git a/libdbusmenu-glib/Makefile.am b/libdbusmenu-glib/Makefile.am
index 2dea5f6..01832ce 100644
--- a/libdbusmenu-glib/Makefile.am
+++ b/libdbusmenu-glib/Makefile.am
@@ -66,7 +66,7 @@ libdbusmenu_glib_la_LDFLAGS = \
libdbusmenu_glib_la_CFLAGS = \
$(DBUSMENUGLIB_CFLAGS) \
$(COVERAGE_CFLAGS) \
- -Wall -Werror -Wno-error=deprecated-declarations \
+ -Wall -Wno-error=deprecated-declarations \
-DG_LOG_DOMAIN="\"LIBDBUSMENU-GLIB\""
libdbusmenu_glib_la_LIBADD = \
diff --git a/libdbusmenu-gtk/Makefile.am b/libdbusmenu-gtk/Makefile.am
index 9a7a2b0..a9a2b49 100644
--- a/libdbusmenu-gtk/Makefile.am
+++ b/libdbusmenu-gtk/Makefile.am
@@ -66,7 +66,7 @@ libdbusmenu_gtk_la_CFLAGS = \
$(DBUSMENUGTK_CFLAGS) \
$(COVERAGE_CFLAGS) \
-I$(top_srcdir) \
- -Wall -Werror -Wno-error=deprecated-declarations \
+ -Wall -Wno-error=deprecated-declarations \
-DG_LOG_DOMAIN="\"LIBDBUSMENU-GTK\""
libdbusmenu_gtk_la_LIBADD = \
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 64e3e75..699c2c9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -103,7 +103,7 @@ TESTS_ENVIRONMENT = env GI_TYPELIB_PATH=$(top_builddir)/libdbusmenu-glib:$(top_b
############################################
DBUSMENU_GLIB_TEST_CFLAGS = \
- -Wall -Werror \
+ -Wall \
-DG_DISABLE_DEPRECATED \
-I$(top_srcdir) \
$(DBUSMENUTESTS_CFLAGS) \
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 029b73e..2258cca 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -16,7 +16,7 @@ dbusmenu_dumper_CFLAGS = \
-I $(srcdir)/.. \
$(DBUSMENUGLIB_CFLAGS) \
$(DBUSMENUDUMPER_CFLAGS) \
- -Wall -Werror
+ -Wall
dbusmenu_dumper_LDADD = \
../libdbusmenu-glib/libdbusmenu-glib.la \

@ -9,7 +9,7 @@
Name: libdbusmenu Name: libdbusmenu
Version: %{ubuntu_release}.0 Version: %{ubuntu_release}.0
Release: 12%{?dist} Release: 13%{?dist}
Summary: Library for passing menus over DBus Summary: Library for passing menus over DBus
# All files installed in final rpms use C sources with dual licensing headers. # All files installed in final rpms use C sources with dual licensing headers.
@ -19,6 +19,9 @@ License: LGPLv3 or LGPLv2 and GPLv3
URL: https://launchpad.net/libdbusmenu URL: https://launchpad.net/libdbusmenu
Source0: https://launchpad.net/libdbusmenu/%{ubuntu_release}/%{version}/+download/%{name}-%{version}.tar.gz Source0: https://launchpad.net/libdbusmenu/%{ubuntu_release}/%{version}/+download/%{name}-%{version}.tar.gz
# patch to remove -Werror flag - fixes build despite usage of deprecated things
Patch0: 00-no-werror.patch
BuildRequires: atk-devel BuildRequires: atk-devel
BuildRequires: autoconf BuildRequires: autoconf
BuildRequires: automake BuildRequires: automake
@ -135,6 +138,11 @@ that use %{name}.
%prep %prep
%setup -q -n %{name}-%{version} -c %setup -q -n %{name}-%{version} -c
pushd %{name}-%{version}
%patch0 -p1
popd
cp -a %{name}-%{version}/{README,COPYING,COPYING.2.1,COPYING-GPL3,AUTHORS,ChangeLog} . cp -a %{name}-%{version}/{README,COPYING,COPYING.2.1,COPYING-GPL3,AUTHORS,ChangeLog} .
cp -a %{name}-%{version} %{name}-gtk3-%{version} cp -a %{name}-%{version} %{name}-gtk3-%{version}
@ -250,6 +258,9 @@ done
%{_datadir}/%{name}/json/test-gtk-label.json %{_datadir}/%{name}/json/test-gtk-label.json
%changelog %changelog
* Mon Sep 09 2019 Fabio Valentini <decathorpe@gmail.com> - 16.04.0-13
- Remove -Werror flag to fix build despite usage of deprecated things.
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 16.04.0-12 * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 16.04.0-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

Loading…
Cancel
Save