[Bug 486409] Wrong python binding installed path

epel9
Ding-Yi Chen 16 years ago
parent 34abd720aa
commit bd01c96cc9

@ -5,3 +5,4 @@ libchewing-0_3_2-1_fc10:HEAD:libchewing-0.3.2-1.fc10.src.rpm:1229994594
libchewing-0_3_2-2_fc10:HEAD:libchewing-0.3.2-2.fc10.src.rpm:1230010807 libchewing-0_3_2-2_fc10:HEAD:libchewing-0.3.2-2.fc10.src.rpm:1230010807
libchewing-0_3_2-3_fc10:HEAD:libchewing-0.3.2-3.fc10.src.rpm:1231914268 libchewing-0_3_2-3_fc10:HEAD:libchewing-0.3.2-3.fc10.src.rpm:1231914268
libchewing-0_3_2-4_fc10:HEAD:libchewing-0.3.2-4.fc10.src.rpm:1232696067 libchewing-0_3_2-4_fc10:HEAD:libchewing-0.3.2-4.fc10.src.rpm:1232696067
libchewing-0_3_2-6_fc10:HEAD:libchewing-0.3.2-6.fc10.src.rpm:1235113283

@ -1,6 +1,6 @@
diff -up ./data/Makefile.am.libpatch ./data/Makefile.am diff -up ./data/Makefile.am.libpatch ./data/Makefile.am
--- ./data/Makefile.am.libpatch 2008-12-02 00:29:20.000000000 +1000 --- ./data/Makefile.am.libpatch 2008-12-02 00:29:20.000000000 +1000
+++ ./data/Makefile.am 2008-12-23 13:54:17.000000000 +1000 +++ ./data/Makefile.am 2009-02-20 12:23:46.000000000 +1000
@@ -9,8 +9,11 @@ datas = \ @@ -9,8 +9,11 @@ datas = \
us_freq.dat \ us_freq.dat \
dict.dat \ dict.dat \
@ -26,20 +26,18 @@ diff -up ./data/Makefile.am.libpatch ./data/Makefile.am
+CLEANFILES = $(datas) $(datas_lib) gendata_stamp checkdata_stamp $(generated_header) +CLEANFILES = $(datas) $(datas_lib) gendata_stamp checkdata_stamp $(generated_header)
diff -up ./src/Makefile.am.libpatch ./src/Makefile.am diff -up ./src/Makefile.am.libpatch ./src/Makefile.am
--- ./src/Makefile.am.libpatch 2008-12-02 00:29:20.000000000 +1000 --- ./src/Makefile.am.libpatch 2008-12-02 00:29:20.000000000 +1000
+++ ./src/Makefile.am 2008-12-23 14:07:56.000000000 +1000 +++ ./src/Makefile.am 2009-02-20 12:26:46.000000000 +1000
@@ -3,7 +3,8 @@ INCLUDES = \ @@ -3,6 +3,7 @@ INCLUDES = \
-I$(top_srcdir)/include \ -I$(top_srcdir)/include \
-I$(top_srcdir)/include/internal \ -I$(top_srcdir)/include/internal \
-I$(top_srcdir)/src/porting_layer/include \ -I$(top_srcdir)/src/porting_layer/include \
- -DCHEWING_DATADIR=\"$(datadir)/chewing\"
+ -DLIBINSTDIR=\"$(libdir)\"\ + -DLIBINSTDIR=\"$(libdir)\"\
+ -DCHEWING_DATADIR=\"$(datadir)/chewing1\" -DCHEWING_DATADIR=\"$(datadir)/chewing\"
lib_LTLIBRARIES = libchewing.la lib_LTLIBRARIES = libchewing.la
libchewing_la_SOURCES = \
diff -up ./src/tree.c.libpatch ./src/tree.c diff -up ./src/tree.c.libpatch ./src/tree.c
--- ./src/tree.c.libpatch 2008-12-02 00:29:20.000000000 +1000 --- ./src/tree.c.libpatch 2008-12-02 00:29:20.000000000 +1000
+++ ./src/tree.c 2008-12-23 14:04:36.000000000 +1000 +++ ./src/tree.c 2009-02-20 12:23:46.000000000 +1000
@@ -114,7 +114,8 @@ void InitTree( const char *prefix ) @@ -114,7 +114,8 @@ void InitTree( const char *prefix )
int i; int i;
#endif #endif

@ -1,7 +1,7 @@
Name: libchewing Name: libchewing
Version: 0.3.2 Version: 0.3.2
Release: 5%{?dist} Release: 6%{?dist}
Summary: Intelligent phonetic input method library for Traditional Chinese Summary: Intelligent phonetic input method library for Traditional Chinese
Group: System Environment/Libraries Group: System Environment/Libraries
@ -24,6 +24,7 @@ Patch9: libchewing-0.3.2.bz477690.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-root BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: autoconf automake libtool BuildRequires: autoconf automake libtool
BuildRequires: python-devel
%description %description
libchewing is an intelligent phonetic input method library for Chinese. libchewing is an intelligent phonetic input method library for Chinese.
@ -56,9 +57,12 @@ library.
%patch9 -p0 -b .libpatch %patch9 -p0 -b .libpatch
%build %build
autoreconf -v --install #./autogen.sh
#autoreconf -v
export CFLAGS=-DLIBINSTDIR='\"%{_libdir}\"'
%configure --disable-static %configure --disable-static
make LIBINSTDIR="\"%{_libdir}\"" #make LIBINSTDIR="\"%{_libdir}\""
make all RPM_CFLAGS="$RPM_OPT_FLAGS"
%install %install
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
@ -66,6 +70,8 @@ make DESTDIR=%{buildroot} install
rm $RPM_BUILD_ROOT%{_libdir}/libchewing.la rm $RPM_BUILD_ROOT%{_libdir}/libchewing.la
mkdir -p $RPM_BUILD_ROOT%{libchewing_python_dir} mkdir -p $RPM_BUILD_ROOT%{libchewing_python_dir}
cp python/chewing.py $RPM_BUILD_ROOT%{libchewing_python_dir} cp python/chewing.py $RPM_BUILD_ROOT%{libchewing_python_dir}
mkdir -p $RPM_BUILD_ROOT%{_libdir}/chewing
cp data/fonetree.dat $RPM_BUILD_ROOT%{_libdir}/chewing
touch $RPM_BUILD_ROOT%{libchewing_python_dir}/__init__.py touch $RPM_BUILD_ROOT%{libchewing_python_dir}/__init__.py
%post -p /sbin/ldconfig %post -p /sbin/ldconfig
@ -92,6 +98,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/*.so %{_libdir}/*.so
%changelog %changelog
* Fri Feb 20 2009 Ding-Yi Chen <dchen at redhat dot com> - 0.3.2-6
- Fix [Bug 486409] - Wrong python binding installed path
Add BuildRequires: python-devel
* Wed Feb 18 2009 Adam Jackson <ajax@redhat.com> 0.3.2-5 * Wed Feb 18 2009 Adam Jackson <ajax@redhat.com> 0.3.2-5
- Rerun autotools so changes to Makefile.am actually take effect. - Rerun autotools so changes to Makefile.am actually take effect.

Loading…
Cancel
Save