Need autoreconf and BuildRequires: pkgconfig to make changes in Makefile.am

effective
epel9
Ding-Yi Chen 16 years ago
parent 42340c0421
commit 6e0e80c70f

@ -8,3 +8,4 @@ libchewing-0_3_2-4_fc10:HEAD:libchewing-0.3.2-4.fc10.src.rpm:1232696067
libchewing-0_3_2-6_fc10:HEAD:libchewing-0.3.2-6.fc10.src.rpm:1235113283 libchewing-0_3_2-6_fc10:HEAD:libchewing-0.3.2-6.fc10.src.rpm:1235113283
libchewing-0_3_2-8_fc10:HEAD:libchewing-0.3.2-8.fc10.src.rpm:1240375796 libchewing-0_3_2-8_fc10:HEAD:libchewing-0.3.2-8.fc10.src.rpm:1240375796
libchewing-0_3_2-9_fc11:HEAD:libchewing-0.3.2-9.fc11.src.rpm:1242719923 libchewing-0_3_2-9_fc11:HEAD:libchewing-0.3.2-9.fc11.src.rpm:1242719923
libchewing-0_3_2-10_fc11:HEAD:libchewing-0.3.2-10.fc11.src.rpm:1242803240

@ -1,6 +1,6 @@
diff -up ./data/Makefile.am.libpatch ./data/Makefile.am diff -up ./data/Makefile.am.bz477690 ./data/Makefile.am
--- ./data/Makefile.am.libpatch 2008-12-02 00:29:20.000000000 +1000 --- ./data/Makefile.am.bz477690 2008-12-02 00:29:20.000000000 +1000
+++ ./data/Makefile.am 2009-02-20 12:23:46.000000000 +1000 +++ ./data/Makefile.am 2009-05-20 14:24:31.000000000 +1000
@@ -9,8 +9,11 @@ datas = \ @@ -9,8 +9,11 @@ datas = \
us_freq.dat \ us_freq.dat \
dict.dat \ dict.dat \
@ -24,9 +24,9 @@ diff -up ./data/Makefile.am.libpatch ./data/Makefile.am
+ $(DESTDIR)/$(libdir)/chewing + $(DESTDIR)/$(libdir)/chewing
+ +
+CLEANFILES = $(datas) $(datas_lib) gendata_stamp checkdata_stamp $(generated_header) +CLEANFILES = $(datas) $(datas_lib) gendata_stamp checkdata_stamp $(generated_header)
diff -up ./src/Makefile.am.libpatch ./src/Makefile.am diff -up ./src/Makefile.am.bz477690 ./src/Makefile.am
--- ./src/Makefile.am.libpatch 2008-12-02 00:29:20.000000000 +1000 --- ./src/Makefile.am.bz477690 2008-12-02 00:29:20.000000000 +1000
+++ ./src/Makefile.am 2009-02-20 12:26:46.000000000 +1000 +++ ./src/Makefile.am 2009-05-20 14:24:31.000000000 +1000
@@ -3,6 +3,7 @@ INCLUDES = \ @@ -3,6 +3,7 @@ INCLUDES = \
-I$(top_srcdir)/include \ -I$(top_srcdir)/include \
-I$(top_srcdir)/include/internal \ -I$(top_srcdir)/include/internal \
@ -35,9 +35,9 @@ diff -up ./src/Makefile.am.libpatch ./src/Makefile.am
-DCHEWING_DATADIR=\"$(datadir)/chewing\" -DCHEWING_DATADIR=\"$(datadir)/chewing\"
lib_LTLIBRARIES = libchewing.la lib_LTLIBRARIES = libchewing.la
diff -up ./src/tree.c.libpatch ./src/tree.c diff -up ./src/tree.c.bz477690 ./src/tree.c
--- ./src/tree.c.libpatch 2008-12-02 00:29:20.000000000 +1000 --- ./src/tree.c.bz477690 2008-12-02 00:29:20.000000000 +1000
+++ ./src/tree.c 2009-02-20 12:23:46.000000000 +1000 +++ ./src/tree.c 2009-05-20 14:24:31.000000000 +1000
@@ -114,7 +114,8 @@ void InitTree( const char *prefix ) @@ -114,7 +114,8 @@ void InitTree( const char *prefix )
int i; int i;
#endif #endif

@ -1,7 +1,7 @@
Name: libchewing Name: libchewing
Version: 0.3.2 Version: 0.3.2
Release: 9%{?dist} Release: 10%{?dist}
Summary: Intelligent phonetic input method library for Traditional Chinese Summary: Intelligent phonetic input method library for Traditional Chinese
Group: System Environment/Libraries Group: System Environment/Libraries
@ -18,13 +18,13 @@ Source: http://chewing.csie.net/download/libchewing/%{name}-%{version}.t
#Patch7: libchewing-0.3.0-9.bz200694.patch #Patch7: libchewing-0.3.0-9.bz200694.patch
#Patch8: libchewing-0.3.0-11.bz195416.patch #Patch8: libchewing-0.3.0-11.bz195416.patch
Patch9: libchewing-0.3.2.bz477690.patch Patch9: libchewing-0.3.2.bz477690.patch
Patch10: libchewing-0.3.2.phraseChoiceRearward Patch10: libchewing-0.3.2.phraseChoiceRearward.patch
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")} %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%define libchewing_python_dir %{python_sitearch}/%{name} %define libchewing_python_dir %{python_sitearch}/%{name}
BuildRoot: %{_tmppath}/%{name}-%{version}-root BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: autoconf automake libtool BuildRequires: autoconf automake libtool pkgconfig
BuildRequires: python-devel BuildRequires: python-devel
%description %description
@ -59,9 +59,8 @@ library.
%patch10 -p0 -b .phraseChoiceRearward %patch10 -p0 -b .phraseChoiceRearward
%build %build
#./autogen.sh
#autoreconf -v
export CFLAGS=-DLIBINSTDIR='\"%{_libdir}\" -g' export CFLAGS=-DLIBINSTDIR='\"%{_libdir}\" -g'
autoreconf -ivf
%configure --disable-static %configure --disable-static
%{__make} RPM_CFLAGS="%{optflags}" %{_smp_mflags} %{__make} RPM_CFLAGS="%{optflags}" %{_smp_mflags}
@ -99,6 +98,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/*.so %{_libdir}/*.so
%changelog %changelog
* Wed May 20 2009 Ding-Yi Chen <dchen at redhat dot com> - 0.3.2-10
- Need autoreconf to make changes in Makefile.am effective.
* Mon May 18 2009 Ding-Yi Chen <dchen at redhat dot com> - 0.3.2-9 * Mon May 18 2009 Ding-Yi Chen <dchen at redhat dot com> - 0.3.2-9
- Possible Fix of Bug 501220 - RFE: edit last preedit character from end of line - Possible Fix of Bug 501220 - RFE: edit last preedit character from end of line
Chewing upstream does not handle if phrase choice rearward is enabled. Chewing upstream does not handle if phrase choice rearward is enabled.

Loading…
Cancel
Save