[Bugfix 477690]

epel9
Ding-Yi Chen 16 years ago
parent 2d53c6b238
commit 09a61817b5

@ -2,3 +2,4 @@ libchewing-0_3_0_901-0_fc9:HEAD:libchewing-0.3.0.901-0.fc9.src.rpm:1221612386
libchewing-0_3_1-0_fc9:HEAD:libchewing-0.3.1-0.fc9.src.rpm:1223448249
libchewing-0_3_2-0_fc9:HEAD:libchewing-0.3.2-0.fc9.src.rpm:1228279004
libchewing-0_3_2-1_fc10:HEAD:libchewing-0.3.2-1.fc10.src.rpm:1229994594
libchewing-0_3_2-2_fc10:HEAD:libchewing-0.3.2-2.fc10.src.rpm:1230010807

@ -1,6 +1,6 @@
diff -up ./data/Makefile.am.libpatch ./data/Makefile.am
--- ./data/Makefile.am.libpatch 2008-12-02 00:29:20.000000000 +1000
+++ ./data/Makefile.am 2008-12-23 10:58:42.000000000 +1000
+++ ./data/Makefile.am 2008-12-23 13:54:17.000000000 +1000
@@ -9,8 +9,11 @@ datas = \
us_freq.dat \
dict.dat \
@ -26,22 +26,27 @@ diff -up ./data/Makefile.am.libpatch ./data/Makefile.am
+CLEANFILES = $(datas) $(datas_lib) gendata_stamp checkdata_stamp $(generated_header)
diff -up ./src/Makefile.am.libpatch ./src/Makefile.am
--- ./src/Makefile.am.libpatch 2008-12-02 00:29:20.000000000 +1000
+++ ./src/Makefile.am 2008-12-23 10:58:42.000000000 +1000
@@ -1,3 +1,5 @@
+AM_CPPFLAGS = ${CFLAGS} -DLIBDIR=\"${libdir}\"
+
SUBDIRS = porting_layer
INCLUDES = \
+++ ./src/Makefile.am 2008-12-23 14:07:56.000000000 +1000
@@ -3,7 +3,8 @@ INCLUDES = \
-I$(top_srcdir)/include \
-I$(top_srcdir)/include/internal \
-I$(top_srcdir)/src/porting_layer/include \
- -DCHEWING_DATADIR=\"$(datadir)/chewing\"
+ -DLIBINSTDIR=\"$(libdir)\"\
+ -DCHEWING_DATADIR=\"$(datadir)/chewing1\"
lib_LTLIBRARIES = libchewing.la
libchewing_la_SOURCES = \
diff -up ./src/tree.c.libpatch ./src/tree.c
--- ./src/tree.c.libpatch 2008-12-02 00:29:20.000000000 +1000
+++ ./src/tree.c 2008-12-23 11:01:03.000000000 +1000
@@ -114,7 +114,7 @@ void InitTree( const char *prefix )
+++ ./src/tree.c 2008-12-23 14:04:36.000000000 +1000
@@ -114,7 +114,8 @@ void InitTree( const char *prefix )
int i;
#endif
- sprintf( filename, "%s" PLAT_SEPARATOR "%s", prefix, PHONE_TREE_FILE );
+ sprintf( filename, "%s" PLAT_SEPARATOR "chewing" PLAT_SEPARATOR "%s", LIBDIR, PHONE_TREE_FILE );
+ sprintf( filename, "%s" PLAT_SEPARATOR "chewing" PLAT_SEPARATOR "%s",
+ LIBINSTDIR, PHONE_TREE_FILE );
#ifdef USE_BINARY_DATA
plat_mmap_set_invalid( &tree_mmap );
tree_size = plat_mmap_create( &tree_mmap, filename, FLAG_ATTRIBUTE_READ );

@ -1,6 +1,6 @@
Name: libchewing
Version: 0.3.2
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Intelligent phonetic input method library for Traditional Chinese
Group: System Environment/Libraries
@ -19,6 +19,7 @@ Source: http://chewing.csie.net/download/libchewing/%{name}-%{version}.t
Patch9: libchewing-0.3.2.bz477690.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRequires: libtool
%description
libchewing is an intelligent phonetic input method library for Chinese.
@ -52,7 +53,7 @@ library.
%build
%configure --disable-static
make
make LIBINSTDIR="\"%{_libdir}\""
%install
rm -rf $RPM_BUILD_ROOT
@ -83,7 +84,7 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/*.so
%changelog
* Tue Dec 23 2008 Ding-Yi Chen <dchen at redhat dot com> - 0.3.2-1
* Tue Dec 23 2008 Ding-Yi Chen <dchen at redhat dot com> - 0.3.2-2
- [Bug 477690] libchewing multilib conflict
Move /usr/share/chewing/fonetree.dat to corresponding libdir.

Loading…
Cancel
Save